Keithley Instruments Series 2800 VSA Help

2810 Getting Started | 2810 General purpose | 2810 Modulation Standards | viewing and outputting data
Getting started | General purpose | Modulation standards | Viewing measurement results
Remote control and programming | 2910 Icon License | 2810 Outputting measurement | 2810 Utilities
Remote control | Measurement personality license files | Global settings | Utilities


Site map

Getting Started

  • About the 2810 VSA
  • About the 2820 VSA
  • Front panel tour
  • Rear panel tour
  • User interface tour

Help

  • System Help
  • Instrument Help
  • Context sensitive

Preset

Remote control

General purpose

  • Spectrum
  • Zero span
  • ACPR
  • Channel power list

Waveform measurements

  • GSM
  • EDGE
  • cdma2000 Reverse Link
  • W-CDMA Uplink
  • W-CDMA Downlink
  • WLAN (802.11x)

Global settings

  • Atten/Preamp
  • Digital I/O
  • Freq Ref Source
  • Marker Config
  • RF Out
  • Sync out
  • Trigger
  • User Flatness
  • Calibrate
  • Advanced

Utilities

  • Screen saver
  • GPIB Address
  • Time and Date
  • Ethernet settings
  • LAN config init
  • Upgrade software
  • Licensing


Getting started

To become familiar with the instrument visit the Home page and the following tours and links.

  • About the 2810 VSA

Describes the instrument features and capabilities
  • About the 2820 VSA

Describes the higher frequency instrument features and capabilities
  • Front panel tour

Tours the instrument display and front panel controls
  • Rear panel tour

Tours the instrument rear panel connections
  • User interface tour

Tours the instrument user interface

 | RedBox
Context sensitive Help Select to get Help on the panel or window. | A red box on an image indicates a link to more information.


Help toolbar

To navigate Help, use these controls on the menu bar:

2910MenuBar1 | HelpTool2 | 2910MenuBar3 | 2910MenuBar4 | 2910MenuBar5
Home page to browse major topics | Site Map to browse individual topics | Alphabetical Index | back and forward buttons | Close Help and return to program


About the Model 2810 VSA

The Keithley Instruments Model 2810 RF Vector Signal Analyzer offers a frequency range of 400MHz to 2.5GHz and an input power range of -125dBm to +13dBm.

Key features:

  • Compact half-rack size that fits neatly next to the Model 2910 RF Vector Signal Generator (VSG) in a test rack
  • Similar look and feel to the Model 2910 VSG:
    • Intuitive LCD graphical user interface for high ease of use
    • Front panel touch-screen or USB mouse operation
  • Same software-defined radio architecture as the Model 2910 VSG
  • Fastest digital signal processing chip on the market for quick analysis
  • Measurement bandwidth in excess of 20MHz to acquire the new wideband technology signals
  • Multiple interfaces: GPIB, USB and LAN with LXI-C compatibility
  • Options for built-in mobile phone signal analysis:
    • GSM/EDGE signal analysis
    • Reverse link cdmaOne/cdma2000 signal analysis
    • Uplink and downlink WCDMA signal analysis
  • Three-year warranty is standard
  • High-power measurement accuracy for higher yields

Capabilities and ranges that can accommodate the following applications:

  • Mobile handset production test
  • Handset R&D and design verification
  • Testing mobile communications infrastructure
  • RFIC testing
  • Research and education in mobile communications

The Model 2810 VSA also has the following capabilities and features:

  • Higher speed for low cost of test:
    • Faster tuning
    • Faster amplitude settling
    • Responsive controls
    • Faster switching between waveforms
  • Powerful built-in tools and capabilities:
    • Digital signal structures
    • Arbitrary waveform generator memory
    • External I/Q modulation inputs
  • Signal generation accuracy
  • Easy to configure, easy to use:
    • Intuitive graphic user interface
    • Compact size
    • Choice of remote programming interfaces
    • Flexible remote software tools
    • LXI Class C compliance
    • Graphical Help system


Select Language

You can choose to view the following portions of the user interface in various languages:

  • Front panel interface
  • Help topics

To choose the language, follow these steps:

  1. Select Menu > Select Language...
  2. Select the Front Panel Language drop-down arrow and select from the available languages.
  3. Select the Help System Language drop-down arrow and select from the available languages.
  4. Select Apply to make your choices take affect.


About the Model 2820 VSA

The Keithley Instruments Model 2820 RF Vector Signal Analyzer (VSA) offers a choice of frequency ranges and an input power range of -125dBm to +13dBm. Two frequency ranges are available as instrument hardware options:

  • Option 2820-004 provides a frequency range of 400MHz to 4GHz.
  • Option 2820-006 provides a frequency range of 400MHz to 6GHz.

Key features:

  • Compact half-rack size that fits neatly next to the Model 2910 or 2920 RF Vector Signal Generator (VSG) in a test rack
  • Similar look and feel to the VSG:
    • Intuitive LCD graphical user interface for high ease of use
    • Front panel touch-screen or USB mouse operation
  • Same software-defined radio architecture as the VSG
  • Fastest digital signal processing chip on the market for quick analysis
  • Measurement bandwidth in excess of 40MHz to acquire the new wideband technology signals
  • Multiple interfaces: GPIB, USB and LAN with LXI-C compatibility
  • Options for built-in mobile phone signal analysis:
    • GSM/EDGE signal analysis
    • Reverse link cdmaOne/cdma2000 signal analysis
    • WLAN (802.11x) signal analysis
    • Uplink WCDMA signal analysis
    • Downlink WCDMA signal analysis
  • Three-year warranty is standard
  • High-power measurement accuracy for higher yields

Capabilities and ranges that can accommodate the following applications:

  • Mobile handset production test
  • Handset R&D and design verification
  • Testing mobile communications infrastructure
  • RFIC testing
  • Wireless connectivity testing (802.11a/b/g/j/n WLAN)
  • Research and education in mobile communications

The 2820 VSA also has the following capabilities and features:

  • Higher speed for low cost of test:
    • Faster tuning
    • Faster amplitude settling
    • Responsive controls
    • Faster switching between waveforms
  • Powerful built-in tools and capabilities:
    • Digital signal structures
    • Arbitrary waveform generator memory
    • External I/Q modulation inputs
  • Signal generation accuracy
  • Easy to configure, easy to use:
    • Intuitive graphic user interface
    • Compact size
    • Choice of remote programming interfaces
    • Flexible remote software tools
    • LXI Class C compliance
    • Graphical Help system


Front panel tour

Select items that have a red box to learn more:

go to Front panel display go to power on button go to preset go to USB ports go to local button go to RF connector go to TG Out connector go to front panel Puck go to front panel Knob


Local button

While the instrument is being remotely controlled, it will not respond to input form the screen, external USB devices, or any of the front panel keys except Local. If the instrument is in remote mode but not in local lockout, selecting the Local button will restore the instrument to local mode.

In local mode, the front panel buttons, screen, external USB mice and keyboards are active.

Local lockout mode is set with the remote programming interface and is used for situations where no front panel control is desired (except the Power On button).


Front panel puck

The front panel puck steps the display cursor in four directions: left, right, up and down. When the center button is pressed, a Number pad appears to allow you to enter a specific value directly.

This control is used in conjunction with the front panel knob and the number pad dialog box. To see how it interacts with these two other controls, see Changing a value.

See also:

  • Front panel knob
  • Number pad


Changing a value

How to change a parameter value (such as frequency or amplitude)

Parameters can be changed in several ways:

  • Directly enter the value into the number pad.
  • Adjust the existing value using the front panel controls.
  • Send a remote command.

This topic describes the first two methods. The method you choose depends on how close the new value is to the existing value. If the gap is large, entering a value directly sets the value in one step. If the gap is small, the front panel control can often get to the new value quicker.

Selecting the parameter to change

Parameters that can be changed are displayed in a text box. Until a parameter is selected, the parameter text boxes have a black background.

To change the parameter value, the text box must first be selected. Once selected, the background color of the text box changes from black to green.

Note: Only one text box can be selected at a time.

Changing the value

Once the text box is selected, there are several ways to change the value:

Controls for changing a value

Front panel knob
Front panel puck | Number pad

Direct value entry using the Number Pad

  1. Select the center button on the front panel puck or double select the parameter text box.
  2. Use the numeric keys to enter the value.
  3. Select the unit.
  4. Select Close.

Adjust the existing value using the front panel controls

Depending on how far off the new value is from the existing value, use the front panel knob and puck. Use the left and right arrows on the puck to move the cursor in the value text box. Use the up and down-arrows on the puck or front panel knob to change the value.

Set to Max and Min values

When you select the number pad, you can set the parameter value directly to its maximum or minimum value by selecting either the Set to Max or Set to Min buttons.

Default values

When you select the number pad, you can set the parameter value directly to its default value by selecting the Default button.

Stepping the value

It is sometimes useful to change the value of a parameter in constant steps. A common example would be to step the frequency in constant steps from one frequency to another. The constant steps are generated by using the vertical controls on the front panel puck. The size of the steps is set in the Number Pad.

To change the step size

  1. Bring up the number pad by either:
    • Selecting the center button on the front panel puck.
    • Double select the value text box.
  2. Select the Step Size tab.
  3. Select Step Size radio button.
  4. Enter a numeric value.
  5. Select the units.
  6. Select Close.


Power On button

This button has a power control symbol; when the unit is powered on, a green LED can be seen.

  • If power is applied to the instrument and the rear panel power switch is in the On/Standby position, an amber light will show.
  • Selecting this button in On/Standby state turns the instrument on and changes the LED color from amber to green.


Preset

To restore the instrument to its default condition select the Preset button on the front panel.

Alternatively, from the LXI web Interface, select Menu > Settings > Preset.

The instrument will preset in less than a second.

Note: The front panel Preset button is not active if the instrument is in the Remote or Local Lockout mode, as set by the remote programming interface.

Note: The following settings are not affected by Preset, *RST, or save/recall state:

  • Background tasks
  • Extended frequency
  • Display On/Off
  • Frequency reference
  • SCPI debug

See also:

Preset conditions

Extend Freq


Series 2800 Preset conditions

When initially powered up, or preset, the instrument state is set to the following values:

Parameter | Preset value | Parameter | Preset value
Center Frequency | 1 GHz | Measurement | Spectrum
Frequency Span | 50 MHz | Detection Type | Normal
Start Frequency | 975 MHz | Trace Hold | Normal
Stop Frequency | 1025 MHz | Spur Cancellation | Off
Bandwidth Auto | On | Trigger | Free Run
Sweep | Continuous | Sync Out | Off

Note: The front panel Preset button is not active if the instrument is in the local lockout mode, as set by the remote programming interface.


Extend Freq

Global Settings > Adv Hardware Settings > Extend Freq

When the Extend Freq check box is selected, the frequency range is extended beyond the specified limits. The specified limits are 400-2500 MHz, and the extended limits are 325-2975 MHz for the Model 2810 VSA receiver and 325-2700 MHz for the RF Output of the Model 2910 VSG. Setting either the start or stop beyond the spec limits will change the text color in the GUI from black to red. With either start or stop in the extended range, both center and span are displayed in red. The color change feature is available in all measurement selections except Channel Power List, which has no frequency selection entry.

The Model 2820-004 VSA has a specified range of 400 MHz to 4.0 GHz. The extended frequency range is 325 MHz to 4.0 GHz. The Model 2820-006 VSA has a specified range of 400 MHz to 6.0 GHz. The extended frequency range is 325 MHz to 6.5 GHz.

The Extend Freq selection is not part of the instrument state. This means that once it is set, it will stay at that setting until the instrument is power cycled (preset and recall have no effect). After a power cycle it defaults to "off" (that is, the instrument is restricted to the specified frequency range).

Note: If an instrument state with extended frequency setting turned-on is saved to a file, the frequency value is saved, but not the extended frequency setting. If that saved file is opened later on the instrument when the extend frequency setting has now been turned off, the frequency value that appears will not be correct, as it will now have to be set within the specified limits. For example, if the extended frequency value was saved as 2.6GHz, the value appearing on the instrument will be 2.4999999GHz and no error will be reported. To prevent this situation from occurring, make sure to turn-on the Extend Freq setting, before opening files that contain extended frequency values.


RF On button

Select this button to connect the modulated RF waveform to the RF Out connector.


Instrument screen

The instrument screen is four inches high by six inches wide.

The exterior interface is a resistive membrane and is not a glass plate. Therefore, some care must be taken to avoid damaging it.

To ensure comfortable viewing, the display backlight is fluorescent.

A calibration utility is provided in the instrument to allow you to calibrate the screen. After you make the initial calibration, further calibration should not be necessary. However, the calibration process is quick and simple, so carry out a calibration if screen accuracy becomes a concern.


TG Out connector

The VSA internal tracking generator is accessed from the TG Out Type-N connector. The tracking generator is a constant amplitude sweep controlled by the RF Out panel.

Depending on the instrument options installed, the TG Out connector can be installed on the instrument front or rear panel.


RF In connector

RF In is an Type-N connector through which RF signals are applied to the instrument.

Depending on the instrument options installed, the RF In connector can be installed on the instrument front or rear panel.

Note: Care must be taken to limit the signals connected to 50 VDC, +35 dBm RF maximum.


USB ports

Use these two ports to connect USB devices to the instrument.

Common USB devices include the following items:

  • Peripherals such as mice and keyboards. When used in a desktop setting, a standard keyboard and mouse may be more convenient for the instrument operator.
  • Memory sticks can be connected to these ports to upload and download data files. Software upgrades can also be made using a memory stick.


Front panel knob

This knob adjusts the value of the active parameter. It is often used in conjunction with the front panel puck and the number pad dialog box to set parameter values. Go to Changing a value to see how the front panel knob functions.

See also:

  • Front panel puck
  • Number pad


Rear panel tour

Select items that have a red box to learn more:

go to Line input socket module go to RF IN connector go to TG out connector go to VGA Output connector go to IQ in connectors go to TRIG IN go to SYNC OUT Digital IO connector go to USB connector to device go to Even SEC in out go to IEEE-488 connector go to USB connector to device go to LAN connector go to Reference in and out


Line input module

The line input module has three components:

  • The power input switch has two positions: "0" = off and "|" =on/standby. When the switch is in the "|" position, power is applied to the instrument's ovenized reference oscillator (even when in standby mode). With power always applied to the reference oscillator, warm up time to frequency stability is minimized.
  • Below the power input switch is a covered fuse. The fuse is a 2 Amp slow blow fuse. This same fuse is used for the line voltage range of 100 to 240 Volts inclusive. It is removed after gaining access to it by pinching on either side of the fuse cover.
  • Below the fuse is the line input socket. Connect the socket to an appropriate line cord for your usage. The instrument automatically supports line voltages ranging from 100 to 240 Volts inclusive.

See also:

  • Line frequency
  • Line power connection
  • Line voltage and fuses


Line frequency

The instrument operates at line frequencies from 50 to 60 Hz. There are no user settings for line frequency.


Line power connection

Follow the procedure below to connect the instrument to line power and power it up:

1. Check to see that the line voltage supply is within 100 to 240 Volts AC; 50 to 60 Hz.

CAUTION: Operating the instrument on an incorrect line voltage may cause damage to the instrument, possibly voiding the warranty.

2. The power switch is located on the rear panel power module. Before plugging in the power cord, make sure that the power switch is in the Off position. The Off position has the "O" symbol depressed on the rear panel power switch rocker.

3. Connect the female end of the supplied power cord to the AC receptacle on the rear panel. Connect the other end of the power cord to a grounded AC outlet.

NOTE: If the power switch on the instrument will not be easily accessible after it is set-up for bench-top use or rack mounted, use a power strip that has a power switch. This will allow you to turn the instrument on or off from the power strip.

WARNING: The power cord supplied with the instrument contains a separate ground wire for use with grounded outlets. When proper connections are made, the instrument chassis is connected to power line ground through the ground wire in the power cord. Failure to use a grounded outlet may result in personal injury or death due to electric shock.

4. Turn on the instrument by pressing the front panel Power On button.


Line voltage and fuses

The instrument is designed to accept a line voltage range of 100 to 240 Volts. No line voltage switch settings are available.

A fuse protects the power line input of the instrument. If the line fuse needs to be replaced, perform the following steps:

WARNING: Make sure the instrument is disconnected from the AC line and other equipment before changing the line fuse. There is a risk of injury or death when handling an instrument that is still connected to the AC line.

1. Using a small flat-blade screwdriver, push the retaining clip toward the center of the module to release the fuse holder assembly.

2. Pull the fuse holder out of the power module.

3. Remove the blown fuse and replace it with similar 2.0 Amp, 250 Volt 5 x 20 mm slow-blow fuse.

CAUTION: For continued protection against fire or instrument damage, only replace fuses with the type and rating listed. If the instrument repeatedly blows fuses, return the unit to Keithley Instruments.


DIGITAL I/O connector

The Digital I/O connector allows for inter-instrument communications between multiple Keithley Instruments units.

To learn more, see Digital I/O


Digital I/O...

The instrument Digital I/O allows you to control external devices, provide input to external logic circuitry, and control the analyzer.

The DIGITAL I/O port is a male DB-9 connector located on the rear panel and controlled by front panel access. Select the following topics to learn more about the Digital I/O functionality:

  • Digital I/O connector pin out
  • Digital input
  • Digital outputs
  • Setting digital output lines


IEEE-488 connector

The IEEE-488 connector is also known as the GPIB connector, and is part of the instrument remote programming interface.

The instrument can be controlled through this connector by commands from a remote host computer over a Remote control interface.

Also see the following topics:

GPIB address

System configuration for remote control


Remote control

You can automate commonly recurring test procedures by sending remote control commands to the instrument over GPIB or Ethernet (LAN). You can also access the instrument and control the operation using the LXI Web interface. To learn about the configuration requirements and programming commands, see the following topics:

  • Remote and local operation differences
  • LXI Web interface
  • System configuration for remote control
  • Programming messages
  • Status structure
  • Recommended programming sequences
  • Series 2800 VSA Command locater
  • Series 2800 SCPI command tree
  • SCPI command error messages


GPIB Address VSA

This topic shows you how to modify the GPIB address. For details on connecting a GPIB system, see GPIB configuration.

The GPIB Address dialog box is accessed by selecting: Menu > Utilities > GPIB Address...

Use this dialog box to change the GPIB address of the instrument.

The range of numbers for selection is 0 to 30.

The default GPIB address value is 10.

To change the value of the GPIB Address, select it and enter a different value.


System configuration for remote control

You can control the VSA remotely over GPIB, USB, or LAN. Select from the following list to learn how to set up your system for remote operation:

  • GPIB setup
    • Connections
    • Configuration
    • Verification of remote control
  • USB setup
    • Connections
    • Configuration
    • Verification of remote control
  • LAN (Ethernet) setup
    • Connections
    • Configuration
    • LAN (Ethernet) operation verification with KI RFI Communicator
    • VISA resource string
    • Troubleshooting


LAN connector

The LAN connector is a standard RJ45 LAN connector, and is part of the instrument remote programming interface. The instrument can be controlled through this connector by commands from a remote host computer over a Remote control interface.

Also see the following topics:

LAN Config init.

System configuration for remote control

LAN (Ethernet) troubleshooting


LAN (Ethernet) troubleshooting

The Series 2800 VSA defaults to an Ethernet setting of "Auto-negotiation On" to detect the speed of the network and set the instrument operation speed to match the network speed. If the auto-negotiation process fails, the operation speed must be set manually:

Note: If the instrument speed does not match the network speed, Auto-negotiation On is the recommended setting.

  1. Select Menu > Utilities > Ethernet Settings.
  2. Select the Advanced tab.
  3. Select the appropriate speed:
    • 10 Mbps
    • 100 Mbps
  4. Select Apply.
  5. To ensure that both the instrument and the network recognize the speed change, you may need to disconnect and then reconnect the LAN cable.


REF IN and OUT connectors

REF IN connector

The 1 to 20 MHz REF IN connector allows an external frequency source to lock the instrument oscillator circuit to a range of from 1 to 20 MHz, which can improve measurement accuracy. A software dialog box enables the instrument to synchronize to the external reference source.

  • Connector type: BNC
  • Amplitude range: -10 to 10 dBm Input (DC blocked)
  • Coupling: DC blocked
  • Impedance: 50 Ohms
  • Lock range: At 10 MHz +/-10 ppm
  • Frequency Range: 1 MHz to 20 MHz, user selectable with 1 Hz resolution

REF OUT connector

The 10 MHz external REF OUT connector is used in a daisy-chain configuration with other measurement instruments to improve measurement accuracy.

  • Connector type: BNC
  • Output impedance: 50 Ohms
  • Output frequency: 10 MHz
  • Amplitude: 5 dBm approximately


SYNC OUT connector

The SYNC OUT connector allows the instrument to communicate with another device. It is often used in conjunction with the trigger input signal to notify another device that the event requested has been performed. To learn more on how this can be done, see Sync Out description and uses.

The SYNC OUT is a low impedance TTL-compatible bus driver output signal capable of sourcing 30 mA or sinking 60 mA maximum.

See also TRIG IN connector.


Sync Out description and uses

The sync pulse output can trigger an external device or circuit to perform a particular operation. The Series 2800 VSA can generate a sync out signal at various events during the process of taking a measurement sweep and acquiring data. The sync pulse is useful for making fast measurements because other equipment will not have to wait any longer than necessary to change state for subsequent measurements.

The sync output and the trigger input are two sides of an interactive communication between the Series 2800 VSA and other test instruments:

  • Sync out indicates when a certain event has happened in the Series 2800 VSA. This information is sent to external equipment where the equipment responds in some controlled way.
  • Trigger in causes the Series 2800 VSA to measure the input signal when the selected trigger conditions are met.
Rear panel connections for SYNC OUT and TRIG IN

You can set the polarity of the 200 ns TTL (3.3 Volt) sync pulse generated:

  • Sync on the rising edge of the pulse.
  • Sync on the falling edge edge of the pulse.

In many measurement applications, the source must settle before the Series 2800 VSA can acquire data. You can send the *OPC query at the end of a programming message so the source sends a "1" to the controller when it has settled and finished executing the command. The "1" sent is a TTL pulse on the source SYNC OUT connector. This interactive communication allows you to synchronize your device measurements with the source output. The syntax for the message is the same whether you are sending commands over GPIB, LAN, or USB.

For details, see Sync Output settings panel.


TRIG IN connector

The TRIG IN connector allows another device to initiate an event in the instrument. To learn more on how this can be done see Trigger description and uses.

TRIG IN is a high impedance (10K Ohms in parallel with 22 pF), diode clamped Schmidt trigger input. A logic signal greater than 1.3 Volts initiates a trigger. The input is diode clamped for protection; absolute maximum levels on this line are -0.4 to 3.7 VDC. This input may be terminated into 50 Ohms using a feed-through termination (not supplied) at the rear panel.

See also Sync Out.


Trigger description and uses

When you switch the Series 2800 VSA to sweep continuously (preset setting), the instrument immediately tunes to the frequency and power values in the measurement span. When the Series 2800 VSA reaches the last set of values in the sweep or channel power list, it immediately returns to the first set of values for the sweep or list, repeating the sweep continuously.

If you want the instrument to wait until you are ready for it to make a measurement, you can set up a trigger. The Series 2800 VSA has trigger options that allow you to control whether the instrument does one of the following operations:

  • Starts a continuous sweep
  • Starts a single sweep
  • Tunes to the next measurement point (frequency/power values)

By default, the instrument trigger point is positioned in the center of the measurement screen. If you want to view measurement trace events that occur before or after the trigger point, set a trigger delay (see To set the trigger).

You can also control what the Series 2800 VSA will accept as a trigger event:

  • Sweep Single button
  • SCPI command (*TRG)
  • External TTL input:
    • Pulse with a rising (positive) edge
    • Pulse with a falling (negative) edge
  • Video input:
    • Specified RF signal power level
    • Leading edge of a bursted RF signal

You can also choose from a few combination triggers where the condition of two trigger events must happen for the instrument to proceed with the specified operation. The first event arms the trigger and the second event causes the trigger. For example, you can choose a trigger event combination of external/video.

Video trigger

The video trigger is intended for data acquisition of multiple bursted RF signals. The trigger settings help to base the trigger event on the leading edge of a burst even when modulation noise is inside the burst.

To ensure that the analyzer performs the measurement when the burst occurs and not when modulation noise occurs, you can set the video trigger pre-qualification. The pre-qualification requires that the input signal stay out of an area you specify that is located before the leading edge of the burst. This pre-qualification area has a level that the RF signal must stay below for a certain length of time. The trigger event is based on the contrast between when there is no burst and when a burst occurs.

Trigger mode

The trigger mode determines how the instrument acquires data when more than one data acquisition is required to complete a measurement:

  • On Measurement starts the first data acquisition and then immediately takes any subsequent data acquisitions needed to complete the measurement. In this mode, only the first data acquisition of a measurement is synchronized with a trigger. Subsequent data acquisitions needed to complete the measurement proceed immediately without any further triggers.
  • On Acquire starts a single data acquisition and then waits for another trigger to continue with the subsequent data acquisition. In this mode, every data acquisition in the measurement waits for a trigger to synchronize it to the events.

The On Acquire trigger mode is most useful for the channel power list and ACPR measurements, since they are comprised of discrete data acquisitions. This mode is also useful if you want data acquisitions synchronized to a trigger event.

See Trigger settings panel and To set the trigger for more information.


USB connectors

There are two USB connectors on the rear panel ("A" and "B"). The "B" connector is labeled "(From Host)" and is normally used to connect the instrument to a host computer.

The USB connectors are a part of the Remote control interface. Through the USB "B" connector, the instrument can be controlled by commands from a remote host computer.

Also see the following topic:

System configuration for remote control


VGA OUT connector

This is a standard VGA output connector. By connecting a standard VGA cable and monitor to this port, you can view the instrument display remotely, providing the convenience of viewing the instrument display on a larger monitor.


I-IN, Q-IN connectors

The I-IN and Q-IN connectors allow you to connect an external arbitrary generator to the instrument I/Q modulator. This gives you additional control of the RF signals that you can analyze. The rear panel I-IN and Q-IN connectors are activated by means of the External I Q dialog box in the VSG.

The external I and Q inputs are designed for a 50 Ohm input impedance and have a bandwidth of greater than 100 MHz.

The user should supply an I and Q signal that is 1.6V peak-to-peak amplitude centered around a nominal 0 Volts. In order to get good carrier and sideband suppression, you will have to adjust DC offset, amplitude and phase of the baseband inputs.


EVEN SEC IN, OUT connectors

Like the REF IN and REF OUT connectors, the EVEN SEC IN and EVEN SEC OUT connectors are used in conjunction with other devices for accurate frequency locking purposes.

EVEN SEC IN is a high impedance (10K Ohms in parallel with 22 pF), diode clamped Schmidt trigger input. A logic signal greater than 1.3 Volts initiates a trigger. The input is diode clamped for protection, and absolute maximum levels on this line are -0.4 to 3.7 VDC. This input may be terminated into 50 Ohms using a feed-through termination (not supplied) at the rear panel.

EVEN SEC OUT is a low impedance, TTL compatible bus driver output signal capable of sourcing 30 mA or sinking 60 mA maximum.


Series 2800 User interface tour

Select a red box to learn more:

go to Menu go to measurements go to measurement settings go to context sensitive Help go to command Help


Menu

From the Menu button, the following selections are available; select one of the following links to learn more:

  • File selects load and save file operations, shared network folders and screen capture.
  • Global Settings are instrument settings (as opposed to measurement settings).
  • Utilities are system settings such GPIB, LAN, Ethernet, upgrading software, licensing, calibrate touch screen, screen saver, debug, time and date.
  • Help opens the system Help and has stored information about this Series 2800 VGA.


Series 2800 file

To learn about Series 2800 VGA File operations, select from the following menu choices:

  • Load setup
  • Save setup
  • Shared network folders
  • Save screen


Open setup...

Instrument settings that have been previously saved, can be loaded and restored on the instrument.

An instrument setup file can be loaded from:

  • A memory location inside the instrument.
  • A memory stick connected to a USB port.
  • A Shared network folder.

Refer to How to load an instrument setup file.

Refer to Shared network folders to see how setup files can be loaded from a remote location.


Save setup...

Instrument settings can be saved for future reloading in three locations.

  • A memory location inside the instrument.
  • A memory stick connected to a USB port.
  • A Shared network folder.

See how to save an instrument setup file.

  • Select the Look in field to select User or USB.

In this example select User to save the setup as a file in the internal flash memory.


Shared network folders...

Use this dialog box to manage shared network folders

Learn about:

Folder or drive sharing


Folder or drive sharing

You can make a connection between the instrument and any Windows computer drive to share or manage files across the multiple memory storage devices. Once you establish a path to another drive through the instrument front panel interface, you can use that path through the remote programming interface or the front panel interface.

Note: You can only establish a shared folder from the front panel interface and if a password is required, you will need a USB keyboard attached to the instrument.

Note: When the power is cycled on the instrument, the drive sharing path must be re-established.


Save Screen...

The Save Screen feature allows you to capture and save a screen image to internal memory or to a USB memory stick.

  • File > Save Screen...
  • Select the Look in field to select User or USB.
  • Navigate to the folder to store the image.
  • Use the Keyboard to give the image a name.
  • Select Save.


Global settings

To learn more about VSA Global Settings, select from the following:

  • Atten/Preamp controls
  • Digital I/O
  • Frequency reference
  • Marker Config
  • RF Out control panel
  • Sync Output settings panel
  • Trigger settings panel
  • User Flatness
  • Calibrate
  • Advanced
    • ADC dither
    • Extend Freq
    • DSP range
    • DSP randomize
    • More...Advanced Settings


Atten/Preamp control panel

The attenuator and preamplifier allow you to modify input signal power.

Atten

Atten Auto On enables the automatic application of attenuation to the input signal when selected. When you select the Ref Level or Expected Power value, the analyzer automatically adjusts the input attenuation to optimize the power measurement range.

Atten Value allows you to view the attenuation value automatically applied by the analyzer (if the Atten Auto is enabled), or you enter an attenuation value manually. The manual setting is useful when you want to step the attenuation value to determine if displayed signal spurs are due to the device under test or the analyzer.

Note: A * symbol will appear next to the word Atten in the Atten/Preamp button when the manual setting is selected. This is a visual indicator that automatic setting is uncoupled and that the instrument no longer tracks changes to the reference level.

Remote control commands

[:SENSe]:POWer[:RF]:ATTenuation

[:SENSe]:POWer[:RF]:ATTenuation:AUTO

[:SENSe]:POWer[:RF]:GAIN[:STATe]

Preamp

Preamp allows you to add power amplification (approximately 13dB) to the input signal. This is useful for improving measurement sensitivity when the signal has lower power.

Note: A * symbol will appear next to the word Preamp in the Atten/Preamp button when the Preamp is selected. This is a visual indicator that the Preamp has been turned on.


Frequency Reference...

You can use a common frequency reference for all the equipment in a measurement setup by choosing from three frequency reference sources:

Frequency source | Rear panel access | Description
Internal (10 MHz) | REF OUT | Used in a daisy-chain configuration with other measurement instruments to improve measurement accuracy.
External (1 to 20 MHz) | REF IN | Allows an external frequency source to lock the instrument oscillator circuit, which can improve measurement accuracy. The locking range is 1 to 20 MHz.

Note: The frequency reference is not affected by Preset, *RST, or save/recall state.

From the front panel interface:

  1. Select Menu > Global Settings > Frequency Reference....
  2. Select the frequency reference source:
    • If you want to use the frequency source internal to the instrument, select Internal.
    • If you want to use an external frequency source, select External and enter the frequency of the external source.

From the remote control interface:

:SOURce:ROSCillator:EXTernal:FREQuency

:SOURce:ROSCillator:SOURce


Marker Config

Marker Config has two Peak Search Criteria to enable you to define a local max on a trace as a peak:

Excursion: Use this editable value to define a local max on a trace as a peak by its amplitude difference from the adjacent local max traces.

Threshold: Use this editable value to define a minimum value (relative to 1 milliwatt) that a local max on a trace must meet to qualify as a peak. This setting is useful in filtering noise from the measurement.


RF Out control panel

RF Out allows you to apply the output signal to devices that may be under test or part of a measurement configuration. For example, you could apply the RF Out to an external mixer that converts the output frequency of a test device to a range that the analyzer can measure.

RF Out

Enables and disables the RF Out signal. Depending on the option of the instrument, you can access the output signal from a front panel connector or a rear panel connector.

Remote control command

:SOURce[:STATe]

RF frequency values
  • Start sets the frequency that starts the measurement sweep.
  • Stop sets the frequency that stops the measurement sweep.
  • Center sets the frequency that is the center of the measurement sweep.
  • Span sets the frequency range above and below the center of the measurement sweep.

Remote control commands

:SOURce:FREQuency:CENTer

:SOURce:FREQuency:SPAN

:SOURce:FREQuency:STOP

:SOURce:FREQuency[:STARt]

Dwell

Sets the length of time the analyzer stays at each measurement point. This is useful for allowing the instrument to settle at the current parameter settings.

Remote control command

:SOURce:DWELl

Number of Points

Sets the number of data points for the measurement sweep. The default is 501 points.

Remote control command

:SOURce:POINts


Trigger settings panel

This panel allows you to set up settings for triggering signals.

Trigger Source

Sets the input trigger source:

  • Free Run triggers another measurement immediately at the end of each measurement if you have set continuous sweep. If you have set single sweep, you must select Sweep Single to trigger a measurement.
  • External triggers a measurement when the instrument receives an external signal pulse.
  • Video triggers a measurement when the input signal reaches the value specified.
  • Bus triggers a measurement when the instrument receives the *TRG command.
  • Ext Arm/Video Trig triggers a measurement when the instrument receives an external signal pulse and the input signal reaches the specified value.
  • Bus Arm/Ext Trig triggers a measurement when the instrument receives a *TRG command to arm the trigger and an external signal pulse.
  • Bus Arm/Video Trig triggers a measurement when the instrument receives a *TRG command to arm the trigger and the input signal reaches the specified value.
  • Ext Latched is similar to External. It triggers a measurement if the external input has sent an active edge since the last latch reset. The external trigger latch is reset when the trigger is used or the receiver sends a sync out signal.

Remote control command

:TRIGger[:SEQuence]:SOURce

:TRIGger[:SEQuence]:SOURce

Sets the source of the trigger signal(s).

  • IMMediate -- sets the instrument to a continuous trigger mode.
  • EXTernal -- sets the instrument to receive a trigger from the rear panel TRIG IN connector.
  • ELATched -- sets the instrument to receive a trigger if the external input has sent an active edge since the last latch reset.
  • VIDeo -- sets the instrument to receive a trigger when the input signal reaches a specified level in dBm.
  • EVIDeo -- sets the instrument to receive a trigger from a combination of sources: an external pulse to arm the trigger, and a video signal to perform the trigger.
  • BUS -- sets the instrument to receive a trigger from a *TRG command.
  • BEXTernal -- sets the instrument to receive a trigger from a combination of sources: a bus *TRG to arm the trigger, and an external signal to perform the trigger.
  • BVIDeo -- sets the instrument to receive a trigger from a combination of sources: a bus *TRG to arm the trigger, and a video signal to perform the trigger.
Query | Return | Set | Special | Units
yes | IMM| EXT| ELAT| VID| EVID| BUS| BEXT| BVID | IMMediate| EXTernal| ELATched| VIDeo| EVIDeo| BUS| BEXTernal| BVIDeo | Default | none

Trigger Mode

The trigger mode determines how the instrument acquires data when more than one data acquisition is required to complete a measurement:

  • On Measurement starts the first data acquisition and then immediately takes any subsequent data acquisitions needed to complete the measurement. In this mode, only the first data acquisition of a measurement is synchronized with a trigger. Subsequent data acquisitions needed to complete the measurement proceed immediately without waiting for any further triggers.
  • On Acquire starts a single data acquisition and then waits for another trigger to continue with the subsequent data acquisition. In this mode, every data acquisition in the measurement waits for a trigger to synchronize it to the events.

The On Acquire trigger mode is most useful for the channel power list and ACPR measurements, since they are comprised of discrete data acquisitions. This mode is also useful if you want data acquisitions synchronized to a trigger event.

Remote control commands

:TRIGger[:SEQuence]:MODE

Video Level

Sets the power level that the incoming RF signal must reach to cause a trigger event.

Remote control commands

:TRIGger[:SEQuence]:LEVel

Trigger Delay

When the trigger delay is set to zero, the center point of the data window is where the trigger occurred. Changing the trigger delay value allows you to see measurement trace events that occurred before or after the trigger. The trigger delay value is the point at the center of the data acquisition window.

Remote control commands

:TRIGger[:SEQuence]:DELay

Auto Trigger Timeout

Sets the time to wait in seconds for a trigger before automatically providing an internal trigger to acquire a measurement:

  • Time Out ON enables the auto trigger timeout when selected.
  • Time Out sets the time to wait for a trigger.

Remote control commands

:TRIGger[:SEQuence]:AUTO:TIMEout

:TRIGger[:SEQuence]:AUTO[:STATe]

Video Trigger

Sets the parameters of the video trigger:

  • Signal Type sets the condition that causes a trigger:
    • Edge sets the trigger condition to be a transition of signal power over the specified video level.
    • Level sets the trigger condition to be a signal power level.
  • Slope sets the video trigger slope:
    • Positive sets the trigger to happen on the positive-going slope of a pulse. If the video trigger signal type is Edge, the RF signal must transition from a lower value to a higher value over the specified video level to cause a trigger.
    • Negative sets the trigger to happen on the negative-going slope of a pulse. If the video trigger signal type is Edge, the RF signal must transition from a higher value to a lower value over the specified video level to cause a trigger.
  • Pre-Qualification:
    • Level sets the power level boundary that the input signal must avoid for some specified time before the trigger will be recognized by the instrument.
    • Time sets a window area in seconds at some specified power level that the input signal must avoid before the trigger will be recognized by the instrument.

Remote control commands

:TRIGger[:SEQuence]:VIDeo:SLOPe

:TRIGger[:SEQuence]:TYPE

:TRIGger[:SEQuence]:PREQual:WINDow

:TRIGger[:SEQuence]:PREQual[:LEVel]

External Trigger
  • Slope sets the external trigger slope:
    • Positive sets the trigger to happen on the positive-going slope of a pulse.
    • Negative sets the trigger to happen on the negative-going slope of a pulse.

Remote control commands

:TRIGger[:SEQuence]:EXTernal:SLOPe


Sync Output settings panel

This panel allows you to set up settings for synchronizing signals.

Sync Type

Sets the event that causes a sync output pulse:

  • Off disables the sync output.
  • Begin Measurement sends a sync pulse when the measurement sweep begins.
  • Start Tune sends a sync pulse when the analyzer switches to the parameters for the next data point measurement.
  • Ready Acquire sends a sync pulse when the analyzer has settled at the current parameters and it is waiting for a trigger to acquire data at that measurement point.
  • Start Acquire sends a sync pulse when the analyzer starts to acquire data at the current measurement point.
  • End Acquire sends a sync pulse when the analyzer has finished acquiring data at the current measurement point.
  • End Measurement sends a sync pulse when the analyzer has reached the end of the measurement sweep.

Remote control commands

:SOUTput:MODE

Sync Polarity

Sets the polarity of the sync pulse:

  • Rising sets the sync pulse polarity to rising.
  • Falling sets the sync pulse polarity to falling.

Remote control commands

:SOUTput:POLarity

Pulse Sync Out

The Sync Output settings panel now offers a Pulse Sync Out button. This feature enables you to immediately send a sync out pulse from a Series 2800 VSA to trigger other equipment. This feature is valuable in making MIMO measurements.

Remote control command:

:SOUTput:IMMediate


Calibrate

Calibrates the analyzer hardware for amplitude accuracy. You should run this calibration daily and when there are changes in the ambient temperature.

Remote control command

:CALibrate[:ALL]


User flatness VSA

With this feature, the user can create or open a user flatness data file to implement a level offset that compensates for path losses.

Access the user flatness dialog box from the front panel interface: select Menu > Global Settings > User Flatness....

When you open a data file or create a new one, the application checks for the following requirements:

  • The maximum of 10 rows is not exceeded.
  • The frequencies are listed in ascending order.
  • The frequencies listed are within the limits of 0Hz to 100GHz. See User flatness range
  • The minimum frequency spacing of 1KHz is maintained.
  • All offsets are within the limits of ±100dB.

    Note: An error message appears at the bottom of the screen if the instrument detects any of the conditions listed above with the user flatness file. Select Dismiss to remove the error message. Otherwise, the error message will stay on the screen and it may block any subsequent messages associated with other user flatness files that you attempt to load.

Example user flatness file:

FLATNESS Version 1.0,

Begin Table,

Frequency(Hz),Offset(dB)

9.980E+08,10

9.981E+08,10

9.982E+08,10

9.983E+08,10

9.984E+08,10

9.985E+08,10

9.986E+08,10

The following control buttons are on the top of the user flatness dialog box:

  • Data File allows manipulation of files with the following choices:
    • Open... opens a file browser window to enable you to select a file from the "user" folder, a USB memory stick, or a shared network folder. The name of the opened file appears (in brackets) in the title bar. If an open file is modified, an asterisk appears next to the file name. If you choose to create a new file or open another existing file, you are prompted to save the modified file. If you select "No," the new file table or the selected file is opened and your modifications to the last file are not saved.
    • New... opens a blank file table that you can modify by inserting and modifying rows. Once you have created a new frequency/offset table, you can save and name it.
    • Save... saves the current active file under the bracketed name displayed in the upper-left title bar (next to the label User Flatness). When no previously saved file is open, this choice is grayed out.
    • Save as... allows saving a new or modified file under a new name.
  • Insert Above creates the first row in a table, or if you first select an existing row, a new row is inserted above it with data in the Frequency(Hz) and Offset(dB) columns. By default the new row is 1 kHz lower in frequency than the row below it and has the same offset.
  • Insert Below creates the first row in a table or if you first select an existing row, a new row is inserted below it with data in the Frequency(Hz) and Offset(dB) columns. By default the new row is 1 kHz higher in frequency than the row above it and has the same offset.
  • Delete deletes an existing row. As rows are deleted, the row above the deleted one becomes the selected row. If the user flatness file is turned On, you can delete all but the last row while maintaining the User Flatness On. If the last row is deleted, the user flatness feature is turned Off.
  • On/Off toggles the amplitude offset On and Off.

You can use the standard controls (front panel knob, or puck) to modify the contents of any cell on the file table. If you double-click on any cell within the file table or press the center button on the puck, the number pad is called up to set the value of that cell. Refer to Changing a value for further details on editing values.

Once a file has been opened and modified, an asterisk appears next to the file name in the title bar and remains until the file is saved.

There are two SCPI commands related to user flatness:

  • [:SOURce]:UFLatness:LOAD selects and loads the user flatness data file. The default file extension is .csv and directory aliases are recognized.
  • [:SOURce]:UFLatness:STATe switches the user flatness on/off.

Under remote programming, no confirmation messages (for example, "Do you want to save changes before continuing?") are present if a new file is called up after changes have been made to the previous file.


User flatness range

The range of frequencies possible in a user flatness data file is 0Hz to 100GHz. Although this range of frequencies is outside the range of the instrument, it has been designed to accommodate customer calibration operations that may be outside the frequency range of the instrument.


[:SOURce]:UFLatness

Controls the user-flatness settings.

Select a blue link to view the command details:

  • [:SOURce]:UFLatness:LOAD
  • [:SOURce]:UFLatness:STATe

Also see User flatness VSA.

[:SOURce]:UFLatness[:STATe]

Enables and disables the user flatness operation. See User flatness.

HorizontalRuleSm
Parameters |
<b> | ON (or 1) switches on the user flatness mode.
 | OFF (or 0) switches off the user flatness mode.
 | DEFault returns to the default (preset) mode.
HorizontalRuleSm
 | [:SOURce]:UFLatness:STATe 1
Examples | :UFL:STAT ON
 | :uflatness:state off
HorizontalRuleSm
Query Syntax | [:SOURce]:UFLatness:STATe?
Return Type | Boolean (1 = On, 0 = Off)
HorizontalRuleSm
Default | Off (or 0)


[:SOURce]:UFLatness:LOAD

Selects the user flatness data file that gets loaded in the instrument. If no filename is specified, the current user flatness parameter settings are loaded. A query returns the filename, if the user flatness is enabled. See User flatness.

HorizontalRuleSm
Parameters |
<string> | Filename sets the filename and path for the selected waveform. You can optionally specify the file extension (*.csv).
HorizontalRuleSm
 | [:SOURce]:UFLatness:LOAD TUESDAY1.csv
Examples | :UFL:LOAD TUESDAY1
 | :uflatness:load tuesday1
HorizontalRuleSm
Query Syntax | [:SOURce]:UFLatness:LOAD?
Return Type | String
HorizontalRuleSm
Default | n/a

Example:

You can use the programming command [:SOURce]:UFLatness:LOAD to load a file from a directory in the Model 2910-VSG, a USB memory stick inserted in the Model 2910-VSG, or another computer directory. To load a file from one of the available directories, use the following paths in the programming message.

Directory | Directory path in programming message
User Flatness User | User flatness\User\filename
another computer directory | \\UNC\directory\filename
USB (connected first) | \USB
USB (connected second) | \USB2
USB (connected third) | \USB3
USB (connected fourth) | \USB4


Advanced
  • ADC dither
  • Extend Freq
  • DSP range
  • DSP randomize
  • Advanced Settings


ADC Dither

Enables and disables the ADC dither functionality. When the function is enabled, the analyzer suppresses discrete spurs in the measurement. When the function is disabled, the analyzer lowers the noise for better phase noise measurements, but the spur suppression is not applied to the measurement.

Remote control command

[:SENSe]:ACD:DITHer[:STATe]


DSP range

Enables and disables the DSP process of checking for an input overload.

Remote control command

[:SENSe]:DSP:RANGe[:STATe]


DSP Randomize

Enables and disables the DSP process of randomly setting the actual start time of a free run trigger to avoid a repetitive static measurement period.

Remote control command

[:SENSe]:DSP:RANDomize[:STATe]


Advanced Settings

The capabilities listed in the Advanced Hardware Settings dialog box are best utilized with the assistance of a Keithley Instruments application engineer. Use of these features may adversely affect other functions of the instrument. These features will evolve over time with new releases of software.

See also:

Background Tasks


Background Tasks

Background tasks include checks on lock status, oven heater temperature and overall temperature.


Utilities

To learn about the VSA utilities, select from the following:

  • Screen saver
  • GPIB address
  • Time and date
  • Ethernet Settings
  • LAN Config Init
  • Upgrade Software
  • Licensing
  • Calibrate Touch Screen
  • SCPI Debug


Screen saver

You can set the screen to switch off after a specified time.

Access the Screen Saver dialog box by selecting Menu > Utilities > Screen Saver.

The selection range is 1 to 600 minutes. The default value is 60 minutes.

  1. Select the Screen Saver Delay to change the value.
  2. Select the Screen Saver On button to apply the change.

Notice the button background color changes to green.


Time and date

You can adjust the instrument computer time and date settings.

Access the Time and Date dialog box by selecting Menu > Utilities > Time and Date...

The current settings are shown. The value range for each field is as follows:

  • Hour (1 - 24)
  • Minute (1 - 60)
  • Second (1 - 60)
  • Month (1 - 12)
  • Day (Depends on the month)
  • Year (2005 - 9999)

To save changes, select the Set System Time and Date To Above Values button.


Ethernet settings

You can adjust the Ethernet (LAN) settings directly or automatically. Select a method to learn more:

  • Obtain an IP address by means of DHCP
  • Specify an IP address
  • Advanced tab

Access the dialog box by selecting Menu > Utilities > Ethernet Settings...


Obtain an IP address via DHCP

Select: Menu > Utilities > Ethernet Settings...

The default condition is to obtain an IP address by means of DHCP as shown. In this condition all IP address and named server fields are grayed out and cannot be changed.

If Specify an IP address is selected:


Specify an IP address
  1. Select Specify an IP address. The IP address and named server text fields are now available for modification.
  2. After modifying these text fields, select Apply to accept the changes, or Cancel to keep the Ethernet setting selection by way of DHCP.

Advanced tab

Select this tab if you want to select the network speed or change sockets numbers.

Network speed:

The default mode is auto-negotiate and this is the recommended setting

Selections for 10 Mbps and 100 Mbps are provided for troubleshooting when network difficulties are experienced.

To change a the network speed setting:

  1. Select one of the three radio buttons
  2. Select Apply
  3. Disconnect the LAN cable for 30 seconds or recycle power for the system to recognize the change

SCPI listen port:

This is the socket port that an application can open to communicate with the instrument using SCPI commands.

Applet listen port:

This is the socket port that the Web applet uses to communicate with the instrument.

Note: You don't normally need to change this number except in cases where this default socket number is not available within your network. In such cases, contact your IT department.


LAN config init

You can restore the following default LAN configuration conditions:

  • The IP address is obtained by way of DHCP
  • The user name is the original value (admin)
  • The password is the original value (admin)

Access the LAN Config Init dialog box by selecting Menu > Utilities > LAN Config Init... Select Yes to restore the default conditions.


Software upgrade files

You can download the instrument software upgrade files from the www.keithley.com website and run the installation from the instrument screen or the LXI web interface.

Access the software upgrade dialog box by selecting Menu > Utilities > Upgrade Software...

See To open a software upgrade file for instructions.


To open a software upgrade file

With the front panel interface:

  1. On a computer, launch a web browser and download the latest software upgrade file from the www.keithley.com website.
  2. Save the file to a location that you can access from the instrument. A USB memory stick is convenient for this purpose.
  3. Select Menu > Utilities > Upgrade Software.
  4. Navigate to the location of the upgrade file that you just downloaded and saved.
  5. Select (highlight) the file and select Open.

With the web interface:

Although you can upgrade the instrument software from the web interface, you will not be able to detect the progress of the upgrade from the remote interface. You may want to upload the upgrade file to the instrument, and then run the upgrade process locally.

  1. Connect the instrument to a web network that includes your computer.
  2. On the computer, launch a web browser and download the latest software upgrade file from the www.keithley.com website. Save it to a directory on the computer.
  3. In the web browser, use the instrument IP address as the URL.
    • If you do not know the instrument IP address, select Menu > Utilities > Ethernet Settings from the instrument front panel.
  4. Click Instrument on the web page. The virtual front panel is shown.
  5. Click Menu > Utilities > Upgrade Software.
  6. You may need to type the username / password (default is admin / admin) to proceed.
  7. Click Browse and navigate to the location of the file that you just downloaded from the Keithley Instrumentswebsite.
  8. Click Upload. This copies the file to the instrument software upgrade directory.
  9. Click Start Upgrade and then click the file that you uploaded to the instrument.
  10. Click Load.


Software Upgrade

You can download the instrument software upgrade files from the www.keithley.com website and run the installation from the instrument screen or the LXI web interface.

Access the software upgrade dialog box by selecting Menu > Utilities > Upgrade Software...

See To open a software upgrade file for instructions.


Licensing

Refer to the measurement personality licensing options available for you instrument:

  • Model 2810 VSA Measurement personality license files
  • Model 2820 VSA Measurement personality license files


Model 2810 VSA Measurement personality license files

The Model 2810 VSA requires license files to access the digital modulation analysis capabilities of the instrument. To view the current licenses installed on your instrument, select Menu > Utilities > Licensing. You can purchase the following licenses for your instrument:

  • License Option 2810-CDMA-R (cdma2000® and IS-95a reverse link signal analysis personality) This license replaces the former 2810-CDMA.
  • License Option 2810-GSM (GSM, GPRS and EDGE signal analysis personality)
  • License Option 2810-WCDMA-U (W-CDMA FDD uplink signal analysis personality) This license replaces the former 2810-WCDMA.
  • License Option 2810-WCDMA-D (W-CDMA FDD downlink signal analysis personality)

Purchasing measurement personality licenses

You can purchase license files when you order your instrument, or at any time after you have received your instrument. Contact your Keithley Instruments sales representative with the description of the licenses that you want to purchase.

  • See To open a measurement personality license file for details on how to purchase and install a license.
  • See RF Product Software License Agreement to view the digital modulation licensing agreement.

Personality license ID

The license identification (ID) contains information that describes the specific instrument and the current license status. The license ID is unique and therefore changes each time the license status is modified. For example, the license ID would change in the following situations:

  • When the instrument imports newly purchased licenses.
  • When the instrument imports existing licenses that were transferred from another instrument.
  • When the instrument exports licenses to another instrument.

For information on viewing and saving the current license ID, see To view current licenses and license ID.

Transferring measurement personality licenses

You can move personality licenses between instruments. For example, if you do not require the GSM license in one instrument, you can move the license to another instrument that is in a test system that requires the GSM measurement capability.

You can also transfer modulation licenses from two separate instruments into a third instrument; however, you must perform the steps in a particular sequence.

Note: You must use the instrument LXI web interface to transfer licenses between instruments.

See To move personality license files for details on how to transfer existing license files between instruments.


RF product software license agreement

NOTICE TO USERS: CAREFULLY READ THE FOLLOWING RF PRODUCT SOFTWARE LICENSE AGREEMENT (THIS "AGREEMENT"). BY USING ALL OR ANY PORTION OF THE LICENSED PRODUCT (AS DEFINED BELOW), YOU ACCEPT ALL TERMS AND CONDITIONS OF THIS AGREEMENT. YOU AGREE THAT THIS AGREEMENT IS ENFORCEABLE LIKE ANY WRITTEN NEGOTIATED AGREEMENT SIGNED BY YOU. THIS AGREEMENT IS ENFORCEABLE AGAINST YOU AND ANY LEGAL ENTITY THAT OBTAINED THE LICENSED PRODUCT AND ON WHOSE BEHALF IT IS USED. IF YOU DO NOT AGREE, DO NOT USE THE LICENSED PRODUCT. IF YOU ACQUIRED THE LICENSED PRODUCT ON TANGIBLE MEDIA (E.G. CD) WITHOUT AN OPPORTUNITY TO REVIEW THIS LICENSE AND YOU DO NOT ACCEPT THIS AGREEMENT, YOU MAY OBTAIN A REFUND OF ANY AMOUNT YOU ORIGINALLY PAID IF YOU: (A) DO NOT USE THE LICENSED PRODUCT AND (B) RETURN IT, WITH PROOF OF PAYMENT, TO THE LOCATION FROM WHICH IT WAS OBTAINED WITHIN THIRTY (30) DAYS OF THE PURCHASE DATE.

"Licensed Product" means (a) all of the contents of the files, disk(s), CD-ROM(s) or other media with which this Agreement is provided, including but not limited to (i) software embedded in and/or provided with RF Product ("Software"); and (ii) related explanatory written materials and manuals pertaining to the Software provided by Keithley Instruments with the Software ("Documentation"); (b) upgrades, modified versions, updates, and additional features and functionality, if any, licensed to you by Keithley Instruments pursuant to the RF Product Software Option Certificate (collectively, "Option").

RF Product shall mean Model 2910 Vector Signal Generator and/or Models 2810 and/or 2820 Vector Signal Analyzer and/or 290101 SignalMeister™ Waveform Creation Software.

"You" means the individual using the Licensed Product, as well as your employer ("Company").

Grant of license

In consideration of payment of the applicable fees to Keithley Instruments ("Keithley"), Keithley grants to you, subject to the terms and conditions of this Agreement, a non-exclusive license to use the portion of the Licensed Product only in connection with the RF Product in which the Licensed Product is embedded and for your own internal business use, and not for the benefit of any other person or entity. The Licensed Product is licensed for use by a single organization and may not be used for processing of third-party data as a service bureau. Any Options requested by you shall require purchase of a software key code from Keithley, and you acknowledge that the Options will not function without a certain, unique software key code provided by Keithley. The software key code will be furnished to you by Keithley with the RF Product Software Option Certificate; you agree that such software key code is to be used solely with the Options for which it is provided, and the Options shall be used only in connection with the Licensed Product and RF Product identified in the Certificate. While Keithley may (in its sole discretion) provide you with the applicable key prior to receipt from you of the applicable license fees, you will remain obligated to pay such fees to Keithley. You may have the right to transfer the Options from one RF Product identified in the Certificate for which the Options are licensed by Keithley ("Transferring RF Product") to another RF Product purchased by the Company from Keithley ("Transferred RF Product"). In the event of the transfer of Options from the Transferring RF Product to Transferred RF Product, the Options will be disabled on the Transferring RF Product by Keithley and you shall have the right to use the Options only on the Transferred RF Product. Floating, concurrent and shared use of the Licensed Product is not permitted under this Agreement.

Ownership

Keithley and its third-party suppliers own all right, title, and interest in and to the Licensed Product. You acknowledge that all right, title and interest in and to the Licensed Product will remain the exclusive property of Keithley and its suppliers, and you will not acquire any rights in or to the Licensed Product except as expressly set forth in this Agreement. The Licensed Product is protected by law, including without limitation the copyright laws of the United States and other countries, trade secret laws, and by international treaty provisions. Except as expressly stated herein, this Agreement does not grant you any intellectual property rights in the Licensed Product and all rights not expressly granted are reserved by Keithley and its third-party suppliers.

Limitations on use

You will not remove any copyright, trademark, or other proprietary notices from the Licensed Product or any media relating thereto. You agree that you will not (i) attempt to reverse compile, reverse engineer, modify, translate, adapt or disassemble the Licensed Product, nor attempt to discover, create the source code from the object code for the Licensed Product, in whole or in part, and (ii) rent, lease, sublicense, assign or transfer your rights in the Licensed Product, or authorize all or any portion of the Licensed Product to be copied onto any products or another user's computer, except as may be expressly permitted herein.

Termination

This Agreement is effective until terminated. Except in the event of your failure to comply with the section titled "Export Restriction," in which case, Keithley shall have the right to terminate this Agreement immediately. Either party shall have the right to terminate this Agreement if the other fails to perform or observe any provision, term, covenant, warranty, or condition of this Agreement (a "Default"), provided fifteen (15) days notice of termination (the "Notice") is provided to the defaulting party, and the defaulting party fails to cure the claimed Default within ten (10) days from the date of receipt of the Notice. Within three (3) days from the date of any termination of this Agreement, each and every embodiment of the Licensed Product in any form whatsoever, and all documentation, files and other materials in any form relating thereto, shall be destroyed, and all traces of the Licensed Product shall be permanently purged from the RF Product.

Export restrictions

You warrant, agree and give assurance to Keithley that you will not at any time (i) sell, transmit, export, re-export, release or otherwise disclose, either directly or indirectly, the Licensed Product and the RF Product, or any part thereof, including without limitation any source code or technology relating to the Licensed Product and the RF Product, (ii) permit Licensed Product and RF Product to be sold, transmitted, disclosed, released, exported, re-exported to countries or nationals of countries in Country Groups D:1 or E:2, as set forth in Supplement 1 to Part 740 of the United States Export Administration Regulation ("EAR"), or (iii) permit use of the Licensed Product and RF Product in any manner prohibited by the EAR or any other export laws, restrictions or regulations. All rights to use the Licensed Product are granted on condition that such rights shall be immediately forfeited if you fail to comply with the terms of this Section.

U.S. government restricted rights

The Licensed Product is "Commercial Items," as that term is defined at 48 C.F.R. §2.101, consisting of "Commercial Computer Software" and "Commercial Computer Software Documentation," as such terms are used in 48 C.F.R. §12.212 or 48 C.F.R. §227.7202, as applicable. Consistent with 48 C.F.R. §12.212 or 48 C.F.R. §§227.7202-1 through 227.7202-4, as applicable, the Commercial Computer Software and Commercial Computer Software Documentation are being licensed to U.S. Government end users (a) only as Commercial Items and (b) with only those rights as are granted to all other end users pursuant to the terms and conditions herein. Unpublished-rights reserved under the copyright laws of the United States to Keithley Instruments, Inc., 28775 Aurora Rd., Solon, Ohio 44139, USA.

Limited warranty

Keithley does not warrant that operation of the Licensed Product will be uninterrupted or error-free, or that the Licensed Product will be adequate for your intended application or use. Keithley warrants to you that the Software will substantially perform in accordance with the specifications set forth in the Documentation for a period of three (3) years after your receipt of the RF Product (the "Warranty Period"), provided the Software is used only in connection with the RF Product in which it is embedded and in accordance with the Documentation. If the Software is not performing as warranted herein during the Warranty Period, as determined by Keithley, in its sole discretion (a "Nonconformity"), your exclusive remedy under this limited warranty is either a correction of the Software or an explanation by Keithley of how to use the Software despite the Nonconformity, at Keithley's option. The foregoing limited warranty shall be null and void (i) upon any modification of the Licensed Product, unless approved in writing by Keithley; (ii) the use of the Licensed Products in combination with any other product or data than the RF Product in which the Software is embedded; (iii) if failure of the Licensed Product has resulted from accident, abuse, misapplication, improper calibration by you, third-party products (i.e., hardware or software) used by you which are not intended by Keithley for use with the Licensed Products; (iv) utilization of an improper hardware or software key (if applicable); and/or (v) unauthorized maintenance of the Licensed Product; The portions of the Licensed Product not developed and owned by Keithley shall not be covered by this limited warranty, and Keithley shall have no duty or obligation to enforce any thirdparty supplier's warranties on your behalf. The failure to notify Keithley of a Nonconformity during the Warranty Period shall relieve Keithley of its obligations and liabilities under this limited warranty.

EXCEPT FOR THE FOREGOING, THE LICENSED PRODUCT IS PROVIDED "AS IS" WITHOUT ANY WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, WHETHER BY STATUTE, COMMON LAW, CUSTOM, USAGE OR OTHERWISE, INCLUDING BUT NOT LIMITED TO, THE WARRANTIES OF MERCHANTABILITY, NONINFRINGEMENT OF THIRDPARTY RIGHTS, INTEGRATION, ACCURACY, SATISFACTORY QUALITY AND FITNESS FOR A PARTICULAR PURPOSE.

THE LICENSED PRODUCT IS NOT FAULT TOLERANT AND IS NOT DESIGNED OR INTENDED FOR USE (i) IN HAZARDOUS ENVIRONMENTS REQUIRING FAIL-SAFE PERFORMANCE INCLUDING WITHOUT LIMITATION, IN THE OPERATION OF NUCLEAR FACILITIES, AIRCRAFT NAVIGATION OR COMMUNICATION SYSTEMS, AIR TRAFFIC CONTROL, WEAPONS SYSTEMS, DIRECT LIFE-SUPPORT MACHINES, OR ANY OTHER APPLICATION IN WHICH THE FAILURE OF THE LICENSED PRODUCT COULD LEAD TO DEATH, PERSONAL INJURY OR SEVERE PHYSICAL OR PROPERTY DAMAGE (COLLECTIVELY "HAZARDOUS ACTIVITIES"); OR (ii) WITH COMPONENTS AND TESTING FOR A LEVEL OF RELIABILITY SUITABLE FOR USE IN OR IN CONNECTION WITH SURGICAL IMPLANTS, OR AS CRITICAL COMPONENTS IN ANY LIFE-SUPPORT SYSTEMS WHOSE FAILURE TO PERFORM CAN REASONABLY BE EXPECTED TO CAUSE SIGNIFICANT INJURY TO HUMANS ("SYSTEMS ACTIVITY"). KEITHLEY AND ITS THIRDPARTY SUPPLIERS EXPRESSLY DISCLAIM ANY EXPRESS OR IMPLIED WARRANTY OF FITNESS FOR HAZARDOUS ACTIVITIES AND/OR SYSTEMS ACTIVITY.

Limitation of liability

KEITHLEY'S SOLE LIABILITY OR OBLIGATION UNDER THIS AGREEMENT IS SET FORTH ABOVE IN THE LIMITED WARRANTY SECTION OF THIS AGREEMENT. IN NO EVENT SHALL KEITHLEY AND ITS THIRD-PARTY SUPPLIERS BE LIABLE FOR ANY DAMAGES RESULTING FROM USE OR INABILITY TO USE THE LICENSED PRODUCT, ANY TECHNICAL SUPPORT SERVICES RELATING TO THE LICENSED PRODUCT OR RELATED HARDWARE, INCLUDING WITHOUT ANY LIMITATION ANY LIABILITY FOR: (1) ECONOMIC, INCIDENTAL, CONSEQUENTIAL, LOST PROFITS, LOST SAVINGS, BUSINESS INTERRUPTION, INDIRECT, SPECIAL, PUNITIVE OR EXEMPLARY DAMAGES, WHETHER CLAIMED UNDER CONTRACT, TORT OR ANY OTHER LEGAL THEORY; (2) LOSS OF OR DAMAGE TO YOUR DATA OR PROGRAMMING; (3) PENALTIES OR PENALTY CLAUSES OF ANY DESCRIPTION; OR (4) INDEMNIFICATION OF YOU OR OTHERS FOR COSTS, DAMAGES, OR EXPENSES RELATED TO THE GOODS OR SERVICES PROVIDED UNDER THIS AGREEMENT. In no event shall Keithley's liability for any bodily injury, death and/or property damage exceed the greater of $500 (U.S.) or the amount of license fee actually paid by you to Keithley for the Licensed Product if the foregoing limitation of liability is not enforceable because the Licensed Product, the services, or the hardware is determined by a court of competent jurisdiction in a final, non-appealable judgment to be defective and to have directly caused bodily injury, death, or property damage. The foregoing limitations, exclusions and disclaimers shall apply to the maximum extent permitted by applicable law, even if any remedy fails its essential purpose.

Limitation of liability for users residing in Germany and Austria.

If you obtained the Licensed Product in Germany or Austria, and you usually reside in such country, then Section titled "Limitation of Liability" does not apply to you. Instead, subject to the provisions in this Section, Keithley's statutory liability for damages shall be limited as follows: (i) Keithley shall be liable only up to the amount of damages as typically foreseeable at the time of entering into the purchase agreement for an RF Product in respect of damages caused by a slightly negligent breach of a material contractual obligation, and (ii) Keithley shall not be liable for damages caused by a slightly negligent breach of a non-material contractual obligation. The aforesaid limitation of liability shall not apply to any mandatory statutory liability, in particular, to liability under the German Product Liability Act, liability for assuming a specific guarantee or liability for culpablycaused personal injuries. You are required to take all reasonable measures to avoid and reduce damages, specifically to make back-up copies of the Licensed Product and your computer data subject to the provisions of this Agreement.

Compliance with licenses

If you are a business or organization, you agree that upon request from Keithley or Keithley's authorized representative, you will within thirty (30) days after receiving notice from Keithley, fully document and certify that use of any and all Licensed Product at the time of the request is in conformity with your valid licenses from Keithley. You agree and your Company shall make all applicable records available for review by Keithley during your Company's normal business hours so as to permit Keithley (upon reasonable notice to you) to verify your and Company's compliance with the terms and conditions of this Agreement. Keithley may (upon written notice) inspect your use of the Licensed Products during your Company's normal business hours to ensure your compliance with this Agreement.

Miscellaneous

In the event of invalidity of any provision of this Agreement, the parties agree that such invalidity shall not affect the validity of the remaining portions of this Agreement. This Agreement shall be governed by and construed in accordance with the laws of the state of Ohio, exclusive of any provisions of the United Nations Convention on the International Sale of Goods, and without regard to any principle of conflicts of laws. This is the entire agreement between you and Keithley Instruments, Inc., and supersedes any prior agreement or understanding, whether written or oral, relating to the subject matter of this license. To the extent the terms of any purchase order, Certificate, or any Keithley policies or programs for providing any support services for the Software conflict with the terms of this Agreement, the terms of this Agreement shall control. Any waiver by either party of any provision of this Agreement shall not constitute or be deemed a subsequent waiver of that or any other provision. The provisions of the Sections titled Ownership, Limitation on Use, Export Restrictions, Limited Warranty, Limitation of Liability, Limitation of Liability for Users Residing in Germany and Austria, Compliance with Licenses, and Miscellaneous shall survive the termination of this Agreement.

Should you have any questions concerning this Agreement, or if you desire to contact Keithley Instruments for any reason, please call Keithley at 1-888-KEITHLEY (1-888-534-8453), or write to Keithley Instruments, 28775 Aurora Rd., Solon, Ohio, USA 44139.

Current worldwide phone numbers are available on the Keithley Instruments website at www.keithley.com.

KEITHLEY

A GREATER MEASURE OF CONFIDENCE

Keithley Instruments, Inc.


Model 2820 VSA Measurement personality license files

The Model 2820 VSA requires license files to access the digital modulation analysis capabilities of the instrument. To view the current licenses installed on your instrument, select Menu > Utilities > Licensing. You can purchase the following licenses for your instrument:

  • License Option 2820-CDMA-R (cdma2000® and IS-95a reverse link signal analysis personality)
  • License Option 2820-GSM (GSM, GPRS and EDGE signal analysis personality)
  • License Option 2820-WCDMA-U (W-CDMA FDD uplink signal analysis personality)
  • License Option 2820-WCDMA-D (W-CDMA FDD downlink signal analysis personality)
  • License Option 2820-80211 (WLAN 802.11a,b,g & j signal analysis)

Purchasing measurement personality licenses

You can purchase license files when you order your instrument, or at any time after you have received your instrument. Contact your Keithley Instruments sales representative with the description of the licenses that you want to purchase.

  • See To open a measurement personality license file for details on how to purchase and install a license.
  • See RF Product Software License Agreement to view the digital modulation licensing agreement.

Personality license ID

The license identification (ID) contains information that describes the specific instrument and the current license status. The license ID is unique and therefore changes each time the license status is modified. For example, the license ID would change in the following situations:

  • When the instrument imports newly purchased licenses.
  • When the instrument imports existing licenses that were transferred from another instrument.
  • When the instrument exports licenses to another instrument.

For information on viewing and saving the current license ID, see To view current licenses and license ID.

Transferring measurement personality licenses

You can move personality licenses between instruments. For example, if you do not require the GSM license in one instrument, you can move the license to another instrument that is in a test system that requires the GSM measurement capability.

You can also transfer modulation licenses from two separate instruments into a third instrument; however, you must perform the steps in a particular sequence.

Note: You must use the instrument LXI web interface to transfer licenses between instruments.

See To move personality license files for details on how to transfer existing license files between instruments.


SCPI debug

SCPI debug is a feature that can be turned on for troubleshooting purposes. Once turned on, all remote commands received by the instrument will be displayed on the instrument display.

This dialog box is accessed by selecting: Menu > Utilities > SCPI Debug...

To enable SCPI Debug, select the SCPI Debug check box.

To disable SCPI Debug, select the SCPI Debug check box again.

NOTE: Once this feature is enabled, a SCPI Debug window opens on the instrument screen. This window displays the SCPI commands sent to the instrument. Once you close this window (by selecting File > Close, or by selecting the "X" on the upper-right corner of the screen, you cannot open this screen again (by the SCPI Debug toggle switch) until you cycle power on the instrument.


Calibrate touch screen

You can calibrate the instrument touch screen by aligning the screen and displayed image at five locations.

Access the Calibrate Touch Screen panel by selecting Menu > Utilities > Calibrate Touch Screen.

  1. Select the center of each of the five cross cursors for the instrument to determine touch screen readings associated with each cursor position.
  2. Tap the screen to save the new readings.

    Note: If you do not tap the screen within 30 seconds the previous values will be restored.


Help

Select one of the following to learn more:

  • Keithley Instruments Series 2800 VSA Help
  • About Keithley Instruments Series 2800 VSA
  • Instrument Help

See also:

Series 2800 VSA System Help

Context sensitive Help


Keithley Instruments Series 2800 VSA Help

Selecting this choice opens the Instrument Help system that is stored in the instrument.


Series 2800 VSA System Help

The Series 2800 System Help is a standalone version of the Help system installed in the instrument. This version can be loaded onto a PC and used for general reference, training and programming command lookup.


About Keithley Instruments Series 2800 VSA

This selection displays information that has been stored for this particular instrument.

This page is very useful for the Keithley Instruments service department.

On this page is you will find the following information:

  • Software Version
  • Build Number
  • Serial Number
  • OS Version

In addition there is also LXI and firmware information.


Instrument Help

Instrument Help provides more topic information, and topics are linked allowing browsing between them. This form of user assistance uses the whole touch screen to display information and interacts with the user. There is a table of contents and an index provided as further reference tools.

Here is how to access Instrument help:

Menu > Help > Help System...

The instrument help system replaces the application program on the display.

There are two major regions in the instrument help system, menu bar and page display. Both have navigation controls and using the two in combination, it is possible to navigate and find content.

Menu Bar

There are several buttons on the menu bar:

Home: Select this to open the instrument help home page. This acts as good starting point to move into major categories of information.

Back: Select this to go back to the previous help page backwards in a time line of help pages. This is handy for coming back from links that didn't have what you were looking for.

Forward: Select this to go forward to the next help page forward in a time line of help pages. This is handy for going backwards and forwards between two related help pages.

TOC: Select this to open a table of contents. All major topics in the instrument help system can be opened and viewed from here. It acts like a site diagram. The structure of the instrument help system can be seen as a whole.

Index: Select this to open an index help page. All major topics in the instrument help system can be viewed in alphabetical order and opened from here. This is handy if you are looking for a particular topic and are not sure where it would be located.

Help Page Display Region

This region displays the target help pages from the navigation links. The navigation links can be the buttons on the menu bar, or links within the help pages themselves. Many large topics start with a list of topics that can be jumped to and then end with "See Also" links to topics that may be related or of interest.

Some links are termed expanded line links and are designed to keep the user on the same page by giving a little more information about a particular topic.


Context sensitive Help

Any window or panel that has this button [image], will have a help page associated with it. Selecting this button will open that page. As the page is associated with the panel, it is referred to as context sensitive help, because the help provided is in the context of the window or panel of interest.


Controlling Measurements

The analyzer allows you to control various aspects of how a measurement is taken or controlled.

  • Attenuator and preamplifier for modifying input signal power.
  • Digital I/O for controlling equipment.
  • Frequency Reference for synchronizing equipment.
  • RF Out for stimulating devices.
  • Trigger for controlling when a measurement is taken.
  • Sync Out for communicating when an event has happened.
  • User Flatness for opening a data file to implement a level offset to compensate for path loss.
  • Calibrate for ensuring amplitude accuracy.
  • Advanced
    • ADC Dither for affecting phase noise.
    • Extend Freq for extending measurement frequency.
    • DSP Range for checking the input overload.
    • DSP Randomize for affecting the start time of a free run trigger.
    • More...Advanced Settings


Digital I/O connector pin out

The connector location and pin designations are shown below:

Digital IO 2810 connections


To set Digital I/O lines

An output line can be set high (H) or low (L). From the front panel, the decimal equivalent of the bit pattern is set. Use the table at the end of this topic to determine the decimal value for the bit pattern. For example, to set output 4 high and the outputs 1, 2, and 3 low, use decimal value "8." There are four output (write) bits and one input (read) bit.

From the front panel interface:

  1. Select Menu > Global Settings > Digital I/O.
  2. Turn the front panel knob to enter the desired Write Bits value in decimal format. This value is equivalent to the digital output pattern in binary format. In this example, the value has been changed to 5.

  3. Select the Read Bit: button. Notice the Read Bit's value is 1.

Use this table to determine the decimal value for the bit pattern. For example, to set output 4 high and the outputs 1, 2, and 3 low, use decimal value "8."

Output patterns for NRf parameter
Out 4 | Out 3 | Out 2 | Out 1 | Decimal
L | L | L | L | 0
L | L | L | H | 1
L | L | H | L | 2
L | L | H | H | 3
L | H | L | L | 4
L | H | L | H | 5
L | H | H | L | 6
L | H | H | H | 7
H | L | L | L | 8
H | L | L | H | 9
H | L | H | L | 10
H | L | H | H | 11
H | H | L | L | 12
H | H | L | H | 13
H | H | H | L | 14
H | H | H | H | 15

From the remote interface:

The :SOURce:TTL subsystem commands are used to set the logic level for the four output lines of the Digital I/O.

To control the Digital I/O output settings:

:TTL [MAXimum | MINimum | DEFault]

An output line can be set high (H) or low (L). When using the decimal format to set the bit pattern, use the table above to determine the decimal value for the parameter.

Example:

To set output 4 high and the outputs 1, 2, and 3 low, use parameter value "8" as shown in the table above.

When you are using one of the non-decimal formats, convert the decimal value for the bit pattern to the equivalent binary, octal, or hexadecimal value. Be sure to use the appropriate header (#B, #Q, or #H) with the non-decimal number. For example, for decimal 8, the binary equivalent for the parameter is #B1000.

When you are using the query command to read the set bit pattern, the format of the returned value depends on the presently set data format for :SOURce:TTL commands.

Example:

Set outputs 4 and 2 high and outputs 3 and 1 low:

:TTL:LEV #B1010 | Binary format.
[:SOURce]:TTL[:LEVel] <NDN> or <NRf> | Specify bit pattern for the four digital output lines 15.
[:SOURce]:TTL[:LEVel]? | Query set bit pattern.
[:SOURce]:TTL:INPut? | Query digital input state: Hi (1) or Lo (0).

Parameters:

<NRf> | = 0 to 15 | Decimal format |
<NDN> | = #Bxxxx | Binary format | xxxx = 0000 to 1111
 | = #Hx | Hexidecimal format | x = 0 to F
 | = #Qx | Octal format | x = 0 to 17


Digital input

Pin 8 of the Digital I/O is the digital input line. You can apply a TTL high or TTL low to this line. The state of the input (high or low) can be determined from the front panel or over the communication bus.

From the instrument front panel interface:

Select Menu > Global Settings > Digital I/O.

From the remote interface:

:SOURce:TTL:INPut?

If a high TTL level is on the input, this command will return a "1". If a low TTL level is present, a "0" will be returned.


Digital outputs

The Digital I/O port has four digital outputs. Each digital output can be used in the following ways:

  • A sink mode to control devices (for example, relays).
  • A source mode to provide input to external logic circuitry (TTL or CMOS).

The simplified schematic for the digital outputs is shown in the following graphic. Notice that this illustration shows the schematic for one digital output. All four digital output circuits are identical.

Digital output port simplified diagram

Digital out smaller


Sink mode

Controlling external devices

Each output can be operated from an external supply (voltage range from +5V to +30V applied through the external device being driven). The high current sink capacity of the output driver allows direct control of relays, solenoids, and lamps (no additional circuitry needed).

As shown in the graphic above, each of the digital, open-collector outputs includes a built-in pull up resistor connected to +5V. The output transistor is capable of sinking 250mA from voltages up to +30V. Each output channel contains a fly-back diode for protection when switching inductive loads (such as a low power solenoid or relay coils). To use these fly-back diodes, connect the external supply voltage to pin 9 of the Digital I/O port. Make sure the external supply voltage is between +5V and +30V and the current required by the device does not exceed 250mA.

CAUTION: On pin 9, do not exceed +30V. For the output lines, do not exceed the maximum sink current. The maximum sink current for an output line is 250mA. Exceeding these limits may cause damage to the instrument that is not covered by the warranty.

An externally powered relay connected to the digital output port is shown in the graphic. Other externally powered devices can be similarly connected by replacing the relay with the device. When the output line is pulled low (0V), the output transistor sinks current through the external device. In the high state, the output transistor is off (transistor switch open). This interrupts current flow through the external device.

Internal +5V supply

The +5V supply of the Digital I/O (pin 7) can be used to drive low-power devices. The maximum current that can be delivered to a DUT load is 100mA. Do not exceed this limit. As shown in the following graphic, the internal 5V supply can be used instead of the external power source by connecting the high side of the coil to pin 7 of the Digital I/O. Make sure both the coil and external power source are disconnected from pin 9.

Controlling externally powered relays


Source mode (logic control)

The digital outputs can be used as logic inputs to active TTL, low-power TTL, or CMOS inputs. For this mode of operation, the output lines can source up to 2mA.

CAUTION: Each output line can source up to 2mA. Exceeding 2mA may cause damage to the Series 2800 VSA that is not covered by the warranty.

The following graphic shows how to connect a logic device to one of the output lines. When the output line is pulled high, the transistor will turn off (transistor switch open) to provide a reliable TTL logic high output. When the output line goes low, the transistor turns on (transistor switch closed) to route current to digital ground. As a result, a low TTL logic output is provided at the output. If the second input (B) of the NAND gate is connected to another output line of the port and both digital outputs are set high, the output of the NAND gate will go to logic 0.

NAND gate control
Digital NAND 2810smaller


Frequency reference

In making measurements, it is often found useful to lock several instruments to the same frequency reference. For example, to achieve better frequency accuracy than the instrument internal frequency reference provides, a precision frequency reference source can be connected to the instrument, through a rear panel connector.

To change the instrument frequency reference source from the instrument screen or the LXI web interface, follow the steps below.

  1. Select Preset.
  2. Select Menu > Settings > Frequency Reference...
  3. Select the source of the frequency reference: Internal | Even Second In | External.
  • If you selected Internal or Even Second In, press Close to accept the settings.
  • If you selected External, select and change the value, if necessary.

    Values allowed for frequency reference are between (1 MHz to 20 MHz).

The Reference status indicator on the instrument screen shows the following indications:

  • Ref External Present if External is selected and an external reference is detected.
  • Ref External Missing if External is selected and no external reference is detected.

See Also:

Reference IN and OUT connector

EVEN SEC IN, OUT connectors

[:SOURce]:ROSCillator:SOURce

[:SOURce]:IEVensecond:POLarity

[:SOURce]:ROSCillator:EXTernal:FREQuency


Trigger settings panel

This panel allows you to set up settings for triggering signals.

Trigger Source

Sets the input trigger source:

  • Free Run triggers another measurement immediately at the end of each measurement if you have set continuous sweep. If you have set single sweep, you must select Sweep Single to trigger a measurement.
  • External triggers a measurement when the instrument receives an external signal pulse.
  • Video triggers a measurement when the input signal reaches the value specified.
  • Bus triggers a measurement when the instrument receives the *TRG command.
  • Ext Arm/Video Trig triggers a measurement when the instrument receives an external signal pulse and the input signal reaches the specified value.
  • Bus Arm/Ext Trig triggers a measurement when the instrument receives a *TRG command to arm the trigger and an external signal pulse.
  • Bus Arm/Video Trig triggers a measurement when the instrument receives a *TRG command to arm the trigger and the input signal reaches the specified value.
  • Ext Latched is similar to External. It triggers a measurement if the external input has sent an active edge since the last latch reset. The external trigger latch is reset when the trigger is used or the receiver sends a sync out signal.

Remote control command

:TRIGger[:SEQuence]:SOURce

Video Level

Sets the power level that the incoming RF signal must reach to cause a trigger event.

Remote control commands

:TRIGger[:SEQuence]:LEVel

Trigger Delay

When the trigger delay is set to zero, the center point of the data window is where the trigger occurred. Changing the trigger delay value allows you to see measurement trace events that occurred before or after the trigger. The trigger delay value is the point at the center of the data acquisition window.

Remote control commands

:TRIGger[:SEQuence]:DELay

Auto Trigger Timeout

Sets the time to wait in seconds for a trigger before automatically providing an internal trigger to acquire a measurement:

  • Time Out ON enables the auto trigger timeout when selected.
  • Time Out sets the time to wait for a trigger.

Remote control commands

:TRIGger[:SEQuence]:AUTO:TIMEout

:TRIGger[:SEQuence]:AUTO[:STATe]

External Trigger

  • Slope sets the external trigger slope:
    • Positive sets the trigger to happen on the positive-going slope of a pulse.
    • Negative sets the trigger to happen on the negative-going slope of a pulse.

Remote control commands

:TRIGger[:SEQuence]:EXTernal:SLOPe

Video Trigger

Sets the parameters of the video trigger:

  • Signal Type sets the condition that causes a trigger:
    • Edge sets the trigger condition to be a transition of signal power over the specified video level.
    • Level sets the trigger condition to be a signal power level.
  • Slope sets the video trigger slope:
    • Positive sets the trigger to happen on the positive-going slope of a pulse. If the video trigger signal type is Edge, the RF signal must transition from a lower value to a higher value over the specified video level to cause a trigger.
    • Negative sets the trigger to happen on the negative-going slope of a pulse. If the video trigger signal type is Edge, the RF signal must transition from a higher value to a lower value over the specified video level to cause a trigger.
  • Pre-Qualification:
    • Level sets the power level boundary that the input signal must avoid for some specified time before the trigger will be recognized by the instrument.
    • Time sets a window area in seconds at some specified power level that the input signal must avoid before the trigger will be recognized by the instrument.

Remote control commands

:TRIGger[:SEQuence]:VIDeo:SLOPe

:TRIGger[:SEQuence]:TYPE

:TRIGger[:SEQuence]:PREQual:WINDow

:TRIGger[:SEQuence]:PREQual[:LEVel]

Trigger Mode

The trigger mode determines how the instrument acquires data when more than one data acquisition is required to complete a measurement:

  • On Measurement starts the first data acquisition and then immediately takes any subsequent data acquisitions needed to complete the measurement. In this mode, only the first data acquisition of a measurement is synchronized with a trigger. Subsequent data acquisitions needed to complete the measurement proceed immediately without waiting for any further triggers.
  • On Acquire starts a single data acquisition and then waits for another trigger to continue with the subsequent data acquisition. In this mode, every data acquisition in the measurement waits for a trigger to synchronize it to the events.

The On Acquire trigger mode is most useful for the channel power list and ACPR measurements, since they are comprised of discrete data acquisitions. This mode is also useful if you want data acquisitions synchronized to a trigger event.

Remote control commands

:TRIGger[:SEQuence]:MODE


To set the trigger

Connections

From the front panel interface:

  1. Select Menu > Global Settings > Trigger.
  2. Select the arrow for the Trigger Source drop-down menu and choose the source of the trigger event:
    • Free Run triggers another measurement immediately at the end of each measurement if you have set continuous sweep.
    • External triggers a measurement when the instrument receives an external signal pulse.
    • Video triggers a measurement when the input signal reaches the value specified.
    • Bus triggers a measurement when the instrument receives the *TRG command.
    • Ext Arm/Video Trig triggers a measurement when the instrument receives an external signal pulse at the rear panel TRIG IN TTL input connector and the input signal reaches the specified value.
    • Bus Arm/Ext Trig triggers a measurement when the instrument receives a *TRG command to arm the trigger and an external signal pulse. (Applies to channel power list measurement only.)
    • Bus Arm/Video Trig triggers a measurement when the instrument receives a *TRG command to arm the trigger and the input signal reaches the specified value. (Applies to channel power list measurement only.)

      The remaining steps do not apply if you set the Trigger Mode to Free Run.

  3. Select Trigger Delay: field and enter a delay in seconds that you want the instrument to wait to respond to a trigger event. The trigger delay value is the point at the center of the data acquisition window
  4. If you want to set the Auto Trigger Timeout, follow the steps below:
    1. Select the Auto Trigger Timeout: checkbox.
    2. Select the Auto Trigger Timeout: field and enter the time for the instrument to wait in seconds for a trigger before automatically providing an internal trigger to acquire a measurement.
  5. Select settings that are relevant to the External trigger source, if you selected it:
    1. Select the arrow for the External Trigger Slope: drop-down menu.
    2. Choose whether the instrument receives a TTL signal pulse with a Positive (rising) edge, or a Negative (falling) edge from an external device.
  6. Select the settings that are relevant to the Video trigger source, if you selected it:
    1. Select the Video Level: field and enter a power level that the input signal must reach for a trigger event.
    2. Under the Advance tab, select the Video Trigger Signal Type: drop-down arrow and choose whether the burst Edge or Level will be the trigger event.
    3. Select the Pre-Qualification Level: field and enter the power level that the signal must stay below before the leading edge of a burst.
    4. Select the Pre-Qualification Time: field and enter the length of time that the signal must stay below the specified pre-qualification level before the leading edge of a burst.
  7. Select the Trigger Mode: drop-down arrow and choose the Series 2800 VSA behavior when it receives the conditions for a trigger event. The following set of tables describe the Series 2800 VSA behavior for each of the measurement/trigger mode combinations:
    • Spectrum measurements can have multiple acquisitions, depending on the span and bandwidth settings.
Trigger Source | On Measurement | On Acquire
Free Run | Measures continuously. | Measures continuously.
External | All acquisitions measured from a single trigger event. | One acquisition measured per trigger event.
Video
Ext Arm/Video Trig | All acquisitions measured from a single arm/trigger event. | One acquisition measured per arm/trigger event.
  • Zero span measurements are a single acquisition.
Trigger Source | On Measurement | On Acquire
Free Run | Measures continuously. | Behavior is the same as "On Measurement."
External | One measurement per trigger event.
Video
Ext Arm/Video Trig | One measurement per arm/trigger event.
  • ACPR consists of five zero-span measurements.
Trigger Source | On Measurement | On Acquire
Free Run | Measures continuously. | Measures continuously.
External | All five measurements taken from a single trigger event. | One of the five total measurements taken per trigger event.
Video
Ext Arm/Video Trig | All five measurements from a single arm/trigger event. | One of five total measurements per arm/trigger event.
  • Channel power list consists of a number of zero span measurements defined by the number of points in the list.
Trigger Source | On Measurement | On Acquire
Free Run | Measures continuously. | Measures continuously.
External | Measures all points in list from a single trigger event. | Measures a single point in the list per trigger event.
Video
Ext Arm/Video Trig | Measures all points in list from a single arm/trigger event. | Measures a single point in the list per arm/trigger event.
Bus Arm/Ext Trig
Bus Arm/Video Trig
  • GSM/EDGE
Trigger Source | On Measurement | On Acquire
Free Run | Measures continuously. | Behavior is the same as "On Measurement."
External | All data acquired from a single trigger event.
Video
Ext Arm/Video Trig | All data acquired from a single arm/trigger event.
  • cdma2000/W-CDMA Demodulate
Trigger Source | On Measurement | On Acquire
Free Run | Measures continuously. | Behavior is the same as "On Measurement."
External | All data acquired from a single trigger event.
Video
Ext Arm/Video Trig | All data is acquired from a single arm/trigger event.
  • cdma2000/W-CDMA ACPR
Trigger Source | On Measurement | On Acquire
Free Run | Measures continuously. | Measures continuously.
External | All data acquired from a single trigger event. | One of five total measurements per trigger event.
Video
Ext Arm/Video Trig | All data acquired from a single arm/trigger event. | One of five total measurements per arm/trigger event.
  • cdma2000/W-CDMA Spectral emission
Trigger Source | On Measurement | On Acquire
Free Run | Measures continuously. | Behavior is the same as "On Measurement."
External | All data acquired from a single trigger event.
Video
Ext Arm/Video Trig | All data acquired from a single arm/trigger event.
  • cdma2000/W-CDMA Occupied bandwidth
Trigger Source | On Measurement | On Acquire
Free Run | Measures continuously. | Behavior is the same as "On Measurement."
External | All data acquired from a single trigger event.
Video
Ext Arm/Video Trig | All data acquired from a single arm/trigger event.

From the remote interface:

:TRIGger[:SEQuence]:AUTO:TIMEout

:TRIGger[:SEQuence]:AUTO[:STATe]

:TRIGger[:SEQuence]:DELay

:TRIGger[:SEQuence]:EXTernal:SLOPe

:TRIGger[:SEQuence]:PREQual:WINDow

:TRIGger[:SEQuence]:PREQual[:LEVel]

:TRIGger[:SEQuence]:LEVel

:TRIGger[:SEQuence]:MODE

:TRIGger[:SEQuence]:SOURce

:TRIGger[:SEQuence]:TYPE

:TRIGger[:SEQuence]:VIDeo:SLOPe

*TRG

See [image] TRIGger commands for more information on using the trigger commands.

: TRIGger[:SEQuence]:AUTO:TIMEout

: TRIGger[:SEQuence]:AUTO[:STATe]

: TRIGger[:SEQuence]:DELay

: TRIGger[:SEQuence]:EXTernal:SLOPe

: TRIGger[:SEQuence]:PREQual:WINDow

: TRIGger[:SEQuence]:PREQual[:LEVel]

: TRIGger[:SEQuence]:LEVel

: TRIGger[:SEQuence]:MODE

: TRIGger[:SEQuence]:SOURce

: TRIGger[:SEQuence]:TYPE

: TRIGger[:SEQuence]:VIDeo:SLOPe


Making measurements

Signals applied to the Series 2800 VSA can be viewed in the spectrum (General Purpose in the time domain) or as a waveform (Modulation Standards in the time domain). Each domain provides different information about the applied signal. Signal markers and triggering can be applied to the signals to help get them in optimum viewing for measurements.

An overview of measurement setup will be followed for each measurement.

To learn how to make measurements, select the following:

  • General Purpose signals can be viewed in all or part of the Series 2800 VSA measurement spectrum.
    • Spectrum
    • Zero Span
    • ACPR
    • Channel Power List
  • .Modulation Standards waveforms of Communication Standards can be measured and viewed in the time domain.
    • GSM
    • EDGE
    • cdma2000 Reverse Link
    • W-CDMA Uplink
    • W-CDMA Downlink
    • 802.11x
  • Measurement settings


Overview of measurement setup-standard procedure

  1. Set up the test equipment.
  2. Acquire an RF signal.
  3. Choose a measurement personality.
  4. Set the measurement parameters and adjust the screen for optimum viewing.
  5. Transfer the measurement results.


General purpose

The Series 2800 VSA has been designed to easily make general purpose measurements on signals in the frequency spectrum. In the frequency spectrum a signal is viewed for its spectral content and where it sits in the spectrum.

Select from the following links to learn how to make these measurements:

  • Spectrum

    Shows where an input signal is on the VSA measurement spectrum and where it is in relation to other signals.

  • Zero Span

    The spectrum span control is set to zero, making the x-axis of the display units of time. Use this to see amplitude variations with time.

  • ACPR

    Measures how self contained a transmitted signal is. This measurement looks for transmitted signal energy spilling over into adjacent channels, where it can interfere with the signals in that channel.

  • Channel Power List

    Channel Power List is a superset of Zero Span. This measurement is a list of Zero Span measurements, collapsed to a single result, made at different frequency points.


Spectrum

What is a Spectrum measurement

The Spectrum measurement allows you to set up, view and measure signals within the frequency range of the Series 2800 VSA. This measurement shows where the signal is on the Series 2800 VSA spectrum, and where it is in relation to other signals.

Spectrum measurement procedure

  1. Set-up test equipment.

    NOTE: This is a typical installation, with the Series 2800 VSA connected to the system controller. This arrangement facilitates making screen captures of the VSA display. The rear panel SCPI control connectors are the same on both instruments. Thus, either or both of the instruments could be directly connected to the system controller for remote control. Connection by LAN enables use of the LXI web interface for licensing operations and other features.

    1. REF IN can accept an input frequency of 1-20MHz.

  2. Acquire an RF signal.

    Make sure the signal to be measured is within the frequency and signal power range of the VSA.

    If a signal generator is generating the signal:

    1. Set the carrier frequency (1 GHz in the following example).
    2. Set the signal amplitude (-10 dBm in the following example).
    3. Apply modulation to the carrier signal.
    4. Turn on the modulated RF signal.
  3. Choose measurement personality.
    1. Select Preset to set the instrument in the default state.
    2. From the measurement selection pull-down, select

    Spectrum > General Purpose > Spectrum

  4. Set the measurement parameters and adjust the screen for optimum viewing.
  5. Transfer measurement results.
    1. Select File > Save Screen.
    2. Select Look in: and navigate to storage location.
    3. Select Keyboard (type image title) and Enter.
    4. Select Save.
    5. Select Yes.


Set and adjust Spectrum

Unless you know where the acquired RF signal is on the Series 2800 VSA spectrum, set the spectrum wide to find the signal. In addition, there can be known spurs generated internally, that if removed, make the spectrum display more clean and simple to view.

1. Set the spectrum wide and cancel known spurs

  1. In the Spectrum measurement panel
    1. Select the Start Stop button.
    2. Set Start Frequency to 700 MHz.
    3. Set Stop Frequency to 2.4 GHz.
  2. Select Settings > Spur Cancellation > On.

.

With the signal showing on the display, make adjustments to optimize the view and make measurements on the signal.
When making measurements in the frequency domain, it is often useful to apply markers to the signal being measured.

2. Apply a marker to the signal of interest

  1. Select Markers and turn Marker 1 On.
  2. Move the marker to the point of interest on the acquired signal.
  3. Select Marker to Center.
  4. Select Close.
  5. Select Center Span tab.
  6. Select Frequency Span and adjust it as needed.

Select from this list to learn what choices are available for setting up a spectrum measurement.

  • Spectrum measurement panel
  • Trigger settings panel
  • Atten Preamp settings panel
  • Trace Hold control
  • Detection Type control
  • Spur Cancellation control
  • Averaging control


Zero Span

It is sometimes useful to zero-in on a frequency point of a signal displayed on the instrument. This is often useful to monitor signal stability.

Selecting the Zero Span measurement effectively sets the Frequency Span to 0 Hz. The signal trace on the display becomes one frequency. Trace markers are often used to get the signal to the center frequency. The sweep time and bandwidth controls can also be useful in making this measurement.

Measurement procedure

  1. Set up the test equipment.

    NOTE: This is a typical installation, with the Series 2800 VSA connected to the system controller. This arrangement facilitates making screen captures of the VSA display. The rear panel SCPI control connectors are the same on both instruments. Thus, either or both of the instruments could be directly connected to the system controller for remote control. Connection by LAN enables use of the LXI web interface for licensing operations and other features.

    1. REF IN can accept an input frequency of 1-20MHz.

  2. Acquire an RF signal.

    Make sure the signal to be measured is within the frequency and signal power range of the VSA.

    If a signal generator is generating the signal:

    1. Set the carrier frequency (1 GHz in the following example).
    2. Set the signal amplitude (-10 dBm in the following example).
    3. Apply modulation to the carrier signal.
    4. Turn on the modulated RF signal.
  3. Choose a measurement personality.
    1. Select Preset to set the instrument in the default state.
    2. From the measurement selection pull-down, select

    Spectrum > General Purpose > Spectrum.

  4. Set the measurement parameters and adjust the screen for optimum viewing.
  5. Transfer the measurement results.
    1. Select File > Save Screen.
    2. Select Look in: and navigate to storage location.
    3. Select Keyboard (type image title) and Enter.
    4. Select Save.
    5. Select Yes.


Set and adjust Zero Span

Unless you know where the acquired RF signal is on the Series 2800 VSA spectrum, set the spectrum wide to find the signal. In addition, there can be known spurs generated internally, that if removed, make the spectrum display more clean and simple to view.

1. Set the spectrum wide and cancel known spurs

  1. In the Spectrum measurement panel
    1. Select the Start Stop button.
    2. Set Start Frequency to 700 MHz.
    3. Set Stop Frequency to 2.4 GHz.
  2. Select Settings > Spur Cancellation > On.

.

Adjustments can be made to better view and make measurements on the signal. In making measurements in the frequency domain, it is often useful to apply markers to the signal being measured.

2. Apply a marker to the signal of interest

  1. Select Markers and turn Marker 1 On.
  2. Move the marker to the point of interest on the acquired signal.
  3. Select Marker to Center.
  4. Select Close.
  5. Select Spectrum > General Purpose > Zero Span

The signal at the marker position will be shown on the display.

Refer to the following image, the frequency is tuned at 1 GHz and sweeping at 0.001 seconds. Markers can be applied to the zero span trace including a Center to Marker selection. The zero span scale is in time units (Sweep Time), therefore the markers will also be referenced in time units.

Select from this list to learn what choices you have for setting up a spectrum zero-span measurement:

  • Zero span measurement panel
  • Trigger settings panel
  • Atten Preamp settings panel
  • Detection Type control
  • Filter Type control
  • Trace Hold control
  • Averaging control


ACPR

The adjacent channel power ratio (ACPR) measurement is often used in transmitter measurements. Many transmitted signals are made up of different signals separated in adjacent frequency channels (bands). It is important that the energy signal in one channel does not interfere with a signal in another channel.

The ACPR measurement applies a mask around the measured signal. With the center signal applied, measurements are made in the adjacent channels to this signal. If the signal energy measured in adjacent channels stays within the mask outline, the measurement results are in a pass condition. However, if the signal energy measured in the adjacent channel extends beyond the measurement mask, a fail condition occurs.

Measurement procedure

  1. Set up test equipment.

    NOTE: This is a typical installation, with the Series 2800 VSA connected to the system controller. This arrangement facilitates making screen captures of the VSA display. The rear panel SCPI control connectors are the same on both instruments. Thus, either or both of the instruments could be directly connected to the system controller for remote control. Connection by LAN enables use of the LXI web interface for licensing operations and other features.

    1. REF IN can accept an input frequency of 1-20MHz.

  2. Acquire an RF signal.

    Make sure the signal to be measured is within the frequency and signal power range of the VSA.

    If a signal generator is generating the signal:

    1. Set the carrier frequency (1 GHz in the following example).
    2. Set the signal amplitude (-10 dBm in the following example).
    3. Apply modulation to the carrier signal.
    4. Turn on the modulated RF signal.
  3. Choose measurement personality.
    1. Select Preset to set the instrument in the default state.
    2. From the measurement selection pull-down, select

    Spectrum > General Purpose > Spectrum.

  4. Set the measurement parameters and adjust the screen for optimum viewing.
  5. Transfer measurement results.
    1. Select File > Save Screen.
    2. Select Look in: and navigate to storage location.
    3. Select Keyboard (type image title) and Enter.
    4. Select Save.
    5. Select Yes.


Set and adjust ACPR

Unless you know where the acquired RF signal is on the Series 2800 VSA spectrum, set the spectrum wide to find the signal. In addition, there can be known spurs generated internally, that if removed, make the spectrum display more clean and simple to view.

1. Set the spectrum wide and cancel known spurs

  1. In the Spectrum measurement panel
    1. Select the Start Stop button.
    2. Set Start Frequency to 700 MHz.
    3. Set Stop Frequency to 2.4 GHz.
  2. Select Settings > Spur Cancellation > On.

.

2. Apply a marker to the signal of interest

  1. Select Markers and turn Marker 1 On.
  2. Move the marker to the point of interest on the acquired signal.
  3. Select Marker to Center.
  4. Select Close.
  5. Select Center Span tab.
  6. Select Frequency Span and adjust it as needed.

With the marker on the signal of interest, apply the ACPR measurement:

Spectrum > General Purpose > ACPR

The carrier signal is set in the center of the General Purpose ACPR signal mask. If the two offset frequencies on both sides of the carrier are below the mask outline, the measurement is a "Pass" condition for the limit test.

Make adjustments to the measurement of the signal showing on the display.

Use the ACPR Main control panel to adjust the carrier signal parameters.

The adjacent channel power ratio (ACPR) is the ratio of the amount of signal power in a main channel that is introduced to the channels immediately above and below the center channel. Select from the list to learn about the choices you have to set up an ACPR measurement.

  • ACPR measurement panel
  • Edit Channels settings panel
  • Edit Limits settings panel
  • Filter type control
  • Trace Hold control
  • Fast Mode control
  • Noise Correction control
  • Averaging control


Channel Power List

Channel Power List is a list of Zero Span measurements. Each entry in the list specifies the conditions of the sweep. This allows creation of a more efficient sweep since only the set of frequencies of interest are specified.

Measurement procedure

  1. Set up test equipment.

    NOTE: This is a typical installation, with the Series 2800 VSA connected to the system controller. This arrangement facilitates making screen captures of the VSA display. The rear panel SCPI control connectors are the same on both instruments. Thus, either or both of the instruments could be directly connected to the system controller for remote control. Connection by LAN enables use of the LXI web interface for licensing operations and other features.

    1. REF IN can accept an input frequency of 1-20MHz.

  2. Acquire an RF signal.

    Make sure the signal to be measured is within the frequency and signal power range of the VSA.

    If a signal generator is generating the signal:

    1. Set the carrier frequency (1 GHz in the following example).
    2. Set the signal amplitude (-10 dBm in the following example).
    3. Apply modulation to the carrier signal.
    4. Turn on the modulated RF signal.
  3. Choose measurement personality.
    1. Select Preset to set the instrument in the default state.
    2. From the measurement selection pull-down, select

    Spectrum > General Purpose > Channel Power List.

  4. Set the measurement parameters and adjust the screen for optimum viewing.
  5. Transfer measurement results.
    1. Select File > Save Screen.
    2. Select Look in: and navigate to storage location.
    3. Select Keyboard (type image title) and Enter.
    4. Select Save.
    5. Select Yes.


Set and adjust Channel Power List

When making this measurement, you must load a Channel List file. The file suffix is *.List, refer to File operations to learn how to search for and load these files.

The channel power list allows you to load a file that contains a list of measurement states that includes state, frequency, RBW, sweep time, reference level and preamp values. Select from the list below to learn about the choices you have to set up a list of channel power measurements:

  • Channel List measurement panel
  • Trigger settings panel
  • Filter type control
  • Trace Hold control
  • Fast Mode control
  • Noise Correction control
  • Averaging control

  • Fast Mode
  • Noise Correction

See also Channel List


Modulation Standards

Wireless communication standards

The Series 2800 VSA has been designed to easily demodulate wireless communication standards.

Select from the following list to learn more:

  • GSM
  • EDGE
  • cdma2000 Reverse Link
    • cdma2000 Demodulate
    • cdma2000 ACPR
    • cdma2000 Spectrum Emission Mask
    • cdma2000 Occupied Bandwidth
  • W-CDMA Uplink
    • W-CDMA Uplink Demodulate
    • W-CDMA Uplink ACLR
    • W-CDMA Uplink Spectrum Emission Mask
    • W-CDMA Uplink Occupied Bandwidth
  • W-CDMA Downlink
    • W-CDMA Downlink Demodulate
    • W-CDMA Downlink ACLR
    • W-CDMA Downlink Spectrum Emission Mask
    • W-CDMA Downlink Occupied Bandwidth
  • WLAN (802.11x)
    • 802.11x Demodulate
    • 802.11x Spectral Mask


GSM

The Series 2800 VSA automatically synchronizes and captures the GSM burst on the instrument screen. From this captured signal, many measurements are made simultaneously. The results are compared with measurement settings and with the GSM Modulation Standard.

Measurement procedure

  1. Set up test equipment.

    NOTE: This is a typical installation, with the Series 2800 VSA connected to the system controller. This arrangement facilitates making screen captures of the VSA display. The rear panel SCPI control connectors are the same on both instruments. Thus, either or both of the instruments could be directly connected to the system controller for remote control. Connection by LAN enables use of the LXI web interface for licensing operations and other features.

    1. REF IN can accept an input frequency of 1-20MHz.

  2. Acquire a GSM signa.l

    Make sure the signal to be measured is within the frequency and signal power range of the VSA.

    If a signal generator is generating the signal:

    1. Set the carrier frequency (1 GHz in the following example).
    2. Set the signal amplitude (-10 dBm in the following example).
    3. Apply modulation to the carrier signal.
    4. Turn on the modulated RF signal.
  3. Choose measurement personality.
    1. Select Preset to set the instrument in the default state.
    2. From the measurement selection pull-down, select

    Spectrum > GSM.

  4. Set the measurement parameters and adjust the screen for optimum viewing.
  5. Transfer measurement results.
    1. Select File > Save Screen.
    2. Select Look in: and navigate to storage location.
    3. Select Keyboard (type image title) and Enter.
    4. Select Save.
    5. Select Yes.


Set and adjust GSM

The GSM burst should be automatically captured and displayed on the instrument display.

The following image shows the GSM burst within the "Time Mask" trace and a table showing the measurement results.

The measurement results are calculated directly from the data in the captured burst and then compared to the GSM Modulation Standard.

Notice the Pass/Fail results for the individual measurements taken.

The Channel Power measurement cannot be de-selected.

However, the following measurements can be turned on or off in the Settings pull-down menu:

  • Phase Error
  • Time Mask
  • Output RF Spectrum (ORFS) due to modulation
  • Output RF Spectrum (ORFS) due to switching

    NOTE: If you are having difficulty in getting a trigger switch to a Zero Span measurement and adjust the trigger delay until the rising edge is squarely on the middle graticule line.

There are settings to view the captured signal differently.

Select from the list to learn what choices you have for setting up a GSM measurement:

  • GSM measurement panel
  • Channel Power Limits settings panel
  • Phase Error Limits settings panel
  • Time Mask Limits settings panel
  • ORFS Mod settings panel
  • ORFS Switch settings panel
  • Phase Error control
  • Time Mask control
  • ORFS Mod control
  • ORFS Switch control
  • Averaging control

Notes on capturing a GSM/EDGE signal

Measurement descriptions:

  • Channel Power
  • Frequency Error
  • Phase Error
  • RMS Phase error
  • Peak Phase Error
  • Time Mask
  • Output RF Spectrum


EDGE

The 2800 Series VSA automatically synchronizes and captures the EDGE burst on the instrument screen. From this captured signal, many measurements are made simultaneously. The results are compared with test limits and with the EDGE Modulation Standard.

Measurement procedure

  1. Set up test equipment.

    NOTE: This is a typical installation, with the Series 2800 VSA connected to the system controller. This arrangement facilitates making screen captures of the VSA display. The rear panel SCPI control connectors are the same on both instruments. Thus, either or both of the instruments could be directly connected to the system controller for remote control. Connection by LAN enables use of the LXI web interface for licensing operations and other features.

    1. REF IN can accept an input frequency of 1-20MHz.

  2. Acquire an EDGE signal.

    Make sure the signal to be measured is within the frequency and signal power range of the VSA.

    If a signal generator is generating the signal:

    1. Set the carrier frequency (1 GHz in the following example).
    2. Set the signal amplitude (-10 dBm in the following example).
    3. Apply modulation to the carrier signal.
    4. Turn on the modulated RF signal.
  3. Choose a measurement personality.
    1. Select Preset to set the instrument in the default state.
    2. From the measurement selection pull-down, select

    Spectrum > EDGE.

  4. Set the measurement parameters and adjust the screen for optimum viewing.
  5. Transfer measurement results.
    1. Select File > Save Screen.
    2. Select Look in: and navigate to storage location.
    3. Select Keyboard (type image title) and Enter.
    4. Select Save.
    5. Select Yes.


Set and adjust EDGE

The EDGE burst should be automatically captured and displayed on the instrument display.

The following image shows the EDGE burst within the "Time Mask" trace and shows a table of measurement results.

The measurement results are calculated directly from the data in the captured burst and then compared to the EDGE Modulation Standard.

Notice the Pass/Fail results for the individual measurements taken.

The Channel Power measurement cannot be de-selected.

However, the following measurements can be turned on or off in the Settings pull-down menu:

  • EDGE: EVM
  • Time Mask
  • Output RF Spectrum (ORFS) due to modulation
  • Output RF Spectrum (ORFS) due to switching

    NOTE: If you are having difficulty in getting a trigger switch to a Zero Span measurement and adjust the trigger delay until the rising edge is squarely on the middle graticule line.

There are settings that can be adjusted to view the captured signal differently.

Select from the list below to learn about the choices you have to set up an EDGE measurement:

  • EDGE measurement panel
  • Channel Power Limit settings panel
  • EVM Limits settings panel
  • Time Mask Limits settings panel
  • ORFS Mod settings panel
  • ORFS Switch settings panel
  • EDGE EVM control
  • Time Mask control
  • ORFS Mod control
  • ORFS Switch control
  • Averaging control

Notes on capturing a GSM/EDGE signal

Measurement descriptions:

  • Channel Power
  • EVM
  • Time Mask
  • Frequency Error
  • IQ Gain Error
  • IQ Origin Offset
  • Droop
  • Time Mask
  • Output RF Spectrum


cdma2000 Reverse Link

The Series 2800 VSA automatically synchronizes and captures the cdma2000 waveform on the instrument screen. From this captured signal, many measurements can be made simultaneously. The results are compared with test limits and with the cdma2000 Standard.

Select from the following measurements to learn more:

  • cdma2000 Demodulate
  • cdma2000 ACPR
  • cdma2000 Spectrum Emission Mask
  • cdma2000 Occupied Bandwidth


cdma2000 Demodulate

Measurement procedure

  1. Set up test equipment.

    NOTE: This is a typical installation, with the Series 2800 VSA connected to the system controller. This arrangement facilitates making screen captures of the VSA display. The rear panel SCPI control connectors are the same on both instruments. Thus, either or both of the instruments could be directly connected to the system controller for remote control. Connection by LAN enables use of the LXI web interface for licensing operations and other features.

    1. REF IN can accept an input frequency of 1-20MHz.

  2. Acquire a cdma2000 signal for Demodulate measurement.

    Make sure the signal to be measured is within the frequency and signal power range of the VSA.

    If a signal generator is generating the signal:

    1. Set the carrier frequency (1 GHz in the following example).
    2. Set the signal amplitude (-10 dBm in the following example).
    3. Apply modulation to the carrier signal.
    4. Turn on the modulated RF signal.
  3. Choose a measurement personality.
    1. Select Preset to set the instrument in the default state.
    2. From the measurement selection pull-down, select

    Spectrum > cdma2000 Reverse Link > Demodulate.

  4. Set the measurement parameters and adjust the screen for optimum viewing.
  5. Transfer measurement results.
    1. Select File > Save Screen.
    2. Select Look in: and navigate to storage location.
    3. Select Keyboard (type image title) and Enter.
    4. Select Save.
    5. Select Yes.


Set and adjust cdma2000 Demodulate

The image below shows a cdma2000 Demodulated measurement on a signal centered on a frequency at 1 GHz.

The top of the image shows the I and Q data. The bottom shows the results of cdma2000 measurements made on this signal.

Select from the following to learn about the measurements:

  • Channel Power

    This is the total power of the signal in a specified frequency band.

  • Rho
  • EVM

    The error vector magnitude is a measure of the difference between the reference waveform and the measured waveform.

  • PCDE (dB)

    Peak code domain error (PCDE) is a measure of how much cross-talk exists between different channels within the WCDMA signal. In other words, it is an indication of how well the orthogonality between different code channels is maintained.

    From 3GPP standard:

    The code domain error is computed by projecting the error vector power onto the code domain at a specific spreading factor. The error power for each code is defined as the ratio to the mean power of the reference waveform expressed in dB. The Peak Code Domain Error is defined as the maximum value for Code Domain Error.

  • Freq Error (Hz)

    The difference between actual measured carrier frequency and specified carrier frequency.

  • IQ Offset (dB)

    This is the DC offset of the signal in % or dB.

  • Total Power (dBm)

    The total power of the signal in a certain bandwidth at a carrier frequency; see Channel power.

Select from the list below to learn what choices you have for setting up a cdma2000 Demodulate measurement:

  • cdma2000 Demodulate measurement panel
  • Edit Limits setting panel
  • Averaging control


cdma2000 ACPR

Measurement procedure

  1. Set up test equipment.

    NOTE: This is a typical installation, with the Series 2800 VSA connected to the system controller. This arrangement facilitates making screen captures of the VSA display. The rear panel SCPI control connectors are the same on both instruments. Thus, either or both of the instruments could be directly connected to the system controller for remote control. Connection by LAN enables use of the LXI web interface for licensing operations and other features.

    1. REF IN can accept an input frequency of 1-20MHz.

  2. Acquire a cdma2000 signal for ACPR measurement.

    Make sure the signal to be measured is within the frequency and signal power range of the VSA.

    If a signal generator is generating the signal:

    1. Set the carrier frequency (1 GHz in the following example).
    2. Set the signal amplitude (-10 dBm in the following example).
    3. Apply modulation to the carrier signal.
    4. Turn on the modulated RF signal.
  3. Choose a measurement personality.
    1. Select Preset to set the instrument in the default state.
    2. From the measurement selection pull-down, select

    Spectrum > cdma2000 Reverse Link > ACPR.

  4. Set the measurement parameters and adjust the screen for optimum viewing.
  5. Transfer measurement results.
    1. Select File > Save Screen.
    2. Select Look in: and navigate to storage location.
    3. Select Keyboard (type image title) and Enter.
    4. Select Save.
    5. Select Yes.


Set and adjust cdma2000 Reverse Link ACPR

The image below shows a cdma2000 Reverse Link ACPR measurement on a signal centered at 1 GHz.

Notice the signal and power in adjacent channels are below the ACPR measurement mask, resulting in a Pass condition.

The cdma2000 Reverse Link ACPR is a Pass/Fail measurement.

Select from the following list below to learn what choices you have for setting up a cdma2000 ACPR (Adjacent Power Leakage ratio) measurement:

  • cdma2000 Reverse Link ACPR measurement panel
  • Trace Hold control
  • Fast Mode control
  • Noise Correction control
  • Averaging control


cdma2000 Spectrum Emission Mask

Measurement procedure

  1. Set up test equipment.

    NOTE: This is a typical installation, with the Series 2800 VSA connected to the system controller. This arrangement facilitates making screen captures of the VSA display. The rear panel SCPI control connectors are the same on both instruments. Thus, either or both of the instruments could be directly connected to the system controller for remote control. Connection by LAN enables use of the LXI web interface for licensing operations and other features.

    1. REF IN can accept an input frequency of 1-20MHz.

  2. Acquire a cdma2000 signal for Spectrum Emission Mask measurement.

    Make sure the signal to be measured is within the frequency and signal power range of the VSA.

    If a signal generator is generating the signal:

    1. Set the carrier frequency (1 GHz in the following example).
    2. Set the signal amplitude (-10 dBm in the following example).
    3. Apply modulation to the carrier signal.
    4. Turn on the modulated RF signal.
  3. Choose a measurement personality.
    1. Select Preset to set the instrument in the default state.
    2. From the measurement selection pull-down, select

    Spectrum > cdma2000 Reverse link > Spectrum Emission Mask.

  4. Set the measurement parameters and adjust the screen for optimum viewing.
  5. Transfer measurement results.
    1. Select File > Save Screen.
    2. Select Look in: and navigate to storage location.
    3. Select Keyboard (type image title) and Enter.
    4. Select Save.
    5. Select Yes.


Set and adjust cdma2000 Reverse Link Spectrum Emission Mask

The image below shows a cdma2000 Spectrum Emission Mask measurement on a signal centered at 1 GHz.

Notice the signal stays within and below the Spectrum Emission measurement mask, resulting in a Pass condition.

The cdma2000 Spectrum Emission Mask measurement is a Pass/Fail measurement.

Select from the list below to learn what choices you have for setting up a cdma2000 Occupied Bandwidth measurement:

  • cdma2000 Occupied Bandwidth measurement panel
  • Trigger settings panel
  • Atten Preamp settings panel
  • Trace Hold control
  • Averaging control


cdma2000 Occupied Bandwidth

Measurement procedure

  1. Set up test equipment.

    NOTE: This is a typical installation, with the Series 2800 VSA connected to the system controller. This arrangement facilitates making screen captures of the VSA display. The rear panel SCPI control connectors are the same on both instruments. Thus, either or both of the instruments could be directly connected to the system controller for remote control. Connection by LAN enables use of the LXI web interface for licensing operations and other features.

    1. REF IN can accept an input frequency of 1-20MHz.

  2. Acquire a cdma2000 signal for Occupied Bandwidth measurement.

    Make sure the signal to be measured is within the frequency and signal power range of the VSA.

    If a signal generator is generating the signal:

    1. Set the carrier frequency (1 GHz in the following example).
    2. Set the signal amplitude (-10 dBm in the following example).
    3. Apply modulation to the carrier signal.
    4. Turn on the modulated RF signal.
  3. Choose a measurement personality.
    1. Select Preset to set the instrument in the default state.
    2. From the measurement selection pull-down, select

    Spectrum > cdma2000 Reverse link > Occupied Bandwidth.

  4. Set the measurement parameters and adjust the screen for optimum viewing.
  5. Transfer measurement results.
    1. Select File > Save Screen.
    2. Select Look in: and navigate to storage location.
    3. Select Keyboard (type image title) and Enter.
    4. Select Save.
    5. Select Yes.


Set and adjust cdma2000 Reverse Link Occupied Bandwidth

The image below shows a cdma2000 Occupied Bandwidth measurement on a signal centered at 1 GHz.

Notice the signal stays within the Occupied Bandwidth measurement markers, resulting in a Pass condition.

The cdma2000 Reverse Link Occupied Bandwidth measurement is a Pass/Fail measurement.

Select from the list to learn what choices you have for setting up a cdma2000 Occupied Bandwidth measurement:

  • cdma2000 Spectrum Emission measurement panel
  • Trigger settings panel
  • Trace Hold control
  • Averaging control

.


W-CDMA Uplink

The VSA automatically synchronizes and captures the W-CDMA Uplink waveform on the instrument screen. From this captured signal, many measurements are made simultaneously. The results are compared with test limit settings and with the W-CDMA Uplink Standard.

Select from the following measurements to learn more:

  • W-CDMA Uplink Demodulate
  • W-CDMA Uplink ACLR
  • W-CDMA Uplink Spectrum Emission Mask
  • W-CDMA Uplink Occupied Bandwidth


W-CDMA Uplink Demodulate

Measurement procedure

  1. Set up test equipment.

    NOTE: This is a typical installation, with the Series 2800 VSA connected to the system controller. This arrangement facilitates making screen captures of the VSA display. The rear panel SCPI control connectors are the same on both instruments. Thus, either or both of the instruments could be directly connected to the system controller for remote control. Connection by LAN enables use of the LXI web interface for licensing operations and other features.

    1. REF IN can accept an input frequency of 1-20MHz.

  2. Acquire a W-CDMA signal.

    Make sure the signal to be measured is within the frequency and signal power range of the VSA.

    If a signal generator is generating the signal:

    1. Set the carrier frequency (1 GHz in the following example).
    2. Set the signal amplitude (-10 dBm in the following example).
    3. Apply modulation to the carrier signal.
    4. Turn on the modulated RF signal.
  3. Choose a measurement personality.
    1. Select Preset to set the instrument in the default state.
    2. From the measurement selection pull-down, select

    Spectrum > W-CDMA Uplink > Demodulate.

  4. Set the measurement parameters and adjust the screen for optimum viewing.
  5. Transfer measurement results.
    1. Select File > Save Screen.
    2. Select Look in: and navigate to storage location.
    3. Select Keyboard (type image title) and Enter.
    4. Select Save.
    5. Select Yes.


Set and adjust W-CDMA Uplink (Demodulate)

The image below shows a W-CDMA Uplink Demodulate measurement on a signal centered on a frequency at 1 GHz.

The top of the image holds the I and Q data. The bottom shows the results of W-CDMA Uplink Demodulate measurements made on this signal.

Select from the following to learn about the measurements:

  • Channel Power

    This is the total power of the signal in a specified frequency band.

  • EVM

    The error vector magnitude is a measure of the difference between the reference waveform and the measured waveform.

  • PCDE (dB)

    Peak code domain error (PCDE) is a measure of how much cross-talk exists between different channels within the WCDMA signal. In other words, it is an indication of how well the orthogonality between different code channels is maintained.

    From 3GPP standard:

    The code domain error is computed by projecting the error vector power onto the code domain at a specific spreading factor. The error power for each code is defined as the ratio to the mean power of the reference waveform expressed in dB. The Peak Code Domain Error is defined as the maximum value for Code Domain Error.

  • Freq Error (Hz)

    The difference between actual measured carrier frequency and specified carrier frequency.

  • IQ Offset (dB)

    This is the DC offset of the signal in % or dB.

  • Total Power (dBm)

    The total power of the signal in a certain bandwidth at a carrier frequency; see Channel power.

Select from the list below to learn what choices you have for setting up a W-CDMA Uplink Demodulate measurement:

  • W-CDMA Uplink Demodulate measurement panel
  • Code Settings panel
  • Edit Limits setting panel
  • Averaging control


W-CDMA Uplink ACLR

Measurement procedure

  1. Set up test equipment.

    NOTE: This is a typical installation, with the Series 2800 VSA connected to the system controller. This arrangement facilitates making screen captures of the VSA display. The rear panel SCPI control connectors are the same on both instruments. Thus, either or both of the instruments could be directly connected to the system controller for remote control. Connection by LAN enables use of the LXI web interface for licensing operations and other features.

    1. REF IN can accept an input frequency of 1-20MHz.

  2. Acquire a W-CDMA signal.

    Make sure the signal to be measured is within the frequency and signal power range of the VSA.

    If a signal generator is generating the signal:

    1. Set the carrier frequency (1 GHz in the following example).
    2. Set the signal amplitude (-10 dBm in the following example).
    3. Apply modulation to the carrier signal.
    4. Turn on the modulated RF signal.
  3. Choose a measurement personality.
    1. Select Preset to set the instrument in the default state.
    2. From the measurement selection pull-down, select

    Spectrum > W-CDMA Uplink > Demodulate.

  4. Set the measurement parameters and adjust the screen for optimum viewing.
  5. Transfer measurement results.
    1. Select File > Save Screen.
    2. Select Look in: and navigate to storage location.
    3. Select Keyboard (type image title) and Enter.
    4. Select Save.
    5. Select Yes.


Set and adjust W-CDMA Uplink ACLR

The image below shows a W-CDMA Uplink ACLR measurement on a signal centered at 1 GHz.

Notice the signal and power in adjacent channels are below the ACLR measurement mask, resulting in a Pass condition.

The W-CDMA Uplink ACLR is a Pass/Fail measurement.

Select from the list below to learn what choices you have for setting up a W-CDMA ACLR (adjacent channel leakage ratio) measurement:

  • W-CDMA Uplink ACLR measurement panel
  • Trace Hold control
  • Fast Mode control
  • Noise Correction control
  • Averaging control


W-CDMA Uplink Spectrum Emission Mask

Measurement procedure

  1. Set up test equipment.

    NOTE: This is a typical installation, with the Series 2800 VSA connected to the system controller. This arrangement facilitates making screen captures of the VSA display. The rear panel SCPI control connectors are the same on both instruments. Thus, either or both of the instruments could be directly connected to the system controller for remote control. Connection by LAN enables use of the LXI web interface for licensing operations and other features.

    1. REF IN can accept an input frequency of 1-20MHz.

  2. Acquire a W-CDMA signal.

    Make sure the signal to be measured is within the frequency and signal power range of the VSA.

    If a signal generator is generating the signal:

    1. Set the carrier frequency (1 GHz in the following example).
    2. Set the signal amplitude (-10 dBm in the following example).
    3. Apply modulation to the carrier signal.
    4. Turn on the modulated RF signal.
  3. Choose a measurement personality.
    1. Select Preset to set the instrument in the default state.
    2. From the measurement selection pull-down, select

    Spectrum > W-CDMA Uplink > Demodulate.

  4. Set the measurement parameters and adjust the screen for optimum viewing.
  5. Transfer measurement results.
    1. Select File > Save Screen.
    2. Select Look in: and navigate to storage location.
    3. Select Keyboard (type image title) and Enter.
    4. Select Save.
    5. Select Yes.


Set and adjust W-CDMA Uplink Spectrum Emission Mask

The image below shows a W-CDMA Uplink Spectrum Emission Mask measurement on a signal centered at 1 GHz.

Notice the signal stays within and below the Spectrum Emission measurement mask, resulting in a Pass condition.

The W-CDMA Uplink Spectrum Emission Mask measurement is a Pass/Fail measurement.

Select from the list below to learn what choices you have for setting up a W-CDMA spectrum emission measurement:

  • W-CDMA Uplink Spectrum Emission measurement panel
  • Trigger settings panel
  • Atten Preamp
  • Detection Type control
  • Averaging control

    The results in the Pass/Fail and Min Margin at columns are provided as diagnostic aides. While the accuracy of these results is excellent, users may find a need for more accurate test results. For situations where the spurious amplitude and frequency are near the edge of a mask transition, the marker function provides a more accurate result.


W-CDMA Uplink Occupied Bandwidth

Measurement procedure

  1. Set up test equipment.

    NOTE: This is a typical installation, with the Series 2800 VSA connected to the system controller. This arrangement facilitates making screen captures of the VSA display. The rear panel SCPI control connectors are the same on both instruments. Thus, either or both of the instruments could be directly connected to the system controller for remote control. Connection by LAN enables use of the LXI web interface for licensing operations and other features.

    1. REF IN can accept an input frequency of 1-20MHz.

  2. Acquire a W-CDMA signal.

    Make sure the signal to be measured is within the frequency and signal power range of the VSA.

    If a signal generator is generating the signal:

    1. Set the carrier frequency (1 GHz in the following example).
    2. Set the signal amplitude (-10 dBm in the following example).
    3. Apply modulation to the carrier signal.
    4. Turn on the modulated RF signal.
  3. Choose a measurement personality.
    1. Select Preset to set the instrument in the default state.
    2. From the measurement selection pull-down, select

    Spectrum > W-CDMA Uplink > Demodulate.

  4. Set the measurement parameters and adjust the screen for optimum viewing.
  5. Transfer measurement results.
    1. Select File > Save Screen.
    2. Select Look in: and navigate to storage location.
    3. Select Keyboard (type image title) and Enter.
    4. Select Save.
    5. Select Yes.


Set and adjust W-CDMA Uplink Occupied Bandwidth

The image below shows a W-CDMA Uplink Occupied Bandwidth measurement on a signal centered at 1 GHz.

Notice the signal stays within the Occupied Bandwidth measurement markers, resulting in a Pass condition.

The W-CDMA UpLink Occupied Bandwidth measurement is a Pass/Fail measurement.

Select from the list below to learn what choices you have for setting up a W-CDMA Uplink Occupied Bandwidth measurement:

  • W-CDMA Uplink Occupied Bandwidth measurement panel
  • Trigger settings panel
  • Atten Preamp control
  • Trace Hold control
  • Averaging control


W-CDMA Downlink

The VSA automatically synchronizes and captures the W-CDMA Downlink waveform on the instrument screen. From this captured signal, many measurements are made simultaneously. The results are compared with test limit settings and with the W-CDMA Downlink Standard.

Select from the following measurements to learn more:

  • W-CDMA Downlink Demodulate
  • W-CDMA Downlink ACLR
  • W-CDMA Downlink Spectrum Emission Mask
  • W-CDMA Downlink Occupied Bandwidth


W-CDMA Downlink Demodulate

Measurement procedure

  1. Set up test equipment.

    NOTE: This is a typical installation, with the Series 2800 VSA connected to the system controller. This arrangement facilitates making screen captures of the VSA display. The rear panel SCPI control connectors are the same on both instruments. Thus, either or both of the instruments could be directly connected to the system controller for remote control. Connection by LAN enables use of the LXI web interface for licensing operations and other features.

    1. REF IN can accept an input frequency of 1-20MHz.

  2. Acquire a W-CDMA signal.

    Make sure the signal to be measured is within the frequency and signal power range of the VSA.

    If a signal generator is generating the signal:

    1. Set the carrier frequency (1 GHz in the following example).
    2. Set the signal amplitude (-10 dBm in the following example).
    3. Apply modulation to the carrier signal.
    4. Turn on the modulated RF signal.
  3. Choose a measurement personality.
    1. Select Preset to set the instrument in the default state.
    2. From the measurement selection pull-down, select

    Spectrum > Standards > W-CDMA Downlink > Demodulate.

  4. Set the measurement parameters and adjust the screen for optimum viewing.
  5. Transfer measurement results.
    1. Select File > Save Screen.
    2. Select Look in: and navigate to storage location.
    3. Select Keyboard (type image title) and Enter.
    4. Select Save.
    5. Select Yes.

.


Set and adjust W-CDMA Downlink (Demodulate)

The instrument display below, shows the data from a W-CDMA Downlink Demodulate measurement on a signal centered at a frequency of 1 GHz.

Below the display on the instrument, the results of W-CDMA Downlink Demodulate measurements are seen numerically. Select from the following to learn about the measurement data:

Channel Power

This is the total power of the signal in a specified frequency band.

EVM

The error vector magnitude is a measure of the difference between the reference waveform and the measured waveform.

PCDE (dB)

Peak code domain error (PCDE) is a measure of how much cross-talk exists between different channels within the WCDMA signal. In other words, it is an indication of how well the orthogonality between different code channels is maintained.

From 3GPP standard:

The code domain error is computed by projecting the error vector power onto the code domain at a specific spreading factor. The error power for each code is defined as the ratio to the mean power of the reference waveform expressed in dB. The Peak Code Domain Error is defined as the maximum value for Code Domain Error.

Freq Error (Hz)

The difference between actual measured carrier frequency and specified carrier frequency.

IQ Offset (dB)

This is the DC offset of the signal in % or dB.

Total Power (dBm)

The total power of the signal in a certain bandwidth at a carrier frequency; see Channel power.

Select from the list below to learn what choices you have for setting up a W-CDMA Downlink Demodulate measurement:

1

W-CDMA Downlink Demodulate measurement panel

2
  • Code Settings panel

  • Symbol EVM panel

  • Edit Limits setting panel

3

Averaging control


W-CDMA Downlink ACLR

Measurement procedure

  1. Set up test equipment.

    NOTE: This is a typical installation, with the Series 2800 VSA connected to the system controller. This arrangement facilitates making screen captures of the VSA display. The rear panel SCPI control connectors are the same on both instruments. Thus, either or both of the instruments could be directly connected to the system controller for remote control. Connection by LAN enables use of the LXI web interface for licensing operations and other features.

    1. REF IN can accept an input frequency of 1-20MHz.

  2. Acquire a W-CDMA signal.

    Make sure the signal to be measured is within the frequency and signal power range of the VSA.

    If a signal generator is generating the signal:

    1. Set the carrier frequency (1 GHz in the following example).
    2. Set the signal amplitude (-10 dBm in the following example).
    3. Apply modulation to the carrier signal.
    4. Turn on the modulated RF signal.
  3. Choose a measurement personality.
    1. Select Preset to set the instrument in the default state.
    2. From the measurement selection pull-down, select

    Spectrum > Standards > W-CDMA Downlink > ACLR.

  4. Set the measurement parameters and adjust the screen for optimum viewing.
  5. Transfer measurement results.
    1. Select File > Save Screen.
    2. Select Look in: and navigate to storage location.
    3. Select Keyboard (type image title) and Enter.
    4. Select Save.
    5. Select Yes.

.


Set and adjust W-CDMA Downlink ACLR

The instrument display below shows a W-CDMA Downlink ACLR measurement on a signal centered at 1 GHz.

Notice the signal and power in adjacent channels are below the ACLR measurement mask, resulting in a Pass condition.

The W-CDMA Downlink ACLR is a Pass/Fail measurement. As long as all the signal components, shown by yellow bars, stay below the red mask line, the ACLR measurement will pass. If any component of the signal rises above the mask, the ACLR measurement will fail.

Select from the list below to learn what choices you have for setting up a W-CDMA Downlink ACLR measurement:

1

W-CDMA Downlink ACLR measurement panel

2
  • Trace Hold control

  • Fast Mode control

  • Noise Correction control

3

Averaging control


W-CDMA Downlink Spectrum Emission Mask

Measurement procedure

  1. Set up test equipment.

    NOTE: This is a typical installation, with the Series 2800 VSA connected to the system controller. This arrangement facilitates making screen captures of the VSA display. The rear panel SCPI control connectors are the same on both instruments. Thus, either or both of the instruments could be directly connected to the system controller for remote control. Connection by LAN enables use of the LXI web interface for licensing operations and other features.

    1. REF IN can accept an input frequency of 1-20MHz.

  2. Acquire a W-CDMA signal.

    Make sure the signal to be measured is within the frequency and signal power range of the VSA.

    If a signal generator is generating the signal:

    1. Set the carrier frequency (1 GHz in the following example).
    2. Set the signal amplitude (-10 dBm in the following example).
    3. Apply modulation to the carrier signal.
    4. Turn on the modulated RF signal.
  3. Choose a measurement personality.
    1. Select Preset to set the instrument in the default state.
    2. From the measurement selection pull-down, select

    Spectrum > Standards > W-CDMA Downlink > Spectrum Emission Mask.

  4. Set the measurement parameters and adjust the screen for optimum viewing.
  5. Transfer measurement results.
    1. Select File > Save Screen.
    2. Select Look in: and navigate to storage location.
    3. Select Keyboard (type image title) and Enter.
    4. Select Save.
    5. Select Yes.

.


Set and adjust W-CDMA Downlink (SEM)

The image below shows a W-CDMA Downlink Spectrum Emission Mask measurement on a signal centered at 1 GHz.

Notice the signal stays within and below the Spectrum Emission measurement mask, resulting in a Pass condition.

The W-CDMA Downlink Spectrum Emission Mask is a Pass/Fail measurement. As long as all the signal components, stay below the red mask line, the ACLR measurement will pass. If any component of the signal rises above the mask, the W-CDMA Downlink Spectrum Emission Mask measurement will fail.

Select from the list below to learn what choices you have for setting up a W-CDMA Downlink Spectrum Emission Mask measurement:

1
  • W-CDMA DL SEM measurement panel

  • Trigger settings panel

  • Atten/Preamp

2

Detection Type control

3

Averaging control


W-CDMA Downlink Occupied Bandwidth

Measurement procedure

  1. Set up test equipment.

    NOTE: This is a typical installation, with the Series 2800 VSA connected to the system controller. This arrangement facilitates making screen captures of the VSA display. The rear panel SCPI control connectors are the same on both instruments. Thus, either or both of the instruments could be directly connected to the system controller for remote control. Connection by LAN enables use of the LXI web interface for licensing operations and other features.

    1. REF IN can accept an input frequency of 1-20MHz.

  2. Acquire a W-CDMA signal.

    Make sure the signal to be measured is within the frequency and signal power range of the VSA.

    If a signal generator is generating the signal:

    1. Set the carrier frequency (1 GHz in the following example).
    2. Set the signal amplitude (-10 dBm in the following example).
    3. Apply modulation to the carrier signal.
    4. Turn on the modulated RF signal.
  3. Choose a measurement personality.
    1. Select Preset to set the instrument in the default state.
    2. From the measurement selection pull-down, select

    Spectrum > Standards > W-CDMA Downlink > Occupied Bandwidth.

  4. Set the measurement parameters and adjust the screen for optimum viewing.
  5. Transfer measurement results.
    1. Select File > Save Screen.
    2. Select Look in: and navigate to storage location.
    3. Select Keyboard (type image title) and Enter.
    4. Select Save.
    5. Select Yes.

.


Set and adjust W-CDMA Downlink (OB)

The image below shows a W-CDMA Downlink Occupied Bandwidth measurement on a signal centered at 1 GHz.

Notice the signal stays within the Occupied Bandwidth measurement markers, resulting in a Pass condition.

The W-CDMA Downlink Occupied Bandwidth is a Pass/Fail measurement. As long as the signal bandwidth stays within the green vertical limit lines, the Occupied Bandwidth measurement will pass. If the signal bandwidth passes beyond the green vertical limit lines, the W-CDMA Downlink Occupied Bandwidth measurement will fail.

Select from the list below to learn what choices you have for setting up a W-CDMA Downlink Occupied Bandwidth measurement:

1
  • W-CDMA Downlink OB measurement panel

  • Trigger settings panel

  • Atten/Preamp control panel

2

Trace Hold control

3

Averaging controls


WLAN (802.11x)

The Keithley Instruments Model 2820 Vector Signal Analyzer automatically synchronizes and captures the 802.11x burst on the instrument screen. From this captured signal, many measurements are made simultaneously. The results are compared with test limits and with the 802.11x Modulation Standards.

NOTE: The terms WLAN (wireless local-area network) and 802.11x are synonymous. The term 802.11x will be used predominantly within the scope of this help system.

Select from the following measurements to learn more:

  • 802.11x Demodulate
    • Please refer to Note: EVM calculation.
  • 802.11x Spectrum Emission Mask


802.11x Demodulate

Measurement operation

The 802.11 demodulation measurement has been optimized to operate in the internal memory of a floating point DSP chip. This memory, though limited, is very fast. To stay within the bounds of that memory, the initial acquisition is limited to a 2 ms block. Once that block is acquired, the measurement searches the block for a burst. The first burst found is processed and the results recorded. The measurement works best with bursts that are less than 1 ms long, although it can handle packets up to 1.9 ms if video trigger is used. If averaging is on, a different data block is acquired for each average. Only one packet from each block is used, so there is a speed advantage to limiting the acquisition to a single burst. This is done by using a video trigger to ensure the burst is at the start of the block, and limiting the acquisition time under the Settings menu to about 10% longer than the burst. The Optimize Setup function on the Settings menu automatically does this for signals that it can recognize. Refer to Acquisition time for more information.

Measurement procedure

  1. Set up test equipment.

    NOTE: This is a typical installation, with the Series 2800 VSA connected to the system controller. This arrangement facilitates making screen captures of the VSA display. The rear panel SCPI control connectors are the same on both instruments. Thus, either or both of the instruments could be directly connected to the system controller for remote control. Connection by LAN enables use of the LXI web interface for licensing operations and other features.

    1. REF IN can accept an input frequency of 1-20MHz.

  2. Acquire an 802.11x signal for Demodulate measurement.

    Make sure the signal to be measured is within the frequency and signal power range of the VSA.

    If a signal generator is generating the signal:

    1. Set the carrier frequency (1 GHz in the following example).
    2. Set the signal amplitude (-10 dBm in the following example).
    3. Apply modulation to the carrier signal.
    4. Turn on the modulated RF signal.
  3. Choose a measurement personality.
    1. Select Preset to set the instrument to the default state.
    2. From the measurement selection pull-down, select:

    Spectrum > Standards > 802.11x > Demodulate

  4. Set the measurement parameters and adjust the screen for optimum viewing.
  5. Transfer measurement results.
    1. Select File > Save Screen.
    2. Select Look in: and navigate to storage location.
    3. Select Keyboard (type image title) and Enter.
    4. Select Save.
    5. Select Yes.


Set and adjust 802.11x Demodulate

The instrument display below, shows the data from an 802.11x Demodulation measurement on a signal centered at a frequency of 1 GHz.

Select from the list below to learn what choices you have for setting up an 802.11x Demodulate measurement:

1
  • 802.11x Demodulate measurement panel
  • 802.11x Trace types
  • Trigger settings panel
  • 802.11x Signal types

2820wlanevmvssymbolfull40

2
  • Optimize Setup
  • Clear EVM history
  • Acquisition time
  • 802.11a/g/j/n (OFDM)...
  • 802.11b/g DSSS/CCK Settings
  • Edit limits
  • 802.11n Header data

3

802.11x Demodulation Averaging


802.11x Spectrum Emission Mask

The spectrum emission mask measurement can test spectral emissions for these standards:

  • 802.11a
  • 802.11b/g
  • 802.11j
  • 802.11n at 20MHz
  • 802.11n at 40MHz

The purpose of the spectral mask measurement is to see whether the signal is spilling into adjacent channels at a level higher than the respective standard allows.

For each standard except 802.11j the mask is drawn relative to the highest spectral density (the peak) of the signal. Signal levels above the mask are drawn in red. Within each range the margin and location of the minimum margin is tabulated. For 802.11j the standard is absolute (dBm), not relative (dBr).

The Signal Type selection box is used to choose the standard to test against. Note that Optimize Setup is not an option.

Caution: If you set up an 802.11x Demodulation measurement and select Optimize Setup from the Settings pull-down menu, the trigger source is changed to Video trigger. If you then choose to make a Spectrum Emission Mask measurement you will see that the trace is no longer visible and a message appears "Waiting for trigger or data...". Select Trigger > Trigger Source > Free Run to re-establish the trigger and the display will update properly.

Measurement procedure

  1. Set up test equipment.

    NOTE: This is a typical installation, with the Series 2800 VSA connected to the system controller. This arrangement facilitates making screen captures of the VSA display. The rear panel SCPI control connectors are the same on both instruments. Thus, either or both of the instruments could be directly connected to the system controller for remote control. Connection by LAN enables use of the LXI web interface for licensing operations and other features.

    1. REF IN can accept an input frequency of 1-20MHz.

  2. Acquire an 802.11x signal for Spectrum Emission Mask measurement.

    Make sure the signal to be measured is within the frequency and signal power range of the VSA.

    If a signal generator is generating the signal:

    1. Set the carrier frequency (1 GHz in the following example).
    2. Set the signal amplitude (-10 dBm in the following example).
    3. Apply modulation to the carrier signal.
    4. Turn on the modulated RF signal.
  3. Choose a measurement personality.
    1. Select Preset to set the instrument to the default state.
    2. From the measurement selection pull-down, select:

    Spectrum > Standards > 802.11x > Spectrum Emission Mask

  4. Set the measurement parameters and adjust the screen for optimum viewing.
  5. Transfer measurement results.
    1. Select File > Save Screen.
    2. Select Look in: and navigate to storage location.
    3. Select Keyboard (type image title) and Enter.
    4. Select Save.
    5. Select Yes.


Set and adjust 802.11x Spectrum Emission Mask

The instrument display below shows the data from an 802.11x Spectrum Emission Mask measurement on a signal centered at a frequency of 1GHz.

. 2820WLANsem75

Select from the list below to learn what choices you have for setting up an 802.11x Spectrum Emission Mask measurement:

1 | 802.11x SEM Measurement panel | 2820WLANsemfull40
2 | Detection Type control
3 | 802.11x SEM Averaging


Measurement settings

For each measurement listed, there is a group of settings associated with the setup and modification of the measurement.

  • General Purpose
    • Spectrum
    • Zero Span
    • ACPR
    • Channel Power List
  • GSM
  • EDGE
  • cdma2000
    • Demodulation
    • ACPR
    • Spectrum Emission
    • Occupied Bandwidth
  • W-CDMA Uplink
    • Demodulation
    • ACPR
    • Spectrum Emission
    • Occupied Bandwidth
  • W-CDMA Downlink
    • Demodulate
    • ACLR
    • Spectrum Emission
    • Occupied Bandwidth
  • 802.11x
    • 802.11x Demodulation settings
    • 802.11x Spectral mask settings


General purpose settings

Select from the lists below to learn about the choices you have to set up a general purpose measurement.

Spectrum

Zero Span
  • Measurement panel
  • Measurement panel
  • Trigger settings panel
  • Trigger settings panel
  • Atten Preamp settings panel
  • Atten Preamp settings panel
  • Detection Type control
  • Detection Type control
  • Trace Hold control
  • Filter Type control
  • Spur Cancellation control
  • Trace Hold control
  • Averaging control
  • Averaging control

ACPR

Channel Power List
  • Measurement panel
  • Measurement panel
  • Edit Channels settings panel
  • Trigger settings panel
  • Edit Limit settings panel
  • Filter Type control
  • Filter Type control
  • Trace Hold control
  • Trace Hold control
  • Fast Mode control
  • Fast Mode control
  • Noise Correction control
  • Noise Correction control
  • Averaging control
  • Averaging control


Spectrum settings

Select from this list to learn what choices are available for setting up a spectrum measurement.

  • Spectrum measurement panel
  • Trigger settings panel
  • Atten Preamp settings panel
  • Trace Hold control
  • Detection Type control
  • Spur Cancellation control
  • Averaging control


Spectrum measurement panel

This panel has settings for measurements that display as amplitude versus frequency.

Frequency values

You can select the frequency values from two sets of parameters:

  • Start and Stop frequencies

    or

  • Center and Span frequencies

If you choose the [Start Stop] set of parameters, you enter the value where the frequency sweep starts and the value where the frequency sweep stops.

If you choose the [Center Span] set of parameters, you enter the value that is in the center of the frequency sweep and the total span of frequencies that you want swept below and above the center frequency.

Remote control commands

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:FUNCtion:CENTer

[:SENSe]:FREQuency:CENTer

[:SENSe]:FREQuency:SPAN

[:SENSe]:FREQuency:STARt

[:SENSe]:FREQuency:STOP

Bandwidth

Bandwidth determines how low a signal amplitude that is close to a larger signal can be and still allow you to resolve the two signals.

You need to balance the effects the bandwidth has on your measurements:

  • Bandwidth Auto: couples the bandwidth value with the frequency span, when selected.
    • If selected, the bandwidth value is automatically set to 0.02% of the frequency span.
    • If not selected, you can set the bandwidth value independently.
  • Bandwidth field allows you to enter a value for the bandwidth.
    • Narrower bandwidths can allow you to measure signals that are close together (or close to the noise floor), yet they can slow down a measurement more than necessary.
    • Wide bandwidths can allow fast measurements, yet they may not provide adequate resolution, and the higher noise may obscure spectral components that are close together.

      Note: You also improve resolution by reducing the frequency span.

Remote control commands

[:SENSe]:SPECtrum:BANDwidth[:RESolution]

[:SENSe]:SPECtrum:BWIDth[:RESolution]

[:SENSe]:ZSPan:BANDwidth[:RESolution]

[:SENSe]:ZSPan:BANDwidth[:RESolution]:TYPE

[:SENSe]:ZSPan:BWIDth[:RESolution]

[:SENSe]:ZSPan:BWIDth[:RESolution]:TYPE

Sweep

Sets the type of sweep:

  • Continuous sweep repeatedly sweeps the span that you specified.
  • Single sweep takes one sweep of the span you specified.

Remote control commands

:INITiate:CONTinuous

:INITiate[:IMMediate][:ALL]

Markers

You can use markers for two different functions:

  • Locating and reading various measurement data.
  • Setting the center or reference parameter value to the marker position.

Each measurement trace has four markers, and each marker has an associated delta marker:

  • The marker indicates the x-axis and y-axis position for any point on a trace.
  • The delta marker indicates the relative value between the marker and the associated delta marker.

The measurement data associated with each of the marker positions is displayed at the top of the instrument screen.

  • Tab 1 2 3 4 selects one of the four markers for editing the marker parameters.
  • Marker On check box enables and disables the marker associated with the selected tab.
  • Marker Position sets the x-axis value of the marker.
  • Delta Marker
    • Off switches off the delta marker for the marker associated with the selected tab.
    • Tracking keeps the delta marker at the set x-axis position and updates the y-axis position with each sweep.
    • Fixed Point keeps the delta marker at both the x-axis and y-axis positions that you set.
  • Delta sets the difference in x-axis positions between the delta marker and the associated marker.
  • Zero Delta brings the delta marker to the same position as the marker associated with the selected tab.
  • Center sets the center frequency parameter value to the current x-axis value of the marker.
  • Ref sets the screen reference value to the current y-axis value of the marker.
  • Max moves the marker to the maximum amplitude of the measurement trace.
  • Next moves the marker to the top of the next largest peak that is below the marker's current y-axis value.
  • Left moves the marker to the top of the next largest peak that is to the left of the current marker position and at least 3 dB below the current marker position.
  • Right moves the marker to the top of the next largest peak that is to the right of the current marker position and at least 3 dB below the current marker position.

Remote control commands

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4|[:STATe]

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:LEFT

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:NEXT

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:PREVious

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:RIGHt

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum[:PEAK]

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:DELTa:ZERO

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:FUNCtion:CENTer

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:FUNCtion:REFerence

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:Y?


Trigger settings panel

This panel allows you to set up settings for triggering signals.

Trigger Source

Sets the input trigger source:

  • Free Run triggers another measurement immediately at the end of each measurement if you have set continuous sweep. If you have set single sweep, you must select Sweep Single to trigger a measurement.
  • External triggers a measurement when the instrument receives an external signal pulse.
  • Video triggers a measurement when the input signal reaches the value specified.
  • Bus triggers a measurement when the instrument receives the *TRG command.
  • Ext Arm/Video Trig triggers a measurement when the instrument receives an external signal pulse and the input signal reaches the specified value.
  • Bus Arm/Ext Trig triggers a measurement when the instrument receives a *TRG command to arm the trigger and an external signal pulse.
  • Bus Arm/Video Trig triggers a measurement when the instrument receives a *TRG command to arm the trigger and the input signal reaches the specified value.
  • Ext Latched is similar to External. It triggers a measurement if the external input has sent an active edge since the last latch reset. The external trigger latch is reset when the trigger is used or the receiver sends a sync out signal.

Remote control command

:TRIGger[:SEQuence]:SOURce

Video Level

Sets the power level that the incoming RF signal must reach to cause a trigger event.

Remote control commands

:TRIGger[:SEQuence]:LEVel

Trigger Delay

When the trigger delay is set to zero, the center point of the data window is where the trigger occurred. Changing the trigger delay value allows you to see measurement trace events that occurred before or after the trigger. The trigger delay value is the point at the center of the data acquisition window.

Remote control commands

:TRIGger[:SEQuence]:DELay

Auto Trigger Timeout

Sets the time to wait in seconds for a trigger before automatically providing an internal trigger to acquire a measurement:

  • Time Out ON enables the auto trigger timeout when selected.
  • Time Out sets the time to wait for a trigger.

Remote control commands

:TRIGger[:SEQuence]:AUTO:TIMEout

:TRIGger[:SEQuence]:AUTO[:STATe]

Video Trigger

Sets the parameters of the video trigger:

  • Signal Type sets the condition that causes a trigger:
    • Edge sets the trigger condition to be a transition of signal power over the specified video level.
    • Level sets the trigger condition to be a signal power level.
  • Slope sets the video trigger slope:
    • Positive sets the trigger to happen on the positive-going slope of a pulse. If the video trigger signal type is Edge, the RF signal must transition from a lower value to a higher value over the specified video level to cause a trigger.
    • Negative sets the trigger to happen on the negative-going slope of a pulse. If the video trigger signal type is Edge, the RF signal must transition from a higher value to a lower value over the specified video level to cause a trigger.
  • Pre-Qualification:
    • Level sets the power level boundary that the input signal must avoid for some specified time before the trigger will be recognized by the instrument.
    • Time sets a window area in seconds at some specified power level that the input signal must avoid before the trigger will be recognized by the instrument.

Remote control commands

:TRIGger[:SEQuence]:VIDeo:SLOPe

:TRIGger[:SEQuence]:TYPE

:TRIGger[:SEQuence]:PREQual:WINDow

:TRIGger[:SEQuence]:PREQual[:LEVel]

External Trigger
  • Slope sets the external trigger slope:
    • Positive sets the trigger to happen on the positive-going slope of a pulse.
    • Negative sets the trigger to happen on the negative-going slope of a pulse.

Remote control commands

:TRIGger[:SEQuence]:EXTernal:SLOPe


Atten/Preamp settings panel

The attenuator and preamplifier allow you to modify input signal power.

Atten

Atten Auto On enables the automatic application of attenuation to the input signal when selected. When you select the Ref Level or Expected Power value, the analyzer automatically adjusts the input attenuation to optimize the power measurement range.

Atten Value allows you to view the attenuation value automatically applied by the analyzer (if the Atten Auto is enabled), or you enter an attenuation value manually. The manual setting is useful when you want to step the attenuation value to determine if displayed signal spurs are due to the device under test or the analyzer.

Note: A * symbol will appear next to the word Atten in the Atten/Preamp button when the manual setting is selected. This is a visual indicator that automatic setting is uncoupled and that the instrument no longer tracks changes to the reference level.

Remote control commands

[:SENSe]:POWer[:RF]:ATTenuation

[:SENSe]:POWer[:RF]:ATTenuation:AUTO

[:SENSe]:POWer[:RF]:GAIN[:STATe]

Preamp

Preamp allows you to add power amplification (approximately 13dB) to the input signal. This is useful for improving measurement sensitivity when the signal has lower power.

Note: A * symbol will appear next to the word Preamp in the Atten/Preamp button when the Preamp is selected. This is a visual indicator that the Preamp has been turned on.


Detection Type control

The display detector type determines the method that the analyzer uses to process the measurement results signal before it is displayed on the analyzer screen. Each trace point represents a band of frequency (or time) that is equal to Span/500. Among the 500 there is an upper and a lower value. The analyzer returns these two values for each of the 501 measurement trace points:

  • Upper value
  • Lower value

The detection method creates the trace from a composition of the measurement point data available. You can choose from the following detection types:

  • Normal draws the measurement trace using the maximum as the upper value and the minimum as the lower value for each of the frequency spans or time intervals associated with the measurement points.
  • Max sets both the upper and lower values to the maximum value of the signal power for each of the frequency spans or time intervals associated with the measurement points.
  • Min sets both the upper and lower values to the minimum value of the signal power for each of the frequency spans or time intervals associated with the measurement point.
  • Sample sets both the upper and lower value to the signal power in the middle of the span interval.
  • Power Average sets both the upper and lower values to the average of the signal power during the span interval.
  • PwrAvg + NoiseCorr draws the trace using the result of two separate measurements with power average detection. The first measurement is a usual power average type of detection. The second measurement is a power average type of detection, but with the input signal disconnected. This second measurement indicates the internal noise of the analyzer. The displayed trace is the result of the first measurement (signal+noise) minus the second measurement (noise). The resulting trace is a more precise representation of the input signal power, but the overall measurement time doubles.

Remote control command

[:SENSe]:DETector[:FUNCtion]

[:SENSe]:SEMask:DETector[:FUNCtion]


Trace Hold control

Holds the measurement trace in a persistent state, visually adding the results of subsequent measurements. This allows you to analyze the data in a steady state.

Each trace point represents a band of frequency (or time) that is equal to Span/500. Among the 500 there is an upper and a lower value. The analyzer returns two values for each of the 501 measurement trace points:

  • Upper value
  • Lower value

The trace is created from a composition of the measurement point data available. You can choose to view the trace with the following characteristics:

  • Normal shows the 501 positions of the current measurement trace, possibly averaged, with no visual persistence.
  • Max Hold shows and visually holds the maximum values for each set of values taken at the 501 measurement points.
  • Min Hold shows and visually holds the minimum values for each set of values taken at the 501 measurement points.
  • Min/Max Hold shows and visually holds the maximum upper value and the minimum lower value for each set of values taken at the 501 measurement points.

Remote control command

:TRACe:HOLD


Spur Cancellation control

Switches on the spur cancellation function, if the check box is selected.

Remote control commands

[:SENSe]:SPECtrum:SPUR:CANCellation


Averaging control

The averaging function minimizes the effects of noise by averaging the results of multiple measurements.

There are two values displayed for each of the 501 measurement points across the instrument screen: a lower value and an upper value. These two values represent the total excursion of the signal within the span of a single display point. When averaging is enabled, the lower and upper values are averaged as independent sets.

  • Averaging On: switches on the averaging function when the check box is selected.
  • Number: specifies how many measurements to take into consideration for the averaging calculation of the measurement results.
  • Type:
    • Log Running shows a new set of averaged logged data for each measurement that is taken. The displayed data trace is calculated based on a weighted average of the previous and current measurements. This result may be useful when you are looking at noise levels. A display result is generated for every measurement.
    • Power Running shows a new set of averaged power data as logged data for each measurement that is taken. The data trace is calculated as a weighted average of power values from the previous and current measurements. The results are then displayed as logged data. A display result is generated for every measurement.
    • Log Group shows the average of the logged data results from multiple measurements. You specify the number of measurements to take for the calculation. A display result is generated for every N measurements.
    • Power Group shows the average of the power data results from multiple measurements. You specify the number of measurements to take for the calculation. The calculated result is then displayed as logged data. A displayed result is generated for every N measurements.
    • Max Group shows the maximum of the upper and lower data sets across N measurements.
    • Min Group shows the minimum of the upper and lower data sets across N measurements.
    • Min/Max Group shows the the minimum of the lower data sets and the maximum of the upper data sets across the N measurements.

Remote control commands

[:SENSe]:SPECtrum:AVERage:COUNt

[:SENSe]:SPECtrum:AVERage:TYPE

[:SENSe]:SPECtrum:AVERage[:STATe]


Zero Span Settings

Select from this list to learn what choices you have for setting up a spectrum zero-span measurement:

  • Zero span measurement panel
  • Trigger settings panel
  • Atten Preamp settings panel
  • Detection Type control
  • Filter Type control
  • Trace Hold control
  • Averaging control


Zero Span measurement panel

When Zero Span is selected, the analyzer is a fixed-tuned receiver. The amplitude variation is detected by the analyzer and displayed in the time domain.

This panel has the fundamental settings for making a zero-span measurement.

Center Frequency

Sets the frequency that the analyzer is tuned to and measures over time.

Remote control commands

:CALCulate:MARKer1:FUNCtion:CENTer

[:SENSe]:FREQuency:CENTer

Sweep Time

Sets the length of time that the measurement takes place.

Remote control command

[:SENSe]:ACPR:CENTer:SWEep:TIME

[:SENSe]:ACPR:ADJacent1|ADJacent2:SWEep:TIME

Bandwidth

Bandwidth determines how low a signal amplitude that is close to a larger signal can be and still allow you to resolve the two signals.

You need to balance the effects the bandwidth has on your measurements:

  • Bandwidth Auto: couples the bandwidth value with the frequency span, when selected.
    • If selected, the bandwidth value is automatically set to 0.02% of the frequency span.
    • If not selected, you can set the bandwidth value independently.
  • Bandwidth field allows you to enter a value for the bandwidth.
    • Narrower bandwidths can allow you to measure signals that are close together (or close to the noise floor), yet they can slow down a measurement more than necessary.
    • Wide bandwidths can allow fast measurements, yet they may not provide adequate resolution, and the higher noise may obscure spectral components that are close together.

      Note: You also improve resolution by reducing the frequency span.

Remote control commands

[:SENSe]:SPECtrum:BANDwidth[:RESolution]

[:SENSe]:SPECtrum:BWIDth[:RESolution]

[:SENSe]:ZSPan:BANDwidth[:RESolution]

[:SENSe]:ZSPan:BANDwidth[:RESolution]:TYPE

[:SENSe]:ZSPan:BWIDth[:RESolution]

[:SENSe]:ZSPan:BWIDth[:RESolution]:TYPE

Sweep

Sets the type of sweep:

  • Continuous sweep repeatedly sweeps the span that you specified.
  • Single sweep takes one sweep of the span you specified.

Remote control commands

:INITiate:CONTinuous

:INITiate[:IMMediate][:ALL]

Markers

You can use markers for two different functions:

  • Locating and reading various measurement data.
  • Setting the center or reference parameter value to the marker position.

Each measurement trace has four markers and delta markers:

  • The marker indicates the x-axis and y-axis position for any point on a trace.
  • The delta marker indicates the relative value between the marker and the delta marker.

The measurement data associated with each of the marker positions is displayed at the top of the instrument screen.

  • Tab 1 2 3 4 selects one of the four markers for editing the marker parameters.
  • Marker On check box enables and disables the marker associated with the selected tab.
  • Marker Position sets the x-axis value of the marker.
  • Delta Marker
    • Off switches off the delta marker for the marker associated with the selected tab.
    • Tracking keeps the delta marker at the set x-axis position and updates the y-axis position with each sweep.
    • Fixed Point keeps the delta marker at both the x-axis and y-axis positions that you set.
  • Delta sets the difference in x-axis positions between the delta marker and the marker associated with the selected tab.
  • Zero Delta brings the delta marker to the same position as the marker associated with the selected tab.
  • Delay sets the trigger delay parameter value to the current x-axis value of the marker.
  • Ref sets the screen reference value to the current y-axis value of the marker.
  • Max moves the marker to the maximum amplitude of the measurement trace.
  • Next moves the marker to the top of the next largest peak that is below the marker's current y-axis value.
  • Left moves the marker to the top of the next largest peak that is to the left of the current marker position and at least 3 dB below the current marker position.
  • Right moves the marker to the top of the next largest peak that is to the right of the current marker position and at least 3 dB below the current marker position.

Remote control commands

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4|[:STATe]

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:LEFT

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:NEXT

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:PREVious

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:RIGHt

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum[:PEAK]

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:DELTa:ZERO

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:FUNCtion:CENTer

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:FUNCtion:REFerence

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:Y?


Filter Type control

The resolution bandwidth filter determines the smoothing of the displayed measurement trace. The bandwidth of the filter is determined by the parameter you choose:

  • Resolution bandwidth for zero span measurements
  • Channel bandwidth for ACPR measurements

You can choose from the following filter shapes and characteristics:

  • Brickwall is a flat-topped filter shape that rolls off very quickly. You can control the width of the flat portion of the filter, using the bandwidth setting. The transition regions are raised cosine, of width equal to 10% of the bandwidth setting. The overall shape of the filter is a raised-cosine filter with an excess bandwidth ratio of 0.09 and a 6 dB and equivalent noise bandwidth equal to 1.09 times the bandwidth setting.
  • Sync Tuned 5 Pole has 5 poles at the same center frequency (synchronously-tuned), with a composite 3 dB bandwidth equal to the bandwidth setting. This filter mimics a filter in older sweeping spectrum analyzers.
  • Sync Tuned 4 Pole has 4 poles at the same center frequency (synchronously-tuned), with a composite 3 dB bandwidth equal to the bandwidth setting. This filter mimics a filter in older sweeping spectrum analyzers.
  • RRC (a=0.22) is a raised-root-cosine filter with excess bandwidth setting of 0.22. The bandwidth setting specifies the 3 dB bandwidth.
  • Gaussian is a true Gaussian shape where the 4 or 5 pole synchronously tuned filters are an approximation. The bandwidth setting specifies the 3 dB bandwidth.

Remote control commands

[:SENSe]:ACPR:BANDwidth[:RESolution]:TYPE

[:SENSe]:ACPR:BWIDth[:RESolution]:TYPE

[:SENSe]:ZSPan:BANDwidth[:RESolution]:TYPE

[:SENSe]:ZSPan:BWIDth[:RESolution]:TYPE


Averaging control

There are two values displayed for each of the 501 measurement points across the instrument screen: a lower value and an upper value. These two values represent the total excursion of the signal within the span of a single display point. When averaging is enabled, the lower and upper values are averaged as independent sets.

  • Averaging On: switches on the averaging function when the check box is selected.
  • Number: specifies how many measurements to take into consideration for the averaging calculation of the measurement results.
  • Type:
    • Log Running shows a new set of averaged logged data for each measurement that is taken. The displayed data trace is calculated based on a weighted average of the previous and current measurements. This result may be useful when you are looking at noise levels. A display result is generated for every measurement.
    • Power Running shows a new set of averaged power data as logged data for each measurement that is taken. The data trace is calculated as a weighted average of power values from the previous and current measurements. The results are then displayed as logged data. A display result is generated for every measurement.
    • Log Group shows the average of the logged data results from multiple measurements. You specify the number of measurements to take for the calculation. A display result is generated for every N measurements.
    • Power Group shows the average of the power data results from multiple measurements. You specify the number of measurements to take for the calculation. The calculated result is then displayed as logged data. A displayed result is generated for every N measurements.
    • Max Group shows the maximum of the upper and lower data sets across N measurements.
    • Min Group shows the minimum of the upper and lower data sets across N measurements.
    • Min/Max Group shows the the minimum of the lower data sets and the maximum of the upper data sets across the N measurements.

Remote control commands

[:SENSe]:ZSPan:AVERage:COUNt

[:SENSe]:ZSPan:AVERage:TYPE

[:SENSe]:ZSPan:AVERage[:STATe]


ACPR settings

The adjacent channel power ratio (ACPR) is the ratio of the amount of signal power in a main channel that is introduced to the channels immediately above and below the center channel. Select from the list to learn about the choices you have to set up an ACPR measurement.

  • ACPR measurement panel
  • Edit Channels settings panel
  • Edit Limits settings panel
  • Filter type control
  • Trace Hold control
  • Fast Mode control
  • Noise Correction control
  • Averaging control


ACPR measurement panel

This panel has the fundamental settings for making an adjacent channel power ratio (ACPR) measurement.

Channel Frequency

Sets the main channel center frequency.

Remote control command

[:SENSe]:FREQuency:CENTer

Channel Bandwidth

Sets the bandwidth of the main channel.

Remote control commands

[:SENSe]:ACPR:CENTer:BANDwidth

[:SENSe]:ACPR:CENTer:BWIDth

Expected Power

Sets the main channel expected power.

Remote control commands

:DISPlay:WINDow:TRACe:Y[:SCALe]:RLEVel

Sweep

Sets the type of sweep:

  • Continuous sweep repeatedly sweeps the span that you specified.
  • Single sweep takes one sweep of the span you specified.

Remote control commands

:INITiate:CONTinuous

:INITiate[:IMMediate][:ALL]


Edit Channels settings panel

This settings panel allows you to edit the parameters for the main channel and the adjacent channels.

Channel

Sets which channel to apply the remaining parameters in the Edit Channels dialog box:

  • Center applies the parameters to the center main channel.
  • 1st Adjacent applies the parameters to the channels immediately adjacent to the main channel.
  • 2nd Adjacent applies the parameters to the second set of channels adjacent to the main channel.
  • On enables and disables the adjacent channel measurement that you have selected to edit.

Offset Frequency or Channel Frequency

Depending on the choice you made for the Channel setting, you will see one of the following parameters:

  • Offset Frequency sets the center frequency of the specified adjacent channels relative to the main channel center frequency.
  • Channel Frequency sets the main channel center frequency.

Remote control commands

[:SENSe]:ACPR:ADJacent1|ADJacent2:OFRequency

[:SENSe]:FREQuency:CENTer

Bandwidth

Sets the bandwidth of the channel that you specified for the Channel parameter.

Remote control commands

[:SENSe]:ACPR:CENTer:BANDwidth

[:SENSe]:ACPR:CENTer:BWIDth

[:SENSe]:ACPR:ADJacent1|ADJacent2:BANDwidth

[:SENSe]:ACPR:ADJacent1|ADJacent2:BWIDth

Sweep Time

Sets the length of time that the measurement takes place.

Remote control command

[:SENSe]:ACPR:CENTer:SWEep:TIME

[:SENSe]:ACPR:ADJacent1|ADJacent2:SWEep:TIME


Edit Limits settings panel

This settings panel allows you to edit the limits for the adjacent channel limit testing.

Channel

Sets which adjacent channel to apply the remaining limits parameters to in the Edit Limits dialog box:

  • 1st Adjacent applies the limits parameters to the channels immediately adjacent to the main channel.
  • 2nd Adjacent applies the limits parameters to the second set of channels adjacent to the main channel.

Limit
  • The Limit On check box enables and disables the limit testing. If the box is selected, the limit testing is enabled. If the check box is unselected, the limit testing is disabled.
  • The Limit value field sets the Pass/Fail power value for the limit test. The power value is is relative to the main channel power (dBc).

Remote control commands

:CALCulate:ACPR:LIMit:ADJacent1|ADJacent2:UPPer

:CALCulate:ACPR:LIMit:ADJacent1|ADJacent2[:STATe]

:CALCulate:ACPR:LIMit:FAIL?


Trace Hold control

Holds the measurement trace in a persistent state, visually adding the results of subsequent measurements. This allows you to analyze the data in a steady state.

Each trace point represents a band of frequency (or time) that is equal to Span/500. Among the 500 there is an upper and a lower value. The analyzer returns these two values for each of the 501 measurement trace points:

  • Upper value
  • Lower value

The trace is created from a composition of the measurement point data available. You can choose to view the trace with the following characteristics.

  • Normal shows the 501 positions of the current measurement trace, possibly averaged, with no visual persistence.
  • Max Hold shows and visually holds the maximum values for each set of values taken at the 501 measurement points.
  • Min Hold shows and visually holds the minimum values for each set of values taken at the 501 measurement points.

Remote control command

:TRACe:ACPR:HOLD


Fast Mode control

This mode uses a faster measurement algorithm that is generally possible if the sweep time is not too long relative to the measurement bandwidth. If the instrument does use fast mode, there is no degradation in accuracy, but the measurement time will most likely be different than the setting for sweep time. It will be somewhere between sweep time and 2x sweep time.

Also, if the filter type is brickwall and the bandwidth is one of 10 or so particular bandwidths, then the measurement will be even faster. In this case, the sweep time will be accurate but the filter will be slightly different than the normal brickwall filter.

Remote control command

[:SENSe]:ACPR:FAST


Noise Correction control

Noise correction is the result of two separate measurements with power average detection. The first measurement is a usual power average type of detection. The second measurement is a power average type of detection, but with the input signal disconnected. This second measurement indicates the internal noise of the analyzer. The displayed trace is the result of the first measurement (signal+noise) minus the second measurement (noise). The resulting trace is a more precise representation of the input signal power, but the overall measurement time doubles.

Remote control command

[:SENSe]:ACPR:NCORrection


Averaging control

The averaging function minimizes the effects of noise by averaging the results of multiple measurements.

There are two values displayed for each of the 501 measurement points across the instrument screen: a lower value and an upper value. These two values represent the total excursion of the signal within the span of a single display point. When averaging is enabled, the lower and upper values are averaged as independent sets.

The ACPR measures five values for each data point: the center channel frequency and two adjacent channels, each offset above and below the center.

  • Averaging On: switches on the averaging function, if the check box is selected.
  • Number: specifies how many measurements to take into consideration for the averaging calculation of the measurement results.
  • Type:
    • Log Running shows a new set of averaged logged data for each measurement that is taken. The displayed data trace is calculated based on a weighted average of the previous measurement and the current measurement. This result may be useful when you are looking at noise levels. A display result is generated for every measurement.
    • Power Running shows a new set of averaged power data as logged data for each measurement that is taken. The data trace is calculated as a weighted average of power values from the previous measurement and the current measurement. The results are then displayed as logged data. A display result is generated for every measurement.
    • Log Group shows the average of the logged data results from multiple measurements. You specify the number of measurements to take for the calculation. A display result is generated for every N measurements.
    • Power Group shows the average of the power data results from multiple measurements. You specify the number of measurements to take for the calculation. The calculated result is then displayed as logged data. a display result is generated for every N measurements.
    • Max Group shows the maximum of the upper and lower data sets across N measurements.
    • Min Group shows the minimum of the upper and lower data sets across N measurements.

Remote control commands

[:SENSe]:ACPR:AVERage:COUNt

[:SENSe]:ACPR:AVERage:TYPE

[:SENSe]:ACPR:AVERage[:STATe]


Channel power list settings

The channel power list allows you to load a file that contains a list of measurement states that includes state, frequency, RBW, sweep time, reference level and preamp values. Select from the list below to learn about the choices you have to set up a list of channel power measurements:

  • Channel List measurement panel
  • Trigger settings panel
  • Filter type control
  • Trace Hold control
  • Fast Mode control
  • Noise Correction control
  • Averaging control


Channel List measurement panel

This panel controls measurement settings relevant to the channel power lists. To access this panel select: Spectrum > General Purpose > Channel Power List. The default setting is a single point at 1 GHz with an RBW of 1 MHz, a sweep time of 1 msec., a reference level of 0 and the Preamp OFF.

Channel List
  • Current List: the name of the channel power list file currently loaded in the instrument.
  • Open... brings up a file management window that allows you to navigate to a channel power list file and open it. Other file management operations, such as copy, paste, rename and delete are also available through this window.

The default file location in the Look in: drop-down menu is User. This is the instrument's internal memory. The Look in: drop-down menu provides access to a connected USB memory stick or to any shared network folder.

Note: You must create and edit the channel power list in an external application, such as Microsoft Excel or Notepad. The maximum number of channels allowed in a channel power list file is 501. The channel list table reflects the content of the file, and is not editable.

If you have existing channel power list files (Version 1.0) to update refer to Channel power list version 1.0.

Example channel power list file:

Channel Power List Version 2.0,,,

Begin Table,,,

State, Frequency, RBW, SweepTime,RefLevel,Preamp

1,1.800000e+009,1.000000e+007,1.000000e-004,20,Off

1,1.788500e+009,1.000000e+006,1.000000e-004,10,Off

1,1.793000e+009,1.000000e+006,1.000000e-004,0,off

1,1.794450e+009,1.000000e+005,1.000000e-004,-10,OFF

1,1.805550e+009,1.000000e+005,1.000000e-004,-20,0

1,1.807000e+009,1.000000e+006,1.000000e-004,-30,0

Remote control command

[:SENSe]:CPList:LOAD

Acquisition Interval

Sets the amount of time between the beginning of the previous data acquisition and the start of the current one. Valid when the list count is greater than one. This is useful for pacing a list of channel measurements.

Remote control command

[:SENSe]:ACD:DITHer[:STATe]

[:SENSe]:AINT

Sync Output

Sets the sync timing anchor for the channel power list:

  • Sync Type:
    • Off switches off the sync output.
    • Begin Measurement sends a pulse at the beginning of the list.
    • Start Tune sends a pulse each time the analyzer tunes to a new frequency.
    • Ready Acquire sends a pulse when the analyzer is ready to acquire data. This is independent of the Acquisition Interval setting.
    • Start Acquire sends as pulse each time the analyzer starts acquiring data.
    • End Acquire sends a pulse each time the analyzer finishes acquiring data.
    • End Measurement sends a pulse when the analyzer has reached the end of the measurement.

Remote control commands

:SOUTput:MODE

Sync Polarity

Sets the polarity of the sync pulse:

  • Rising sets the channel power list sync to a rising edge pulse.
  • Falling sets the channel power list sync to a falling edge pulse.

Remote control commands

:SOUTput:POLarity

Sweep

Sets the type of sweep:

  • Continuous sweep repeatedly sweeps the span that you specified.
  • Single sweep takes one sweep of the span you specified.

Remote control commands

:INITiate:CONTinuous

:INITiate[:IMMediate][:ALL]


Channel power list version 1.0

A version 1.0 channel power list has four columns rather than the six columns of a version 2.0 list. You can use a version 1.0 channel power list, but RefLevel and Preamp are set to the global values. Here, the global values are "0.0" for RefLevel and "Off" for Preamp. You will notice that if you load a version 1.0 file that an asterisk appears at the top of the RefLevel and Preamp columns.

NOTE: No warning message is displayed on the front panel or returned by way of the remote interface (SCPI) if you load a version 1.0 file.

The global reference level sets hardware and the top of the graph reference level. When you change the RefLevel in a version 2.0 channel power list it affects the hardware but does not change the graph reference level. To upgrade an existing version 1.0 file to version 2.0 refer to the two examples and make the following changes in a text editor tool:

  1. On line 1 change 1.0 to 2.0.
  2. On line 3 add the terms RefLevel and Preamp. Both of these terms are case sensitive. RefLevel may be any value within the allowable reference level limits. Preamp is either on or off. The acceptable terms for the Preamp setting are 1, 0, on and off. "On" and "Off" are not case sensitive.

Channel Power List Version 1.0

Begin Table

State, Frequency, RBW, SweepTime

1, 650000000, 1000000, 0.00001,

1, 795000000, 1000000, 0.00001,

1, 940000000, 1000000, 0.00001,

1, 1085000000, 1000000, 0.00001,

1, 1230000000, 1000000, 0.00001,

1, 1375000000, 1000000, 0.00001,

1, 1520000000, 1000000, 0.00001,

1, 1665000000, 1000000, 0.00001,

1, 1810000000, 1000000, 0.00001,

1, 1955000000, 1000000, 0.00001,

1, 2100000000, 1000000, 0.00001,

Channel Power List Version 2.0,,,

Begin Table,,,

State, Frequency, RBW, SweepTime,RefLevel,Preamp

1,1.800000e+009,1.000000e+007,1.000000e-004,20,Off

1,1.788500e+009,1.000000e+006,1.000000e-004,10,Off

1,1.793000e+009,1.000000e+006,1.000000e-004,0,off

1,1.794450e+009,1.000000e+005,1.000000e-004,-10,OFF

1,1.805550e+009,1.000000e+005,1.000000e-004,-20,0

1,1.807000e+009,1.000000e+006,1.000000e-004,-30,0


Averaging control

The averaging function minimizes the effects of noise by averaging the results of multiple measurements.

There are two values displayed for each of the 501 measurement points across the instrument screen: a lower value and an upper value. These two values represent the total excursion of the signal within the span of a single display point. When averaging is enabled, the lower and upper values are averaged as independent sets.

The ACPR measures five values for each data point: the center channel frequency and two adjacent channels, each offset above and below the center.

  • Averaging On: switches on the averaging function, if the check box is selected.
  • Number: specifies how many measurements to take into consideration for the averaging calculation of the measurement results.
  • Type:
    • Log Running shows a new set of averaged logged data for each measurement that is taken. The displayed data trace is calculated based on a weighted average of the previous measurement and the current measurement. This result may be useful when you are looking at noise levels. A display result is generated for every measurement.
    • Power Running shows a new set of averaged power data as logged data for each measurement that is taken. The data trace is calculated as a weighted average of power values from the previous measurement and the current measurement. The results are then displayed as logged data. A display result is generated for every measurement.
    • Log Group shows the average of the logged data results from multiple measurements. You specify the number of measurements to take for the calculation. A display result is generated for every N measurements.
    • Power Group shows the average of the power data results from multiple measurements. You specify the number of measurements to take for the calculation. The calculated result is then displayed as logged data. a display result is generated for every N measurements.
    • Max Group shows the maximum of the upper and lower data sets across N measurements.
    • Min Group shows the minimum of the upper and lower data sets across N measurements.

Remote control commands

[:SENSe]:CDMA:REVerse:AVERage:COUNt

[:SENSe]:CDMA:REVerse:AVERage:TYPE

[:SENSe]:CDMA:REVerse:AVERage[:STATe]

[:SENSe]:ACPR:AVERage:COUNt

[:SENSe]:ACPR:AVERage:TYPE

[:SENSe]:ACPR:AVERage[:STATe]


GSM settings

Select from the list to learn what choices you have for setting up a GSM measurement:

  • GSM measurement panel
  • Channel Power Limits settings panel
  • Phase Error Limits settings panel
  • Time Mask Limits settings panel
  • ORFS Mod settings panel
  • ORFS Switch settings panel
  • Phase Error control
  • Time Mask control
  • ORFS Mod control
  • ORFS Switch control
  • Averaging control


GSM measurement panel

This panel has the fundamental settings for making a GSM measurement.

Training Sequence

Sets the training sequence to look for in the selected slot to measure.

The middle part of a GSM burst is dedicated to one of eight possible training sequences (numbered 0 to 7).

  • If there is only one time slot active, just set the appropriate training sequence (usually 0).
  • If there is more than one time slot active, you must also set the following parameters:
    • First active slot
    • Slot to measure
    • Number of active time slots

Remote control command

[:SENSe]:GSM:TSEQuence

Carrier Frequency

Tunes the analyzer to the frequency of the carrier signal.

Remote control command

[:SENSe]:FREQuency:CENTer

Expected Power

Sets the expected incoming power of the GSM burst. To optimize the instrument dynamic range, set the largest expected channel power value.

Remote control command

[:SENSe]:EPOWer

Time Slot Configuration
  • Training Sequence sets the training sequence to look for in the selected slot to measure.
  • Active Slots sets the number of active time slots in the incoming signal. Must be contiguous and no more than 7 slots.
  • First Active Slot sets the first slot that is active.
  • Slot To Measure sets the time slot to measure, 0 to 7.

For more information, see Configuring time slots

Remote control command

[:SENSe]:GSM:TSLot:COUNt

[:SENSe]:GSM:TSLot:FIRSt

[:SENSe]:GSM:TSLot[:SELect]

GSM Trace Type

Sets the type of GSM trace to display on the instrument screen:

  • None disables the GSM measurement trace.
  • Time Mask shows the whole GSM burst and overlays a mask on the screen that allows you to determine if the entire GSM burst power over time meets specified limits:
    • Rising shows only the rising edge of the GSM burst and overlays a mask on the screen that allows you to determine if the rising edge of the burst meets specified limits.
    • Falling shows only the falling edge of the GSM burst and overlays a mask on the screen that allows you to determine if the falling edge of the burst meets specified limits.
    • Top shows only the top of the GSM burst and overlays a mask on the screen that allows you to determine if the top of the burst meets specified limits.
  • Phase Error shows the resulting modulation phase error over time on the instrument screen.
  • Phase Trace shows the actual measured phase on the instrument screen.
  • Symbols shows the demodulated I and Q bits on the instrument screen.

Remote control command

:DISPlay:VIEW:GSM:TYPE

Sweep

Sets the type of sweep:

  • Continuous sweep repeatedly sweeps the span that you specified.
  • Single sweep takes one sweep of the span you specified.

Remote control commands

:INITiate:CONTinuous

:INITiate[:IMMediate][:ALL]

Markers

You can use markers for two different functions:

  • Locating and reading various measurement data.
  • Setting the center or reference parameter value to the marker position.

Each measurement trace has four markers, and each marker has an associated delta marker:

  • The marker indicates the x-axis and y-axis position for any point on a trace.
  • The delta marker indicates the relative value between the marker and the associated delta marker.

The measurement data associated with each of the marker positions is displayed at the top of the instrument screen.

  • Tab 1 2 3 4 selects one of the four markers for editing the marker parameters.
  • Marker On check box enables and disables the marker associated with the selected tab.
  • Marker Position sets the x-axis value of the marker.
  • Delta Marker
    • Off switches off the delta marker for the marker associated with the selected tab.
    • Tracking keeps the delta marker at the set x-axis position and updates the y-axis position with each sweep.
    • Fixed Point keeps the delta marker at both the x-axis and y-axis positions that you set.
  • Delta sets the difference in x-axis positions between the delta marker and the associated marker.
  • Zero Delta brings the delta marker to the same position as the marker associated with the selected tab.
  • Center sets the center frequency parameter value to the current x-axis value of the marker.
  • Ref sets the screen reference value to the current y-axis value of the marker.
  • Max moves the marker to the maximum amplitude of the measurement trace.
  • Next moves the marker to the top of the next largest peak that is below the marker's current y-axis value.
  • Left moves the marker to the top of the next largest peak that is to the left of the current marker position and at least 3 dB below the current marker position.
  • Right moves the marker to the top of the next largest peak that is to the right of the current marker position and at least 3 dB below the current marker position.

Remote control commands

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4|[:STATe]

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:LEFT

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:NEXT

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:PREVious

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:RIGHt

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum[:PEAK]

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:DELTa:ZERO

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:FUNCtion:CENTer

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:FUNCtion:REFerence

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:Y?

Autoscale

Scales the displayed measurement so that you can view the entire trace on the instrument screen. The scaling is done by automatically adjusting the value per division and the reference level.

View

Allows you to select the view of the measurement results:

  • Graph & Table displays a graph in the bottom of the screen and a table in the top of the screen. The graph shows the measurement results as a trace. The table shows a tabular listing of measured values, set limits, and limit test results for each of the associated measurements.
  • Graph displays the graph as full screen.
  • Table displays the table as full screen.

Remote command

:DISPlay:VIEW:CDMA

:DISPlay:VIEW:EDGE:TYPE

:DISPlay:VIEW:GSM:TYPE

:DISPlay:VIEW:WCDMa


Channel Power Limits settings panel

This settings panel allows you specify the limits that will be used for the channel power limit test.

Max

Sets the maximum power value that will be accepted as a passing condition for the channel power limit test. If you want to disable the test for the maximum limit, set the value to +200 dBm.

Remote control commands

:CALCulate:GSM:CPOWer:DATA?

:CALCulate:GSM:CPOWer:LIMit[:MAX]

Min

Sets the minimum power value that will be accepted as a passing condition for the channel power limit test. If you want to disable the test for the minimum limit, set the value to -200 dBm.

Remote control commands

:CALCulate:GSM:CPOWer:DATA?

:CALCulate:GSM:CPOWer:LIMit:MIN


Phase Error Limits settings panel

This settings panel allows you specify the limits that will be used for the phase error limit test.

Max RMS

Sets the maximum RMS value that will be accepted as a passing condition for the phase error limit test.

Remote control command

:CALCulate:GSM:PERRor:DATA?

:CALCulate:GSM:PERRor:LIMit:RMS

Max Peak

Sets the maximum peak value that will be accepted as a passing condition for the phase error limit test.

Remote control command

:CALCulate:GSM:PERRor:DATA?

:CALCulate:GSM:PERRor:LIMit:PEAK

Max Freq Error

Sets the maximum frequency error value that will be accepted as a passing condition for the phase error limit test.

Remote control command

:CALCulate:GSM:PERRor:DATA?

:CALCulate:GSM:PERRor:FREQ


Time Mask Limits settings panel

Allows you to set up a table that has multiple sets of maximum values (dBc and dBm) for a limit test that is performed at associated offset times:

  • File loads or saves a time mask limits table file (*.tml).
  • Add Row adds a row to the bottom of the table with the same values as the previous row.
  • Delete Row deletes the row that is selected.
  • OK applies the current table values to the time mask limit test, which includes any edits that you made to the table.
  • Cancel applies the previous table values to the limit test, not applying any of the edits that you made to the table.

    Note: The GSM standard specifies both relative (dBc) and absolute (dBm) limits. You should use absolute limits with caution because the GSM standard states that the device will pass a limit test even if it only meets one of the limits specified (absolute or relative). For example, if you enter an absolute limit without accounting for the fixture loss, devices that do not meet the specification will appear to pass the test.

Remote control command

:CALCulate:GSM:TMASk:DATA?

:CALCulate:GSM:TMASk:LIMit:FAIL?

:CALCulate:GSM:TMASk:LIMit:MARGin?

:CALCulate:GSM:TMASk:LIMit:STATus?


ORFS Mod Settings panel

This settings panel allows you to choose the parameters for an Output RF Spectrum due to Modulation measurement. You can also choose multiple sets of maximum values for a limit test that is performed at associated offset frequencies.

Detector Mode

The display detector mode determines the method that the analyzer uses to process the measurement results signal before it is displayed on the analyzer screen. You can choose to view the trace data in the following modes:

  • Power (Watts) displays the trace data on the instrument screen where the unit of measure is in Watts.
  • Log (dB) displays the trace data on the instrument screen where the unit of measure is in Log.
  • Voltage Mag displays the trace data on the instrument screen where the unit of measure is in Voltage Mag.

Remote control commands

[:SENSe]:GSM:ORFS:MODulation:DETector[:FUNCtion]

[:SENSe]:GSM:ORFS:SWITching:DETector[:FUNCtion]

Averaging Data Type

Specifies what data type is used in the measurement averaging. This allows you to set the analyzer to detect the data in one mode, integrate across a portion of the pulse, then save that result in another mode. When averaging is then applied burst-to-burst, you get statistical variation (depending on the averaging data type).

  • Power (Watts) sets the measurement averaging to use Watts as the unit of measure.
  • Log (dB) sets the measurement averaging to use Log as the unit of measure.
  • Voltage Mag sets the measurement averaging to use Voltage Mag as the unit of measure.

Remote control command

[:SENSe]:GSM:ORFS:MODulation:AVERage:UNIT

[:SENSe]:GSM:ORFS:SWITching:AVERage:UNIT

Video Filter

Sets whether the video bandwidth filter is applied in the ORFS calculation.

  • When the On check box is selected, the filter is applied.

Remote control command

[:SENSe]:GSM:ORFS:MODulation:VBW[:STATe]

[:SENSe]:GSM:ORFS:SWITching:VBW[:STATe]

Freqs/Limits

Allows you to set up a table that has multiple sets of maximum values (dBc and dBm) for a limit test that is performed at associated offset frequencies:

  • Edit:
    • File loads or saves a frequency/limits table file.
    • Add Row adds a row to the bottom of the table with the same values as the previous row.
    • Delete Row deletes the row that is selected.
    • Apply applies the current table values to the ORFS limit test, which includes any edits that you made to the table.
    • Cancel applies the previous table values to the ORFS limit test, not applying any of the edits that you made to the table.

      Note: The GSM standard specifies both relative (dBc) and absolute (dBm) limits. You should use absolute limits with caution because the GSM standard states that the device will pass a limit test even if it only meets one of the limits specified (absolute or relative). For example, if you enter an absolute limit without accounting for the fixture loss, devices that do not meet the specification will appear to pass the test.

Remote control command

[:SENSe]:GSM:ORFS:MODulation:FLIMits

[:SENSe]:GSM:ORFS:SWITching:FLIMits


ORFS Switch Settings panel

This settings panel allows you to choose the parameters for an Output RF Spectrum due to Switching measurement. You can also choose multiple sets of maximum values for a limit test that is performed at associated offset frequencies.

Detector Mode

The display detector mode determines the method that the analyzer uses to process the measurement results signal before it is displayed on the analyzer screen. You can choose to view the trace data in the following modes:

  • Power (Watts) displays the trace data on the instrument screen where the unit of measure is in Watts.
  • Log (dB) displays the trace data on the instrument screen where the unit of measure is in Log.
  • Voltage Mag displays the trace data on the instrument screen where the unit of measure is in Voltage Mag.

Remote control commands

[:SENSe]:GSM:ORFS:MODulation:DETector[:FUNCtion]

[:SENSe]:GSM:ORFS:SWITching:DETector[:FUNCtion]

Averaging Data Type

Specifies what data type is used in the measurement averaging. This allows you to set the analyzer to detect the data in one mode, integrate across a portion of the pulse, then save that result in another mode. When averaging is then applied burst-to-burst, you get statistical variation (depending on the averaging data type).

  • Power (Watts) sets the measurement averaging to use Watts as the unit of measure.
  • Log (dB) sets the measurement averaging to use Log as the unit of measure.
  • Voltage Mag sets the measurement averaging to use Voltage Mag as the unit of measure.

Remote control command

[:SENSe]:GSM:ORFS:MODulation:AVERage:UNIT

[:SENSe]:GSM:ORFS:SWITching:AVERage:UNIT

Video Filter

Sets whether the video bandwidth filter is applied in the ORFS calculation.

  • When the On check box is selected, the filter is applied.

Remote control command

[:SENSe]:GSM:ORFS:MODulation:VBW[:STATe]

[:SENSe]:GSM:ORFS:SWITching:VBW[:STATe]

Freqs/Limits

Allows you to set up a table that has multiple sets of maximum values (dBc and dBm) for a limit test that is performed at associated offset frequencies:

  • Edit:
    • File loads or saves a frequency/limits table file.
    • Add Row adds a row to the bottom of the table with the same values as the previous row.
    • Delete Row deletes the row that is selected.
    • Apply applies the current table values to the ORFS limit test, which includes any edits that you made to the table.
    • Cancel applies the previous table values to the ORFS limit test, not applying any of the edits that you made to the table.

      Note: The GSM standard specifies both relative (dBc) and absolute (dBm) limits. You should use absolute limits with caution because the GSM standard states that the device will pass a limit test even if it only meets one of the limits specified (absolute or relative). For example, if you enter an absolute limit without accounting for the fixture loss, devices that do not meet the specification will appear to pass the test.

Remote control command

[:SENSe]:GSM:ORFS:MODulation:FLIMits

[:SENSe]:GSM:ORFS:SWITching:FLIMits


Phase Error control

Enables the phase error limit test when selected.

Remote control commands

[:SENSe]:GSM:PERRor[:STATe]


Time Mask control

Enables the time mask limit test when selected.

Remote control commands

[:SENSe]:GSM:TMASk[:STATe]


ORFS Mod control

Enables the ORFS due to modulation limit test when selected.

Remote control commands

[:SENSe]:GSM:ORFS:MODulation[:STATe]


ORFS Switch control

Enables the ORFS due to switching limit test when selected.

Remote control commands

[:SENSe]:GSM:ORFS:SWITching[:STATe]


Averaging control

The averaging function minimizes the effects of noise by averaging the results of multiple measurements.

There are two values displayed for each of the 501 measurement points across the instrument screen: a lower value and an upper value. These two values represent the total excursion of the signal within the span of a single display point. When averaging is enabled, the lower and upper values are averaged as independent sets.

  • Averaging On: switches on the averaging function, if the check box is selected.
  • Number: specifies how many measurements to take for calculating the average of the results.
  • Type:
    • Mean Group sets the measurement trace to show the calculated mean of the power data results from multiple measurements. You specify the number of measurements to take for the calculation.
    • Max Group sets the measurement trace to show the average of the maximum power data results from multiple measurements. You specify the number of measurements to take for the calculation.
    • Min Group sets the measurement trace to show the average of the minimum power data results from multiple measurements. You specify the number of measurements to take for the calculation.

Remote control commands

[:SENSe]:GSM:CPOWer:AVERage:COUNt

[:SENSe]:GSM:CPOWer:AVERage:TYPE

[:SENSe]:GSM:ORFS:MODulation:AVERage:COUNt

[:SENSe]:GSM:ORFS:MODulation:AVERage:TYPE

[:SENSe]:GSM:ORFS:MODulation:AVERage:UNIT

[:SENSe]:GSM:ORFS:SWITching:AVERage:COUNt

[:SENSe]:GSM:ORFS:SWITching:AVERage:TYPE

[:SENSe]:GSM:ORFS:SWITching:AVERage:UNIT

[:SENSe]:GSM:PERRor:AVERage:COUNt

[:SENSe]:GSM:PERRor:AVERage:TYPE

[:SENSe]:GSM:TMASk:AVERage:COUNt

[:SENSe]:GSM:TMASk:AVERage:TYPE


Configuring time slots

In order to locate the decision point and do initial carrier recovery, the Series 2800 VSA uses the burst edges and the training sequence embedded in the transmitted signal. The accuracy of the GSM or EDGE measurement can be improved by entering known information in the Time Slot Configuration panel.

Single time slot

In most cases, a single time slot is active and the transmitted training sequence is the same as the time slot index. For example, if you configure the transmitter to turn on time slot zero with training sequence zero, entering "0" on the Series 2800 VSA will allow it to recover the incoming signal.

Multiple time slots

The measurement is more complex when more than one time slot is active. The Series 2800 VSA uses the rising edge of the first active time slot and the falling edge of the last active time slot for initial burst and carrier recovery. In order for that to work, the Series 2800 VSA needs to know how many slots are active and where they are within the frame. All active slots have to be adjacent so that they appear as one large "super burst" to the VSA. Further more, no more than 7 time slots can appear active, so there is a clear rising and falling edge for the VSA to find.

Normally, Slot to Measure and Training Sequence will be the same value.

Note: The time mask limits do not automatically adjust for time slot configuration. You must enter the appropriate time mask limits.


EDGE Settings

Select from the list below to learn about the choices you have to set up an EDGE measurement:

  • EDGE measurement panel
  • Channel Power Limit settings panel
  • EVM Limits settings panel
  • Time Mask Limits settings panel
  • ORFS Mod settings panel
  • ORFS Switch settings panel
  • EDGE EVM control
  • Time Mask control
  • ORFS Mod control
  • ORFS Switch control
  • Averaging control


EDGE measurement panel

This panel has the fundamental settings for making an EDGE measurement.

Training Sequence

Sets the training sequence to look for in the selected slot to measure.

The middle part of an EDGE burst is dedicated to one of eight possible training sequences (numbered 0 to 7).

  • If there is only one time slot active, just set the appropriate training sequence (usually 0).
  • If there is more than one time slot active, you must also set the following parameters:
    • First active slot
    • Slot to measure
    • Number of active time slots

For more information, see Configuring time slots.

Remote control command

[:SENSe]:EDGE:TSEQuence

Carrier Frequency

Tunes the analyzer to the frequency of the carrier signal.

Remote control command

[:SENSe]:FREQuency:CENTer

Expected Power

Sets the expected power of the incoming EDGE burst. To optimize the instrument dynamic range, set the largest expected channel power value.

Remote control command

[:SENSe]:EPOWer

Time Slot Configuration
  • Training Sequence sets the training sequence to look for in the selected slot to measure.
  • Active Slots sets the number of active time slots in the incoming signal. Must be contiguous and no more than 7 slots.
  • First Active Slot sets the first slot that is active.
  • Slot To Measure sets the time slot to measure, 0 to 7.

Remote control command

[:SENSe]:EDGE:TSLot:COUNt

[:SENSe]:EDGE:TSLot:FIRSt

[:SENSe]:EDGE:TSLot[:SELect]

EDGE Trace Type

Sets the type of EDGE trace to display on the instrument screen:

  • None disables the EDGE measurement trace.
  • Time Mask shows the whole EDGE burst and overlays a mask on the screen that allows you to determine if the entire EDGE burst power over time meets specified limits:
    • Rising shows only the rising edge of the EDGE burst and overlays a mask on the screen that allows you to determine if the rising edge of the burst meets specified limits.
    • Falling shows only the falling edge of the EDGE burst and overlays a mask on the screen that allows you to determine if the falling edge of the burst meets specified limits.
    • Top shows only the top of the EDGE burst and overlays a mask on the screen that allows you to determine if the top of the burst meets specified limits.
  • Error Vectors shows the error vectors associated with the amplitude modulation quality.
  • Symbols shows the data symbol stream.
  • Constellation shows the constellation generated from the data symbol stream.

Remote control command

:DISPlay:VIEW:EDGE:TYPE

Sweep

Sets the type of sweep:

  • Continuous sweep repeatedly sweeps the span that you specified.
  • Single sweep takes one sweep of the span you specified.

Remote control commands

:INITiate:CONTinuous

:INITiate[:IMMediate][:ALL]

Markers

You can use markers for two different functions:

  • Locating and reading various measurement data.
  • Setting the center or reference parameter value to the marker position.

Each measurement trace has four markers, and each marker has an associated delta marker:

  • The marker indicates the x-axis and y-axis position for any point on a trace.
  • The delta marker indicates the relative value between the marker and the associated delta marker.

The measurement data associated with each of the marker positions is displayed at the top of the instrument screen.

  • Tab 1 2 3 4 selects one of the four markers for editing the marker parameters.
  • Marker On check box enables and disables the marker associated with the selected tab.
  • Marker Position sets the x-axis value of the marker.
  • Delta Marker
    • Off switches off the delta marker for the marker associated with the selected tab.
    • Tracking keeps the delta marker at the set x-axis position and updates the y-axis position with each sweep.
    • Fixed Point keeps the delta marker at both the x-axis and y-axis positions that you set.
  • Delta sets the difference in x-axis positions between the delta marker and the associated marker.
  • Zero Delta brings the delta marker to the same position as the marker associated with the selected tab.
  • Center sets the center frequency parameter value to the current x-axis value of the marker.
  • Ref sets the screen reference value to the current y-axis value of the marker.
  • Max moves the marker to the maximum amplitude of the measurement trace.
  • Next moves the marker to the top of the next largest peak that is below the marker's current y-axis value.
  • Left moves the marker to the top of the next largest peak that is to the left of the current marker position and at least 3 dB below the current marker position.
  • Right moves the marker to the top of the next largest peak that is to the right of the current marker position and at least 3 dB below the current marker position.

Remote control commands

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4|[:STATe]

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:LEFT

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:NEXT

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:PREVious

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:RIGHt

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum[:PEAK]

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:DELTa:ZERO

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:FUNCtion:CENTer

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:FUNCtion:REFerence

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:Y?

Auto Scale

Scales the displayed measurement so that you can view the entire trace on the instrument screen. The scaling is done by automatically adjusting the value per division and the reference level.

View

Allows you to select the view of the measurement results:

  • Graph & Table displays a graph in the bottom of the screen and a table in the top of the screen. The graph shows the measurement results as a trace. The table shows a tabular listing of measured values, set limits, and limit test results for each of the associated measurements.
  • Graph displays the graph as full screen.
  • Table displays the table as full screen.

Remote command

:DISPlay:VIEW:CDMA

:DISPlay:VIEW:EDGE:TYPE

:DISPlay:VIEW:GSM:TYPE

:DISPlay:VIEW:WCDMa


Channel Power Limits settings panel

This settings panel allows you specify the limits that will be used for the channel power limit test.

Max

Sets the maximum power value that will be accepted as a passing condition for the channel power limit test. If you want to disable the test for the maximum limit, set the value to +200 dBm.

Remote control commands

:CALCulate:EDGE:CPOWer:LIMit[:MAX]

Min

Sets the minimum power value that will be accepted as a passing condition for the channel power limit test. If you want to disable the test for the maximum limit, set the value to -200 dBm.

Remote control commands

:CALCulate:EDGE:CPOWer:LIMit:MIN


EVM Limits settings panel

This settings panel allows you specify the limits that will be used for the EVM (error vector magnitude) limit test.

Max RMS

Sets the maximum RMS value (%) that will be accepted as a passing condition for the EVM limit test.

Remote control command

:CALCulate:EDGE:EVM:LIMit:RMS

Max Peak

Sets the maximum peak value (%) that will be accepted as a passing condition for the EVM limit test.

Remote control command

:CALCulate:EDGE:EVM:LIMit:PEAK

Max 95%

Sets the maximum 95th percentile value (%) that will be accepted as a passing condition for the EVM limit test.

Remote control command

:CALCulate:EDGE:EVM:LIMit:NFIVe

Max Origin Offset

Sets the maximum origin offset value (dB) that will be accepted as a passing condition for the EVM limit test.

Remote control command

:CALCulate:EDGE:EVM:LIMit:OFFSet

Max Freq Error

Sets the maximum frequency error value (ppm) that will be accepted as a passing condition for the EVM limit test.

Remote control command

:CALCulate:EDGE:EVM:LIMit:FREQ


Time Mask Limits settings panel

Allows you to set up a table that has multiple sets of maximum values (dBc and dBm) for a limit test that is performed at associated offset times:

  • File loads or saves a time mask limits table file (*.tml).
  • Add Row adds a row to the bottom of the table with the same values as the previous row.
  • Delete Row deletes the row that is selected.
  • OK applies the current table values to the time mask limit test, which includes any edits that you made to the table.
  • Cancel applies the previous table values to the limit test, not applying any of the edits that you made to the table.

    Note: The EDGE standard specifies both relative (dBc) and absolute (dBm) limits. You should use absolute limits with caution because the EDGE standard states that the device will pass a limit test even if it only meets one of the limits specified (absolute or relative). For example, if you enter an absolute limit without accounting for the fixture loss, devices that do not meet the specification will appear to pass the test.

Remote control command

:CALCulate:EDGE:TMASk:DATA:X?

:CALCulate:EDGE:TMASk:DATA[:Y]?

:CALCulate:EDGE:TMASk:LIMit

:CALCulate:EDGE:TMASk:LIMit:FAIL?

:CALCulate:EDGE:TMASk:LIMit:FCOunt?

:CALCulate:EDGE:TMASk:LIMit:MARGin?

:CALCulate:EDGE:TMASk:LIMit:STATus?


ORFS Mod Settings panel

This settings panel allows you to choose the parameters for an Output RF Spectrum due to Modulation measurement. You can also choose multiple sets of maximum values for a limit test that is performed at associated offset frequencies.

Detector Mode

The display detector mode determines the method that the analyzer uses to process the measurement results signal before it is displayed on the analyzer screen. You can choose to view the trace data in the following modes:

  • Power (Watts) displays the trace data on the instrument screen where the unit of measure is in Watts.
  • Log (dB) displays the trace data on the instrument screen where the unit of measure is in Log.
  • Voltage Mag displays the trace data on the instrument screen where the unit of measure is in Voltage Mag.

Remote control commands

[:SENSe]:EDGE:ORFS:MODulation:DETector[:FUNCtion]

[:SENSe]:EDGE:ORFS:SWITching:DETector[:FUNCtion]

Averaging Data Type

Specifies what data type is used in the measurement averaging. This allows you to set the analyzer to detect the data in one mode, integrate across a portion of the pulse, then save that result in another mode. When averaging is then applied burst-to-burst, you get statistical variation, depending on the averaging data type.

  • Power (Watts) sets the measurement averaging to use Watts as the unit of measure.
  • Log (dB) sets the measurement averaging to use Log as the unit of measure.
  • Voltage Mag sets the measurement averaging to use Voltage Mag as the unit of measure.

Remote control command

[:SENSe]:EDGE:ORFS:MODulation:AVERage:UNIT

[:SENSe]:EDGE:ORFS:SWITching:AVERage:UNIT

Video Filter

Sets whether the video bandwidth filter is applied in the ORFS calculation.

  • When the On check box is selected, the filter is applied.

Remote control command

[:SENSe]:EDGE:ORFS:MODulation:VBW[:STATe]

[:SENSe]:EDGE:ORFS:SWITching:VBW[:STATe]

Freqs/Limits

Allows you to set up a table that has multiple sets of maximum values (dBc and dBm) for a limit test that is performed at associated offset frequencies:

  • Edit:
    • File loads or saves a frequency/limits table file.
    • Add Row adds a row to the bottom of the table with the same values as the previous row.
    • Delete Row deletes the row that is selected.
    • Apply applies the current table values to the ORFS limit test, which includes any edits that you made to the table.
    • Cancel applies the previous table values to the ORFS limit test, not applying any of the edits that you made to the table.

Remote control command

[:SENSe]:EDGE:ORFS:MODulation:FLIMits

[:SENSe]:EDGE:ORFS:SWITching:FLIMits


ORFS Switch Settings panel

This settings panel allows you to choose the parameters for an Output RF Spectrum due to Switching measurement. You can also choose multiple sets of maximum values for a limit test that is performed at associated offset frequencies.

Detector Mode

The display detector mode determines the method that the analyzer uses to process the measurement results signal before it is displayed on the analyzer screen. You can choose to view the trace data in the following modes:

  • Power (Watts) displays the trace data on the instrument screen where the unit of measure is in Watts.
  • Log (dB) displays the trace data on the instrument screen where the unit of measure is in Log.
  • Voltage Mag displays the trace data on the instrument screen where the unit of measure is in Voltage Mag.

Remote control commands

[:SENSe]:EDGE:ORFS:MODulation:DETector[:FUNCtion]

[:SENSe]:EDGE:ORFS:SWITching:DETector[:FUNCtion]

Averaging Data Type

Specifies what data type is used in the measurement averaging. This allows you to set the analyzer to detect the data in one mode, integrate across a portion of the pulse, then save that result in another mode. When averaging is then applied burst-to-burst, you get statistical variation, depending on the averaging data type.

  • Power (Watts) sets the measurement averaging to use Watts as the unit of measure.
  • Log (dB) sets the measurement averaging to use Log as the unit of measure.
  • Voltage Mag sets the measurement averaging to use Voltage Mag as the unit of measure.

Remote control command

[:SENSe]:EDGE:ORFS:MODulation:AVERage:UNIT

[:SENSe]:EDGE:ORFS:SWITching:AVERage:UNIT

Video Filter

Sets whether the video bandwidth filter is applied in the ORFS calculation.

  • When the On check box is selected, the filter is applied.

Remote control command

[:SENSe]:EDGE:ORFS:MODulation:VBW[:STATe]

[:SENSe]:EDGE:ORFS:SWITching:VBW[:STATe]

Freqs/Limits

Allows you to set up a table that has multiple sets of maximum values (dBc and dBm) for a limit test that is performed at associated offset frequencies:

  • Edit:
    • File loads or saves a frequency/limits table file.
    • Add Row adds a row to the bottom of the table with the same values as the previous row.
    • Delete Row deletes the row that is selected.
    • Apply applies the current table values to the ORFS limit test, which includes any edits that you made to the table.
    • Cancel applies the previous table values to the ORFS limit test, not applying any of the edits that you made to the table.

Remote control command

[:SENSe]:EDGE:ORFS:MODulation:FLIMits

[:SENSe]:EDGE:ORFS:SWITching:FLIMits


EDGE EVM control

Enables the EVM limit test when selected.

Remote control commands

[:SENSe]:EDGE:EVM[:STATe]


Time Mask control

Enables the time mask limit test when selected.

Remote control commands

[:SENSe]:EDGE:TMASk[:STATe]


ORFS Mod control

Enables the ORFS due to modulation limit test when selected.

Remote control commands

[:SENSe]:EDGE:ORFS:MODulation[:STATe]


ORFS Switch control

Enables the ORFS due to switching limit test when selected.

Remote control commands

[:SENSe]:EDGE:ORFS:SWITching[:STATe]


Averaging control

The averaging function minimizes the effects of noise by averaging the results of multiple measurements.

There are two values displayed for each of the 501 measurement points across the instrument screen: a lower value and an upper value. These two values represent the total excursion of the signal within the span of a single display point. When averaging is enabled, the lower and upper values are averaged as independent sets.

  • Averaging for: sets to the averaging function for the specified measurement which allows you to select the measurement averaging count and type.
  • Count: specifies how many measurements to take for calculating the average of the results.
  • Type:
    • Mean Group sets the measurement trace to show the calculated mean of the power data results from multiple measurements. You specify the number of measurements to take for the calculation.
    • Max Group sets the measurement trace to show the average of the maximum power data results from multiple measurements. You specify the number of measurements to take for the calculation.
    • Min Group sets the measurement trace to show the average of the minimum power data results from multiple measurements. You specify the number of measurements to take for the calculation.

Remote control commands

[:SENSe]:EDGE:CPOWer:AVERage:COUNt

[:SENSe]:EDGE:CPOWer:AVERage:TYPE

[:SENSe]:EDGE:EVM:AVERage:COUNt

[:SENSe]:EDGE:EVM:AVERage:TYPE

[:SENSe]:EDGE:TMASK:AVERage:COUNt

[:SENSe]:EDGE:TMASK:AVERage:TYPE

[:SENSe]:EDGE:ORFS:MODulation:AVERage:COUNt

[:SENSe]:EDGE:ORFS:MODulation:AVERage:TYPE

[:SENSe]:EDGE:ORFS:SWITching:AVERage:COUNt

[:SENSe]:EDGE:ORFS:SWITching:AVERage:TYPE


cdma2000 settings

Select from the lists to learn about the choices you have to set up a cdma2000 measurement.

Demodulate

ACPR
  • Measurement panel
  • Measurement panel
  • Edit Limits settings panel
  • Trace Hold control
  • Averaging control
  • Fast Mode control

  • Noise Correction control

  • Averaging control

Spectrum Emission

Occupied Bandwidth
  • Measurement panel
  • Measurement panel
  • Trigger settings panel
  • Trigger settings panel
  • Atten Preamp settings panel
  • Atten Preamp settings panel
  • Detection Type control
  • Trace Hold
  • Averaging control
  • Averaging control


cdma2000 Demodulate settings

Select from the list below to learn what choices you have for setting up a cdma2000 Demodulate measurement:

  • cdma2000 Demodulate measurement panel
  • Edit Limits setting panel
  • Averaging control


cdma2000 Demodulate measurement panel

Carrier Frequency

Tunes the analyzer to the frequency of the carrier signal.

Remote control command

[:SENSe]:FREQuency:CENTer

Expected Power

Sets the expected power of the incoming cdma2000 signal.

Remote control command

[:SENSe]:EPOWer

Sweep

Sets the type of sweep:

  • Continuous sweep repeatedly sweeps the span that you specified.
  • Single sweep takes one sweep of the span you specified.

Remote control commands

:INITiate:CONTinuous

:INITiate[:IMMediate][:ALL]

Markers

Sets the markers for the cdma2000 measurement.

  • I Marker:
    • On check box enables the I Marker, when selected.
    • Index selects the index on which to place the I Marker.
  • Q Marker:
    • On check box enables the Q Marker, when selected.
    • Index selects the index on which to place the Q Marker.

Remote control commands

:CALCulate:CDMA:REVerse:IMARker:CNUMber?

:CALCulate:CDMA:REVerse:IMARker:SFACtor?

:CALCulate:CDMA:REVerse:IMARker:X

:CALCulate:CDMA:REVerse:IMARker:Y?

:CALCulate:CDMA:REVerse:IMARker[:STATe]

:CALCulate:CDMA:REVerse:QMARker:CNUMber?

:CALCulate:CDMA:REVerse:QMARker:SFACtor?

:CALCulate:CDMA:REVerse:QMARker:X

:CALCulate:CDMA:REVerse:QMARker:Y?

:CALCulate:CDMA:REVerse:QMARker[:STATe]

View

Allows you to select the view of the measurement results:

  • Graph & Table displays a graph in the bottom of the screen and a table in the top of the screen. The graph shows the measurement results as a trace. The table shows a tabular listing of measured values, set limits, and limit test results for each of the associated measurements.
  • Graph displays the graph as full screen.
  • Table displays the table as full screen.

Remote command

:DISPlay:VIEW:CDMA

:DISPlay:VIEW:EDGE:TYPE

:DISPlay:VIEW:GSM:TYPE

:DISPlay:VIEW:WCDMa


Edit Limits setting panel

This settings panel allows you to specify the value that will be considered a passing condition for a limit test performed on the specified measurement.

Measurement
  • Rho selects the reflection coefficient limit value for editing, (the default value is 0.944).
  • EVM rms selects the error vector magnitude rms measurement limit value for editing (the default value is 17.5%).
  • EVM peak selects the error vector magnitude peak measurement limit value for editing (the default value is 100%).
  • PCDE select the peak code-domain error measurement limit value for editing (the default value is -15 dB).
  • Freq Error selects the frequency error measurement limit value for editing (the default value is 100 Hz).
  • IQ Offset selects the frequency error measurement limit value for editing (the default value is -40 dB).

Limit
  • The Limit On check box enables and disables the limit testing. If the box is selected, the limit testing is enabled. If the check box is unselected, the limit testing is disabled.
  • The Limit value field sets value that will be considered a passing condition for a limit test performed on the specified measurement.

Remote control commands

:CALCulate:CDMA:REVerse:LIMit:EVM:PEAK:UPPer

:CALCulate:CDMA:REVerse:LIMit:EVM:PEAK:FAIL?

:CALCulate:CDMA:REVerse:LIMit:EVM:PEAK[:STATe]

:CALCulate:CDMA:REVerse:LIMit:EVM:RMS:UPPer

:CALCulate:CDMA:REVerse:LIMit:EVM:RMS:FAIL?

:CALCulate:CDMA:REVerse:LIMit:EVM:RMS[:STATe]

:CALCulate:CDMA:REVerse:LIMit:FERRor:UPPer

:CALCulate:CDMA:REVerse:LIMit:FERRor:FAIL?

:CALCulate:CDMA:REVerse:LIMit:FERRor[:STATe]

:CALCulate:CDMA:REVerse:LIMit:IQOFfset:UPPer

:CALCulate:CDMA:REVerse:LIMit:IQOFfset:FAIL?

:CALCulate:CDMA:REVerse:LIMit:IQOFfset[:STATe]

:CALCulate:CDMA:REVerse:LIMit:PCDE:UPPer

:CALCulate:CDMA:REVerse:LIMit:PCDE:FAIL?

:CALCulate:CDMA:REVerse:LIMit:PCDE[:STATe]

:CALCulate:CDMA:REVerse:LIMit:RHO:LOWer

:CALCulate:CDMA:REVerse:LIMit:RHO:FAIL?

:CALCulate:CDMA:REVerse:LIMit:RHO[:STATe]

Set Default

Set Default returns the limit value to the default value.


Averaging control

The averaging function minimizes the effects of noise by averaging the results of multiple measurements.

  • Averaging On: switches on the averaging function, if the check box is selected.
  • Number: specifies how many measurements to take when calculating the average of the results.
  • Type:
    • Mean Group sets the measurement trace to show the calculated mean of the power data results from multiple measurements. You specify the number of measurements to take for the calculation.
    • Max Group sets the measurement trace to show the average of the maximum power data results from multiple measurements. You specify the number of measurements to take for the calculation.
    • Min Group sets the measurement trace to show the average of the minimum power data results from multiple measurements. You specify the number of measurements to take for the calculation.

Remote control commands

[:SENSe]:CDMA:REVerse:AVERage:COUNt

[:SENSe]:CDMA:REVerse:AVERage:TYPE

[:SENSe]:CDMA:REVerse:AVERage[:STATe]


cdma2000 ACPR Settings

Select from the following list below to learn what choices you have for setting up a cdma2000 ACPR (Adjacent Power Leakage ratio) measurement:

  • cdma2000 Reverse Link ACPR measurement panel
  • Trace Hold control
  • Fast Mode control
  • Noise Correction control
  • Averaging control


cdma2000 ACPR measurement panel

Channel Frequency

Sets the main channel center frequency.

Remote control command

[:SENSe]:FREQuency:CENTer

Expected Power

Sets the expected power of the incoming cdma2000 signal.

Remote control command

[:SENSe]:EPOWer

Sweep Time

Sets the length of time that the measurement takes place for each channel.

Remote control command

[:SENSe]:ACPR:CENTer:SWEep:TIME

Limits
  • The Limit On check box enables and disables the limit testing. If the box is selected, the limit testing is enabled. If the check box is unselected, the limit testing is disabled.
  • The Limit Margin value field allows you to add or subtract an offset to the pass/fail limits specified by the cdma2000 standard.

Remote control command

:CALCulate:ACPR:LIMit:FAIL?

:CALCulate:CDMA:REVerse:ACPR:FAIL:CHANnels?

:CALCulate:CDMA:REVerse:ACPR:LIMit:MARGin

:CALCulate:CDMA:REVerse:ACPR:LIMit[:STATe]

Sweep

Sets the type of sweep:

  • Continuous sweep repeatedly sweeps the span that you specified.
  • Single sweep takes one sweep of the span you specified.

Remote control commands

:INITiate:CONTinuous

:INITiate[:IMMediate][:ALL]


cdma2000 Spectrum Emission Settings

Select from the list below to learn what choices you have for setting up a cdma2000 spectrum emission measurement:

  • cdma2000 Spectrum Emission measurement panel
  • Trigger settings panel
  • Atten Preamp settings panel
  • Detection type control
  • Averaging control


cdma2000 Spectrum Emission measurement panel

Carrier Frequency

Tunes the analyzer to the frequency of the carrier signal.

Remote control command

[:SENSe]:FREQuency:CENTer

Limits
  • The Limit On check box enables and disables the limit testing. If the box is selected, the limit testing is enabled. If the check box is unselected, the limit testing is disabled.
  • The Limit Margin value field allows you to add or subtract an offset to the pass/fail limits specified by the cdma2000 standard.

Remote control commands

:CALCulate:CDMA:REVerse:SEMask:LIMit:FAIL?

:CALCulate:CDMA:REVerse:SEMask:LIMit:MARGin

:CALCulate:CDMA:REVerse:SEMask:LIMit[:STATe]

Sweep

Sets the type of sweep:

  • Continuous sweep repeatedly sweeps the span that you specified.
  • Single sweep takes one sweep of the span you specified.

Remote control commands

:INITiate:CONTinuous

:INITiate[:IMMediate][:ALL]

Markers

You can use markers for two different functions:

  • Locating and reading various measurement data.
  • Setting the center or reference parameter value to the marker position.

Each measurement trace has four markers, and each marker has an associated delta marker:

  • The marker indicates the x-axis and y-axis position for any point on a trace.
  • The delta marker indicates the relative value between the marker and the associated delta marker.

The measurement data associated with each of the marker positions is displayed at the top of the instrument screen.

  • Tab 1 2 3 4 selects one of the four markers for editing the marker parameters.
  • Marker On check box enables and disables the marker associated with the selected tab.
  • Marker Position sets the x-axis value of the marker.
  • Delta Marker
    • Off switches off the delta marker for the marker associated with the selected tab.
    • Tracking keeps the delta marker at the set x-axis position and updates the y-axis position with each sweep.
    • Fixed Point keeps the delta marker at both the x-axis and y-axis positions that you set.
  • Delta sets the difference in x-axis positions between the delta marker and the associated marker.
  • Zero Delta brings the delta marker to the same position as the marker associated with the selected tab.
  • Center sets the center frequency parameter value to the current x-axis value of the marker.
  • Ref sets the screen reference value to the current y-axis value of the marker.
  • Max moves the marker to the maximum amplitude of the measurement trace.
  • Next moves the marker to the top of the next largest peak that is below the marker's current y-axis value.
  • Left moves the marker to the top of the next largest peak that is to the left of the current marker position and at least 3 dB below the current marker position.
  • Right moves the marker to the top of the next largest peak that is to the right of the current marker position and at least 3 dB below the current marker position.

Remote control commands

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4|[:STATe]

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:LEFT

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:NEXT

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:PREVious

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:RIGHt

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum[:PEAK]

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:DELTa:ZERO

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:FUNCtion:CENTer

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:FUNCtion:REFerence

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:Y?


Detection Type control

The display detector type determines the method that the analyzer uses to process the measurement results signal before it is displayed on the analyzer screen. Each trace point represents a band of frequency (or time) that is equal to Span/500. Among the 500 there is an upper and a lower value.The analyzer returns these two values for each of the 501 measurement trace points:

  • Upper value
  • Lower value

The detection method creates the trace from a composition of the measurement point data available. You can choose from the following detection types:

  • Normal draws the measurement trace using the maximum as the upper value and the minimum as the lower value for each of the frequency spans or time intervals associated with the measurement points.
  • Max sets both the upper and lower values to the maximum value of the signal power for each of the frequency spans or time intervals associated with the measurement points.
  • Min sets both the upper and lower values to the minimum value of the signal power for each of the frequency spans or time intervals associated with the measurement point.
  • Sample sets both the upper and lower value to the signal power in the middle of the span interval.
  • Power Average sets both the upper and lower values to the average of the signal power during the span interval.
  • PwrAvg + NoiseCorr draws the trace using the result of two separate measurements with power average detection. The first measurement is a usual power average type of detection. The second measurement is a power average type of detection, but with the input signal disconnected. This second measurement indicates the internal noise of the analyzer. The displayed trace is the result of the first measurement (signal+noise) minus the second measurement (noise). The resulting trace is a more precise representation of the input signal power, but the overall measurement time doubles.

Remote control command

[:SENSe]:SEMask:DETector[:FUNCtion]

[:SENSe]:WLAN:SEMask:DETector[:FUNCtion]


Averaging control

The averaging function minimizes the effects of noise by averaging the results of multiple measurements.

There are two values displayed for each of the 501 measurement points across the instrument screen: a lower value and an upper value. These two values represent the total excursion of the signal within the span of a single display point. When averaging in enabled, the lower and upper values are averaged as independent sets.

  • Averaging On: switches on the averaging function when the check box is selected.
  • Number: specifies how many measurements to take into consideration for the averaging calculation of the measurement results.
  • Type:
    • Log Group shows the average of the logged data results from multiple measurements. You specify the number of measurements to take for the calculation. A display result is generated for every N measurements.
    • Power Group shows the average of the power data results from multiple measurements. You specify the number of measurements to take for the calculation. The calculated result is then displayed as logged data. A display result is generated for every N measurements.
    • Max Group shows the maximum of the upper and lower data sets across N measurements.
    • Min Group shows the minimum of the upper and lower data sets across N measurements.
    • Min/Max Group shows the the minimum of the lower data sets and the maximum of the upper data sets across the N measurements.

.

Remote control commands:

[:SENSe]:WLAN:AVERaging:COUNT

[:SENSe]:WLAN:AVERaging:STATe


cdma2000 Occupied Bandwidth settings

Select from the list below to learn what choices you have for setting up a cdma2000 Occupied Bandwidth measurement:

  • cdma2000 Occupied Bandwidth measurement panel
  • Trigger settings panel
  • Atten Preamp settings panel
  • Trace Hold control
  • Averaging control


cdma2000 Occupied Bandwidth measurement panel

Carrier Frequency

Tunes the analyzer to the frequency of the carrier signal.

Remote control command

[:SENSe]:FREQuency:CENTer

Limits
  • The Limit On check box enables and disables the limit testing. If the box is selected, the limit testing is enabled. If the check box is unselected, the limit testing is disabled.
  • The Limit Margin value field allows you to add or subtract an offset to the pass/fail limits specified by the cdma2000 standard.

Remote control command

:CALCULATE:CDMA:REVerse:OBWidth:LIMit:FAIL?

:CALCulate:CDMA:REVerse:OBWidth:LIMit:MARGin

:CALCulate:CDMA:REVerse:OBWidth:LIMit[:STATe]

Sweep

Sets the type of sweep:

  • Continuous sweep repeatedly sweeps the span that you specified.
  • Single sweep takes one sweep of the span you specified.

Remote control commands

:INITiate:CONTinuous

:INITiate[:IMMediate][:ALL]

Markers

You can use markers for two different functions:

  • Locating and reading various measurement data.
  • Setting the center or reference parameter value to the marker position.

Each measurement trace has four markers, and each marker has an associated delta marker:

  • The marker indicates the x-axis and y-axis position for any point on a trace.
  • The delta marker indicates the relative value between the marker and the associated delta marker.

The measurement data associated with each of the marker positions is displayed at the top of the instrument screen.

  • Tab 1 2 3 4 selects one of the four markers for editing the marker parameters.
  • Marker On check box enables and disables the marker associated with the selected tab.
  • Marker Position sets the x-axis value of the marker.
  • Delta Marker
    • Off switches off the delta marker for the marker associated with the selected tab.
    • Tracking keeps the delta marker at the set x-axis position and updates the y-axis position with each sweep.
    • Fixed Point keeps the delta marker at both the x-axis and y-axis positions that you set.
  • Delta sets the difference in x-axis positions between the delta marker and the associated marker.
  • Zero Delta brings the delta marker to the same position as the marker associated with the selected tab.
  • Center sets the center frequency parameter value to the current x-axis value of the marker.
  • Ref sets the screen reference value to the current y-axis value of the marker.
  • Max moves the marker to the maximum amplitude of the measurement trace.
  • Next moves the marker to the top of the next largest peak that is below the marker's current y-axis value.
  • Left moves the marker to the top of the next largest peak that is to the left of the current marker position and at least 3 dB below the current marker position.
  • Right moves the marker to the top of the next largest peak that is to the right of the current marker position and at least 3 dB below the current marker position.

Remote control commands

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4|[:STATe]

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:LEFT

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:NEXT

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:PREVious

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:RIGHt

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum[:PEAK]

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:DELTa:ZERO

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:FUNCtion:CENTer

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:FUNCtion:REFerence

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:Y?


Trace Hold

Holds the measurement trace in a persistent state, visually adding the results of subsequent measurements. This allows you to analyze the data in a steady state.

Each trace point represents a band of frequency (or time) that is equal to Span/500. Among the 500 there is an upper and a lower value. The analyzer returns two values for each of the 501 measurement trace points:

  • Upper value
  • Lower value

The trace is created from a composition of the measurement point data available. You can choose to view the trace with the following characteristics:

  • Normal shows the 501 positions of the current measurement trace, possibly averaged, with no visual persistence.
  • Max Hold shows and visually holds the maximum values for each set of values taken at the 501 measurement points.
  • Min Hold shows and visually holds the minimum values for each set of values taken at the 501 measurement points.
  • Min/Max Hold shows and visually holds the maximum upper value and the minimum lower value for each set of values taken at the 501 measurement points.

Remote control command

:TRACe:HOLD


Averaging controls

The averaging function minimizes the effects of noise by averaging the results of multiple measurements.

There are two values displayed for each of the 501 measurement points across the instrument screen: a lower value and an upper value. These two values represent the total excursion of the signal within the span of a single display point. When averaging is enabled, the lower and upper values are averaged as independent sets.

  • Averaging On: switches on the averaging function, if the check box is selected.
  • Number: specifies how many measurements to take for calculating the average of the results.
  • Type:
    • Power Running shows a new set of averaged power data as logged data for each measurement that is taken. The data trace is calculated as a weighted average of power values from the previous measurement and the current measurement. The results are then displayed as logged data. A display result is generated for every measurement.
    • Power Group shows the average of the power data results from multiple measurements. You specify the number of measurements to take for the calculation. The calculated result is then displayed as logged data. a display result is generated for every N measurements.

Remote control commands

[:SENSe]:OBWidth:AVERage:COUNt

[:SENSe]:OBWidth:AVERage:TYPE

[:SENSe]:OBWidth:AVERage[:STATe]


W-CDMA Uplink Settings

Select from the lists to learn about the choices you have to set up a W-CDMA Uplink measurement.

  • W-CDMA Upllink Demodulate Settings
  • W-CDMA Uplink ACLR Settings
  • W-CDMA Uplink Spectrum Emission Settings
  • W-CDMA Uplink Occupied Bandwidth Settings

Demodulate

ACLR
  • Measurement panel
  • Measurement panel
  • Code settings panel
  • Trace Hold control
  • Edit Limits setting panel
  • Fast Mode control
  • Averaging control
  • Noise Correction control

  • Averaging control

Spectrum Emission

Occupied Bandwidth
  • Measurement panel
  • Measurement panel
  • Trigger settings panel
  • Trigger settings panel
  • Atten Preamp control
  • Atten Preamp control
  • Detection Type control
  • Trace Hold control
  • Averaging control
  • Averaging control


W-CDMA Uplink Demodulate Settings

Select from the list below to learn what choices you have for setting up a W-CDMA Uplink Demodulate measurement:

  • W-CDMA Uplink Demodulate measurement panel
  • Code Settings panel
  • Edit Limits setting panel
  • Averaging control


W-CDMA Uplink Demodulate measurement panel

This panel has the fundamental settings for making a W-CDMA demodulation measurement.

Carrier Frequency

Tunes the analyzer to the frequency of the carrier signal.

Remote control command

[:SENSe]:FREQuency:CENTer

Expected Power

Sets the expected power of the incoming signal.

Remote control commands

[:SENSe]:EPOWer

Sweep

Sets the type of sweep:

  • Continuous sweep repeatedly sweeps the span that you specified.
  • Single sweep takes one sweep of the span you specified.

Remote control commands

:INITiate:CONTinuous

:INITiate[:IMMediate][:ALL]

Markers W-CDMA Uplink Settings

Sets the markers for the W-CDMA measurement.

  • I Marker:
    • On check box enables the I Marker when selected.
    • Index selects the index on which to place the I Marker.
  • Q Marker:
    • On check box enables the Q Marker when selected.
    • Index selects the index on which to place the Q Marker.

Remote control commands

:CALCulate:WCDMa:UPLink:IMARker:CNUMber?

:CALCulate:WCDMa:UPLink:IMARker:SFACtor?

:CALCulate:WCDMa:UPLink:IMARker:X

:CALCulate:WCDMa:UPLink:IMARker:Y

:CALCulate:WCDMa:UPLink:IMARker[:STATe]

:CALCulate:WCDMa:UPLink:QMARker:CNUMber?

:CALCulate:WCDMa:UPLink:QMARker:SFACtor?

:CALCulate:WCDMa:UPLink:QMARker:X

:CALCulate:WCDMa:UPLink:QMARker:Y

:CALCulate:WCDMa:UPLink:QMARker[:STATe]

View

Allows you to select the view of the measurement results:

  • Graph & Table displays a graph in the bottom of the screen and a table in the top of the screen. The graph shows the measurement results as a trace. The table shows a tabular listing of measured values, set limits, and limit test results for each of the associated measurements.
  • Graph displays the graph as full screen.
  • Table displays the table as full screen.

Remote command

:DISPlay:VIEW:WCDMa


Code Settings panel

This settings panel allows you to specify the various aspects of a code domain measurement on a W-CDMA signal.

Sync Type

Sets the sync type for the physical channel selected.

Remote control command

[:SENSe]:WCDMa:UPLink:CODE:STYPe

Slot Format

Sets the slot format.

Remote control command

[:SENSe]:WCDMa:UPLink:CODE:SFORmat

Scramble Code

Sets the scramble code.

Remote control command

[:SENSe]:WCDMa:UPLink:CODE:SCRamble


Edit Limits settings panel

This settings panel allows you to specify the maximum value that will be considered a passing condition for a limit test performed on the specified measurement.

Measurement
  • EVM rms selects the error vector magnitude rms measurement limit value for editing (the default value is 17.5%).
  • EVM peak selects the error vector magnitude peak measurement limit value for editing (the default value is 100%).
  • PCDE selects the peak code-domain error measurement limit value for editing (the default value is -15 dB).
  • Freq Error selects the frequency error measurement limit value for editing (the default value is 100 Hz).
  • IQ Offset selects the frequency error measurement limit value for editing (the default value is -40 dB).

Limits
  • The Limit On check box enables and disables the limit testing. If the box is selected, the limit testing is enabled. If the check box is unselected, the limit testing is disabled.
  • The Limit value field sets maximum value that will be considered a passing condition for a limit test performed on the specified measurement.

Remote control commands

:CALCulate:WCDMa:UPLink:LIMit:EVM:PEAK:UPPer

:CALCulate:WCDMa:UPLink:LIMit:EVM:PEAK:FAIL?

:CALCulate:WCDMa:UPLink:LIMit:EVM:PEAK[:STATe]

:CALCulate:WCDMa:UPLink:EVM:PEAK?

:CALCulate:WCDMa:UPLink:LIMit:EVM:RMS:UPPer

:CALCulate:WCDMa:UPLink:LIMit:EVM:RMS:FAIL?

:CALCulate:WCDMa:UPLink:LIMit:EVM:RMS[:STATe]

:CALCulate:WCDMa:UPLink:EVM:RMS?

:CALCulate:WCDMa:UPLink:LIMit:FERRor:UPPer

:CALCulate:WCDMa:UPLink:LIMit:FERRor:FAIL?

:CALCulate:WCDMa:UPLink:LIMit:FERRor[:STATe]

:CALCulate:WCDMa:UPLink:FERRor?

:CALCulate:WCDMa:UPLink:LIMit:IQOFfset:UPPer

:CALCulate:WCDMa:UPLink:LIMit:IQOFfset:FAIL?

:CALCulate:WCDMa:UPLink:LIMit:IQOFfset[:STATe]

:CALCulate:WCDMa:UPLink:IQOFfset?

:CALCulate:WCDMa:UPLink:LIMit:PCDE:UPPer

:CALCulate:WCDMa:UPLink:LIMit:PCDE:FAIL?

:CALCulate:WCDMa:UPLink:LIMit:PCDE[:STATe]

:CALCulate:WCDMa:UPLink:PCDE?

Set Default

Set Default returns the limit value to the default value.


Averaging control W-CDMA Uplink demodulation

The averaging function minimizes the effects of noise by averaging the results of multiple measurements.

There are two values displayed for each of the 501 measurement points across the instrument screen: a lower value and an upper value. These two values represent the total excursion of the signal within the span of a single display point. When averaging is enabled, the lower and upper values are averaged as independent sets.

  • Averaging On: switches on the averaging function, if the check box is selected.
  • Number: specifies how many measurements to take when calculating the average of the results.
  • Type:
    • Mean Group sets the measurement trace to show the calculated mean of the power data results from multiple measurements. You specify the number of measurements to take for the calculation.
    • Max Group sets the measurement trace to show the average of the maximum power data results from multiple measurements. You specify the number of measurements to take for the calculation.
    • Min Group sets the measurement trace to show the average of the minimum power data results from multiple measurements. You specify the number of measurements to take for the calculation.

Remote control commands

[:SENSe]:WCDMa:UPLink:AVERage:COUNt

[:SENSe]:WCDMa:UPLink:AVERage:TYPE

[:SENSe]:WCDMa:UPLink:AVERage[:STATe]


W-CDMA Uplink ACLR Settings

Select from the list below to learn what choices you have for setting up a W-CDMA ACLR (adjacent channel leakage ratio) measurement:

  • W-CDMA Uplink ACLR measurement panel
  • Trace Hold control
  • Fast Mode control
  • Noise Correction control
  • Averaging control


W-CDMA Uplink ACLR measurement panel

This panel has the fundamental settings for making a W-CDMA ACLR (adjacent channel leakage ratio) measurement.

Channel Frequency

Sets the main channel center frequency.

Remote control command

[:SENSe]:FREQuency:CENTer

Expected Power

Sets the expected power of the incoming signal.

Remote control commands

[:SENSe]:EPOWer

Sweep Time

Sets the length of time that the measurement takes place.

Remote control command

[:SENSe]:ACPR:CENTer:SWEep:TIME

[:SENSe]:ACPR:ADJacent1|ADJacent2:SWEep:TIME

Limits
  • The Limit On check box enables and disables the limit testing. If the box is selected, the limit testing is enabled. If the check box is unselected, the limit testing is disabled.
  • The Limit value field sets maximum value that will be considered a passing condition for a limit test performed on the W-CDMA ACLR measurement.

Remote control commands

:CALCulate:WCDMa:UPLink:ACLR:LIMit:FAIL?

:CALCulate:WCDMa:UPLink:ACLR:LIMit:FAIL:CHANnels?

:CALCulate:WCDMa:UPLink:ACLR:LIMit:MARGin

:CALCulate:WCDMa:UPLink:ACLR:LIMit[:STATe]

Sweep

Sets the type of sweep:

  • Continuous sweep repeatedly sweeps the span that you specified.
  • Single sweep takes one sweep of the span you specified.

Remote control commands

:INITiate:CONTinuous

:INITiate[:IMMediate][:ALL]


W-CDMA Uplink Spectrum Emission Settings

Select from the list below to learn what choices you have for setting up a W-CDMA spectrum emission measurement:

  • W-CDMA Uplink Spectrum Emission measurement panel
  • Trigger settings panel
  • Atten Preamp
  • Detection Type control
  • Averaging control

    The results in the Pass/Fail and Min Margin at columns are provided as diagnostic aides. While the accuracy of these results is excellent, users may find a need for more accurate test results. For situations where the spurious amplitude and frequency are near the edge of a mask transition, the marker function provides a more accurate result.


W-CDMA Uplink Spectrum Emission measurement panel

Carrier Frequency

Tunes the analyzer to the frequency of the carrier signal.

Remote control command

[:SENSe]:FREQuency:CENTer

Limits
  • The Limit On check box enables and disables the limit testing. If the box is selected, the limit testing is enabled. If the check box is unselected, the limit testing is disabled.
  • The Limit Margin value field allows you to add or subtract an offset to the pass/fail limits specified by the W-CDMA standard.

Remote control command

:CALCulate:WCDMa:UPLink:SEMask:LIMit:FAIL?

:CALCulate:WCDMa:UPLink:SEMask:LIMit:MARGin

:CALCulate:WCDMa:UPLink:SEMask:LIMit[:STATe]

Sweep

Sets the type of sweep:

  • Continuous sweep repeatedly sweeps the span that you specified.
  • Single sweep takes one sweep of the span you specified.

Remote control commands

:INITiate:CONTinuous

:INITiate[:IMMediate][:ALL]

Markers

You can use markers for two different functions:

  • Locating and reading various measurement data.
  • Setting the center or reference parameter value to the marker position.

Each measurement trace has four markers, and each marker has an associated delta marker:

  • The marker indicates the x-axis and y-axis position for any point on a trace.
  • The delta marker indicates the relative value between the marker and the associated delta marker.

The measurement data associated with each of the marker positions is displayed at the top of the instrument screen.

  • Tab 1 2 3 4 selects one of the four markers for editing the marker parameters.
  • Marker On check box enables and disables the marker associated with the selected tab.
  • Marker Position sets the x-axis value of the marker.
  • Delta Marker
    • Off switches off the delta marker for the marker associated with the selected tab.
    • Tracking keeps the delta marker at the set x-axis position and updates the y-axis position with each sweep.
    • Fixed Point keeps the delta marker at both the x-axis and y-axis positions that you set.
  • Delta sets the difference in x-axis positions between the delta marker and the associated marker.
  • Zero Delta brings the delta marker to the same position as the marker associated with the selected tab.
  • Center sets the center frequency parameter value to the current x-axis value of the marker.
  • Ref sets the screen reference value to the current y-axis value of the marker.
  • Max moves the marker to the maximum amplitude of the measurement trace.
  • Next moves the marker to the top of the next largest peak that is below the marker's current y-axis value.
  • Left moves the marker to the top of the next largest peak that is to the left of the current marker position and at least 3 dB below the current marker position.
  • Right moves the marker to the top of the next largest peak that is to the right of the current marker position and at least 3 dB below the current marker position.

Remote control commands

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4|[:STATe]

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:LEFT

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:NEXT

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:PREVious

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:RIGHt

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum[:PEAK]

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:DELTa:ZERO

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:FUNCtion:CENTer

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:FUNCtion:REFerence

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:Y?


Atten/Preamp control

The attenuator and preamplifier allow you to modify input signal power.

Atten

Atten Auto On enables the automatic application of attenuation to the input signal when selected. When you select the Ref Level or Expected Power value, the analyzer automatically adjusts the input attenuation to optimize the power measurement range.

Atten Value allows you to view the attenuation value automatically applied by the analyzer (if the Atten Auto is enabled), or you enter an attenuation value manually. The manual setting is useful when you want to step the attenuation value to determine if displayed signal spurs are due to the device under test or the analyzer.

Note: A * symbol will appear next to the word Atten in the Atten/Preamp button when the manual setting is selected. This is a visual indicator that automatic setting is uncoupled and that the instrument no longer tracks changes to the reference level.

Remote control commands

[:SENSe]:POWer[:RF]:ATTenuation

[:SENSe]:POWer[:RF]:ATTenuation:AUTO

[:SENSe]:POWer[:RF]:GAIN[:STATe]

Preamp

Preamp allows you to add power amplification (approximately 13dB) to the input signal. This is useful for improving measurement sensitivity when the signal has lower power.

Note: A * symbol will appear next to the word Preamp in the Atten/Preamp button when the Preamp is selected. This is a visual indicator that the Preamp has been turned on.


Detection Type control

The display detector type determines the method that the analyzer uses to process the measurement results signal before it is displayed on the analyzer screen. Each trace point represents a band of frequency (or time) that is equal to Span/500. Among the 500 there is an upper and a lower value. The analyzer returns these two values for each of the 501 measurement trace points:

  • Upper value
  • Lower value

The detection method creates the trace from a composition of the measurement point data available. You can choose from the following detection types:

  • Normal draws the measurement trace using the maximum as the upper value and the minimum as the lower value for each of the frequency spans or time intervals associated with the measurement points.
  • Max sets both the upper and lower values to the maximum value of the signal power for each of the frequency spans or time intervals associated with the measurement points.
  • Min sets both the upper and lower values to the minimum value of the signal power for each of the frequency spans or time intervals associated with the measurement point.
  • Sample sets both the upper and lower value to the signal power in the middle of the span interval.
  • Power Average sets both the upper and lower values to the average of the signal power during the span interval.
  • PwrAvg + NoiseCorr draws the trace using the result of two separate measurements with power average detection. The first measurement is a usual power average type of detection. The second measurement is a power average type of detection, but with the input signal disconnected. This second measurement indicates the internal noise of the analyzer. The displayed trace is the result of the first measurement (signal+noise) minus the second measurement (noise). The resulting trace is a more precise representation of the input signal power, but the overall measurement time doubles.

Remote control command

[:SENSe]:SEMask:DETector[:FUNCtion]


Averaging control

The averaging function minimizes the effects of noise by averaging the results of multiple measurements.

There are two values displayed for each of the 501 measurement points across the instrument screen: a lower value and an upper value. These two values represent the total excursion of the signal within the span of a single display point. When averaging in enabled, the lower and upper values are averaged as independent sets.

  • Averaging On: switches on the averaging function when the check box is selected.
  • Number: specifies how many measurements to take into consideration for the averaging calculation of the measurement results.
  • Type:
    • Log Group shows the average of the logged data results from multiple measurements. You specify the number of measurements to take for the calculation. A display result is generated for every N measurements.
    • Power Group shows the average of the power data results from multiple measurements. You specify the number of measurements to take for the calculation. The calculated result is then displayed as logged data. A display result is generated for every N measurements.
    • Max Group shows the maximum of the upper and lower data sets across N measurements.
    • Min Group shows the minimum of the upper and lower data sets across N measurements.
    • Min/Max Group shows the the minimum of the lower data sets and the maximum of the upper data sets across the N measurements.

.

Remote control commands

[:SENSe]:SEMask:AVERage:COUNt

[:SENSe]:SEMask:AVERage:TYPE

[:SENSe]:SEMask:AVERage[:STATe]


W-CDMA Uplink Occupied Bandwidth Settings

Select from the list below to learn what choices you have for setting up a W-CDMA Uplink Occupied Bandwidth measurement:

  • W-CDMA Uplink Occupied Bandwidth measurement panel
  • Trigger settings panel
  • Atten Preamp control
  • Trace Hold control
  • Averaging control


W-CDMA Uplink Occupied Bandwidth measurement panel

Carrier Frequency

Tunes the analyzer to the frequency of the carrier signal.

Remote control command

[:SENSe]:FREQuency:CENTer

Limits
  • The Limit On check box enables and disables the limit testing. If the box is selected, the limit testing is enabled. If the check box is unselected, the limit testing is disabled.
  • The Limit Margin value field allows you to add or subtract an offset to the pass/fail limits specified by the W-CDMA standard.

Remote control commands

:CALCulate:WCDMa:UPLink:OBWidth:LIMit:FAIL?

:CALCulate:WCDMa:UPLink:OBWidth:LIMit:MARGin

:CALCulate:WCDMa:UPLink:OBWidth:LIMit[:STATe]

Sweep

Sets the type of sweep:

  • Continuous sweep repeatedly sweeps the span that you specified.
  • Single sweep takes one sweep of the span you specified.

Remote control commands

:INITiate:CONTinuous

:INITiate[:IMMediate][:ALL]

Markers

You can use markers for two different functions:

  • Locating and reading various measurement data.
  • Setting the center or reference parameter value to the marker position.

Each measurement trace has four markers, and each marker has an associated delta marker:

  • The marker indicates the x-axis and y-axis position for any point on a trace.
  • The delta marker indicates the relative value between the marker and the associated delta marker.

The measurement data associated with each of the marker positions is displayed at the top of the instrument screen.

  • Tab 1 2 3 4 selects one of the four markers for editing the marker parameters.
  • Marker On check box enables and disables the marker associated with the selected tab.
  • Marker Position sets the x-axis value of the marker.
  • Delta Marker
    • Off switches off the delta marker for the marker associated with the selected tab.
    • Tracking keeps the delta marker at the set x-axis position and updates the y-axis position with each sweep.
    • Fixed Point keeps the delta marker at both the x-axis and y-axis positions that you set.
  • Delta sets the difference in x-axis positions between the delta marker and the associated marker.
  • Zero Delta brings the delta marker to the same position as the marker associated with the selected tab.
  • Center sets the center frequency parameter value to the current x-axis value of the marker.
  • Ref sets the screen reference value to the current y-axis value of the marker.
  • Max moves the marker to the maximum amplitude of the measurement trace.
  • Next moves the marker to the top of the next largest peak that is below the marker's current y-axis value.
  • Left moves the marker to the top of the next largest peak that is to the left of the current marker position and at least 3 dB below the current marker position.
  • Right moves the marker to the top of the next largest peak that is to the right of the current marker position and at least 3 dB below the current marker position.

Remote control commands

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4|[:STATe]

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:LEFT

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:NEXT

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:PREVious

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:RIGHt

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum[:PEAK]

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:DELTa:ZERO

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:FUNCtion:CENTer

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:FUNCtion:REFerence

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:Y?


Averaging control

The averaging function minimizes the effects of noise by averaging the results of multiple measurements.

There are two values displayed for each of the 501 measurement points across the instrument screen: a lower value and an upper value. These two values represent the total excursion of the signal within the span of a single display point. When averaging is enabled, the lower and upper values are averaged as independent sets.

  • Averaging On: switches on the averaging function, if the check box is selected.
  • Number: specifies how many measurements to take for calculating the average of the results.
  • Type:
    • Power Running shows a new set of averaged power data as logged data for each measurement that is taken. The data trace is calculated as a weighted average of power values from the previous measurement and the current measurement. The results are then displayed as logged data. A display result is generated for every measurement.
    • Power Group shows the average of the power data results from multiple measurements. You specify the number of measurements to take for the calculation. The calculated result is then displayed as logged data. a display result is generated for every N measurements.

Remote control commands

[:SENSe]:OBWidth:AVERage:COUNt

[:SENSe]:OBWidth:AVERage:TYPE

[:SENSe]:OBWidth:AVERage[:STATe]


W-CDMA Downlink Settings

Select from the lists to learn about the choices you have to set up a W-CDMA Downlink measurement:

  • W-CDMA Downlink Demodulation Settings
  • W-CDMA Downlink ACLR Settings
  • W-CDMA DL SEM settings
  • W-CDMA Downlink OB Settings


W-CDMA Downlink Demodulation Settings

Select from the list below to learn what choices you have for setting up a W-CDMA Downlink Demodulate measurement:

1

W-CDMA Downlink Demodulate measurement panel

2
  • Code Settings panel

  • Symbol EVM panel

  • Edit Limits setting panel

3

Averaging control


W-CDMA Downlink Demodulation measurement panel

Carrier Frequency

Tunes the analyzer to the frequency of the carrier signal.

Remote control command

[:SENSe]:FREQuency:CENTer

Expected Power

Sets the expected power of the incoming signal.

Remote control commands

[:SENSe]:EPOWer

Sweep

Sets the type of sweep:

  • Continuous sweep repeatedly sweeps the span that you specified.
  • Single sweep takes one sweep of the span you specified.

Remote control commands

:INITiate:CONTinuous

:INITiate[:IMMediate][:ALL]

Markers W-CDMA Downlink Demodulation

Sets the markers for the W-CDMA measurement.

  • Marker:
    • On check box enables the Marker when selected.
    • Index selects the index on which to place the Marker.

Remote control commands

:CALCulate:WCDMa:DOWNlink:MARKer:CNUMber

:CALCulate:WCDMa:DOWNlink:MARKer:SFACtor

:CALCulate:WCDMa:DOWNlink:MARKer[:STATe]

:CALCulate:WCDMa:DOWNlink:MARKer:X

:CALCulate:WCDMa:DOWNlink:MARKer:Y

View

Allows you to select the view of the measurement results:

  • Graph & Table displays a graph in the bottom of the screen and a table in the top of the screen. The graph shows the measurement results as a trace. The table shows a tabular listing of measured values, set limits, and limit test results for each of the associated measurements.
  • Graph displays the graph as full screen.
  • Table displays the table as full screen.

Remote command

:DISPlay:VIEW:WCDMa


Code Settings panel

Sync Type

Sets the sync type for the physical channel selected.

Remote control command

[:SENSe]:WCDMa:DOWNlink:CODE:STYPe

Scramble Code

Sets the scramble code.

Remote control command

[:SENSe]:WCDMa:DOWNlink:CODE:SCRamble


Symbol EVM panel

Spread Factor W-CDMA Downlink Settings

Sets the spread factor.

Remote control command

[:SENSe]:WCDMa:DOWNlink:EVM:SYMBol:SFACtor

Code Number W-CDMA Downlink Settings

Sets the code number.

Remote control command

[:SENSe]:WCDMa:DOWNlink:EVM:SYMBol:CNUMber


Edit Limits setting panel

Measurement
  • EVM rms selects the error vector magnitude rms measurement limit value for editing (the default value is 17.5%).
  • EVM peak selects the error vector magnitude peak measurement limit value for editing (the default value is 100%).
  • PCDE selects the peak code-domain error measurement limit value for editing (the default value is -15 dB).
  • Freq Error selects the frequency error measurement limit value for editing (the default value is 100 Hz).
  • IQ Offset selects the frequency error measurement limit value for editing (the default value is -40 dB).

Limits
  • The Limit On check box enables and disables the limit testing. If the box is selected, the limit testing is enabled. If the check box is unselected, the limit testing is disabled.
  • The Limit value field sets maximum value that will be considered a passing condition for a limit test performed on the specified measurement.

Remote control commands

:CALCulate:WCDMa:DOWNlink:EVM:PEAK

:CALCulate:WCDMa:DOWNlink:EVM:PEAK:LIMit:FAIL

:CALCulate:WCDMa:DOWNlink:EVM:PEAK:LIMit[:STATe]

:CALCulate:WCDMa:DOWNlink:EVM:PEAK:LIMit:UPPer

:CALCulate:WCDMa:DOWNlink:EVM:RMS

:CALCulate:WCDMa:DOWNlink:EVM:RMS:LIMit:FAIL

:CALCulate:WCDMa:DOWNlink:EVM:RMS:LIMit[:STATe]

:CALCulate:WCDMa:DOWNlink:EVM:RMS:LIMit:UPPer

:CALCulate:WCDMa:DOWNlink:EVM:SYMBol

:CALCulate:WCDMa:DOWNlink:EVM:SYMBol:LIMit:FAIL

:CALCulate:WCDMa:DOWNlink:EVM:SYMBol:LIMit[:STATe]

:CALCulate:WCDMa:DOWNlink:EVM:SYMBol:LIMit:UPPer

:CALCulate:WCDMa:DOWNlink:FERRor

:CALCulate:WCDMa:DOWNlink:FERRor:LIMit:FAIL

:CALCulate:WCDMa:DOWNlink:FERRor:LIMit[:STATe]

:CALCulate:WCDMa:DOWNlink:FERRor:LIMit:UPPer

:CALCulate:WCDMa:DOWNlink:IOFFset

:CALCulate:WCDMa:DOWNlink:IQOFfset

:CALCulate:WCDMa:DOWNlink:IQOFfset:LIMit:FAIL

:CALCulate:WCDMa:DOWNlink:IQOFfset:LIMit[:STATe]

:CALCulate:WCDMa:DOWNlink:IQOFfset:LIMit:UPPer

:CALCulate:WCDMa:DOWNlink:QOFFset

:CALCulate:WCDMa:DOWNlink:PCDE

:CALCulate:WCDMa:DOWNlink:PCDE:LIMit:FAIL

:CALCulate:WCDMa:DOWNlink:PCDE:LIMit[:STATe]

:CALCulate:WCDMa:DOWNlink:PCDE:LIMit:UPPer

Set Default

Set Default returns the limit value to the default value.


Averaging control W-CDMA Downlink demodulation

The averaging function minimizes the effects of noise by averaging the results of multiple measurements.

There are two values displayed for each of the 501 measurement points across the instrument screen: a lower value and an upper value. These two values represent the total excursion of the signal within the span of a single display point. When averaging is enabled, the lower and upper values are averaged as independent sets.

  • Averaging On: switches on the averaging function, if the check box is selected.
  • Number: specifies how many measurements to take when calculating the average of the results.
  • Type:
    • Mean Group sets the measurement trace to show the calculated mean of the power data results from multiple measurements. You specify the number of measurements to take for the calculation.
    • Max Group sets the measurement trace to show the average of the maximum power data results from multiple measurements. You specify the number of measurements to take for the calculation.
    • Min Group sets the measurement trace to show the average of the minimum power data results from multiple measurements. You specify the number of measurements to take for the calculation.

Remote control commands

[:SENSe]:WCDMa:DOWNlink:AVERage:COUNt

[:SENSe]:WCDMa:DOWNlink:AVERage[:STATe]

[:SENSe]:WCDMa:DOWNlink:AVERage:TYPE


W-CDMA Downlink ACLR Settings

Select from the list below to learn what choices you have for setting up a W-CDMA Downlink ACLR measurement:

1

W-CDMA Downlink ACLR measurement panel

2
  • Trace Hold control

  • Fast Mode control

  • Noise Correction control

3

Averaging control


W-CDMA Downlink ACLR measurement panel

Channel Frequency

Sets the main channel center frequency.

Remote control command

[:SENSe]:FREQuency:CENTer

Expected Power

Sets the expected power of the incoming signal.

Remote control commands

[:SENSe]:EPOWer

Sweep Time

Sets the length of time that the measurement takes place.

Remote control command

[:SENSe]:ACPR:CENTer:SWEep:TIME

[:SENSe]:ACPR:ADJacent1|ADJacent2:SWEep:TIME

W-CDMA Downlink settings limits
  • The Limit On check box enables and disables the limit testing. If the box is selected, the limit testing is enabled. If the check box is unselected, the limit testing is disabled.
  • The Limit value field sets maximum value that will be considered a passing condition for a limit test performed on the W-CDMA ACLR measurement.

Remote control commands

:CALCulate:WCDMa:DOWNlink:ACLR:LIMit:FAIL

:CALCulate:WCDMa:DOWNlink:ACLR:LIMit:FAIL:CHANnels

:CALCulate:WCDMa:DOWNlink:ACLR:LIMit:MARGin

:CALCulate:WCDMa:DOWNlink:ACLR:LIMit[:STATe]

Sweep

Sets the type of sweep:

  • Continuous sweep repeatedly sweeps the span that you specified.
  • Single sweep takes one sweep of the span you specified.

Remote control commands

:INITiate:CONTinuous

:INITiate[:IMMediate][:ALL]


W-CDMA DL SEM settings

Select from the list below to learn what choices you have for setting up a W-CDMA Downlink Spectrum Emission Mask measurement:

1
  • W-CDMA DL SEM measurement panel

  • Trigger settings panel

  • Atten/Preamp

2

Detection Type control

3

Averaging control


W-CDMA DL SEM measurement panel

Carrier Frequency

Tunes the analyzer to the frequency of the carrier signal.

Remote control command

[:SENSe]:FREQuency:CENTer

W-CDMA DL SEM limits
  • The Limit On check box enables and disables the limit testing. If the box is selected, the limit testing is enabled. If the check box is unselected, the limit testing is disabled.
  • The Limit Margin value field allows you to add or subtract an offset to the pass/fail limits specified by the W-CDMA standard.

Remote control command

:CALCulate:WCDMa:DOWNlink:SEMask:BSMPower

:CALCulate:WCDMa:DOWNlink:SEMask:LIMit:FAIL

:CALCulate:WCDMa:DOWNlink:SEMask:LIMit:MARGin

:CALCulate:WCDMa:DOWNlink:SEMask:LIMit[:STATe]

Sweep

Sets the type of sweep:

  • Continuous sweep repeatedly sweeps the span that you specified.
  • Single sweep takes one sweep of the span you specified.

Remote control commands

:INITiate:CONTinuous

:INITiate[:IMMediate][:ALL]

Markers

You can use markers for two different functions:

  • Locating and reading various measurement data.
  • Setting the center or reference parameter value to the marker position.

Each measurement trace has four markers, and each marker has an associated delta marker:

  • The marker indicates the x-axis and y-axis position for any point on a trace.
  • The delta marker indicates the relative value between the marker and the associated delta marker.

The measurement data associated with each of the marker positions is displayed at the top of the instrument screen.

  • Tab 1 2 3 4 selects one of the four markers for editing the marker parameters.
  • Marker On check box enables and disables the marker associated with the selected tab.
  • Marker Position sets the x-axis value of the marker.
  • Delta Marker
    • Off switches off the delta marker for the marker associated with the selected tab.
    • Tracking keeps the delta marker at the set x-axis position and updates the y-axis position with each sweep.
    • Fixed Point keeps the delta marker at both the x-axis and y-axis positions that you set.
  • Delta sets the difference in x-axis positions between the delta marker and the associated marker.
  • Zero Delta brings the delta marker to the same position as the marker associated with the selected tab.
  • Center sets the center frequency parameter value to the current x-axis value of the marker.
  • Ref sets the screen reference value to the current y-axis value of the marker.
  • Max moves the marker to the maximum amplitude of the measurement trace.
  • Next moves the marker to the top of the next largest peak that is below the marker's current y-axis value.
  • Left moves the marker to the top of the next largest peak that is to the left of the current marker position and at least 3 dB below the current marker position.
  • Right moves the marker to the top of the next largest peak that is to the right of the current marker position and at least 3 dB below the current marker position.

Remote control commands

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4|[:STATe]

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:LEFT

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:NEXT

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:PREVious

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:RIGHt

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum[:PEAK]

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:DELTa:ZERO

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:FUNCtion:CENTer

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:FUNCtion:REFerence

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:Y?


W-CDMA Downlink OB Settings

Select from the list below to learn what choices you have for setting up a W-CDMA Downlink Occupied Bandwidth measurement:

1
  • W-CDMA Downlink OB measurement panel

  • Trigger settings panel

  • Atten/Preamp control panel

2

Trace Hold control

3

Averaging controls


W-CDMA Downlink OB measurement panel

Carrier Frequency

Tunes the analyzer to the frequency of the carrier signal.

Remote control command

[:SENSe]:FREQuency:CENTer

W-CDMA Downlink OB settings limits
  • The Limit On check box enables and disables the limit testing. If the box is selected, the limit testing is enabled. If the check box is unselected, the limit testing is disabled.
  • The Limit Margin value field allows you to add or subtract an offset to the pass/fail limits specified by the W-CDMA standard.

Remote control command

:CALCulate:WCDMa:DOWNlink:OBWidth:LIMit:FAIL

:CALCulate:WCDMa:DOWNlink:OBWidth:LIMit:MARGin

:CALCulate:WCDMa:DOWNlink:OBWidth:LIMit[:STATe]

:CALCulate:WCDMa:DOWNlink:OBWidth:LIMit:UPPer

Sweep

Sets the type of sweep:

  • Continuous sweep repeatedly sweeps the span that you specified.
  • Single sweep takes one sweep of the span you specified.

Remote control commands

:INITiate:CONTinuous

:INITiate[:IMMediate][:ALL]

Markers

You can use markers for two different functions:

  • Locating and reading various measurement data.
  • Setting the center or reference parameter value to the marker position.

Each measurement trace has four markers, and each marker has an associated delta marker:

  • The marker indicates the x-axis and y-axis position for any point on a trace.
  • The delta marker indicates the relative value between the marker and the associated delta marker.

The measurement data associated with each of the marker positions is displayed at the top of the instrument screen.

  • Tab 1 2 3 4 selects one of the four markers for editing the marker parameters.
  • Marker On check box enables and disables the marker associated with the selected tab.
  • Marker Position sets the x-axis value of the marker.
  • Delta Marker
    • Off switches off the delta marker for the marker associated with the selected tab.
    • Tracking keeps the delta marker at the set x-axis position and updates the y-axis position with each sweep.
    • Fixed Point keeps the delta marker at both the x-axis and y-axis positions that you set.
  • Delta sets the difference in x-axis positions between the delta marker and the associated marker.
  • Zero Delta brings the delta marker to the same position as the marker associated with the selected tab.
  • Center sets the center frequency parameter value to the current x-axis value of the marker.
  • Ref sets the screen reference value to the current y-axis value of the marker.
  • Max moves the marker to the maximum amplitude of the measurement trace.
  • Next moves the marker to the top of the next largest peak that is below the marker's current y-axis value.
  • Left moves the marker to the top of the next largest peak that is to the left of the current marker position and at least 3 dB below the current marker position.
  • Right moves the marker to the top of the next largest peak that is to the right of the current marker position and at least 3 dB below the current marker position.

Remote control commands

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4|[:STATe]

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:LEFT

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:NEXT

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:PREVious

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:RIGHt

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum[:PEAK]

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:DELTa:ZERO

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:FUNCtion:CENTer

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:FUNCtion:REFerence

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:Y?


802.11X Settings

Select from the list to learn about the choices you have to set up an 802.11x measurement:

  • 802.11x Demodulate
  • 802.11x Spectrum Emission Mask


802.11x Demodulate measurement panel

Channel Frequency

Sets the main channel center frequency.

Remote control command

[:SENSe]:FREQuency:CENTer

Expected Power

Sets the expected power of the incoming signal.

Remote control commands

[:SENSe]:EPOWer

Sweep

Sets the type of sweep:

  • Continuous sweep repeatedly sweeps the span that you specified.
  • Single sweep takes one sweep of the span you specified.

Remote control commands

:INITiate:CONTinuous

:INITiate[:IMMediate][:ALL]


802.11x Signal types

There are several types of 802.11x signals. The default behavior is for the instrument to auto detect the signal type. You may explicitly specify the signal type to obtain faster measurements.

Types:

  • Auto (default) Selecting this will cause the instrument to automatically identify the signal type. There is a small speed penalty for making this determination on high quality signals, but for poor quality signals this can take a significant amount of time. Refer to Auto detection for details.
  • 802.11a/g 20MHz OFDM signals meeting the 802.11a, or the OFDM portion of 802.11g. Refer to 802.11a/g/j/n (OFDM)...
  • 802.11b/g CCK/DSSS signals meeting 802.11b or the CCK/DSSS portion of 802.11g. Refer to 802.11b/g DSSS/CCK Settings.
  • 802.11j Half clock (10MHz) OFDM signals meeting 802.11j. Refer to 802.11a/g/j/n (OFDM)...
  • 802.11n (draft 2.0) Refer to 802.11n (draft 2.0) demodulation.


802.11n (draft 2.0) demodulation

The 802.11 demodulation application can demodulate certain 802.11n Draft 2.0 waveforms:

  • Either 20 or 40MHz bandwidth, except duplicate mode
  • Mixed mode (as opposed to green field)
  • Long guard interval
  • Any SISO waveform See SISO (single input, single output) signal
  • MIMO waveforms from a single transmit channel with direct mapping and no space time block coding. Refer to MIMO (multiple input, multiple output) signal.


SISO (single input, single output) signal

A SISO signal is a single transmit channel of a MIMO signal with direct mapping, no spatial multiplexing and no space time coding.

NOTE: The measurement application is not able to decode 802.11n duplicate channels.


MIMO (multiple input, multiple output) signal

MIMO signals can be measured when a single transmit channel (antenna output) is cabled directly to the Model 2820 VSA input. This allows a single receiver to switch between transmitter outputs to validate the modulation quality of a MIMO transmitter. If signal from more than one transmit channel or more than one spatial stream is present, a single receiver does not have enough information to solve the MIMO matrix and separate the information. Thus, the Model 2820 measurement cannot be used to measure MIMO signals captured by an antenna or at the output of a channel simulator. Similarly, the Model 2820 measurement cannot be used when spatial multiplexing or space time block coding is used by the transmitter.


Auto detection

The WLAN demodulation measurement includes a powerful, fast auto detection function that can identify the type of signal being provided to the instrument. This simplifies front panel operation of the instrument - enter the carrier frequency and about what power level is expected, and the instrument will figure out the rest.

In order to improve throughput for remote operation, auto detection can be turned off. The Optimize Setup function on the Settings menu is provided to identify what settings to use for a given signal. When the button is pressed the instrument analyzes the current input signal and selects the format, acquisition time and trigger configuration best for that signal. The optimized configuration uses a video trigger so that only the samples required are gathered. The down side to using a video trigger is that when the input level changes, you have to remember to change the trigger level as well. If you switch to a general purpose spectrum sweep or the 802.11x Spectral Emission Mask while using a video trigger, the instrument may fail to trigger because the LO is tuned to measure spectrum away from the main signal. If the main signal is not in band, there is no energy for the video trigger to detect.


802.11x Demodulation settings
  • Optimize Setup
  • Clear EVM history
  • Acquisition time
  • 802.11a/g/j/n (OFDM)...
  • 802.11b/g DSSS/CCK Settings
  • Edit limits
  • 802.11n Header data
  • CCDF Enabled. Refer to Trace type: CCDF (Complementary Cumulative Distribution Function)


802.11x Demodulation measurement settings

Select a blue link to view further details:

  • 802.11x Signal types
  • 802.11x Settings menu
  • 802.11x Trace types
  • 802.11x Max symbol count

.


Optimize Setup

Optimize Setup is used to set signal type, constellation type, acquisition time and trigger settings for fast data throughput. The instrument attempts to auto detect signal type and constellation type. If successful, signal type and constellation type are set explicitly and so will not be auto detected on subsequent sweeps. Acquisition time is set to 1.8 times the detected packet length. Max symbol count is set to its default value of 100 so that packets with no more than 100 symbols are measured in their entirety. Trigger source is changed to video trigger. The video trigger level is set to 20 dB below channel power. Video trigger type and slope are set to their default values. Pre-Qual level is set to 5.0 dB and Pre-Qual Time is set to 2 microseconds.

Optimize Setup can handle a large class of signals, but not necessarily all signals. In order to properly optimize, the instrument must acquire a complete packet inside the 2 ms acquisition interval. Since the input signal is considered unknown, video trigger is not used during the optimization. If the time block acquired does not include an entire packet, the optimization may fail outright. Refer to Auto detection for additional details.

Caution: If you set up an 802.11x Demodulation measurement and select Optimize Setup from the Settings pull-down menu, the trigger source is changed to Video trigger. If you then choose to make a Spectrum Emission Mask measurement you will see that the trace is no longer visible and a message appears "Waiting for trigger or data...". Select Trigger > Trigger Source > Free Run to re-establish the trigger and the display will update properly.

Refer to the following table for further details:

Quantity | SCPI | Description
Expected power | [:SENSe]:EPOWer | Set the expected power to the observed channel power. Slightly better performance can be achieved by reducing the expected power, although there is more risk of a test device overloading the input.
Trigger mode | :TRIGger[:SEQuence]:SOUR VIDeo | For fastest measurement, use a video trigger so that the system only acquires data around the packet.
Video trigger level | :TRIGger[:SEQuence]:LEVel | The video trigger level is set 20 dB below the observed channel power.
Video trigger delay | :TRIGger[:SEQuence]:DELay 0.0 | No video delay is required or desired.
Video trigger prequalification level | :TRIGger[:SEQuence]:PREQual[:LEVel] | To prevent false triggers, this is set to 5 dB.
Video trigger prequalification time | TRIGger[:SEQuence]:PREQual:WINDow | Also to prevent false triggers, this is set to 2 microseconds
WLAN signal type (abgjn) | [:SENSe]:WLAN:SIGNal | Set to the observed signal type, to avoid searching for the signal type. This saves considerable time when testing a failed device, so the instrument can declare the device failed without trying every possible format.
WLAN constellation | [:SENSe]:WLAN:CONStellation | Set to the observed constellation type. A very small time savings. If your tests involve multiple constellation types, just leave in Optimize Setup.
WLAN acquisition time | [:SENSe]:WLAN:ATIMe | With the video trigger, the acquisition time is the packet time plus about 5 microsecond buffer at start and finish. You can use a zero span measurement to figure out what time to use, or let Optimize Setup figure it out.
Graph type | :DISPlay:VIEW:WLAN:TYPE NONE | Graphs take time, whether the display is on or not. Set graph type to NONE.
Front panel display | :DISPlay:ENABle 0 | Turning off the front panel display saves considerable test time. The display will come back on when the Local key is pressed, or when you send DISPlay:ENABLe 1.

NOTE: The last two entries in the table (Graph type and Front panel display) are not set by Optimize Setup, but are recommended for highest throughput.

Remote control command

[:SENSe]:WLAN:OPTimize


Clear EVM history

You may restart the EVM history at any time. The Settings menu has an item for Clear EVM History. The remote interface has a command for clearing the history.

Remote control command

[:SENSe]:WLAN:EHIStory:CLEar


Acquisition time

You specify the length of time over which data is acquired. If you are using video or external trigger, the acquisition time is set to the packet time plus some buffer at the beginning and end of the packet. If you are using trigger free run (the default) set the acquisition time to one and one-half the time from packet start to packet start to ensure that a complete packet is acquired. Partial OFDM packets can be processed, but partial CCK/DSSS packets cannot.

  • Default: 2 ms
  • Min: 50 µs
  • Max: 2 ms
  • Resolution: 1µs

Remote control command

[:SENSe]:WLAN:ATIMe


802.11a/g/j/n (OFDM)

For 802.11a/g/j/n, the signal types that employ OFDM, there are several constellation types. The default behavior is for the instrument to auto detect the constellation type. You may explicitly specify the constellation type to obtain faster measurements.

The OFDM 802.11 signals can be configured to use any of four different constellation types.

[:SENSe]:WLAN:CONStellation AUTodetect | BPSK | QPSK | QAM16 | QAM64

Constellation:

  • Auto (default) This setting causes the instrument to automatically figure out which constellation is in use. There is a negligible time penalty for using automatic detection, and is the recommended selection except for fastest speed under SCPI control. Refer to Auto detection for further details.
  • BPSK, Binary Phase Shift Keying
  • QPSK, Quadrature Phase Shift Keying
  • QAM16, 16 QAM
  • QAM64, 64 QAM


802.11b/g DSSS/CCK Settings

DC offset removal:

  • Estimates the center of the constellation and shifts it to zero offset prior to computing EVM.
  • Should be enabled to maintain consistency with the IEEE 802.11b transmit modulation accuracy test (Max EVM).
  • The options are: On or Off. The default is On.

Remote control command

[:SENSe]:WLAN:CCK:DCOFfset:STATe ON/OFF

Equalizer:

  • Used to estimate and remove errors resulting from intersymbol interference.
  • Enabling equalization can be a useful tool for troubleshooting problems in the system, but should be turned off when testing compliance to maintain consistency with the IEEE 802.11b transmit modulation accuracy test.
  • The built-in equalizer has 11 steps.
  • The options are: On or Off. The default is On.

Remote control command

[:SENSe]:WLAN:CCK:EQUalizer:STATe ON/OFF

Filter type:

  • Filtering is selectable between the following filter types: Bartlett, Blackman, Gaussian, Hamming, Hann, None, RC (Spectrally raised cosine), and RRC (Spectrally raised root cosine).
  • The default is None.

Remote control command

[:SENSe]:WLAN:CCK:FILTer


Edit limits

Limit values for 802.11x data table results

Results | Default state | Default value | Minimum | Maximum
EVM rms (dB) | On | -28.0 | -100.0 | 0.0
EVM peak (dB) | Off | -14.0 | -100.0 | 0.0
Pilot EVM rms (dB) | Off | -28.0 | -100.0 | 0.0
Pilot EVM peak (dB) | Off | -14.0 | -100.0 | 0.0
Channel Power (dBm) | Off | -10.0 | -100.0 | 10.0
Carrier Freq Error (Hz) | On | ±60000 | 0.0 | 1,000,000
Carrier Feedthru (dB) | On | -20 | -50 | 0.0
Symbol Clock Error (ppm) | On | ±25.00 | 0.0 | 50.0
Flatness Margin (dB) | On | 0.0 | -50.0 | 50.0
Power-On Ramp (µSec) | On | 2 | 0.01 | 20
Power-Down Ramp (µSec) | On | 2 | 0.01 | 20

Limit testing is provided for all the measured values in the data table. The actual limit values provided are nominal values that don't change as the detected signal type changes, so it is left to the user to enter the correct limit values for the current measurement situation. For example, if an 802.11b signal is being measured, you would normally turn off the limit on RMS EVM and turn on the limit for Peak EVM. The 802.11b standard specifies a peak EVM of 35%, which is -9.12 dB.


802.11n Header data

The data table also contains a section for display of 802.11n header data. You must enable decoding of header data. This is done through check box item in the Settings menu or through the remote interface. If the measured signal is detected as being 802.11n then the header data result in the table shows "No signal".

Remote control command

[:SENSe]:WLAN:HDECode ON/OFF

The header data values are described in the following table.

802.11n Header data table

Mod/Coding Scheme | Index into a table of Modulation/Coding values such as constellation, coding rate and MIMO info.
Nss | Number of spatial streams. This is the key to knowing that MIMO has been turned on.
Modulation | BPSK, QPSK, QAM16 or QAM64. If the header contains a numeric value that does not map to one of these modulation types then the raw numeric value is displayed. A SCPI query maps these to 2, 4, 16, 64.
Rate | 1/2, 2/3, 4/5 or 5/6. If the header contains a numeric value that does not map to one of these rates then the raw numeric value is displayed. A SCPI query maps these to 1, 2, 3, 4.
Data Bits/Symbol | A highly derived number that says how many raw data bits are carried on each OFDM symbol. This depends on coding rate, constellation, and channel bandwidth.
Bandwidth | 20 MHz or 40 MHz. If the header contains a numeric value that does not map to one of these bandwidths then the raw numeric value is displayed. A SCPI query maps to a Boolean "1" which means 40 MHz.
HT length | (High Throughput) Number of (uncoded) bytes in data portion
STBC | Value to do with space time coding
Short guard interval | 0 indicates data portion uses 800 ns guard interval. 1 indicates 400 ns guard interval.
Num Ext HT-LTF | Number of HT-LTF extensions. Transmitter can insert extra long training field symbols. Not commonly done, but the field is there.
Data Symbols/Packet | Number of symbols as derived from the data header. The number of symbols in main part of data table will be less than or equal to this.

This table can be read by using the SCPI command: :CALCulate:WLAN:HEADer?. The values come back as comma separated ASCII in the order of the above table.


802.11x Demodulation trace types

You specify the trace type. This determines what type of data is returned from the DSP to the host:

  • Trace type: None,
  • Trace type: Constellation (default)
  • Trace type: EVM vs Channel
  • Trace type: EVM vs Symbol
  • Trace type: EVM History
  • Trace type: CCDF (Complementary Code Distribution Function)
  • Trace type: Gain Compression
  • Trace type: Magnitude Flatness
  • Trace type: Phase Flatness

Remote control command

:DISPlay:VIEW:WLAN:TYPE

The user-specified Gain Compression and CCDF require additional processing in the DSP. They are available only if you explicitly enable them. The Settings menu has options for enabling/disabling these two trace types. The default is: Gain Compression/CCDF disabled. To control Gain Compression and CCDF use [:SENSe]:WLAN:GAIN:STATe ON/OFF.

Trace data and display are updated if you change trace type while the sweep is stopped. The previous trace data is discarded and new trace data is read from the DSP and processed.


Trace type: None

The trace type of None serves two purposes:

  • Provides for faster measurements if you are only interested in the data table. This choice is recommended for remote programming.
  • Is set as the default trace type if the current trace type is not valid for a newly selected signal type.

Remote control command

:DISPlay:VIEW:WLAN:TYPE NONE


Trace type: Constellation

Data samples are plotted as single points on a graph with I/Q axes. The graph includes pilot data which uses BPSK modulation.

When Averaging is turned on, the constellation graph accumulates points to a maximum of 100,000 points.

The Error Magnify feature allows you to expand/reduce each constellation cluster about its nominal center. The default is 1.0x. and the maximum is 10.0x.

Note: The Error Magnify feature only works with OFDM signal types, not CCK/DSSS.

EVM rms is displayed along with the constellation graph when graph-only view is selected. EVM rms is displayed in the data table when the view is Graph & Table.

No markers are available for constellation traces. The Markers… button is disabled.

Remote control command

:DISPlay:VIEW:WLAN:TYPE CONStellation


Trace type: EVM vs Channel

Mean EVM is displayed for each channel in the form of a bar graph. The number of channels is a function of signal type and signal bandwidth. The maximum and minimum channel values are displayed below the graph.

You can rescale the Y-axis using the Top Value and Scale/div settings. Top Value has a default value of 0.0 db, minimum of -50.0 dB and maximum of 0.0 dB. Scale/div has a default value of 10.0 dB/div, minimum of 0.1 dB/div and maximum of 100.0 dB/div.

Markers are available for the EVM vs Channel graph. There are four markers with each regular marker having a corresponding Delta marker. The markers function in a manner similar to that of existing markers for Spectrum and Zero Span measurements. The available set of marker functions are Marker to Max, Marker to Min, Marker to Next peak, Marker to Left Peak and Marker to Right Peak.

The 802.11n 40 MHz signal skips Channels -1, 0 and +1. The other signals skip Channel 0. A vertical bar is drawn on the graph to separate negative and positive channels.

Two values are added to the data table when the trace type is EVM vs Channel. The first is the maximum EVM value in the graph. The second is the number of the channel with maximum EVM.

This trace type is available for OFDM signals only.

NOTE: Each channel occupies 312.5 kHz, if you want to convert the channel number to baseband frequency. For 802.11, half clocked, the channels are 156.25 kHz apart.

Remote control command

:DISPlay:VIEW:WLAN:TYPE EVCHannel


Trace type: EVM vs Symbol

Mean EVM is displayed for each symbol in the form of a bar graph. The number of symbols is a function of the signal's symbols/packet, the acquisition time setting and the max symbol count setting. The maximum and minimum symbol indexes are displayed below the graph, starting at count 0.

For OFDM signal types, the X axis is the number of OFDM symbols. For CCK/DSSS signal types, the X axis is actually the number of chips.

You can scale the Y-axis using the Top Value and Scale/div settings. Top Value has a default value of 0.0 db, minimum of -50.0 dB and maximum of 0.0 dB. Scale/div has a default value of 10.0 dB/div, minimum of 0.1 dB/div and maximum of 100.0 dB/div.

Markers are available for the EVM vs Symbol graph. There are four markers with each regular marker having a corresponding Delta marker. The markers function in a manner similar to that of existing markers for Spectrum and Zero Span measurements. The available set of marker functions are Marker to Max, Marker to Min, Marker to Next peak, Marker to Left Peak and Marker to Right Peak.

Remote control command

:DISPlay:VIEW:WLAN:TYPE EVSYmbol


Trace type: EVM History

The EVM History trace type is like a strip chart of EVM rms values measured. Each EVM rms value is added to the history regardless of the current trace type. Measured values shift right to left. The X-axis domain is sample number with sample number zero being the most recent EVM rms value. You may select how many values to display: 501, 251, 101, 51, 26 or 11. The instrument keeps track of the most recent 501 values regardless of the number of values displayed.

You can scale the Y-axis using the Top Value and Scale/div settings. Top Value has a default value of 0.0 db, minimum of -50.0 dB and maximum of 0.0 dB. Scale/div has a default value of 10.0 dB/div, minimum of 0.1 dB/div and maximum of 100.0 dB/div.

Markers are available for the EVM History graph. There are four markers with each regular marker having a corresponding Delta marker. The markers function in a manner similar to that of existing markers for Spectrum and Zero Span measurements. The available set of marker functions are Marker to Max, Marker to Min, Marker to Next peak, Marker to Left Peak and Marker to Right Peak.

No trace is drawn for sample numbers that have not been measured. If the marker is set to a sample number that has not yet been acquired the value is shown as "No data" with the marker at the bottom of the graph.

See: Clear EVM history.

Remote control command

:DISPlay:VIEW:WLAN:TYPE EHIStory


Trace type: CCDF (Complementary Cumulative Distribution Function)

The CCDF (Complementary Cumulative Distribution Function) trace type requires additional processing by the DSP. To avoid slowing down other trace types CCDF may be selected as trace type only if it has been enabled. The Settings menu contains a check box item for enabling/disabling Gain Compression and CCDF.

CCDF displays a probability, in percent, of observing a power value above the power on the X axis. Average power is 0 dB on the X-axis. The default behavior is to accumulate data from each sweep into a histogram which is then processed into the displayed trace. You may restart data accumulation at any time by clicking the Restart button or sending a command through the remote interface. You may turn off data accumulation, in which case the trace is derived from the most recent sweep only. Refer to:

[:SENSe]:WLAN:CCDF:ACCumulate:STATe

[:SENSe]:WLAN:CCDF:RESTart

Your may set the X-axis scale/div to 0.5, 1.0, 1.5 or 2.0 dB/div.

No markers are available for CCDF trace type. The Markers… button is disabled.

This trace type is available for OFDM signals only.

Remote control command

:DISPlay:VIEW:WLAN:TYPE CCDF


Trace type: Gain Compression

The Gain Compression trace type produces a graph with two data traces. The first, in yellow, is a scatter gram of error in observed linear magnitude versus expected linear magnitude. The second, in green, is a third order curve fit to the raw data with 11 values, one every 10% on the X-axis.

Gain Compression and CCDF (Complementary Cumulative Distribution Function) trace types require additional processing by the DSP. To avoid slowing down other trace types Gain Compression may be selected as trace type only if it has been enabled. The Settings menu contains a check box item for enabling/disabling Gain Compression and CCDF. See also:

[:SENSe]:WLAN:GAIN:STATe ON/OFF

You may control the Y-axis scaling by setting the Y-axis position of 0% as a division value. The default is 9, minimum is 0 and maximum is 10. Where 0 is the bottom of the graph and 10 is the top of the graph. Scale/div has a default value of 10.0%, minimum of 0.1% and maximum of 100.0%.

There are no markers for the Gain Compression trace type. The Markers... button is disabled.

An additional value is added to the data table when Gain Compression is the trace type. Gain compression is characterized as low, medium or high based on factor indicating the flatness of the data. Gain compression is low when the factor is less than 1.0, medium when less than 3.0 and high when greater than 3.0. The gain compression factor is not accessible through the GUI but may be queried through the remote interface.

This trace type is available for OFDM signals only.

Remote control command

:DISPlay:VIEW:WLAN:TYPE GCOM


Trace type: Magnitude Flatness

The Magnitude flatness trace gives a measure of the channel flatness. There is a data point for each sample. The DC value is interpolated from the values on either side.

The X-axis range is automatically set to ±5 MHz, ±10 MHz or ±20 MHz to match the bandwidth of the signal.

The user may set the scale/div of the Y-axis. The default is 1.0 dB/div, with minimum of 0.1 dB/div and maximum of 10.0 dB/div. The reference level is always 0 dB and is always at the center of the graph.

Markers are available for the Magnitude Flatness graph. There are four markers with each regular marker having a corresponding Delta marker. The markers function in a manner similar to that of existing markers for Spectrum and Zero Span measurements. The available set of marker functions are Marker to Max, Marker to Min, Marker to Next peak, Marker to Left Peak and Marker to Right Peak.

An additional value is added to the data table for magnitude flatness. It is the peak-to-peak flatness of the trace.

This trace type is available for OFDM signals only. Magnitude flatness is derived from the channel response and determined by the long training field as described in the 802.11 Standard. This is the data from which the flatness margin in the data table is calculated.

Remote control command

:DISPlay:VIEW:WLAN:TYPE MFL


Trace type: Phase Flatness

The Phase flatness trace gives a measure of the channel flatness. There is a data point for each sample. The DC value is interpolated from the values on either side.

The X-axis range is automatically set to ±5 MHz, ±10 MHz or ±20 MHz to match the bandwidth of the signal.

The user may set the scale/div of the Y-axis. The default is 10.0 °/div, with minimum of 0.1 °/div and maximum of 40.0 °/div. The reference level is always 0 °/div and is always at the center of the graph.

Markers are available for the Phase Flatness graph. There are four markers with each regular marker having a corresponding Delta marker. The markers function in a manner similar to that of existing markers for Spectrum and Zero Span measurements. The available set of marker functions are Marker to Max, Marker to Min, Marker to Next peak, Marker to Left Peak and Marker to Right Peak.

An additional value is added to the data table for Phase Flatness. It is the peak-to-peak flatness of the trace.

This trace type is available for OFDM signals only.

The phase flatness trace is the phase of the channel model as derived from the long training field.

Remote control command

:DISPlay:VIEW:WLAN:TYPE PFL


802.11x Max symbol count

You may specify the maximum number of symbols to decode. The actual number of symbols decoded is less than or equal to this maximum count. The decoded symbol count is also less than or equal to the number of symbols within the acquisition time and less than or equal to the number of symbols in a packet. For normal use, leave this setting at the maximum so that all available data is used. For maximum speed under SCPI control you can use this feature to reduce the number of symbols processed and thus speed up the measurement.

  • Default: 400
  • Min: 4
  • Max: 400

Remote control command

  • [:SENSe]:WLAN:OFDM:COUNt MAX


802.11x Demodulation Averaging

The averaging function minimizes the effects of noise by averaging the results of multiple measurements.

There are two values displayed for each of the 501 measurement points across the instrument screen: a lower value and an upper value. These two values represent the total excursion of the signal within the span of a single display point. When averaging is enabled, the lower and upper values are averaged as independent sets.

  • Averaging On: Switches on the averaging function, if the check box is selected.
  • Number: Specifies how many measurements to take for calculating the average of the results.

Remote control commands:

[:SENSe]:WLAN:AVERaging:COUNT

[:SENSe]:WLAN:AVERaging:STATe


802.11x SEM measurement panel

Channel Frequency

Sets the main channel center frequency.

Remote control command

[:SENSe]:FREQuency:CENTer

802.11x settings limits
  • The Limit On check box enables and disables the limit testing. If the box is selected, the limit testing is enabled. If the check box is unselected, the limit testing is disabled.
  • The Limit Margin value field allows you to add or subtract an offset to the pass/fail limits specified by the W-CDMA standard.

Remote control command

Sweep

Sets the type of sweep:

  • Continuous sweep repeatedly sweeps the span that you specified.
  • Single sweep takes one sweep of the span you specified.

Remote control commands

:INITiate:CONTinuous

:INITiate[:IMMediate][:ALL]

Markers

You can use markers for two different functions:

  • Locating and reading various measurement data.
  • Setting the center or reference parameter value to the marker position.

Each measurement trace has four markers, and each marker has an associated delta marker:

  • The marker indicates the x-axis and y-axis position for any point on a trace.
  • The delta marker indicates the relative value between the marker and the associated delta marker.

The measurement data associated with each of the marker positions is displayed at the top of the instrument screen.

  • Tab 1 2 3 4 selects one of the four markers for editing the marker parameters.
  • Marker On check box enables and disables the marker associated with the selected tab.
  • Marker Position sets the x-axis value of the marker.
  • Delta Marker
    • Off switches off the delta marker for the marker associated with the selected tab.
    • Tracking keeps the delta marker at the set x-axis position and updates the y-axis position with each sweep.
    • Fixed Point keeps the delta marker at both the x-axis and y-axis positions that you set.
  • Delta sets the difference in x-axis positions between the delta marker and the associated marker.
  • Zero Delta brings the delta marker to the same position as the marker associated with the selected tab.
  • Center sets the center frequency parameter value to the current x-axis value of the marker.
  • Ref sets the screen reference value to the current y-axis value of the marker.
  • Max moves the marker to the maximum amplitude of the measurement trace.
  • Next moves the marker to the top of the next largest peak that is below the marker's current y-axis value.
  • Left moves the marker to the top of the next largest peak that is to the left of the current marker position and at least 3 dB below the current marker position.
  • Right moves the marker to the top of the next largest peak that is to the right of the current marker position and at least 3 dB below the current marker position.

Remote control commands

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4|[:STATe]

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:LEFT

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:NEXT

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:PREVious

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:RIGHt

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum[:PEAK]

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:DELTa:ZERO

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:FUNCtion:CENTer

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:FUNCtion:REFerence

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:Y?


802.11x SEM Averaging

The averaging function minimizes the effects of noise by averaging the results of multiple measurements.

There are two values displayed for each of the 501 measurement points across the instrument screen: a lower value and an upper value. These two values represent the total excursion of the signal within the span of a single display point. When averaging in enabled, the lower and upper values are averaged as independent sets.

  • Averaging On: switches on the averaging function when the check box is selected.
  • Number: specifies how many measurements to take into consideration for the averaging calculation of the measurement results.
  • Type:
    • Log Group shows the average of the logged data results from multiple measurements. You specify the number of measurements to take for the calculation. A display result is generated for every N measurements.
    • Power Group shows the average of the power data results from multiple measurements. You specify the number of measurements to take for the calculation. The calculated result is then displayed as logged data. A display result is generated for every N measurements.
    • Max Group shows the maximum of the upper and lower data sets across N measurements.
    • Min Group shows the minimum of the upper and lower data sets across N measurements.
    • Min/Max Group shows the the minimum of the lower data sets and the maximum of the upper data sets across the N measurements.

.

Remote control commands

[:SENSe]:WLAN:SEMask:AVERage:COUNt

[:SENSe]:WLAN:SEMask:AVERage:TYPE

[:SENSe]:WLAN:SEMask:AVERage[:STATe]


Viewing measurement results

You can view measurement results in a number of ways and apply various processing functions to view different aspects of the captured data. Explore the following settings to optimize the view of the current measurement results:

  • Auto Scale
  • Scale / div
  • View
  • Trace Hold
  • Markers
  • Detection Type
  • Bandwidth
  • Averaging
  • Sweep
  • Trigger
  • 802.11x Demodulation results

    Note: To find the location and applicability of the settings listed above for the particular measurement that you are making, see Measurement Settings.


Auto Scale

Scales the displayed measurement so that you can view the entire trace on the instrument screen. The scaling is done by automatically adjusting the value per division and the reference level.


Scale / div

Sets the number of measurement units assigned to each division of the instrument screen:

  • Increase the number to zoom out on the measurement trace.
  • Decrease the number to zoom in on the measurement trace.

You can find the Scale / div text entry field to the right of the measurement trace graph.


View

Allows you to select the view of the measurement results:

  • Graph & Table displays a graph in the bottom of the screen and a table in the top of the screen. The graph shows the measurement results as a trace. The table shows a tabular listing of measured values, set limits, and limit test results for each of the associated measurements.
  • Graph displays the graph as full screen.
  • Table displays the table as full screen.

Remote command

:DISPlay:VIEW:CDMA

:DISPlay:VIEW:EDGE:TYPE

:DISPlay:VIEW:GSM:TYPE

:DISPlay:VIEW:WCDMa


Markers

  • Markers for General Purpose and modulation standard measurements
  • Markers for W-CDMA uplink demodulation measurements
  • Markers for W-CDMA downlink demodulation measurements
  • Markers for cdma2000 demodulation measurements


General purpose and modulation standard measurement markers

You can use markers for two different functions:

  • Locating and reading various measurement data.
  • Setting the center or reference parameter value to the marker position.

Each measurement trace has four markers, and each marker has an associated delta marker:

  • The marker indicates the x-axis and y-axis position for any point on a trace.
  • The delta marker indicates the relative value between the marker and the associated delta marker.

The measurement data associated with each of the marker positions is displayed at the top of the instrument screen.

  • Tab 1 2 3 4 selects one of the four markers for editing the marker parameters.
  • Marker On check box enables and disables the marker associated with the selected tab.
  • Marker Position sets the x-axis value of the marker.
  • Delta Marker
    • Off switches off the delta marker for the marker associated with the selected tab.
    • Tracking keeps the delta marker at the set x-axis position and updates the y-axis position with each sweep.
    • Fixed Point keeps the delta marker at both the x-axis and y-axis positions that you set.
  • Delta sets the difference in x-axis positions between the delta marker and the associated marker.
  • Zero Delta brings the delta marker to the same position as the marker associated with the selected tab.
  • Center sets the center frequency parameter value to the current x-axis value of the marker.
  • Ref sets the screen reference value to the current y-axis value of the marker.
  • Max moves the marker to the maximum amplitude of the measurement trace.
  • Next moves the marker to the top of the next largest peak that is below the marker's current y-axis value.
  • Left moves the marker to the top of the next largest peak that is to the left of the current marker position and at least 3 dB below the current marker position.
  • Right moves the marker to the top of the next largest peak that is to the right of the current marker position and at least 3 dB below the current marker position.

Remote control commands

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4|[:STATe]

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:LEFT

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:NEXT

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:PREVious

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:RIGHt

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum[:PEAK]

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:DELTa:ZERO

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:FUNCtion:CENTer

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:FUNCtion:REFerence

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:Y?


W-CDMA Uplink markers

Sets the markers for the W-CDMA measurement.

  • I Marker:
    • On check box enables the I Marker when selected.
    • Index selects the index on which to place the I Marker.
  • Q Marker:
    • On check box enables the Q Marker when selected.
    • Index selects the index on which to place the Q Marker.

Remote control commands

:CALCulate:WCDMa:UPLink:IMARker:CNUMber?

:CALCulate:WCDMa:UPLink:IMARker:SFACtor?

:CALCulate:WCDMa:UPLink:IMARker:X

:CALCulate:WCDMa:UPLink:IMARker:Y

:CALCulate:WCDMa:UPLink:IMARker[:STATe]

:CALCulate:WCDMa:UPLink:QMARker:CNUMber?

:CALCulate:WCDMa:UPLink:QMARker:SFACtor?

:CALCulate:WCDMa:UPLink:QMARker:X

:CALCulate:WCDMa:UPLink:QMARker:Y

:CALCulate:WCDMa:UPLink:QMARker[:STATe]

Markers W-CDMA Downlink Demodulation

Sets the markers for the W-CDMA measurement.

  • Marker:
    • On check box enables the Marker when selected.
    • Index selects the index on which to place the Marker.

Remote control commands

:CALCulate:WCDMa:DOWNlink:MARKer:CNUMber

:CALCulate:WCDMa:DOWNlink:MARKer:SFACtor

:CALCulate:WCDMa:DOWNlink:MARKer[:STATe]

:CALCulate:WCDMa:DOWNlink:MARKer:X

:CALCulate:WCDMa:DOWNlink:MARKer:Y


cdma2000 markers

Sets the markers for the cdma2000 measurement.

  • I Marker:
    • On check box enables the I Marker, when selected.
    • Index selects the index on which to place the I Marker.
  • Q Marker:
    • On check box enables the Q Marker, when selected.
    • Index selects the index on which to place the Q Marker.

Remote control commands

:CALCulate:CDMA:REVerse:IMARker:CNUMber?

:CALCulate:CDMA:REVerse:IMARker:SFACtor?

:CALCulate:CDMA:REVerse:IMARker:X

:CALCulate:CDMA:REVerse:IMARker:Y?

:CALCulate:CDMA:REVerse:IMARker[:STATe]

:CALCulate:CDMA:REVerse:QMARker:CNUMber?

:CALCulate:CDMA:REVerse:QMARker:SFACtor?

:CALCulate:CDMA:REVerse:QMARker:X

:CALCulate:CDMA:REVerse:QMARker:Y?

:CALCulate:CDMA:REVerse:QMARker[:STATe]


Bandwidth

  • Bandwidth for General Purpose > Spectrum measurements
  • Bandwidth for General Purpose > ACPR measurements


Spectrum measurement bandwidth

Bandwidth determines how low a signal amplitude that is close to a larger signal can be and still allow you to resolve the two signals.

You need to balance the effects the bandwidth has on your measurements:

  • Bandwidth Auto: couples the bandwidth value with the frequency span, when selected.
    • If selected, the bandwidth value is automatically set to 0.02% of the frequency span.
    • If not selected, you can set the bandwidth value independently.
  • Bandwidth field allows you to enter a value for the bandwidth.
    • Narrower bandwidths can allow you to measure signals that are close together (or close to the noise floor), yet they can slow down a measurement more than necessary.
    • Wide bandwidths can allow fast measurements, yet they may not provide adequate resolution, and the higher noise may obscure spectral components that are close together.

      Note: You also improve resolution by reducing the frequency span.

Remote control commands

[:SENSe]:SPECtrum:BANDwidth[:RESolution]

[:SENSe]:SPECtrum:BWIDth[:RESolution]

[:SENSe]:ZSPan:BANDwidth[:RESolution]

[:SENSe]:ZSPan:BANDwidth[:RESolution]:TYPE

[:SENSe]:ZSPan:BWIDth[:RESolution]

[:SENSe]:ZSPan:BWIDth[:RESolution]:TYPE


ACPR measurement bandwidth

Sets the bandwidth of the channel that you specified for the Channel parameter.

Remote control commands

[:SENSe]:ACPR:CENTer:BANDwidth

[:SENSe]:ACPR:CENTer:BWIDth

[:SENSe]:ACPR:ADJacent1|ADJacent2:BANDwidth

[:SENSe]:ACPR:ADJacent1|ADJacent2:BWIDth


Averaging

The averaging function minimizes the effects of noise by averaging the results of multiple measurements.

  • For General Purpose
    • Spectrum
    • Zero Span
    • ACPR
    • Channel Power List
  • For GSM and EDGE
    • Averaging Data Type for GSM
    • Averaging Data Type for EDGE
  • For cdma2000
    • Demodulate
    • ACPR
    • Spectrum Emission Mask
    • Occupied Bandwidth
  • For W-CDMA
    • Demodulate
    • ACLR
    • Spectrum Emission Mask
    • Occupied Bandwidth


Sweep

Sets the type of sweep:

  • Continuous sweep repeatedly sweeps the span that you specified.
  • Single sweep takes one sweep of the span you specified.

Remote control commands

:INITiate:CONTinuous

:INITiate[:IMMediate][:ALL]


802.11x Demodulation results

Each sweep returns a collection of measurement results. Several of the measurement results are scalar values, such as RMS EVM and Frequency Error. The other results are trace data such as EVM vs. Channel and I/Q Constellation data.

  • Signal characteristics: Refer to 802.11x Demodulation signal characteristics
  • Data table: Refer to WLAN Data table for details.
  • 802.11n Header data: Refer to 802.11n Header data

802.11x Demodulation signal characteristics

Signal type, constellation type and signal bandwidth are displayed at the top of the measurement results panel on the GUI. These characteristic may also be queried by way of the remote interface. The signal type is the auto detected type if "Auto Detect" is the user-specified signal type. If the instrument is unable to auto detect the signal type then "Unknown signal type" is displayed. If you have explicitly specified the signal type then that type is displayed. Refer to Auto detection for further details.

The constellation type displayed is either the auto detected type or the explicit type that you specify. "Signal not found" is displayed in place of constellation type if you have explicitly specified the signal type but the instrument is unable to demodulate the signal.

The signal bandwidth, that is "10 MHz", "20 MHz", or "40 MHz" is disabled if the signal is successfully demodulated. Nothing is displayed if the signal could not be demodulated.

"No data" is displayed in the upper left corner of the measurement results panel if data from the current sweep could not be demodulated or if no sweep has yet been taken.


802.11x Demodulation data table

A common set of scalar measurement results are made for each signal type. These results are displayed in a data table on the GUI. Each result may be queried by way of the remote interface. Additional measurement results are added to the table for some of the trace types. The common measurement results are described in the following table:

Value in 802.11x data table

EVM rms (dB) | The rms EVM of all data channels in the packet, not including EVM of pilot symbols. RMS over multiple packets if averaged. See Note: EVM calculation
EVM peak (dB) | The peak EVM of all data channels in the packet. Peak over multiple packets if averaging on (not average of peaks, but largest peak.)
Pilot EVM rms (dB) | The rms EVM of all pilot channels in the packet. Rms over multiple packets if averaging is on.
Pilot EVM peak (dB) | The peak EVM of all pilot channels in the packet. Peak over multiple packets if averaging on (not average of peaks, but largest peak.)
Channel Power (dB) | Rms power over inner 80% of the packet. Rms over multiple packets if averaging on
Carrier Frequency Error (Hz) | Error in the transmitted carrier frequency. Average over multiple packets if averaging on
Carrier Feedthru (dB) | Amount of power observed in the DC bin of the OFDM FFT (Fast Fourier Transform). Similar measure for CCK/DSSS. For OFDM, we take the power in the DC bin and divide by the total power of all the bins. If averaging is active, the linear power ratio (not dB) is averaged.
Symbol Clock Error (ppm) | Error in the transmitter DAC clock. Average over multiple packets if averaging on.
Flatness Margin (dB) | The channel flatness limit test is done in DSP. This is the margin of the worst point in the test. A positive number means it passed, a negative means it failed. If averaging on, returns worst case from all packets.
Number Decoded Symbols | Number of symbols decoded. This is the number of symbols in the EVM vs Symbol trace.

802.11x Value limits

Each of the values in the table above, with the exception of Number Decoded Symbols, may be limit tested. Limit test may be turned on/off independently for each value. Each value in the data table has its own limit value. Limit state and value are set through the GUI using the Edit Limits dialog.

When limit testing is on the value in the Pass/Fail column of the data table is the difference between the measurement result and its limit. A result that passes the limit test has a positive margin value which is annotated with a green check mark. A failed limit test is indicated by a negative margin value and a red X. Pass/Fail shows "Off" when the limit state is off.


Note: EVM calculation

NOTE: The 802.11b Standard uses a definition of EVM (error vector magnitude) that includes a factor of 1/sqrt(2) that is not consistent with way that EVM is normally defined. This application calculates EVM based on the more generally accepted definition of EVM. To convert to the method called out in the standard subtract 3.01dB from the measured value. For example, if the measurement result on the instrument is -27dB, the value consistent with the defiinition in the standard is -30dB. The instrument definition of EVM is more conservative than the standard.


Outputting measurement results

You can output the results of a measurement using the following methods:

  • Save a screen capture
  • Query the analyzer for data


To save a screen capture

You can save an image of the current measurement screen that includes any visible settings and data.

Note: It is recommended that you save the files to a drive that is external to the instrument, ensuring adequate memory storage. See To share a drive or folder on the network.

With the front panel interface:

Set the instrument state to the values that you want:

  1. Select Sweep Single to put the instrument in single sweep.
  2. Select Menu > File > Save Screen.
  3. Select the memory location to store the file by selecting the drop-down arrow in the Look In: field and navigating to the drive location.
  4. Select the File name: field or the keyboard button and type a name.
  5. Select Enter > Save.

With the remote programming interface:

:DISPlay:CAPTure

With the LXI Web interface:

  1. Connect the instrument to a Web network that includes your computer.
  2. On the computer, launch a Web browser and use the instrument IP address as the URL.
    • If you do not know the instrument IP address, select Menu > Utilities > Ethernet Settings from the instrument front panel to view the address.
  3. Click Instrument from the menu at the left of the instrument Web page to view the Series 2800 VSA virtual front panel.
  4. Put the instrument in single sweep by clicking Sweep Single on the virtual front panel.
  5. Click Screen Capture from the menu at the left of the instrument Web page.
  6. Right-click over the image of the instrument screen and select Save Picture As....
  7. Navigate to the location to store the file, type a name, and click Save.


:CALCulate:DATA?

Reads the data on the graph display for the currently active measurement. Returns ASCII, Real 32, Real 64. The data type follows the :FORMat command.

Query | Return | Set | Special | Units
yes | NR2, ..., NR2 | n/a | none | none


Remote and local operation differences

In addition to controlling the instrument from the front panel, you can control the instrument remotely through the LXI web interface or by sending SCPI commands. When you send a command to the instrument, it goes from local operation to remote mode operation where the following conditions occur:

  • All front panel control keys except Local are disabled.
  • All menus and dialogs are exited.
  • All pending front panel operations are aborted.
  • An "In Remote" message is displayed in the upper-left of the instrument screen.

Press the Local key to return the instrument to the local mode. When the instrument switches from remote to local operation, the following conditions occur:

  • All front panel control keys are enabled.
  • If Preset is selected, the display is enabled (if it was previously disabled), see DISPlay:ENABle commands for details.
  • The "In Remote" message disappears.


LXI Web interface

The Keithley Instruments Series 2800 VSA has a Web interface that complies with LXI class C requirements and offers a convenient way to communicate with the VSA from a PC browser. For more information on LXI compliance, see http://www.lxistandard.org/home. The LXI Class C compliance includes the following features:

  • Instrument Welcome page
  • IP configuration control
  • Status information: security, errors/warnings
  • Administration password control

The Web interface also offers the following features:

  • Virtual instrument front panel access
  • Print screen capability from Web browser
  • Instrument help
  • Personality license file management

To access the web interface, launch a web browser and use the LAN-connected instrument IP address for the URL; for example, http://192.40.128.183.

  • If you do not know the instrument IP address, you can find it from the instrument front panel interface by selecting Menu > Utilities > Ethernet Settings.
  • If you need details on configuring the Ethernet settings, refer to Ethernet Settings.

The Web interface menu offers the following choices:

Welcome page -- describes the instrument model and manufacturer, serial number, LXI class, hostname, address, firmware revision, and VISA resource string.

IP Configuration -- lists the instrument Ethernet configuration and allows you to modify the Ethernet configuration, which includes enabling or disabling support for ping.

Status -- lists the status for the instrument security, and errors and warnings.

Instrument -- offers a virtual front panel interface to the Series 2800 VSA. This interface is a subset of the functionality that is available with the actual instrument front panel. Here are a few differences between the true instrument front panel interface and the virtual interface:

  • All editable fields are highlighted on the virtual interface so you can make multiple setting modifications and then select Submit to send the modifications to the instrument.
  • Selection of button elements on the virtual interface will cause immediate instrument action for the button functionality and any other editable fields that you modified.
  • Changes made to the settings from the actual instrument front panel will not be indicated on the virtual interface until you select Refresh.

Administration offers a dialog box that allows administration password control. The default user name/password is admin/admin. The user/password authorization is required to modify the Ethernet configuration, use the remote file browser, upgrade the instrument software, or export an instrument option license over the web. Once you enter the correct user/password, the browser caches the login to enable you to use other password-dependent features without additional password inputs. Please refer to LAN Config Init.

CAUTION: The current release of Keithley Instruments Series 2800 VSA software is 2.0 or higher. If you have a Keithley Instruments Model 2810 VSA with a software revision of less than 2.0 you will be unable to upgrade the software build (CAB file) by way of the LXI web interface. Software revisions prior to the 2.0 release have a 20 Mbyte limit for upload files. Software release 2.0 increases this limit to 40 Mbytes (enough for future upgrades to your instrument over the LXI web interface.) You can verify the software version currently installed on your VSA by selecting Menu > Help > About Keithley 28xx. If your instrument has software release prior to 2.0. you must copy the CAB file to a USB memory stick to upload it to your instrument. Once you have completed this, future uploads may be done using the LXI web interface.

Licensing -- shows the current licenses in the instrument and allows you to export or import license files. See To move personality license files or To open a license file for details. For general licensing information, see Licensing. License files cannot be exported from the instrument front panel; you can only export license files from the Web interface through a password controlled page that has the same password used in the Administration page, described above.

Screen Capture -- allows you to capture an image of the current instrument screen. Click Capture each time you want to update the browser (it is highly recommended that you put the instrument in single sweep before you capture the screen).

NOTE: If you are using Microsoft® Internet Explorer browser, and you are experiencing a failure to update screen captures: First, from the instrument front panel, select: Menu > Utilities > Time and Date... and verify that the time and date are correct. Then, change the browser caching policy by following these steps: In the browser window, click Tools > Internet Options. In the General tab, click Settings. In the Check for newer version of stored pages: section, select Every visit to the page. Click OK.

Print -- offers the standard Windows Print dialog so you can print the screen image.

Help -- offers the same Help topics that are available from the actual front panel interface when you select Menu > Help > Help System....

ID button when selected, visually indicates that a particular instrument is connected through the LXI web interface by displaying a blinking green light on the lower-right corner of the front panel of the connected instrument. This can be helpful when more than one instrument is connected to the LAN. This green indicator is always lit when the instrument is connected to an operational LAN. If there is a LAN error, this indicator changes from green to red. A LAN disconnection indicator is also shown at the lower-right portion of the instrument front panel.

LXI Web interface setup

To access the instrument and control the operation over the LXI Web interface, you must install a Java Runtime Environment (JRE) in the computer that is connected to the instrument. The Series 2800 RF Vector Signal Analyzer Product Information CD-ROM that accompanied your Keithley Instruments Series 2800 VSA contains a Java Runtime Environment 5.0 Update 7. This JRE contains the Java virtual machine, runtime class libraries, and Java applications launcher that are necessary to run the program that accesses and controls the instrument through the LXI Web interface.

Install the JRE from the CD-ROM:

  1. Install the CD-ROM into your computer drive.
  2. Download the JRE.

Check online for future updates to the JRE

You can receive free future updates to this JRE by downloading them from the Keithley Instrument website. This JRE is appropriate only if you are operating in a Windows environment.

  1. Using your internet browser, type in the following URL: http://www.keithley.com.
  2. From the left pane select: RF Spectrum Analysis, Signal Generation and Switching.
  3. From the SELECT ONE dialog box in the center pane select: Vector Signal Analyzers (Spectrum Analyzers)
  4. From the VECTOR SIGNAL ANALYZERS list select: any one of the Series 2800 analyzers.
  5. From the DOWNLOADS menu in the left pane select: software.
  6. Scroll to and select: J2SE™ Runtime Environment 5.0 Update 7.
  7. Download the software from the website.

If you are operating in a Unix, Linus, or Solaris environment, you may download the appropriate JRE from the Sun Microsystems Website:

  1. Using your internet browser, type in the following URL: http://java.sun.com/javase/downloads/index.jsp
  2. Scroll to the Java Runtime Environment (JRE) 5.0 Update 7 and select "Download."
  3. From this page you are able to download the appropriate executable file.


Power meter SCPI command pass-through

The Keithley Instruments Model 3500 Portable RF PowerMeter® (power meter) can be programmed through a Keithley Instruments VSA or VSG. SCPI programming commands sent from the PC through the instrument on the GPIB, LAN or USB bus pass-through the instrument to the power meter by way of a USB cable between the instrument and the power meter. This capability is useful when calibrating the test equipment.

The following SCPI command is used to pass-through the commands to the power meter.

:PMETer:COMMand <command><LF>

To read data back from the power meter use the following syntax:

:PMETer:COMMand? <query><LF>

Examples:

:PMET:COMM* TRG<LF>

:PMET:COMM? PWR?<LF>

PWR? is a command that is specific to the power meter and is not covered in the list of SCPI commands.

Refer to the Keithley Instruments Model 3500 Portable RF PowerMeter® User's Guide (3500S-900-01) for details on programming commands.


:PMETer:COMMand

Passes through the specified Model 3500 power meter commands. See Power meter SCPI command pass-through.

HorizontalRuleSm
Parameters |
<string> | Power meter command specifies the Model 3500 power meter command to pass through.
HorizontalRuleSm
 | :PMETer:COMMand
Examples | :PMET:COMM
 | :pmeter:command
HorizontalRuleSm
Query Syntax | :PMETer:COMMand?
Return Type | String
HorizontalRuleSm
Default | n/a


GPIB setup

Select the following topics to configure the Series 2800 VSA so that you can control the operation remotely over GPIB:

  • GPIB connections
  • GPIB configuration
  • GPIB operation verification

GPIB connections

  • Connect a GPIB bus cable equipped with standard IEEE-488 connectors to the Series 2800 VSA back panel IEEE-488 connector.
  • Connect many instruments to one instrument, using parallel connections that stack the connectors.

    Note: To prevent physical damage, do not stack more than three connectors on any one unit.

Two screws are located on each connector to ensure that connections remain secure. Present standards call for metric threads, which are identified with dark-colored screws. Earlier versions have different screws, which are silver-colored. Do not use these silver-colored types of connectors on the Series 2800 VSA; it is designed for metric threads.

To minimize interference caused by electromagnetic radiation, use only shielded IEEE-488 cables. Available shielded cables from Keithley Instruments are Models 7007-1 and 7007-2.

Typical system components diagram

2810 config larger again

1 REF IN can accept an input frequency reference of 1 to 20 MHz.

GPIB configuration

To avoid communication conflicts over the bus, each device in a GPIB system must have a unique primary address. The VSA is shipped from the factory with the primary address set to 10.

If you want to verify the GPIB address or change it, perform the following steps:

  1. Select Menu > Utilities > GPIB Address.
  2. Use the front panel knob to change the GPIB address, if necessary.
  3. Select Close.

GPIB operation verification

If you want to verify communication between a computer and the Series 2800 VSA over the GPIB, install the KI RFI Communicator application (included on the Series 2800 VSA CD-ROM) that allows you to test SCPI communication of your instrument. Perform the following steps:

  1. Make sure you have a GPIB cable connected between the instrument back panel IEEE-488 connector and the computer GPIB board connector.
  2. Insert the VSA CD-ROM in the computer drive.
  3. After the CD-ROM launches, click Applications Info > KI RFI Communicator to download the application installation program.
  4. Click the downloaded setup.exe file to install the application on your computer.
  5. On your computer desktop, click the KI RFI Communicator icon to start the application.
  6. In the KI RFI Communicator home screen, click Setup Interface.
  7. In the Configure VISA Interface dialog, select the GPIB tab.
  8. Set the values for the following GPIB settings:
    • GPIB board # (leave this set to zero, unless you have more than one GPIB interface board in your computer)
    • GPIB primary address
  9. Click OK.
  10. Click Send Command to send the command *IDN? that is shown in the Command: box.
  11. You should see the instrument identification information in the Response: field.
  12. Continue sending any other SCPI commands of interest. Refer to the Series 2800 VSA command locater or Series 2800 VSA SCPI command tree for a complete list of compatible SCPI commands.


USB setup

Select the following topics to configure the Series 2800 VSA so that you can control the operation remotely over USB:

  • USB connections
  • USB configuration
  • USB operation verification

USB connections

  • Connect a computer controller to the Series 2800 VSA back panel USB (FROM HOST) connector.
  • Connect all other USB devices to the Series 2800 VSA back panel USB (TO DEVICE) connector or to the two USB connectors on the front panel.

Typical system components diagram

2810 config larger again

1 REF IN can accept an input frequency reference of 1 to 20 MHz.


USB configuration

It is necessary to load a USB driver onto the computer that will be running the remote control program. For convenience, the USB driver can be installed from the Series 2800 VSA CD-ROM. Updates for the USB driver can be downloaded from the Keithley Instruments website at www.keithley.com.

Installing USB driver from the CD-ROM

Perform the following steps to install the USB driver to your computer:

  1. Insert the Series 2800 VSA CD-ROM into the disk drive of the computer.
  2. With the Series 2800 VSA powered on, connect a USB cable between the PC and the USB (FROM HOST) connector on the Series 2800 VSA rear panel.
  3. Follow the operating system instructions to load the USB driver.

Installing USB driver from the Keithley Instruments Website

Perform the following steps to look for updates of the USB driver to install on your computer.

  1. With the computer connected to the internet, insert the Series 2800 VSA CD-ROM into the computer disk drive.
  2. After the CD-ROM launches, click Online Updates to get to the Keithley Instruments Website: www.keithley.com.
  3. From the left pane select: RF Spectrum Analysis, Signal Generation and Switching.
  4. From the SELECT ONE dialog box in the center pane select: Vector Signal Analyzers (Spectrum Analyzers).
  5. From the VECTOR SIGNAL ANALYZERS list select: any one of the Series 2800 analyzers.
  6. From the DOWNLOADS menu in the left pane select: software driver.
  7. Scroll to and select: the USB driver for the Series 2800 VSA.
  8. Download the Series 2800 VSA USB driver from the website.

USB operation verification

If you want to verify communication between a computer and the Series 2800 instrument over the USB, install the Keithley Instruments KI RFI Communicator application that allows you to test SCPI communication of your instrument. Perform the following steps:

  1. Set-up the equipment as shown in the procedure, USB connections and USB configuration.
  2. Insert the Model Series 2800 CD-ROM in the computer drive and click Application Info then click KI RFI Communicator to install the application program.
  3. Select Run and follow the instructions to install the program on your computer.
  4. Select the KI RFI Communicator icon that has been placed on the desktop.
  5. In the KI RFI Communicator home screen, click Setup Interface.
  6. In the Configure VISA Interface dialog, select the USB tab and click Find USB Devices. This will display a list of all instruments connected by USB.
  7. Select the list item that corresponds with the serial number of the instrument that you want to communicate with, and then click OK.
  8. Click Send Command to send the *IDN? command that is in the Command: box.
  9. You should see the instrument identification information in the Response: field.
  10. Continue sending any other SCPI commands of interest. Refer to the Series 2800 VSA command locater or Series 2800 VSA SCPI command tree for a complete list of compatible SCPI commands.


LAN (Ethernet) setup

Select the following topics to configure the Series 2800 VSA so that you can control the operation remotely over LAN (Ethernet).

  • LAN (Ethernet) connections
  • LAN (Ethernet) configuration
  • LAN (Ethernet) operation verification with KI RFI Communicator
  • VISA resource string
  • LAN (Ethernet) troubleshooting

LAN (Ethernet) connections

  • Connect the Series 2800 VSA back panel LAN connector to an existing site network through a router, switch, or hub. Use a standard patch cable for this connection.

or

  • Connect the Series 2800 VSA back panel LAN connector directly to a computer. You must use a crossover cable for this connection to ensure that the computer transmit connections are input to the Series 2800 VSA receive connections, and vice versa (Model CA-180-3A crossover can be ordered from Keithley Instruments).

    Note: The Ethernet crossover cable can be up to 100 meters in length.

Typical system components diagram

1 REF IN can accept an input frequency reference of 1 to 20MHz.

LAN (Ethernet) configuration

It is necessary to assign an IP address to the Series 2800 VSA. The IP address is a persistent state; it is not affected by an instrument preset or a power cycle. The following procedures assume that you have connected the equipment as instructed in "Connecting system components" earlier in this section.

The appropriate procedure depends on the Series 2800 VSA connection configuration:

  • Existing site network connection

or

  • Direct connection to a computer

    Note: This procedure assumes that the instrument is connected to the LAN using a CAT 5e or better patch cable.


Existing site network configuration

Contact your I.T. administrator to receive direction on the preferred method of assigning IP addresses:

  • Static IP address assignment
  • DHCP address assignment

Static IP address assignment

Perform the following steps to assign a static IP address for an instrument in an existing site network:

  1. From the Series 2800 VSA, select Menu > Utilities > Ethernet Settings.
  2. Select the IP Address tab.
  3. Enter an IP address:
    1. Select Specify an IP address.
    2. Select the IP Address field or the keyboard button next to it.
    3. Repeatedly select the ?backspace) button to clear the current IP address.
    4. Select the desired IP address and then select Enter.
  4. Enter a subnet mask:
    1. Select the Subnet Mask field or the keyboard button next to it.
    2. Repeatedly select the ?backspace) button to clear the current subnet mask.
    3. Select the desired subnet mask and then select Enter.
  5. Set the default gateway and DNS per your I.T. administrator's recommendations.
  6. Set the following values per your I.T. administrator's recommendations (you can leave the values blank if there are no recommendations):
    1. Default gateway
    2. Primary DNS
    3. Primary WINS
  7. Select the Apply button.
  8. Select Close to close the dialog.

    Note: Make sure that the combination of Series 2800 VSA IP address and subnet mask is within the range of directly addressable IP addresses of the computer.

For example:

Computer IP address: 192.168.1.50

Computer subnet mask: 255.255.255.0

Series 2800 VSA IP address: 192.168.1.51

Series 2800 VSA subnet mask: 255.255.255.0

DHCP address assignment

If a DHCP server is on the LAN, you can choose to have a DHCP automatically assign an IP address:

  1. From the Series 2800 VSA, select Menu > Utilities > Ethernet Settings.
  2. Select the IP Address tab.
  3. Select Obtain an IP address via DHCP.
  4. Select the Apply button.
  5. This configures the signal analyzer as a DHCP client. In DHCP mode, the signal analyzer requests a new IP address from the DHCP server. The assigned address appears in the IP Address field.
  6. Select Close to close the dialog.


Direct connection to a computer

Assigning a static IP address is the preferred method of assigning an IP address for a configuration that has the Series 2800 VSA directly connected to the computer. Optionally, you can use the DHCP method, which results in a Link Local Address (LLA) being assigned to the VSA.

  • Static IP address assignment
  • DHCP address assignment

Static IP address assignment

Perform the following steps to assign a static IP address for an instrument that has a direct connection to a computer.

  1. From the Series 2800 VSA, select Menu > Utilities > Ethernet Settings.
  2. Select the IP Address tab.
  3. Enter an IP address:
  4. Select Specify an IP address.
    1. Select the IP Address field or the keyboard button next to it.
    2. Repeatedly select the (backspace) button to clear the current IP address.
    3. Select the desired IP address and then select Enter.
  5. Enter a subnet mask:
    1. Select the Subnet Mask field or the keyboard button next to it.
    2. Repeatedly select the (backspace) button to clear the current subnet mask.
    3. Select the desired subnet mask and then select Enter.
  6. Set the following values per your I.T. administrator's recommendations (you can leave the values blank if there are no recommendations):
    • Default gateway under the IP Address tab
    • Primary DNS under the Name Servers tab
    • Primary WINS under the Name Servers tab
  7. Select the Apply button.
  8. Select Close to close the dialog.

    Note: Make sure that the combination of Series 2800 VSA IP address and subnet mask is within the range of directly addressable IP addresses of the computer.

For example:

Computer IP address: 192.168.1.50

Computer subnet mask: 255.255.255.0

Series 2800 VSA IP address: 192.168.1.51

Series 2800 VSA subnet mask: 255.255.255.0

DHCP address assignment

Optionally, you can use the DHCP method to assign an IP address. Since there is no DHCP server in a configuration that directly connects the Series 2800 VSA to a computer, the instrument times out and then automatically assigns itself a Link Local Address (LLA). This process takes 60 to 90 seconds.

  1. From the Series 2800 VSA, select Menu > Utilities > Ethernet Settings.
  2. Select the IP Address tab.
  3. Select Obtain an IP address via DHCP.
  4. Select the Apply button. This attempts to configure the signal analyzer as a DHCP client.
  5. Select Close to close the dialog.
  6. When the LAN error indicator disappears (60-90 seconds), select Menu > Utilities > Ethernet Settings. The LLA that was automatically assigned appears in the IP Address field.
  7. Select Close to close the dialog.


LAN (Ethernet) operation verification with KI RFI Communicator

If you want to verify communication between a computer and the Series 2800 VSA instrument over the LAN, install the KI RFI Communicator application that allows you to test SCPI communication of your instrument. Perform the following steps:

  1. Set-up the equipment as shown in the procedure, LAN (Ethernet) connections.
  2. Assign an IP address for the Series 2800 by following a procedure for one of the configurations described in LAN (Ethernet) configuration.
  3. Insert the Series 2800 VSA CD-ROM in the computer drive.
  4. When the CD-ROM launches, click Applications Info > KI RFI Communicator to download the application installation program.
  5. Click the downloaded setup.exe file to install the application on your computer.
  6. On your computer desktop, click the KI RFI Communicator icon to start the application.
  7. In the KI RFI Communicator home screen, click Setup Interface.
  8. In the Configure VISA Interface dialog, select the LAN/TCPIP tab.
  9. Set the values for the following settings, or the values displayed in the Ethernet dialog if DHCP is used:
    • NIC # (leave this set to zero, unless you have more than one NIC card installed in your computer).
    • TCPIP port # = 5025
    • TCPIP address = IP address that you assigned to the Series 2800.
  10. Click OK.
  11. Click Send Command to send the *IDN? command that is in the Command: box.
  12. You should see the instrument identification information in the Response: field.
  13. Continue sending any other SCPI commands of interest. Refer to the Series 2800 VSA command locater or Series 2800 VSA SCPI command tree for a complete list of compatible SCPI commands.


VISA resource string

Software revision 2.0 and later supports two interfaces of remote control over LAN, VXI-11 and raw socket. VXI-11 provides additional features such as auto discovery of instruments on the LAN, but raw socket is faster. You can verify that your connection to the instrument works with any utilities that implement the VISA I/O Standard for VXI-11 and raw socket.

To verify operation use one of the two following VISA resource strings:

  • Raw socket - TCPIP::X.X.X.X::5025::SOCKET
  • VXI-11 - TCPIP::X.X.X.X::INSTR

Where X.X.X.X represents the IP address of your instrument.

Refer to Ethernet Settings for further details.


Programming messages

Programming messages are made up of one or more command words sent by the computer to the instrument. These SCPI commands show how command words are structured to formulate program messages.

:SYSTem (path)

:SYSTem:DATE <NRf> (command and parameter)

:SYSTem:DATE? ( query command)

:SYSTem:PRESet (command)

Select from the following categories of programming message information:

  • Types of commands
  • Types of messages
  • Programming syntax

    Tips for fastest operation:
    Use all upper case.
    Use the short form.
    Do not send optional data.
    Do not use a colon at the beginning of a programming message.
    Disable the display circuitry.


Types of commands

  • SCPI commands
  • Common commands
  • Query commands

SCPI commands

SCPI commands are used to control most instrument operations. For details on these commands, see Series 2800 VSA SCPI command tree.

Common commands

Common commands are device commands that are common to all devices on the bus. These commands are designated and defined by the IEEE-488.2 standard.

For details on these commands, see Common commands.

Query commands

This type of command requests (queries) the current instrument state. It is identified by the question mark (?) at the end of the fundamental form of the command.

Most commands have a query form.

Example:

:IDN? Queries the identification code of the instrument that includes the manufacturer, model number, serial number, and firmware revision.

Most commands that require a numeric parameter (no) can also use the DEFault, MINimum, and MAXimum parameters for the query form. These query forms are used to determine the *RST default value and the upper and lower limits for the fundamental command.


Types of messages

  • Single command messages
  • Multiple command messages
  • SCPI/Common command messages
  • Response messages

Single command messages

The single-command examples below have a structure with three levels:

  • The first level is made up of the root command (STATus) and serves as a path.
  • The second level is made up of another path (:OPERation).
  • The third level is a command (:ENABle).

Example:

STAT:OPER:ENAB <NRf>

STAT:OPER:ENAB?

The commands in this example can be executed by sending two separate program messages.

In each of the above program messages, the path pointer starts at the root command (stat) and moves down the command levels until the command is executed.

The next command example is made up of one command for the :STATus path.

Example:

:STAT:PRES

Multiple command messages

You can send multiple command messages in the same program message as long as you separate them by semicolons (;). The following example shows two commands in one program message.

Example:

STAT:OPER?; :STAT:OPER:ENAB <NRf>

When the above message is sent, the first command word is recognized as the root command (STAT). When the next colon is detected, the path pointer moves down to the text command level and executes the command. When the path pointer sees the colon after the semicolon (;), it resets back to the root level and starts over.

Commands that are on the same command level can be executed without having to retype the entire command path.

Example:

STAT:OPER:ENAB <NRf>; ENAB?

After the first command (:ENAB) is executed, the path pointer is at the third command level in the structure. Since :ENAB? is also on the third level, it can be typed in without repeating the entire path name. Notice that the leading colon for :ENAB? is not included in the program message. If a colon were included, the path pointer would reset to the root level and expect a root command. Since :ENAB? is not a root command, an error would occur.

SCPI and common commands in the same message

Both SCPI and common commands can be used in the same message, as long as you separate them by semicolons (;). A common command can be executed at any command level and will not affect the path pointer.

Example:

STAT:OPER:ENAB <NRf>; *ESE <NRf>

Response messages

A response message is the message sent by the instrument to the computer in response to a query command. The following sequence takes place:

  1. A query message is sent to the instrument.
  2. The instrument responds to the query by placing a response message in the output queue.
  3. The instrument is addressed to talk.
  4. The response message is sent from the output queue to the computer.

    Note: The complete response message must be received by the computer before another program message can be sent to the instrument. Also, remember to read the trailing line feed.

Multiple response messages

If you send more than one query command in the same program message, the following happens:

  • The multiple response messages for all the queries are sent to the computer when the instrument is addressed to talk.
  • The responses are sent in the order the query commands were sent and are separated by semicolons (;).
  • Items within the same query are separated by commas (,).

The following example shows the response message for a program message that contains four single item query commands.

Example:

0; 1; 1; 0

Response message terminator (RMT)

Each response is terminated with an LF (line feed) and EOI (end or identify). The following example shows how a multiple response message is terminated.

Example:

0; 1; 1; 0 <RMT>


Programming syntax

The following information explains syntax for both common commands and SCPI commands. For additional information on commands, see Series 2800 VSA SCPI Command tree. Select from the following categories to learn about message syntax:

  • Case sensitivity
  • Long-form and short-form versions
  • Short-form rules
  • Command path rules
  • Program message terminator
  • Command execution rules

Case sensitivity

Common commands and SCPI commands are not case sensitive. You can use upper or lower case and any case combination.

Example:

*RST = *rst

:OUTPut? = :output?

:SYSTem:PRESet = :system:preset

Note: Using all upper case will result in slightly faster command response times.

Long-form and short-form versions

A SCPI command word can be sent in its long-form or short-form version. The commands are listed in the long-form version in SCPI Commands. However, the short-form version is indicated by upper case characters. Examples:

:SYSTem:PRESet (long-form)

:SYST:PRES (short-form)

:SYSTem:PRES (long-form and short-form combination)

Note: Each command word must be in long-form or short-form, and not something in between. For example, :SYSTe:PRESe is illegal and will generate an error. The command will not be executed.

Short-form rules

Use the following rules to determine the short-form version of any SCPI command:

  • If the length of the command word is four letters or less, no short-form version exists.

    Example:

    :data? = :data?

  • If the fourth letter of the command word is a vowel (including "y"), delete it and all the letters after it.

    Example:

    immediate = imm

  • If the fourth letter of the command word is a consonant, retain it but drop all the letters after it.

    Example:

    format = form

  • If the command contains a question mark (?; query) or a non-optional number included in the command word, you must include it in the short-form version.

    Example:

    :output? = :outp?

  • Command words or characters that are enclosed in brackets ([ ]) are optional in the program message.

    Note: For fastest response to commands, always use short forms.

Command path rules

Each new program message must begin with the root command, unless it is optional (for example, [SOURce]). If the root is optional, treat a command word on the next level as the root.

Note: For fastest operation, do not send optional data.

A colon (:) can be used at the beginning of a program message. However, using the colon slows down execution time.

Example:

STAT:PRES = :STAT:PRES

When the path pointer detects a colon (:) it moves down to the next command level. An exception is when the path pointer detects a semicolon (;), which is used to separate commands within the program message.

When the path pointer detects a colon (:) that immediately follows a semicolon (;), it resets back to the root level.

The path pointer can only move down. It cannot be moved up a level. Executing a command at a higher level requires that you start over at the root command.

Program message terminator (PMT)

Each program message must be terminated with an LF (line feed), EOI (end or identify), or an LF+EOI. The following command shows how a program message must be terminated.

Example:

inp:prot:stat on <PMT>

Command execution rules

  • Commands execute in the order that they are presented in the program message.
  • An invalid command generates an error and is not executed.
  • Valid commands that precede an invalid command in a multiple-command program message are executed.
  • Valid commands that follow an invalid command in a multiple-command program message are ignored.


Status structure

The center of the status structure is the status byte register. This register can be read by a test program to determine if a service request (SRQ) has occurred and what event caused it. To learn more about the status structure, select from the following topics:

  • Status byte and service request (SRQ)
  • Status register sets
  • Queues

The instrument allows the operator to monitor and manipulate the various instrument events through the status register structure:

  • Status byte register
  • Four status register sets
    • Standard event register
    • Operation event register
    • Measurement event register
    • Questionable event register
  • Two queues
    • Output queue
    • Error queue

Each of the four status register sets contain the following:

  • Condition register (read-only)
  • Event register (read-only)
  • Event enable register (programmable)

A condition register is a read-only register that constantly updates to reflect the present operating conditions of the instrument.

An event register bit sets to 1 when an event occurs. The bit remains latched to 1 until the register is reset.

When an event register bit is set and its corresponding enable bit is set (as programmed by the user), the output (summary) of the register will set to 1. This sets the summary bit of the status byte register.

Click the image to see more information.


Status structure diagram

Click the image to see more information.


Status register sets

As shown in the status structure diagram, there are four status register sets in the status structure of the instrument:

  • Standard event register
  • Operation event register
  • Measurement event register
  • Questionable event register


Standard event register

The used bits of the standard event register (see following diagram) are described as follows:

  • Bit B0, Operation Complete (OPC) -- set bit indicates that all pending selected device operations are completed and the instrument is ready to accept new commands. This bit only sets in response to the *OPC? query command. See Common commands for details on *OPC and *OPC?.
  • Bit B1 -- not used.
  • Bit B2, Query Error (QYE) -- set bit indicates that you attempted to read data from an empty output queue.
Standard event status register diagram

  • Bit B3, Device-Specific Error (DSE) -- set bit indicates that an instrument operation did not execute properly due to some internal condition.
  • Bit B4, Execution Error (EXE) -- set bit indicates that the instrument detected an error while trying to execute a command. Places error message -200 in the error queue.
  • Bit B5, Command Error (CME) -- set bit indicates that a command error has occurred. Places error message -100 in the error queue. Command errors include:
    • IEEE-488.2 syntax error -- instrument received a message that does not follow the defined syntax of the IEEE-488.2 standard.
    • Semantic error -- instrument received a command that was misspelled or received an optional IEEE-488.2 command that is not implemented.
    • The instrument received a group execute trigger (GET) inside a program message.
  • Bit B6, User Request (URQ) -- set bit indicates that the LOCAL key on the instument front panel was pressed.
  • Bit B7, Power On (PON) -- set bit indicates that the instrument has been turned off and turned back on since the last time this register has been read.
  • 1 -- standard event status register.
  • 2 -- standard event status enable register.


Operation event register

The bits of the operation event register (see following diagram) are described as follows:

  • Bits B0, Calibrating (Cal) -- set bit indicates that the instrument is calibrating.
  • Bits B1 through B4 -- not used.
  • Bit B5, Waiting for Trigger (Trig) -- set bit indicates that the instrument is in the trigger layer waiting for a trigger event to occur.
  • Bits B6 through B9 -- not used.
  • Bit B10, Idle State (Idle) -- set bit indicates the instrument is in the idle state.
  • Bits B11 through B15 -- not used.
Operation event status register diagram

1 = Operation condition register
2 = Operation event register
3 = Operation event enable register


Measurement event register

The used bits of the Measurement Event Register (following graphic) are described as follows:

  • Bit B0, External Reference Detected (ERD) -- Set bit indicates that an external reference is connected and has been detected. See next bit to determine if the external reference is locked in.
  • Bit B1, External Reference Lock (ERL) -- Set bit indicates that the external reference has been locked.
  • Bits B2 through B9 -- Not used.
  • Bit B10, Overload (OL) -- Set bit indicates an input overload.
  • Bits B11 through B15 -- Not used.
Measurement event status register diagram

1 = Measurement condition register
2= Measurement event register
3 = Measurement event enable register


Questionable event register

The used bits of the questionable event register (see following diagram) are described as follows:

  • Bits B0 through B7 -- not used.
  • Bit B8, Calibration Summary (Cal) -- set bit indicates that an invalid calibration constant was detected during the power-up sequence. The instrument will instead use a default calibration constant. This error will clear after successful calibration of the instrument.
  • Bits B9 through B13 -- not used.
  • Bit B14, Command Warning (Warn) -- set bit indicates that a signal-oriented measurement command parameter has been ignored. Places status message +414 in the status queue.
  • Bit B15 -- not used.

    Note: Whenever a questionable event occurs, the ERR annunciator turns on. The annunciator turns off when the questionable event clears.

Questionable event status register diagram

1 = Questionable condition register
2 = Questionable event register
3 = Questionable event enable register


Condition registers

As the status structure diagram shows, each status register set (except the standard event register set) has a condition register. A condition register is a real-time, read-only register that constantly updates to reflect the present operating conditions of the instrument. For example, while the instrument is in the idle state, bit B10 (Idle) of the operation condition register will be set. When the instrument is taken out of idle, bit B10 clears.

The commands to read the condition registers are listed in the following table. For details on reading registers, see Reading registers.

Condition register commands

Command | Description
:STATus:OPERation:CONDition? | Reads operation condition register.
:STATus:MEASurement:CONDition? | Reads measurement condition register.
:STATus:QUEStionable:CONDition? | Reads questionable condition register.

Note: The format of the response messages for the above queries is set by the :FORMat:SREGister commands.


Event registers

Each status register set has an event register. When an event occurs, the appropriate event register bit sets to 1. The bit remains latched to 1 until the register is reset. Reading an event register clears the bits of that register.

*CLS resets all four event registers.

The commands to read the event registers are listed in the following table. For details on reading registers, see Reading registers.

Event register commands

Command | Description
*ESR? | Reads standard event status register.
:STATus:OPERation[:EVENt]? | Reads operation event register.
:STATus:MEASurement[:EVENt]? | Reads measurement event register.
:STATus:QUEStionable [:EVENt]? |

Note: The format of the response messages for the above queries is set by the :FORMat:SREGister commands. Power-up and *CLS reset all bits of all event registers to 0. The :STATus:PRESet command has no effect.


Event enable registers

As the status structure diagram shows, each status register set has an enable register. Each event register bit is logically ANDed (&) to a corresponding enable bit of an enable register. Therefore, this sequence takes place:

  1. An event bit is set.
  2. The corresponding enable bit is set (as programmed by the user).
  3. The output (summary) of the register is set to 1.
  4. The Status Byte Register summary bit is set.

The commands to program and read the event enable registers are listed in the following table. For details on programming and reading registers, see Programming enable registers and Reading registers.

Note: The bits of any enable register can be reset to 0 by sending the 0 parameter value using STATus:OPERation:ENABle 0.

Event enable register commands

Command |  |  | Description
*ESE <NDN> or <NRf> |  |  | Programs standard event enable register.
*ESE? |  |  | Reads standard event enable register.
STATus:OPERation:ENABle <NDN> or <NRf> |  |  | Programs operation event enable register.
STATus:OPERation:ENABle? |  |  | Reads enable register.
STATus:MEASurement:ENABle<NDN> or <NRf> |  |  | Programs measurement event enable register.
STATus:MEASurement:ENABle? |  |  | Reads enable register.
STATus:QUEStionable:ENABle <NDN> or <NRf> |  |  | Programs questionable event enable register.
STATus:QUEStionable:ENABle? |  |  | Reads enable register.
Parameters: |  |
<NDN> | = #Bxx...x | Binary format (each x = 1 or 0)
 | = #Hx | Hexadecimal format (x = 0 to 7FFF)
 | = #Qx | Octal format (x = 0 to 77777)
<NRf> | = 0 to 32767 | Decimal format

Note: The format of the response messages for the above queries is set by the :FORMat:SREGister commands. Power-up and :STATus:PRESet reset all bits of all event registers to 0. *CLS has no effect.

Programming example

Program and read a register set

The following command sequence programs and reads the measurement register set:

:FORM:SREG BIN | ' Select binary format to read registers.
:STAT:MEAS:ENAB 512 | ' Enable BFL (buffer full).
:STAT:MEAS:COND? | ' Read measurement condition register.
:STAT:MEAS? | ' Read measurement event register.

Programming example

Read RAV bit of measurement event register

The following command sequence demonstrates the proper method to read the RAV bit of the measurement event register. In general, the state of an event register bit is determined by enabling the event bit, then reading the status byte (*STB?).

*RST | ' Put instrument in one-shot mode.
*CLS | ' Clear measurement event register.
:STAT:PRES | ' Clear measurement event enable register.
:STAT:MEAS:ENAB 32 | ' Enable RAV bit (B5) of the measurement event register.
:INIT | ' Trigger one measurement.
*STB? | ' Read status byte register.

*CLS and :STAT:PRES reset the measurement register bits to zero. The :ENAB command enables the reading available bit B5 (RAV) of the measurement event register. When a reading is triggered and becomes available, bit B0 (MSB) of the status byte will set. INIT triggers a reading and *STB? reads the status byte.

Since you are only interested in bit B0 of the status byte, it is recommended that your program routing mask out the other bits, which may also be set. For example, *STB? may return decimal "17." The binary bit pattern for decimal 17 is as follows:

B7 | B6 | B5 | B4 | B3 | B2 | B1 | B0 |
0 | 0 | 0 | 1 | 0 | 0 | 0 | 1 | *STB? returns decimal "17" (B4 and B0 set)

If, in your program, you logically AND the above returned binary value with 00000001, you will mask out bits B1 through B7:

B7 | B6 | B5 | B4 | B3 | B2 | B1 | B0 |
0 | 0 | 0 | 1 | 0 | 0 | 0 | 1 | *STB? returns decimal "17" (B4 and B0 set)
0 | 0 | 0 | 0 | 0 | 0 | 0 | 1 | Mask to read B0 (decimal 1)
-------------------------------------------------- |  |  |  |  |  |  |  |
0 | 0 | 0 | 0 | 0 | 0 | 0 | 1 | Result of logic AND operation (decimal 1)

As shown in the above result for the AND operation, when B0 is set, your program routine will generate a "1" to indicate that RAV is set. If B0 is not set (0), the AND operation will result in "0" to indicate that RAV is not set.


Status byte and service request (SRQ)

Service request is controlled by two 8-bit registers:

  • Status Byte Register
  • Service Request Enable Register

The graphic below shows the structure of these registers.

The following sequence happens with this part of the status structure:

  1. Register sets and queues monitor the various instrument events.
  2. An enabled event occurs.
  3. A summary bit is set in the Status Byte Register.
  4. The corresponding enable bit is set in the Status Byte (as programmed by the user).
  5. The RQS/MSS bit is set to indicate that an SRQ has occurred.
    • The following graphic shows the status byte and service request portion of the overall status structure.
    • Click on the graphic to see the overall status structure graphic.
Status byte and service request diagram

1 = Service request generation
2 = Status summary message
3 = Read by serial poll
4 = Status byte register
5 = Read by *STB?
6 = Service request enable register

Status byte register

The summary messages from the status registers and queues are used to set or clear the appropriate bits (B0, B2, B3, B4, B5, and B7) of the Status Byte Register. These summary bits do not latch and their states (0 or 1) are solely dependent on the summary messages (0 or 1).

Example:

The Standard Event Register is read; its register then clears. As a result, its summary message resets to 0, which then resets the ESB bit in the Status Byte Register.

The bits of the Status Byte Register are described as follows:

  • Bit B0, Measurement Summary Bit (MSB) -- set summary bit indicates that an enabled measurement event has occurred.
  • Bit B1 -- not used.
  • Bit B2, Error Available (EAV) -- set summary bit indicates that an error or status message is present in the Error Queue.
  • Bit B3, Questionable Summary Bit (QSB) -- set summary bit indicates that an enabled questionable event has occurred.
  • Bit B4, Message Available (MAV) -- set summary bit indicates that a response message is present in the Output Queue.
  • Bit B5, Event Summary Bit (ESB) -- set summary bit indicates that an enabled standard event has occurred.
  • Bit B6, Request Service (RQS)/Master Summary Status (MSS) -- set bit indicates that an enabled summary bit of the Status Byte Register is set.
  • Bit B7, Operation Summary Bit (OSB) -- set summary bit indicates that an enabled operation event has occurred.

Depending on how it is used, bit B6 of the status byte register is either the Request for Service (RQS) bit or the Master Summary Status (MSS) bit:

  • When using the serial poll sequence of the instrument to obtain the status byte (serial poll byte), B6 is the RQS bit. See Serial polling and SRQ for details on using the serial poll sequence.
  • When using the *STB? command to read the status byte, B6 is the MSS bit.

Service request enable register

The generation of a service request is controlled by the service request enable register. You program this register to enable or disable the setting of bit B6 (RQS/MSS) by the status summary message bits (B0, B2, B3, B4, B5, and B7) of the status byte register.

As shown in the status byte and service request diagram, the summary bits are logically ANDed (&) with the corresponding enable bits of the service request enable register. When a set (1) summary bit is ANDed with an enabled (1) bit of the enable register, the logic "1" output is applied to the input of the OR gate and, therefore, sets the MSS bit in the status byte register.

  • To set or clear the individual bits of the service request enable register, use the *SRE common command.
  • To read the service request enable register, use the *SRE? query command.
  • To clear the service request enable register, cycle the power or send a parameter value of 0 with the *SRE command (*SRE 0).

The commands to program and read the SRQ enable register are listed in Status byte and service request commands.


Serial polling and SRQ

Any enabled event summary bit that goes from 0 to 1 will set bit B6 and generate an SRQ (service request). In your test program, you can periodically monitor (poll) the status byte to check if an SRQ has occurred and what caused it.

For example:

If an SRQ occurs, the program can branch to an appropriate subroutine that will service the request.

Typically, SRQs are managed by the serial poll sequence of the instrument.

  • If an SRQ does not occur, bit B6 (RQS) of the status byte register will remain cleared and the program will proceed normally after the serial poll is performed.
  • If an SRQ does occur, bit B6 of the status byte register is set and the program can branch to a service subroutine when an SRQ is detected by the serial poll.

The serial poll automatically resets RQS of the status byte register. This allows subsequent serial polls to monitor bit B6 for an SRQ occurrence generated by other event types. After a serial poll, the same event can cause another SRQ, even if the event register that caused the first SRQ has not been cleared.

The serial poll does not clear MSS. The MSS bit stays set until all status byte summary bits are reset.

SPE, SPD (serial polling)

The SPE, SPD General Bus Command sequence is used to serial poll the instrument. Serial polling obtains the serial poll byte (status byte). Typically, serial polling is used by the controller to determine which of several instruments has requested service with the SRQ line.


Status byte and service request commands

The commands to program and read the status byte register and service request enable register are listed in the following table. For details on programming and reading registers, see Programming enable registers and Reading registers.

Note: To reset the bits of the service request enable register to 0, use 0 as the parameter value for the *SRE command (*SRE 0).

Status Byte and Service Request Enable Register commands

Command | Description
*STB? | Read status byte register.
*SRE <NDN> <NRf> | Program the service request enable register:
 | <NDN> | = #Bxx...x | Binary format (each x = 1 or 0)
 |  | = #Hx | Hexadecimal format (x = 0 to 377)
 |  | = #Qx | Octal format (x = 0 to 377)
 | <NRf> | = 0 to 255 | Decimal format
*SRE? | Read the service request enable register

Note: *CLS and :STATus:PRESet have no effect on the service request enable register.

Programming Example

Set MSS (B6) when error occurs

The second command in the following sequence enables EAV (error available). When an invalid command is sent (line 4), bits B2 (EAV) and B6 (MSS) of the status byte register set to 1. The last command reads the status byte register using the binary format (which directly indicates which bits are set). The command to select format (:FORMat:SREGister) is documented in the table in Reading registers.

To determine the exact nature of the error, you will have to read the error queue (see Error queue).

*CLS | ' Clear error queue.
*SRE 4 | ' Enable EAV.
:FORM:SREG BIN | ' Select binary format.
*XYZ | ' Generate error.
*STB? | ' Read status byte register.


Queues

The instrument uses two queues, which are first-in first-out (FIFO) registers:

  • Output queue -- holds query response messages.
  • Error queue -- holds error and status messages.

The status structure diagram shows how the two queues are structured with the other registers.

When a queue contains data, it sets the appropriate summary bit of the status byte register.

Note: While operating within the trigger model (not in idle), you cannot send a status model command (for example, *ESE?). These commands can only be executed when the instrument is in idle.

Output queue

The output queue holds data that pertains to the normal operation of the instrument.

Example sequence:

  1. A query command is sent.
  2. The response message is placed in the output queue.
  3. The message available (MAV) bit in the status byte register sets.
  4. A data message is cleared from the output queue when it is read.
  5. The output queue is considered cleared when it is empty.
  6. An empty output queue clears the MAV bit in the status byte register.
  7. A message is read from the output queue over that particular bus (GPIB, USB or LAN) after the appropriate query is sent.

Error queue

The error queue holds error and status messages.

Example sequence:

  1. An error or status event occurs.
  2. A message that defines the error/status is placed in the error queue.
  3. The error available (EAV) bit in the status byte register is set.
  4. An error/status message is cleared from the error queue when it is read.
  5. The error queue is considered cleared when it is empty.
  6. An empty error queue clears the EAV bit in the status byte register.

The error queue holds up to 10 error/status messages. The commands to read the error queue are listed in the following table. When you read a message in the error queue, the "oldest" message is read and then removed from the queue.

  • The message "350, 'Queue Overflow'" will occupy the last memory location, if the queue becomes full.
  • The message "0, No Error" is placed in the queue, when it is empty. On power-up, the error queue is empty.

Messages in the error queue are preceded by a code number. Negative (-) numbers are used for SCPI-defined messages and positive (+) numbers are used for Keithley Instruments-defined messages.

  • On power-up, all error messages are enabled and will go into the error queue as they occur.
  • Status messages are not enabled and will not go into the queue.

As listed in the following table, there are commands to enable and/or disable messages. For these commands, the <list> parameter is used to specify which messages to enable or disable. The messages are specified by their codes. The following examples show various forms for using the <list> parameter.

<list> | = (-110) | Single message
 | = (-110:-222) | Range of messages (-110 through -222)
 | = (-110:-220, -220) | Range entry and single entry (separated by a comma)
  • When you enable messages, messages not specified in the list are disabled.
  • When you disable messages, each listed message is removed from the enabled list.

    Note: To prevent all messages from entering the error queue, send the null list parameter as :STATus:QUEue:ENABle ().

Command | Description
:STATus:QUEue:CLEar | Clears message from error queue.
:SYSTem:ERRor? | Reads error queue.
:SYSTem:CLEar | Clears messages from error queue.
*CLS | Clears messages from error queue.

Note: Power-up and *CLS empties the error queue. The :STATus:PRESet command has no effect. Power-up enables error messages and disables status messages. *CLS and :STATus:PRESet have no effect.

Programming example

Read error queue

The following command reads the error queue:

:STAT:QUE?


Programming and reading registers

See Programming enable registers and Reading registers for detailed information on registers.

Programming enable registers

The enable registers are the only registers that you can program. All other registers in the status structure are read-only registers.

The following section explains how to ascertain the parameter values for the various commands used to program enable registers.

A command to program an event enable register is sent with a parameter value that determines the desired state (0 or 1) of each bit in the appropriate register. An enable register can be programmed using any of the following data formats for the parameter value:

  • binary
  • decimal
  • hexadecimal
  • octal

The bit positions of the register (see the following table) indicate the binary parameter value.

Example:

To set bits B4, B3 and B1, the binary value would be 11010 (where B4=1, B3=1, B1=1 and all other bits are 0).

When you use one of the other formats, convert the binary number to its decimal, hexadecimal, or octal equivalent.

Example:

Binary 11010 = Decimal 26 = Hexadecimal 1A = Octal 32

Note that the following tables include the decimal weight for each register bit. To set bits B4, B3, and B1, the decimal parameter value would be the sum of the decimal weights for those bits (16+8+2 = 26).

16-bit status register -- Bits 0 through 7

Bit Position | B7 | B6 | B5 | B4 | B3 | B2 | B1 | B0
Binary Value | 0/1 | 0/1 | 0/1 | 0/1 | 0/1 | 0/1 | 0/1 | 0/1
Decimal | 128 | 64 | 32 | 16 | 8 | 4 | 2 | 1
Weights | (27) | (26) | (25) | (24) | (23) | (22) | (21) | (20)

16-bit status register -- Bits 8 through 15

Bit Position | B15 | B14 | B13 | B12 | B11 | B10 | B9 | B8
Binary Value | 0/1 | 0/1 | 0/1 | 0/1 | 0/1 | 0/1 | 0/1 | 0/1
Decimal | 32768 | 16384 | 8192 | 4096 | 2048 | 1024 | 512 | 256
Weights | (215) | (214) | (213) | (212) | (211) | (210) | (29) | (28)

The <NDN> (non-decimal numeric) parameter type is used to send non-decimal values. These values require a header (#B, #H, or #Q) to identify the data format being sent. The letter in the header can be upper or lower case. The <NRf> (numeric representation format) parameter type is used to send decimal values and does not use a header. The following examples show the proper parameter syntax for setting bits B5, B3, and B2:

#b101100 | Binary format (<NDN> parameter type)
#h2C | Hexadecimal format (<NDN> parameter type)
#q54 | Octal format (<NDN> parameter type)
44 | Decimal format (<NRf> parameter type)

Valid characters for the non-decimal parameter values are shown as follows:

<NDN> format | Valid characters
Binary | 1s and 0s
Hexadecimal | 0 through 9 and A through F
Octal | 0 through 7

Reading registers

Any register in the status structure can be read by using the appropriate query (?) command. The following explains how to interpret the returned value (response message).

The response message will be a value that indicates which bits in the register are set. That value (if not already binary) will have to be converted to its binary equivalent.

Example:

For a binary value of 100101, bits B5, B2, and B0 are set.

The returned value can be in the binary, decimal, hexadecimal, or octal format. The FORMat:SREGister command is used to select the data format for the returned value (see the following table).

For non-decimal formats, one of the following headers will accompany the returned value to indicate which format is selected:

#B = Header for binary values

#H = Header for hexadecimal values

#Q = Header for octal values

Data format command for reading status registers

Command | Description |  |  | Default
:FORMat:SREGISTER <name> | Select data format for reading status registers: |  |  | ASCii
 | <name> = | ASCii | Decimal format |
 |  | HEXadecimal | Hexadecimal format |
 |  | OCTal | Octal format |
 |  | BINary | Binary format |


Clearing registers and queues

When the instrument is turned on, the bits of all registers in the status structure are cleared (reset to 0) and the two queues are empty. Commands to reset the event registers, event enable registers, and the error queue are listed in the following table. In addition to these commands, any enable register can be reset by sending the 0 parameter value with the individual command to program the register.

Note: :SYSTem:PRESet and *RST have no effect on status structure registers and queues.

Commands |  | Description
To reset registers: |  |  |
 | *CLS | Reset all bits of the following event registers to 0:
 |  |  | Standard event register
 |  |  | Operation event register
 |  |  | Measurement event register
 |  |  | Questionable event register
 | :STATus:PRESet | Reset all bits of the following enable registers to 0:
 |  |  | Operation event enable register
 |  |  | Measurement event enable register
 |  |  | Questionable event enable register
To clear error queue: |  |  |
 | *CLS | Clear all messages from error queue
 | :STATus:QUEue:CLEar | Clear messages from error queue
 | :SYSTem:ERRor:CLEar | Clear messages from error queue
  • The standard event enable register is not reset by :STATus:PRESet or *CLS. Send the 0 parameter value with *ESE to reset all bits of that enable register to 0 (see Status byte and service request commands).
  • The :STATus:PRESet command has no effect on the error queue. Use either of the two clear commands to clear the error queue.


Recommended programming sequences

Select the following procedures for the recommended programming sequences.

  • EDGE measurements
  • GSM measurements
  • IQ Data extraction


Programming Edge measurements

This procedure shows you the recommended sequence for an EDGE measurement program. There are five main steps for the program:

  1. Set up the initial settings.
  2. Activate the EDGE measurement.
  3. Select the desired measurements and the number of averages.
  4. Start the measurement and wait for it to complete.
  5. Read the measured data.

Refer to the Series 2800 VSA command locater or the Series 2800 VSA SCPI command tree to find the topics for the individual commands.

Refer to EDGE to find an outline for setting up an EDGE measurement from the front panel interface.

Step 1. Set up the initial settings

Command | Discussion
:INIT:CONT OFF | This command puts the instrument in single sweep mode. This is required for all remote operations, so that the instrument does not overwrite the data you are trying to read.
:DISP:ENABle OFF | Optional: There are significant speed benefits to switching off the instrument display. The display switches on if you press the LOCAL key.
:FORMat REAL,32 | When transferring traces with the :CALC:DATA? command, the 32-bit binary transfer is the fastest. However, the receiving program has to decode the header and swap the bytes.

Step 2. Activate the EDGE Measurement

Command | Discussion
:MEAS:SEL EDGE | This command activates the EDGE measurement. Since the instrument is in single sweep mode, no data is taken until you complete the set up.
:FREQ 950 MHz | If the instrument is not already at the desired frequency, set the instrument to the expected frequency. All the measurements such as GSM, EDGE, and Spectrum share the same frequency.
:RLEV -10 dBm | Sets the expected channel power. This value is shared by all the measurements, sometimes called the reference level.
:EDGE:TSEQ 0 | Sets the training sequence that has been embedded in the time slot that you want to measure. This is often the same as the index of the time slot. The default is 0, acceptable values are 0 to 7. If there is only one time slot active, this is the only setting that needs to be changed. The command is optionally preceded by [:SENSe].
:EDGE:TSL:COUN 3 | Sets the number of active time slots. The default is 1. The acceptable values range from 1 to 7. This command is optionally preceded by [:SENSe].
:EDGE:TSL:FIRSt | Sets the index of the first active time slot. The default is 0. The acceptable values range from 0 to 7. You only need to set this parameter if more than one time slot is active. This command is optionally preceded by [:SENSe].
:EDGE:TSL 2 | Sets the index of the timeslot that you would like the Series 2800 VSA to measure. The default is 0. The acceptable values range from 0 to 7. You only need to be set this parameter if more than one time slot is active. This command is optionally preceded by [:SENSe].

Step 3. Select the desired measurements and number of averages

Command | Discussion
:EDGE:TMASK ON | If desired, activate the time mask measurement. The default is On.
:EDGE:TMASK:AVER:COUN 1 | Sets the number of averages used for time mask. Normally, no averaging (averaging count of 1) is used with time mask.
:EDGE:EVM ON | If desired, activate the EDGE EVM measurement. The default is On.
:EDGE:EVM:AVER:COUN 21 | Sets the number of averages used for the EDGE EVM measurement. The standard specifies at least 200 averages. A more typical value in practice is 20 to 30 averages. If another measurement such as ORFS due to modulation has more averaging than EVM, you will generally want to use the larger number of averages in the EVM measurement as there is very little time penalty to calculate EVM in addition to the other parameter.
:EDGE:ORFS:MOD ON | If desired, activate the ORFS due to mdulation measurement. The default is Off.
:EDGE:ORFS:MOD:AVER:COUN 21 | This measurement has a very high standard deviation and some averaging will be required. The instrument default is 21 averages. The standard specifies 200 averages, but that requires more time.
:EDGE:ORFS:SWIT ON | If desired, activate the ORFS due to switching measurement. This is a less common version of ORFS that captures the spectral spreading due to the entire burst, including the pulse edges. The default is Off.
:EDGE:ORFS:SWITCH:AVER:COUN 21 | This measurement has a very high standard deviation, and some averaging will be required. The instrument default is 21 averages. The standard does not specify a number of averages.

Step 4. Start the measurement and wait for it to complete

Command | Discussion
:INIT:IMM; *WAI; :CALC:DATA:VALID? | This message has three commands on one line, to be sent as one message. This message tells the instrument to make a measurement, wait until it is complete, and then return an ascii Boolean: "1" if a burst was found and successfully demodulated, "0" otherwise. If a "0" is returned, do not try reading back any data – it will all be blanks and generate errors. If you have other instruments to talk to and do not want to occupy the bus, you can delay reading the response back until you are ready to wait for the instrument to complete.

Note: A more usual approach is to send ":INIT:IMM;*OPC?" and wait for the "1" to come back from the OPC?. This works well with the Series 2800 VSA, but it is likely that the next command you will want to send is ":CALC:DATA:VALID?" to find out if there is data to read. It is a little faster replacing *OPC? with "*WAI; :CALC:DATA:VALID?".

Step 5. Read the measured data

Command

Discussion

:CALC:EDGE:LIMIT:FAIL?

Returns an ascii "1" if any measured values failed their limit test. This is a quick way to tell if the test was successful.

:CALC:EDGE:TMASK:DATA?

Reads back the time mask data in dBc. If :FORM REAL,32 was specified, this will be a binary transfer. Expect 992 points.

:CALC:EDGE:TMASK:DATA:X?

Reads back the time value associated with each point in the time mask data query. These values do not change. You should only need to do this once to figure out the time axis.

:CALC:EDGE:CPOW:DATA?

Reads back the channel power in dBm, as an ascii floating point number.

:CALC:EDGE:EVM:DATA?

Reads back the different values for edge EVM. The response is ascii, and will look like " 0.2079, 0.4367, 0.3577, -0.281, -0.0005, -52.5554, -0.0009"

0.2079

0.2079

RMS EVM, in %

0.4367

0.4367

Peak EVM, in %

0.3577

0.3577

Ninety-five percentile EVM

-0.281

-0.281

Frequency Error, in Hz

-0.0005

-0.0005

IQ Gain Error in dB. Also called IQ gain imbalance.

-52.5554

-52.5554

IQ Origin Offset, in dB. Also called Carrier Feedthru.

-0.0009

-0.0009

Droop in dB, from decision point of first symbol to decision point of last.

:FORM REAL,32

:CALC:EDGE:ORFS:MOD:DATA?

Reads back the ORFS due to modulation data as binary values. If there are N offsets, there will be 2*N+1 return values. The default is 6 offsets, so there are 13 return values. If you set :FORM ASCII, the response looks like "-63.15942383,-69.77606964,-68.96424866,-66.44515228,-42.28766632,-39.15406036,0.00000000,-38.48074341,-41.16877747,-65.88758850,-69.12230682,-70.27355957,-63.05799866", where

-63.15942383 | The first value corresponds to the largest negative offset. For default settings, this is -1800 kHz.
-69.77606964 | -1200 kHz
-68.96424866 | -600 kHz
-66.44515228 | -400 kHz
-42.28766632 | -250 kHz
-39.15406036 | -200 kHz
0.00000000 | The middle value is always zero because the trace is referenced to the middle value. Use :CALC:EDGE:ORFS:MOD:REF? to get the middle value in dBm, which you can use to convert the entire trace to dBm.
-38.48074341 | + 200 kHz
-41.16877747 | + 250 kHz
-65.88758850 | + 400 kHz
-69.12230682 | + 600 kHz
-70.27355957 | + 1200 kHz
-63.05799866 | The last value corresponds to the largest positive offset. For default settings, that is +1800 kHz.

:CALC:EDGE:ORFS:MOD:DATA:X?

Reads the explicit list of frequency offsets in Hz that corresponds to the ORFS data above. Returns as a 2*N+1 ascii array.

:CALC:EDGE:ORFS:MOD:REF?

Returns the reference power in dBm. For ORFS modulation, the reference power is the power measured in a 30 kHz band centered on the carrier. By adding this value to the dBc values in the trace, you convert the values from dBc to dBm.

:CALC:EDGE:ORFS:SWIT:DATA?

Reads back the ORFS due to switching data as ascii values. If there are N offsets, there will be 2*N+1 return values. The default is has 4 offsets, so there are 9 return values. The return data format is similar to ORFS due to modulation data.

:CALC:EDGE:ORFS:SWIT:DATA:X?

Reads the explicit list of frequency offsets in Hz that corresponds to the ORFS due to switching data, above. Returns as a 2*N + 1 ascii array.

:CALC:EDGE:ORFS:SWIT:REF?

Returns the ORFS due to switching reference power in dBm. This is the same as the channel power. HorizontalRule


Programming GSM measurements

This procedure shows you the recommended sequence for an GSM measurement program. There are five main steps for the program:

  1. Set up the initial settings.
  2. Activate the GSM measurement.
  3. Select the desired measurements and the number of averages.
  4. Start the measurement and wait for it to complete.
  5. Read the measured data.

Refer to the Series 2800 VSA SCPI command tree or the Series 2800 VSA command locater to find the topics for the individual commands.

Refer to GSM to find an outline for setting up an GSM measurement from the front panel interface.

Step 1. Set up the initial measurement

Command | Discussion
:INIT:CONT OFF | This command puts the instrument in single sweep mode. This mode is required for all remote operations, so that the instrument does not overwrite the data you are trying to read.
:DISP:ENABle OFF | Optional: There are significant speed benefits to switch off the instrument display. The display switches on if you press the LOCAL key.
:FORMat REAL,32 | When transferring traces with the :CALC:DATA? command, the 32-bit binary transfer is the fastest. However, the receiving program has to decode the header and swap the bytes.

Step 2. Activate the GSM measurement

Command | Discussion
:MEAS:SEL GSM | This activates the GSM measurement. Since the instrument is in single sweep mode, no data is taken until you complete the set up.
:FREQ 950 MHz | If the instrument is not already at the desired frequency, set the instrument to the expected frequency. All the measurements such as GSM, EDGE, and Spectrum share the same frequency.
:RLEV -10 dBm | Sets the expected channel power. This value is shared by all the measurements, sometimes called the reference level.
:GSM:TSEQ 0 | Sets the training sequence that has been embedded in the time slot that you want to measure. This is often the same as the index of the time slot. The default is 0, acceptable values are 0 to 7. If there is only one time slot active, this is the only setting that needs to be changed. The command is optionally preceded by [:SENSe].
:GSM:TSL:COUN 3 | Sets the number of active time slots. The default is 1. The acceptable values range from 1 to 7. This command is optionally preceded by [:SENSe].
:GSM:TSL:FIRSt | Sets the index of the first active time slot. The default is 0. The acceptable values range from 0 to 7. You only need to set this parameter if more than one time slot is active. This command is optionally preceded by [:SENSe].
:GSM:TSL 2 | Sets the index of the timeslot that you would like the Series 2800 VSA to measure. The default is 0. The acceptable values range from 0 to 7. You only need to be set this parameter if more than one time slot is active. This command is optionally preceded by [:SENSe].

Step 3. Select the desired measurements and number of averages

Command | Discussion
:GSM:TMASK ON | If desired, activate the time mask measurement. The default is On.
:GSM:TMASK:AVER:COUN 1 | Sets the number of averages used for time mask. Normally, no averaging (averaging count of 1) is used with time mask.
:GSM:PERR ON | If desired, activate the GSM Phase Error measurement. The default is On.
:GSM:PERR:AVER:COUN 21 | Sets the number of averages used for a GSM phase error measurement. The standard specifies at least 200 averages. A more typical value in practice is 20 to 30 averages. If another measurement such as ORFS due to modulation has more averaging than phase error, you will generally want to use the larger number of averages in the phase error measurement as there is very little time penalty to calculate phase error in addition to the other parameter.
:GSM:ORFS:MOD ON | If desired, activate the ORFS due to modulation measurement. The default is Off.
:GSM:ORFS:MOD:AVER:COUN 21 | This measurement has a very high standard deviation and some averaging will be required. The instrument default is 21 averages. The standard specifies 200 averages, but that requires more time.
:GSM:ORFS:SWIT ON | If desired, activate the ORFS due to switching measurement. This is a less common version of ORFS that captures the spectral spreading due to the entire burst, including the pulse edges. The default is Off.
:GSM:ORFS:SWITCH:AVER:COUN 21 | This measurement has a very high standard deviation, and some averaging will be required. The instrument default is 21 averages. The standard does not specify a number of averages.

Step 4. Start the measurement and wait for it to complete

Command | Discussion
:INIT:IMM; *WAI; :CALC:DATA:VALID? | This message has three commands on one line, to be sent as one message. This message tells the instrument to make a measurement, wait until it is complete, and then return an ascii Boolean: "1" if a burst was found and successfully demodulated, "0" otherwise. If a "0" is returned, do not try reading back any data – it will all be blanks and generate errors. If you have other instruments to talk to and do not want to occupy the bus, you can delay reading the response back until you are ready to wait for the instrument to complete.

Note: A more usual approach is to send ":INIT:IMM;*OPC?" and wait for the "1" to come back from the OPC?. This works well with the Series 2800 VSA, but it is likely that the next command you will want to send is ":CALC:DATA:VALID?" to find out if there is data to read. It is a little faster replacing *OPC? with "*WAI; :CALC:DATA:VALID?".

Step 5. Read the measured data

Command

Discussion

:CALC:GSM:LIMIT:FAIL?

Returns an ascii "1" if any measured values failed their limit test. This is a quick way to tell if the test was successful.

:CALC:GSM:TMASK:DATA?

Reads back the time mask data in dBc. If :FORM REAL,32 was specified, this will be a binary transfer. Expect 992 points.

:CALC:GSM:TMASK:DATA:X?

Reads back the time value associated with each point in the time mask data query. These values do not change – you should only need to do this once to figure out the time axis.

:CALC:GSM:CPOW:DATA?

Reads back the channel power in dBm as an ascii floating point number.

:CALC:GSM:PERRor:DATA?

Reads back the different values for GSM phase error. The response is ascii, and will look like 0.1533, 0.4723, 43.0000, -299611.0313"

0.1533

0.1533

RMS Phase Error, in deg

0.4723

0.4723

Peak Phase Error, in deg

43

43

Symbol with peak Phase Error

-299611.0313

-299611.0313

Frequency Error, in Hz

:FORM REAL,32

:CALC:GSM:ORFS:MOD:DATA?

Reads back the ORFS due to modulation data as binary values. If there are N offsets, there will be 2*N+1 return values. The default is 6 offsets, so there are 13 return values. If you set :FORM ASCII, the response looks like "-63.15942383,-69.77606964,-68.96424866,-66.44515228,-42.28766632,-39.15406036,0.00000000,-38.48074341,-41.16877747,-65.88758850,-69.12230682,-70.27355957,-63.05799866", where

-63.15942383

-63.15942383

The first value corresponds to the largest negative offset. For default settings, this is -1800 kHz

-69.77606964

-69.77606964

-1200 kHz

-68.96424866

-600 kHz

-66.44515228

-400 kHz

-42.28766632

-250 kHz

-39.15406036

-200 kHz

0.00000000

The middle value is always zero because the trace is referenced to the middle value. Use :CALC:EDGE:ORFS:MOD:REF? to get the middle value in dBm, which you can use to convert the entire trace to dBm.

-38.48074341

+ 200 kHz

-41.16877747

+ 250 kHz

-65.88758850

+ 400 kHz

-69.12230682

+ 600 kHz

-70.27355957

+ 1200 kHz

-63.05799866

The last value corresponds to the largest positive offset. For default settings, that is +1800 kHz.

:CALC:GSM:ORFS:MOD:DATA:X?

Reads the explicit list of frequency offsets in Hz that corresponds to the ORFS data above. Returned as a 2*N+1 ascii array.

:CALC:GSM:ORFS:MOD:REF?

Returns the reference power in dBm. For ORFS modulation, the reference power is the power measured in a 30 kHz band centered on the carrier. By adding this value to the dBc values in the trace, you convert the values from dBc to dBm.

:CALC:GSM:ORFS:SWIT:DATA?

Reads back the ORFS due to switching data as ascii values. If there are N offsets, there will be 2*N+1 return values. The default is to have 4 offsets, so there are 9 return values. The return data format is similar to ORFS due to modulation data.

:CALC:GSM:ORFS:SWIT:DATA:X?

Reads the explicit list of frequency offsets in Hz that corresponds to the ORFS due to switching data above. Returns as a 2*N + 1 ascii array.

:CALC:GSM:ORFS:SWIT:REF?

Returns the ORFS due to switching reference power in dBm. This is the same as the channel power. HorizontalRule


Extracting IQ data

You can acquire complex samples of an RF waveform by extracting the measured IQ data from the analyzer with commands that perform the following sequence:

  1. Put the analyzer in zero span mode.

    :MEASure[:SELect] ZSPan

  2. Put the analyzer in single sweep mode.

    :INITiate:CONTinuous OFF

  3. Set the sweep time and bandwidth.

    [:SENSe]:ZSPan:SWEep:TIME

    [:SENSe]:ZSPan:BANDwidth[:RESolution]

  4. Query the analyzer for the IQ data.

    :MEAS:IQ?

The SCPI response consists of the following:

  • A binary header:
    • Sample rate as an ASCII floating point number
    • A comma
    • "#" SCPI block transfer delimiter
    • The number of digits in the block size
    • ASCII digits indicating the block size in bytes
  • IQ values as 16-bit signed integers, with the real values interleaved with the imaginary values (bits 0-15 = I values, bits 16-31 = Q values)
  • Newline character

    Note: The format #nddd<binary data> is called "Arbitrary Block Program Data."

Example:

A SCPI response for a 1 ms sweep time and 1 MHz bandwidth:

50000000.0000,#520040
I
Q
I
Q
...
newline character

Where:

50000000.0000 = sample rate
# = SCPI block transfer delimiter
5 = the number of digits in the block size
20040 = the ASCII digits indicating the block size in bytes (5010 complex pairs consisting of 10020 16-bit signed integers)
I = real value (even sample, bits 0-15)
Q = imaginary value (odd sample, bits 16-31)
newline character = indicates the end of the binary block

The information transferred has the scaling in volts and is dependent on the following aspects of the instrument:

  • Front end attenuation
  • Calibration
  • Frequency

    Note: If you want to cancel the IQ data extraction, press Local and Preset on the instrument front panel. Or, send a "Device Clear" through remote control. The time it takes for the Series 2800 VSA to return to normal operation mode depends on the size of the file that is in the buffer. For example, for a file size of 20 kBytes, the analyzer will respond quickly. For a file size of 20 Mbytes, the analyzer will respond more slowly.


Series 2800 VSA SCPI command tree

IEEE - 488.2
:CALCulate
 | :ACPR:LIMit
 | :CDMA:REVerse
 | :DATA?
 | :DATA:VALid?
 | :EDGE
 | :GSM
 | :MARKer
 | :WCDA:DOWNlink
 | :WCDMa:UPLink
 | :WLAN
:CALibration[:ALL]
:DIAGnostic:FREQuency
:DIAGnostic:REMote
:DISPlay
:FORMat
:INITiate
:MEASure
:MMEMory:DATA
:SERVice:BACKground[:STATe]
:SOURce
:SOUTput
:STATus
:SYSTem
 | :CLEar
 | :COMMunicate
 | :DATE
 | :ERRor
 | :KLOCk
 | :LOCal
 | :PRESet
 | :REMote
 | :SSAVer
 | :TIME
:TRACe
:TRIGger
[:SENSe]
 | :ACPR
 | :ADC
 | :AINT
 | :CDMA:REVerse:AVERage
 | :CPList
 | :DETector
 | :DSP
 | :EDGE
 | :EPOWer
 | :FREQuency
 | :GSM
 | :POWer
 | :OBWidth:AVERage
 | :SEMask:AVERage
 | :SPECtrum
 | WCDMa:DOWNlink
 | : WCDMa:UPLink
 | ;WLAN
 | :ZSPan


IEEE- 488.2 common commands

*CLS | *RST
*ESE | *SAV
*ESE? | *SRE
*ESR? | *SRE?
*IDN? | *STB?
*OPC | *TRG
*OPC? | *WAI
*RCL |

*CLS -- Clear status

Clears the instrument status byte by emptying the error queue and clearing all event registers. Also cancels any preceding *OPC command or query. The standard event enable register is not reset by :STATus:PRESet or *CLS. Send the 0 parameter value with *ESE to reset all bits of that enable register to 0.

Note: :SYSTem:PRESet and *RST have no effect on status structure registers and queues.

*ESE <NRf> -- Event status enable

Sets bits in the standard event status enable register. The parameter values to set the individual bits of the enable registers can be sent using the decimal format (NRf = 0 to 225). See Standard event register topic for more information.

*ESE? -- Event status enable query

Returns the results of the standard event enable register. The register is cleared after reading it. See Standard event register topic for more information.

*ESR? -- Event status register query

Reads the event status enable register. See [image] Status register commands and Reading Registers.

*CLS

*ESE

*ESE?

*ESR?

*OPC

*OPC?

*SRE

*SRE?

*STB?

:FORMat:SREGister

:STATus:MEASurement:CONDition?

:STATus:MEASurement:ENABle

:STATus:MEASurement?

:STATus:OPERation:CONDition?

:STATus:OPERation:ENABle

:STATus:OPERation?

:STATus:PRESet

:STATus:QUEStionable:CONDition?

:STATus:QUEStionable:ENABle

:STATus:QUEStionable?

:STATus:QUEue:CLEar

:SYSTEM:CLEar

:SYSTem:ERRor?

:SYSTem:ERRor:ALL?

:SYSTem:ERRor:CLEar

:SYSTem:ERRor:CODE?

:SYSTem:ERRor:CODE:ALL?

:SYSTem:ERRor:COUNt

:SYSTem:ERRor:ENABle

:SYSTem:ERRor:ENABle:ADD

:SYSTem:ERRor:ENABle:DELete

:SYSTem:ERRor:ENABle

*IDN? -- Identify

Returns a string that uniquely identifies the instrument. The identification code includes the manufacturer, model number, serial number, and firmware revision levels and is sent in the following format:

KEITHLEY INSTRUMENTS INC.,MODEL nnnn,nnnnnnnn,xxx Jan 27 2007 14:59:09

Where:

nnnn is the model number

nnnnnnn is the serial number

xxx is the firmware revision level

Jan 27 2007 14:59:09 is the date and time (24hr format, hr:min:sec) for the firmware release

*OPC -- Operation complete command

Sets the *OPC bit in the standard event register after all pending commands are complete.

Description

After the *OPC command is sent and the last pending command is completed, the operation complete bit (bit B0) of the standard event status register will be set. If the corresponding bit (bit B0) in the standard event enable register and Bit 5 (event summary bit) of the service request enable register are set, the MSS (master summary status) bit in the status byte register is set. See Event registers for more information.

When used with the immediate initiation command (:INITiate), the OPC bit in the standard event status register will not set until the instrument goes back into the idle state. See the description for *WAI for more information on command execution.

Programming example

The first group of commands sends the *OPC command after the :INITiate command and verifies that the OPC bit in the standard event status register does not set while the instrument continues to make measurements (not in idle). The second group of commands returns the instrument to the idle state and verifies that the OPC bit did get set.

:SYST:PRES | ' Returns the instrument to default setup.
:INIT:IMM;*OPC | ' Initiates one trigger cycle and sends the OPC command.
*ESR? | ' Reads the standard event status register.

The returned value of 0 denotes that the bit (bit 0) is not set indicating that the :INITiate operation is not complete.

*ESR?

' Reads the standard event status register.

The returned value of 1 denotes that the bit (bit 1 is set indicating that the :INITiate operation is now complete.

:SYST:PRES

' Returns the instrument to default setup.

Note: The following commands take a long time to process and may benefit from using *OPC or *OPC?:

  • *RST and SYST:PRES
  • *RCL and *SAV

*OPC? -- Operation complete query

Places a "1" in the output queue after all pending operations are completed.

Description

When this common command is sent, an ASCII "1" will be placed in the output queue after the last pending operation is completed. The "1" in the output queue will be sent to the controller. See Output queue for more information.

The "1" in the output queue will set the MAV (message available) bit (B4) of the status byte register. If the corresponding bit (B4) in the service request enable register is set, the RQS/MSS (request for service/master summary status) bit in the status byte register will set.

When used with the Initiate Immediately command (:INITiate), a "1" will not be placed into the output queue until the instrument goes back into the idle state. The :INIT command operation is not considered finished until the instrument goes back into the idle state. See the description for *WAI for more information on command execution.

The execution of OPC? is not completed until it has placed the '1' in the output queue.

Programming example

This command sequence demonstrates how to use *OPC? to signal the end of a measurement process:

:SYST:PRES | ' Returns instrument to default setup.
:INIT;*OPC? | ' Starts measurement process and sends OPC? command.

After the measurement is performed and the instrument returns to the idle state, an ASCII "1" will be placed in the output queue. The "1" from the output queue is sent to the controller.

:SYST:PRES

' Returns the instrument to default setup.

Note: The following commands take a long time to process and may benefit from using *OPC or *OPC?:

  • *RST and SYST:PRES
  • *RCL and *SAV

*RCL <NRf> -- Recall *SAV -- Save

  • The *SAV command saves the current instrument setup in memory.
  • The *RCL command returns the instrument to the setup stored memory.

Any control affected by *RST can be saved by the *SAV command.

Ten setup configurations (numbered from 0 to 9) can be saved and recalled. A saved setup configuration is approximately 4k bytes in size.

The instrument leaves the factory with :SYSTem:PRESet defaults loaded into the available setup memory. If a recall error occurs, the setup memory defaults to the :SYSTem:PRESet values.

Note: *OPC or *OPC? should be used with *SAV and *RCL, which are slow-responding commands.

Programming example

The following summarizes the basic command sequence for saving and recalling a setup. The present setup is stored in memory location 2, GPIB defaults are restored, and the memory location 2 setup is recalled.

*SAV 2 | ' Save present setup in memory location 2.
*RST | ' Restore GPIB defaults.
*RCL 2 | ' Recall location 2 setup.

*RST -- Reset

Returns the instrument to RST defaults.

  1. Returns the instrument to the RST default conditions, which is exactly the same as a SYSTem:PRESet (see "Default" area in SCPI commands).
  2. Cancels all pending commands.
  3. Cancels response to any previously received *OPC and *OPC? commands.

    Note: *OPC or *OPC? should be used with *SAV and *RCL, which are slow-responding commands.

Note: The frequency reference is not affected by Preset, *RST, or Save/Recall state.

*SAV -- Save*RCL <NRf> -- Recall

  • The *SAV command saves the current instrument setup in memory.
  • The *RCL command returns the instrument to the setup stored memory.

Any control affected by *RST can be saved by the *SAV command.

Ten setup configurations (numbered from 0 to 9) can be saved and recalled from the instrument. A saved setup configuration is approximately 4k bytes in size.

The instrument leaves the factory with :SYSTem:PRESet defaults loaded into the available setup memory. If a recall error occurs, the setup memory defaults to the :SYSTem:PRESet values.

Note: *OPC or *OPC? should be used with *SAV and *RCL, which are slow-responding commands.

Programming example

The following summarizes the basic command sequence for saving and recalling a setup. The present setup is stored in memory location 2, GPIB defaults are restored, and the memory location 2 setup is recalled.

*SAV 2 | ' Save present setup in memory location 2.
*RST | ' Restore GPIB defaults.
*RCL 2 | ' Recall location 2 setup.

*SRE -- Service request enable command

Before reading a status register, bits must be enabled. This command enables bits in the service request register. The current setting is saved in non-volatile memory. See Service request enable register for more information.

*SRE? -- Service request enable query

Reads the current state of the service request enable register. The register is cleared after reading it. The return value can be decoded using the table in Programming and reading registers. See also Reading Registers.

*STB? -- Status byte query

Reads the value of the instrument status byte. The register is cleared only when the registers feeding it are cleared. See Programming and reading registers and Clearing registers and queues.

*TRG - Trigger

Issues a GPIB trigger to the instrument 2. Use the *TRG command as an event to control operation. The instrument reacts to this trigger if BUS is the programmed control source. See Triggering and Sync Out for more information.

Programming example

The following command sequence configures the instrument to be controlled by bus triggers. The last command, which sends a bus trigger, triggers one measurement. Each subsequent bus trigger will also trigger a single measurement.

Note: With TRIG:SOURce BUS selected, do not send any commands (except *TRG, GET, DCL, SDC, IFC, and ABORt) while performing measurements. Otherwise, erratic operation will occur.

*RST | ' Restore RST defaults.
:TRIG:SOUR BUS | ' Select BUS control source.
:INIT | ' Take instrument out of idle.
*TRG | ' Trigger one measurement.

*WAI -- Wait

Prevents execution of commands until previous commands are completed.

Description

The *WAI command can be used with the following commands:

  • INITiate
  • *TRG

The INITiate command removes the instrument from the idle state. The device operations of :INITiate are not considered complete until the instrument returns to idle. By sending the *WAI command after the INITiate command, all subsequent commands will not execute until the instrument goes back into idle.

The *TRG command issues a bus trigger that could be used to provide the arm, scan, and measure events for the Trigger Model. By sending the *WAI command after the *TRG command, subsequent commands will not be executed until the pointer for the Trigger Model has finished moving in response to *TRG and has settled at its next state.

Programming example

The following command sequence shows how to use the *WAI command to allow the instrument to wait for the programmed measurements to be completed before requesting a reading.

:SYST:PRES | Returns the instrument to default setup.
:INIT | Starts measurement process.
*WAI | Sends the WAI command. The program waits for the instrument to go into idle before executing the next command.


:CALCulate:ACPR:LIMit

Select a blue link to view the command details:

  • :CALCulate:ACPR:LIMit:ADJacent1|ADJacent2:Upper
  • :CALCulate:ACPR:LIMit:ADJacent1|ADJacent2[:STATe]
  • :CALCulate:ACPR:LIMit:FAIL?
  • :CALCulate:ACPR:LIMit:FAIL:CHANnels?

:CALCulate:ACPR:LIMit:ADJacent1|ADJacent2:UPPer

Sets the limit value for the specified adjacent ACPR channel.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | dBc

:CALCulate:ACPR:LIMit:ADJacent1|ADJacent2[:STATe]

Enables and disables the limit testing on the specified adjacent ACPR channel.

  • ON (or 1) -- enables the limit testing.
  • OFF (or 0) -- disables the limit testing.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

:CALCulate:ACPR:LIMit:FAIL?

Queries the fail status of the ACPR measurement.

  • Returns 1 if there is no valid data, if no limit test is turned on, or if any channel with a limit test turned on has failed.
  • Returns 0 if at least one channel has limit test turned on and all the channels with limit test turned on have passed.
Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:ACPR:LIMit:FAIL:CHANnels?

Reads the fail status of each adjacent channel.

Returns: no, <fail status of low-side first adjacent channel>,<fail status of high-side first adjacent channel>.

Where: no is the number of status values and <fail status...> is 0= no failure or 1=failure.

Query | Return | Set | Special | Units
yes | NR1, Boolean,..., Boolean | n/a | none | none


:CALCulate:CDMA:REVerse

Select a blue link to view the command details:

  • :CALCulate:CDMA:REVerse:ACHannela?
  • :CALCulate:CDMA:REVerse:ACPR:LIMit
  • :CALCulate:CDMA:REVerse:EVM
  • :CALCulate:CDMA:REVerse:FERRor
  • :CALCulate:CDMA:REVerse:IMARker
  • :CALCulate:CDMA:REVerse:IOFFset?
  • :CALCulate:CDMA:REVerse:IQOFfset
  • :CALCulate:CDMA:REVerse:LIMit
  • :CALCulate:CDMA:REVerse:OBWidth
  • :CALCulate:CDMA:REVerse:PCDE
  • :CALCulate:CDMA:REVerse:QMARker
  • :CALCulate:CDMA:REVerse:QOFFset?
  • :CALCulate:CDMA:REVerse:RHO
  • :CALCulate:CDMA:REVerse:SEMask:LIMit


:CALCulate:CDMA:REVerse:ACHannels?

Reads the data for the active channels. The return format is no, <channel data for each of the N active channels>.

The channel data is {I|Q}, <SpreadFactor>, <CodeNumber>, <ChannelAmplitude>, in BitReverse order.

Query | Return | Set | Special | Units
yes | NR1, <ACH#1 info>, ..., <ACH#n info> | n/a | none | none


:CALCulate:CDMA:REVerse:ACPR:LIMit

Select a blue link to view the command details:

  • :CALCulate:CDMA:REVerse:ACPR:LIMit:FAIL?
  • :CALCulate:CDMA:REVerse:ACPR:LIMIT:FAIL:CHANnels?
  • :CALCulate:CDMA:REVerse:ACPR:LIMIT:MARGin
  • :CALCulate:CDMA:REVerse:ACPR:LIMIT[:STATe]

:CALCulate:CDMA:REVerse:ACPR:LIMit:FAIL?

Reads the fail status of the adjacent channel power measurement. The return format is no, <fail status of low-side 1st adjacent channel>, <fail status of high-side 1st adjacent channel>, etc. no is the number of status values.

Fail status:

"0" indicates data tested with no failure.

"1" indicates failure, no data or test is off.

Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:CDMA:REVerse:ACPR:LIMIT:FAIL:CHANnels?

Reads the fail status of each adjacent channel. The return format is no, <fail status of low-side 1st adjacent channel>, <fail status of high-side 1st adjacent channel>, etc. no is the number of status values.

Fail status:

"0" indicates data tested with no failure

"1" indicates failure, no data or test is off

Query | Return | Set | Special | Units
yes | NR1, Boolean, ..., Boolean | n/a | none | none

:CALCulate:CDMA:REVerse:ACPR:LIMIT:MARGin

Sets the margin for adjacent channel power limit test. Adding a positive value makes the limit more stringent. Adding a negative value makes the limit less stringent. (Range = +50 to -50.)

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | dB

:CALCulate:CDMA:REVerse:ACPR:LIMIT[:STATe]

Enables and disables the limit testing for the ACPR measurement.

  • ON (or 1) -- enables the limit testing.
  • OFF (or 0) -- disables the limit testing.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none


:CALCulate:CDMA:REVerse:EVM

Select a blue link to view the command details:

  • :CALCulate:CDMA:REVerse:EVM:PEAK?
  • :CALCulate:CDMA:REVerse:EVM:PEAK:LIMit:FAIL?
  • :CALCulate:CDMA:REVerse:EVM:PEAK:LIMit:[:STATe]
  • :CALCulate:CDMA:REVerse:EVM:PEAK:LIMit:UPPer
  • :CALCulate:CDMA:REVerse:EVM:RMS?
  • :CALCulate:CDMA:REVerse:EVM:RMS:LIMit:FAIL?
  • :CALCulate:CDMA:REVerse:EVM:RMS:LIMit:[:STATe]
  • :CALCulate:CDMA:REVerse:EVM:RMS:LIMit:UPPer

:CALCulate:CDMA:REVerse:EVM:PEAK?

Reads the EVM peak value for a cdma2000 measurement.

Query | Return | Set | Special | Units
yes | NR3 | n/a | none | none

:CALCulate:CDMA:REVerse:EVM:PEAK:LIMit:FAIL?

Reads the fail status of EVM peak limit test. This is an alternate command to :CALCulate:CDMA:REVerse:LIMit:EVM:PEAK:FAIL.

  • 1 = failure
  • 0 = no failure; not the same as pass
Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:CDMA:REVerse:EVM:PEAK:LIMit:[:STATe]

Enables and disables the limit testing for the EVM peak measurement.This is an alternate command to :CALCulate:CDMA:REVerse:LIMit:EVM:PEAK[:STATe].

  • 1 = enabled
  • 0 = disabled
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

:CALCulate:CDMA:REVerse:EVM:PEAK:LIMit:UPPer

Sets the upper limit value for the EVM peak measurement. This is an alternate command to :CALCulate:CDMA:REVerse:LIMit:EVM:PEAK:UPPer.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | %

:CALCulate:CDMA:REVerse:EVM:RMS?

Reads the EVM RMS value for a cdma2000 measurement.

Query | Return | Set | Special | Units
yes | NR3 | n/a | none | none

:CALCulate:CDMA:REVerse:EVM:RMS:LIMit:FAIL?

Reads the status of EVM RMS limit test. This is an alternate command to :CALCulate:CDMA:REVerse:LIMit:EVM:RMS:FAIL.

Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:CDMA:REVerse:EVM:RMS:LIMit:[:STATe]

Enables and disables the limit testing for the EVM RMS measurement. This is an alternate command to :CALCulate:CDMA:REVerse:LIMit:EVM:RMS:[:STATe].

  • ON (or 1) -- enables the limit testing.
  • OFF (or 0) -- disables the limit testing.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

:CALCulate:CDMA:REVerse:EVM:RMS:LIMit:UPPer

Sets the limit value for the frequency error measurement. This is an alternate command to :CALCulate:CDMA:REVerse:LIMit:EVM:RMS:UPPer.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | Hz


:CALCulate:CDMA:REVerse:FERRor

Select a blue link to view the command details:

  • :CALCulate:CDMA:REVerse:FERRor:FAIL?
  • :CALCulate:CDMA:REVerse:FERRor:LIMit[:STATe]
  • :CALCulate:CDMA:REVerse:FERRor:LIMit:UPPer

:CALCulate:CDMA:REVerse:FERRor:FAIL?

Reads the status of frequency error limit test. This is an alternate command to :CALCulate:CDMA:REVerse:LIMit:FERRor:FAIL.

  • 1 = failure
  • 0 = no failure; not the same as pass
Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:CDMA:REVerse:FERRor:LIMit[:STATe]

Enables and disables the limit testing for the frequency error measurement. This is an alternate command to :CALCulate:CDMA:REVerse:LIMit:FERRor[:STATe].

  • ON (or 1) -- enables the limit testing.
  • OFF (or 0) -- disables the limit testing.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

:CALCulate:CDMA:REVerse:FERRor:LIMit:UPPer

Sets the limit value for the frequency error measurement. This is an alternate command to :CALCulate:CDMA:REVerse:LIMit:FERRor:UPPer.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | Hz


:CALCulate:CDMA:REVerse:IMARker

Select a blue link to view the command details:

  • :CALCulate:CDMA:REVerse:IMARker:CNUMber?
  • :CALCulate:CDMA:REVerse:IMARker:SFACtor?
  • :CALCulate:CDMA:REVerse:IMARker:X
  • :CALCulate:CDMA:REVerse:IMARker:Y?
  • :CALCulate:CDMA:REVerse:IMARker[:STATe]

:CALCulate:CDMA:REVerse:IMARker:CNUMber?

Reads the code number at the X-axis position of the I marker on the code domain power graph.

Query | Return | Set | Special | Units
yes | NR1 | n/a | none | none

:CALCulate:CDMA:REVerse:IMARker:SFACtor?

Reads the spread factor at the X-axis position of the I marker on the code domain power graph.

Query | Return | Set | Special | Units
yes | NR2 | n/a | none | none

:CALCulate:CDMA:REVerse:IMARker:X

Sets the X-axis position of the I marker on the code domain power graph.

Query | Return | Set | Special | Units
yes | NR1 | NRf | Max | Min | Def | none

:CALCulate:CDMA:REVerse:IMARker:Y?

Reads Y-axis power of I marker on code domain power graph.

Query | Return | Set | Special | Units
yes | NR3 | n/a | none | none

:CALCulate:CDMA:REVerse:IMARker[:STATe]

Switches the I marker on/off for the code domain power graph.

  • ON (or 1) -- enables the Imarker.
  • OFF (or 0) -- disables the Imarker.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none


:CALCulate:CDMA:REVerse:IOFFset

Reads the I offset value for a cdma2000 measurement.

Query | Return | Set | Special | Units
yes | NR3 | n/a | none | none


CALCulate:CDMA:REVerse:IQOFfset

Select a blue link to view the command details:

  • :CALCulate:CDMA:REVerse:IQOFfset:LIMit:FAIL?
  • :CALCulate:CDMA:REVerse:IQOFfset:LIMit[:STATe]
  • :CALCulate:CDMA:REVerse:IQOFfset:LIMit:UPPer


:CALCulate:CDMA:REVerse:IQOFfset:FAIL?

Reads the fail status of I/Q offset limit test. This command is an alternate to :CALCulate:CDMA:REVerse:LIMit:IQOFfset:FAIL.

  • 1 = failure
  • 0 = no failure; not the same as pass
Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:CDMA:REVerse:IQOFfset:LIMit[:STATe]

Enables and disables the limit testing for the I/Q offset measurement. This command is an alternate to :CALCulate:CDMA:REVerse:LIMit:IQOFfset[:STATe].

  • ON (or 1) -- enables the limit testing.
  • OFF (or 0) -- disables the limit testing.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

:CALCulate:CDMA:REVerse:IQOFfset:LIMit:UPPer

Sets the limit value for the I/Q offset measurement. This command is an alternate to :CALCulate:CDMA:REVerse:LIMit:IQOFfset:UPPer.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | dB


:CALCulate:CDMA:REVerse:LIMit

Select a blue link to view the command details:

  • :CALCulate:CDMA:REVerse:LIMit:EVM:PEAK
  • :CALCulate:CDMA:REVerse:LIMit:EVM:RMS
  • :CALCulate:CDMA:REVerse:LIMit:FERRor
  • :CALCulate:CDMA:REVerse:LIMit:IQOFfset
  • :CALCulate:CDMA:REVerse:LIMit:PCDE
  • :CALCulate:CDMA:REVerse:LIMit:RHO


:CALCulate:CDMA:REVerse:LIMit:EVM:PEAK

Select a blue link to view the command details:

  • :CALCulate:CDMA:REVerse:LIMit:EVM:PEAK:FAIL?
  • CALCulate:CDMA:REVerse:LIMit:EVM:PEAK:UPPer
  • :CALCulate:CDMA:REVerse:LIMit:EVM:PEAK[:STATe]

:CALCulate:CDMA:REVerse:LIMit:EVM:PEAK:FAIL?

Reads the fail status of EVM peak limit test. This is an alternate command to :CALCulate:CDMA:REVerse:EVM:PEAK:LIMit:FAIL.

  • 1 = failure
  • 0 = no failure; not the same as pass
Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:CDMA:REVerse:LIMit:EVM:PEAK:UPPer

Sets the limit value for the EVM peak measurement. This is an alternate command to :CALCulate:CDMA:REVerse:EVM:PEAK:LIMit:UPPer.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | %

:CALCulate:CDMA:REVerse:LIMit:EVM:PEAK[:STATe]

Enables and disables the limit testing for the EVM peak measurement. This is an alternate command to :CALCulate:CDMA:REVerse:EVM:PEAK:LIMit[:STATe].

  • 1 = enabled
  • 0 = disabled
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none


:CALCulate:CDMA:REVerse:LIMit:EVM:RMS

Select a blue link to view the command details:

  • :CALCulate:CDMA:REVerse:LIMit:EVM:RMS:FAIL?
  • :CALCulate:CDMA:REVerse:LIMit:EVM:RMS:UPPer
  • :CALCulate:CDMA:REVerse:LIMit:EVM:RMS[:STATe]

:CALCulate:CDMA:REVerse:LIMit:EVM:RMS:FAIL?

Reads the status of EVM RMS limit test. This is an alternate command to :CALCulate:CDMA:REVerse:EVM:RMS:LIMit:FAIL.

Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:CDMA:REVerse:LIMit:EVM:RMS:UPPer

Sets the limit value for the EVM RMS measurement. This is an alternate command to :CALCulate:CDMA:REVerse:EVM:RMS:LIMit:UPPer.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | %

:CALCulate:CDMA:REVerse:LIMit:EVM:RMS[:STATe]

Enables and disables the limit testing for the EVM RMS measurement. This is an alternate command to :CALCulate:CDMA:REVerse:EVM:RMS:LIMit:UPPer.

  • ON (or 1) -- enables the limit testing.
  • OFF (or 0) -- disables the limit testing.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none


:CALCulate:CDMA:REVerse:LIMit:FERRor

Select a blue link to view the command details:

  • :CALCulate:CDMA:REVerse:LIMit:FERRor:FAIL?
  • :CALCulate:CDMA:REVerse:LIMit:FERRor:UPPer
  • :CALCulate:CDMA:REVerse:LIMit:FERRor[:STATe]

:CALCulate:CDMA:REVerse:LIMit:FERRor:FAIL?

Reads the status of frequency error limit test.

  • 1 = failure
  • 0 = no failure; not the same as pass
Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:CDMA:REVerse:LIMit:FERRor:UPPer

Sets the limit value for the frequency error measurement.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | Hz

:CALCulate:CDMA:REVerse:LIMit:FERRor[:STATe]

Enables and disables the limit testing for the frequency error measurement.

  • ON (or 1) -- enables the limit testing.
  • OFF (or 0) -- disables the limit testing.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none


:CALCulate:CDMA:REVerse:LIMit:IQOFfset

Select a blue link to view the command details:

  • :CALCulate:CDMA:REVerse:LIMit:IQOFfset:FAIL?
  • :CALCulate:CDMA:REVerse:LIMit:IQOFfset:UPPer
  • :CALCulate:CDMA:REVerse:LIMit:IQOFfset[:STATe]

:CALCulate:CDMA:REVerse:LIMit:IQOFfset:FAIL?

Reads the fail status of I/Q offset limit test. This command is an alternate to :CALCulate:CDMA:REVerse:IQOFfset:LIMit:FAIL.

  • 1 = failure
  • 0 = no failure; not the same as pass
Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:CDMA:REVerse:LIMit:IQOFfset:UPPer

Sets the limit value for the I/Q offset measurement. This command is an alternate to :CALCulate:CDMA:REVerse:IQOFfset:LIMit:UPPer.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | dB

:CALCulate:CDMA:REVerse:LIMit:IQOFfset[:STATe]

Enables and disables the limit testing for the I/Q offset measurement. This command is an alternate to :CALCulate:CDMA:REVerse:IQOFfset:LIMit[:STATe].

  • ON (or 1) -- enables the limit testing.
  • OFF (or 0) -- disables the limit testing.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none


:CALCulate:CDMA:REVerse:LIMit:PCDE

Select a blue link to view the command details:

  • :CALCulate:CDMA:REVerse:LIMit:PCDE:FAIL?
  • :CALCulate:CDMA:REVerse:LIMit:PCDE:UPPer
  • :CALCulate:CDMA:REVerse:LIMit:PCDE:STATe

:CALCulate:CDMA:REVerse:LIMit:PCDE:FAIL?

Reads the fail status of PCDE limit test. This command is an alternate to :CALCulate:CDMA:REVerse:PCDE:LIMit:FAIL.

  • 1 = failure
  • 0 = no failure; not the same as pass
Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:CDMA:REVerse:LIMit:PCDE:UPPer

Sets the limit value for the PCDE measurement. This command is an alternate to :CALCulate:CDMA:REVerse:PCDE:LIMit:UPPer.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | dB

:CALCulate:CDMA:REVerse:LIMit:PCDE[:STATe]

Enables and disables the limit testing for a PCDE measurement. This command is an alternate to :CALCulate:CDMA:REVerse:PCDE:LIMit[:STATe].

  • ON (or 1) -- enables the limit testing.
  • OFF (or 0) -- disables the limit testing.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none


:CALCulate:CDMA:REVerse:LIMit:RHO

Select a blue link to view the command details:

  • :CALCulate:CDMA:REVerse:LIMit:RHO:FAIL?
  • :CALCulate:CDMA:REVerse:LIMit:RHO:LOWer
  • :CALCulate:CDMA:REVerse:LIMit:RHO[:STATe]

:CALCulate:CDMA:REVerse:LIMit:RHO:FAIL?

Reads the fail status of the rho limit test. This command is an alternate to :CALCulate:CDMA:REVerse:RHO:LIMit:FAIL.

  • 1 = failure
  • 0 = no failure; not the same as pass
Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:CDMA:REVerse:LIMit:RHO:LOWer

Sets the limit value for the rho measurement. This command is an alternate to :CALCulate:CDMA:REVerse:RHO:LIMit:LOWer.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | none

:CALCulate:CDMA:REVerse:LIMit:RHO[:STATe]

Enables and disables the limit testing for the rho measurement. This command is an alternate to :CALCulate:CDMA:REVerse:RHO:LIMit[;STATe].

  • ON (or 1) -- enables the limit testing.
  • OFF (or 0) -- disables the limit testing.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none


:CALCulate:CDMA:REVerse:OBWidth

Select a blue link to view the command details:

  • :CALCulate:CDMA:REVerse:OBWidth?
  • :CALCulate:CDMA:REVerse:OBWidth:LIMit:FAIL?
  • :CALCulate:CDMA:REVerse:OBWidth:LIMit[:STATe]
  • :CALCulate:CDMA:REVerse:OBWidth:LIMit:MARGin
  • :CALCulate:CDMA:REVerse:OBWidth:RANGe?
  • :CALCulate:CDMA:REVerse:OBWidth:TPOWer?

:CALCulate:CDMA:REVerse:OBWidth?

Reads the measured occupied bandwidth value, which is the bandwidth that contains 99% of the total power measured.

Query | Return | Set | Special | Units
yes | NR3 | n/a | none | none

:CALCulate:CDMA:REVerse:OBWidth:LIMit:FAIL?

Reads the occupied bandwidth limit test failure status. A single Boolean value is returned: true indicates the channel power exceeded the limits, false indicates a pass or no limit was applied to the test.

  • 1 = failure
  • 0 = no failure; not the same as passed
Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:CDMA:REVerse:OBWidth:LIMit[:STATe]

Enables and disables the limit testing for occupied bandwidth.

  • 1 = enabled
  • 0 = disabled
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

:CALCulate:CDMA:REVerse:OBWidth:LIMit:MARGin

Sets the margin for occupied bandwidth limit test. This margin is added to default upper bandwidth limit of 1.48 MHz.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | Hz

:CALCulate:CDMA:REVerse:OBWidth:RANGe?

Reads the lower and upper frequencies that define the occupied bandwidth.

Query | Return | Set | Special | Units
yes | NR3 | n/a | none | none

:CALCulate:CDMA:REVerse:OBWidth:TPOWer?

Reads the total power that is used to determine the occupied bandwidth.

Query | Return | Set | Special | Units
yes | NR2 | n/a | none | none


:CALCulate:CDMA:REVerse:PCDE

Select a blue link to view the command details:

  • :CALCulate:CDMA:REVerse:PCDE?
  • :CALCulate:CDMA:REVerse:PCDE:LIMit:FAIL?
  • :CALCulate:CDMA:REVerse:PCDE:LIMit[:STATe]
  • :CALCulate:CDMA:REVerse:PCDE:LIMit:UPPer

:CALCulate:CDMA:REVerse:PCDE?
  • Query PCDE value for cdma2000 measurement. Returns three comma-seperated values: PCDE, Spread factor of peak active CDE and Code number of peak active CDE.
Query | Return | Set | Special | Units
yes | NR3 | n/a | none | none

:CALCulate:CDMA:REVerse:PCDE:LIMit:FAIL?

Reads the fail status of PCDE limit test. This command is an alternate to :CALCulate:CDMA:REVerse:LIMit:PCDE:FAIL.

  • 1 = failure
  • 0 = no failure; not the same as pass
Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:CDMA:REVerse:PCDE:LIMit[:STATe]

Enables and disables the limit testing for a PCDE measurement. This command is an alternate to :CALCulate:CDMA:REVerse:LIMit:PCDE[:STATe].

  • ON (or 1) -- enables the limit testing.
  • OFF (or 0) -- disables the limit testing.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

:CALCulate:CDMA:REVerse:PCDE:LIMit:UPPer

Sets the limit value for the PCDE measurement. This command is an alternate to :CALCulate:CDMA:REVerse:LIMit:PCDE:UPPer.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | dB


:CALCulate:CDMA:REVerse:QMARker

Select a blue link to view the command details:

  • :CALCulate:CDMA:REVerse:QMARker:CNUMber?
  • :CALCulate:CDMA:REVerse:QMARker:SFACtor?
  • :CALCulate:CDMA:REVerse:QMARker:X
  • :CALCulate:CDMA:REVerse:QMARker:Y?
  • :CALCulate:CDMA:REVerse:QMARker[:STATe]

:CALCulate:CDMA:REVerse:QMARker:CNUMber?

Reads the code number at the X-axis position of the I marker on the code domain power graph.

Query | Return | Set | Special | Units
yes | NR1 | n/a | none | none

:CALCulate:CDMA:REVerse:QMARker:SFACtor?

Reads the spread factor at the X-axis position of the I marker on the code domain power graph.

Query | Return | Set | Special | Units
yes | NR2 | n/a | none | none

:CALCulate:CDMA:REVerse:QMARker:X

Sets the X-axis position of the Q marker on the code domain power graph.

Query | Return | Set | Special | Units
yes | NR1 | NRf | Max | Min | Def | none

:CALCulate:CDMA:REVerse:QMARker:Y?

Reads the Y-axis power value of the Q marker on the code domain power graph.

Query | Return | Set | Special | Units
yes | NR3 | n/a | none | none

:CALCulate:CDMA:REVerse:QMARker[:STATe]

Switches the Q marker on/off for the code domain power graph.

  • ON (or 1) -- enables the Qmarker.
  • OFF (or 0) -- disables the Qmarker.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none


:CALCulate:CDMA:REVerse:QOFFset?

Reads the Q offset value for a cdma2000 measurement.

Query | Return | Set | Special | Units
yes | NR3 | n/a | none | none


:CALCulate:CDMA:REVerse:RHO

Select a blue link to view the command details:

  • :CALCulate:CDMA:REVerse:RHO?
  • :CALCulate:CDMA:REVerse:RHO:LIMit:FAIL?
  • :CALCulate:CDMA:REVerse:RHO:LIMit:LOWer
  • :CALCulate:CDMA:REVerse:RHO:LIMit[:STATe]

:CALCulate:CDMA:REVerse:RHO?
  • Queries the total power value for cdma2000 measurement.
Query | Return | Set | Special | Units
yes | NR3 | n/a | none | none

:CALCulate:CDMA:REVerse:RHO:LIMit:FAIL?

Reads the fail status of the rho limit test. This command is an alternate to :CALCulate:CDMA:REVerse:LIMit:RHO:FAIL.

  • 1 = failure
  • 0 = no failure; not the same as pass
Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:CDMA:REVerse:RHO:LIMit:LOWer

Sets the limit value for the rho measurement. This command is an alternate to :CALCulate:CDMA:REVerse:LIMit:RHO:LOWer.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | none

:CALCulate:CDMA:REVerse:RHO:LIMit[:STATe]

Enables and disables the limit testing for the rho measurement. This command is an alternate to :CALCulate:CDMA:REVerse:LIMit:RHO[;STATe].

  • ON (or 1) -- enables the limit testing.
  • OFF (or 0) -- disables the limit testing.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none


:CALCulate:CDMA:REVerse:SEMask:LIMit

Select a blue link to view the command details:

  • :CALCulate:CDMA:REVerse:SEMask:LIMit:FAIL?
  • :CALCulate:CDMA:REVerse:SEMask:LIMit:MARGin
  • :CALCulate:CDMA:REVerse:SEMask:LIMit[:STATe]

:CALCulate:CDMA:REVerse:SEMask:LIMit:FAIL?

Reads the fail status of the spectrum emission mask measurement. A returned "1" indicates that the data is tested and failed, or no data was tested, or the limit state is off. A returned "0" indicates that data is tested and passed.

  • 1 = failure
  • 0 = no failure; not the same as passed
Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:CDMA:REVerse:SEMask:LIMit:MARGin

Set the margin for the spectrum emission limit test. This margin is added to the default limit values for each frequency as derived from the cdma2000 standard.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | dB

:CALCulate:CDMA:REVerse:SEMask:LIMit[:STATe]

Enables and disables the spectrum emission mask limit test.

  • 1 = enabled
  • 0 = disabled
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none


:CALCulate:DATA:VALid?

Queries the completion of a measurement. If the measurement has completed successfully, a "1" is returned. If the measurement has not completed successfully, a "0" is returned.

It is recommended that you start a measurement sweep with the following command message:

:INIT:IMM; *WAI; :CALC:DATA:VALID?

This command message causes the instrument to take a sweep and if a "1" is returned, then you can proceed to read the data. If a "0" is returned, then you know that the measurement failed to lock on the burst/carrier and there is no data to read.

Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none


:CALCulate:EDGE

Select a blue link to view the command details:

  • :CALCulate:EDGE:CONStellation
  • :CALCulate:EDGE:CPOWer
  • :CALCulate:EDGE:EVECtors:DATA
  • :CALCulate:EDGE:EVM:DATA?
  • :CALCulate:EDGE:EVM:LIMit
  • :CALCulate:EDGE:EVMTrace:DATA
  • :CALCulate:EDGE:IQData:DATA
  • :CALCulate:EDGE:LIMit:FAIL?
  • :CALCulate:EDGE:ORFS:MODulation
  • :CALCulate:EDGE:ORFS:SWITching
  • :CALCulate:EDGE:SYMBols:DATA
  • :CALCULATE:EDGE:TMASk


:CALCulate:EDGE:CONStellation

Select a blue link to view the command details:

  • :CALCulate:EDGE:CONStellation:DATA:X?
  • :CALCulate:EDGE:CONStellation:DATA[:Y]?

:CALCulate:EDGE:CONStellation:DATA:X?

Reads the real part of the complex points that represent the constellation diagram. You must select the constellation diagram, using :DISP:VIEW:EDGE:TYPE. Returns ASCII, Real 32, Real 64. The data type follows the :FORMat command.

Query | Return | Set | Special | Units
yes | ascii| hexadecimal| octal| binary | n/a | none | none

:CALCulate:EDGE:CONStellation:DATA[:Y]?

Reads the imaginary part of the complex points that represent the constellation diagram. You must select the constellation diagram, using :DISP:VIEW:EDGE:TYPE. Returns ASCII, Real 32, Real 64. The data type follows the :FORMat command.

Query | Return | Set | Special | Units
yes | ascii| hexadecimal| octal| binary | n/a | none | none


:CALCulate:EDGE:CPOWer

Select a blue link to view the command details:

  • :CALCulate:EDGE:CPOWer:DATA?
  • :CALCulate:EDGE:CPOWer:LIMit:FAIL?
  • :CALCulate:EDGE:CPOWer:LIMit:FCOunt?
  • :CALCulate:EDGE:CPOWer:LIMit:MARGin?
  • :CALCulate:EDGE:CPOWer:LIMit:MIN
  • :CALCulate:EDGE:CPOWer:LIMit:STATus?
  • :CALCulate:EDGE:CPOWer:LIMit[:MAX]

:CALCulate:EDGE:CPOWer:DATA?

Reads the channel power in dBm and returns a single ASCII value.

Query | Return | Set | Special | Units
yes | NR2 | n/a | none | dBm

:CALCulate:EDGE:CPOWer:LIMit:FAIL?

Reads the channel power limit test failure status. A single Boolean value is returned: true indicates the channel power exceeded the limits, false indicates a pass or no limit was applied to the test.

  • 1 = failure
  • 0 = pass or no limit applied
Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:EDGE:CPOWer:LIMit:FCOunt?

Reads the number of measured values in the EDGE channel power data block that failed the limit test. A value of zero indicates the device under test passed all of the limits in the test.

  • -1 = no limit was applied
  • 0 = passed all limits
  • positive value = number of failures
Query | Return | Set | Special | Units
yes | NR1 | n/a | none | none

:CALCulate:EDGE:CPOWer:LIMit:MARGin?

Returns one margin per measured value that appears in the data table. The returned array is same length as returned from EDGE:EVM:DATA? query.

  • 0 = no limit is applied
  • positive value = margin
  • negative value = failed limit margin
Query | Return | Set | Special | Units
yes | NR2 | n/a | none | none

:CALCulate:EDGE:CPOWer:LIMit:MIN

Sets the minimum channel power in dBm. If the value is set to -200, the limit is not applied to the test. When you choose the limit value, you should take into account both the fixture loss and the measurement uncertainty. Default = -200 dBm (disabled).

Query | Return | Set | Special | Units
yes | NR2 | [-200...100] | Max | Min | Def | dBm

:CALCulate:EDGE:CPOWer:LIMit:STATus?

Reads if the channel power limit test is enabled.

  • 1 = limit is applied
  • 0 = no limit is applied
Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:EDGE:CPOWer:LIMit[:MAX]

Sets the maximum channel power in dBm. If the value is set to 200, the limit is not applied to the test. Default = +200 dBm (disabled).

Query | Return | Set | Special | Units
yes | NR2 | [-100...200] | Max | Min | Def | dBm


:CALCulate:EDGE:EVECtors:DATA

Select a blue link to view the command details:

  • :CALCulate:EDGE:EVECtors:DATA:X?
  • :CALCulate:EDGE:EVECtors:DATA[:Y]?

:CALCulate:EDGE:EVECtors:DATA:X?

Reads the real part of the complex error vectors for the 142 decision points that are in useful part of burst. You must select the EVM trace or constellation diagram, using :DISP:VIEW:EDGE:TYPE. Returns ASCII, Real 32, Real 64.The data type follows :FORMat command.

Query | Return | Set | Special | Units
yes | ascii| hexadecimal| octal| binary | n/a | none | none

:CALCulate:EDGE:EVECtors:DATA[:Y]?

Reads the imaginary part of the complex error vectors for the 142 decision points that are in useful part of burst. You must select the EVM trace or constellation diagram, using :DISP:VIEW:EDGE:TYPE. Returns ASCII, Real 32, Real 64.The data type follows :FORMat command.

Query | Return | Set | Special | Units
yes | ascii| hexadecimal| octal| binary | n/a | none | none


:CALCulate:EDGE:EVM:DATA?

Reads the EVM measurement data. Returns comma-separated values (CSV).

If the measurement completed successfully, the following are returned:

  • RMS EVM in %
  • peak EVM in %
  • 95 percentile EVM
  • carrier frequency offset in Hz
  • IQ gain error in dB
  • IQ origin offset in dB
  • droop in dB/burst

If the measurement did not complete successfully, a blank string is returned.

Query | Return | Set | Special | Units
yes | string | n/a | none | none


:CALCulate:EDGE:EVM:LIMit

Select a blue link to view the command details:

  • :CALCulate:EDGE:EVM:LIMit:FAIL?
  • :CALCulate:EDGE:EVM:LIMit:FCOunt?
  • :CALCulate:EDGE:EVM:LIMit:FREQ
  • :CALCulate:EDGE:EVM:LIMit:MARGin?
  • :CALCulate:EDGE:EVM:LIMit:NFIVe
  • :CALCulate:EDGE:EVM:LIMit:OFFSet
  • :CALCulate:EDGE:EVM:LIMit:PEAK
  • :CALCulate:EDGE:EVM:LIMit:RMS
  • :CALCulate:EDGE:EVM:LIMit:STATus?

:CALCulate:EDGE:EVM:LIMit:FAIL?

Reads the failure status of the measured values returned by the :CALCulate:EDGE:EVM:DATA? query. The values are returned as a Boolean array. You must also query the status of the limit test to separate an actual failure from the situation of no limit being applied during the test.

  • 1 = failure
  • 0 = pass or no limit applied
Query | Return | Set | Special | Units
yes | Boolean,..., Boolean | n/a | none | none

:CALCulate:EDGE:EVM:LIMit:FCOunt?

Reads the number of measured values in the EDGE EVM data block that failed the limit test. A value of zero indicates the device under test passed all of the limits in the test. A value of -1 indicates that none of the limits were applied during the test.

  • -1 = no limit was applied
  • 0 = passed all limits
  • positive value = number of failures
Query | Return | Set | Special | Units
yes | NR1 | n/a | none | none

:CALCulate:EDGE:EVM:LIMit:FREQ

Sets the limit value for the largest frequency error, expressed in parts per million.

Query | Return | Set | Special | Units
yes | NR2 | [0...1000] | Max | Min | Def | ppm

:CALCulate:EDGE:EVM:LIMit:MARGin?

Reads the frequency error limit test and returns a margin value for each of the measured values returned from the :CALCulation:EDGE:EVM:DATA? query. A zero indicates that no limit is applied during the test. A negative margin indicates a failed limit.

Query | Return | Set | Special | Units
yes | NR2 | n/a | none | none

:CALCulate:EDGE:EVM:LIMit:NFIVe

Sets the limit value for the 95 percentile frequency error, expressed in percent.

Query | Return | Set | Special | Units
yes | NR2 | [0...100] | Max | Min | Def | %

:CALCulate:EDGE:EVM:LIMit:OFFSet

Sets the limit value for the origin offset, expressed in decibels.

Query | Return | Set | Special | Units
yes | NR2 | [-200...200] | Max | Min | Def | dB

:CALCulate:EDGE:EVM:LIMit:PEAK

Sets the upper limit value for the error vector magnitude peak, expressed in percent.

Query | Return | Set | Special | Units
yes | NR2 | [0...100] | Max | Min | Def | %

:CALCulate:EDGE:EVM:LIMit:RMS

Sets the upper limit value for the RMS error vector magnitude, expressed in percent.

Query | Return | Set | Special | Units
yes | NR2 | [0...100] | Max | Min | Def | %

:CALCulate:EDGE:EVM:LIMit:STATus?

Returns an array, indicating if limits were enabled. One element is returned for each value returned by the :CALCulate:EDGE:EVM:DATA? query.

  • 1 = limit is applied
  • 0 = no limit is applied
Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none


:CALCulate:EDGE:EVMTrace:DATA

Select a blue link to view the command details:

  • :CALCulate:EDGE:EVMTrace:DATA:X?
  • :CALCulate:EDGE:EVMTrace:DATA[:Y]?

:CALCulate:EDGE:EVMTrace:DATA:X?

Returns the x axis data, in seconds, that is associated with the EVM trace. Returns ASCII, Real 32, Real 64. The data type follows the :FORMat command.

Query | Return | Set | Special | Units
yes | ascii| hexadecimal| octal| binary | n/a | none | none

:CALCulate:EDGE:EVMTrace:DATA[:Y]?

Reads the EVM data in percent and returns an array, corresponding to the EVM trace selection. You must select the EVM trace using :DISP:VIEW:EDGE:TYPE EVM. Returns ASCII, Real 32, Real 64. The data type follows the :FORMat command.

Query | Return | Set | Special | Units
yes | ascii| hexadecimal| octal| binary | n/a | none | none


:CALCulate:EDGE:IQData:DATA

Select a blue link to view the command details:

  • :CALCulate:EDGE:IQData:DATA:X?
  • :CALCulate:EDGE:IQData:DATA[:Y]?

:CALCulate:EDGE:IQData:DATA:X?

Reads the real part of the IQ data sampled at 1.625 MHz (6 samples per symbol). You must select the constellation diagram, using :DISP:VIEW:EDGE:TYPE CONST. Returns ASCII, Real 32, Real 64. The data type follows :FORMat command.

Query | Return | Set | Special | Units
yes | ascii| hexadecimal| octal| binary | n/a | none | none

:CALCulate:EDGE:IQData:DATA[:Y]?

Reads the imaginary part of the IQ data sampled at 1.625 MHz (6 samples per symbol). You must select the constellation diagram, using :DISP:VIEW:EDGE:TYPE CONST. Returns ASCII, Real 32, Real 64. The data type follows :FORMat command.

Query | Return | Set | Special | Units
yes | ascii| hexadecimal| octal| binary | n/a | none | none


:CALCulate:EDGE:LIMit:FAIL?

Reads the EDGE limit test and returns "1" if at least one EDGE measurement failed or "0" if all passed. You must also query the status of the limit test to separate an actual failure from the situation of no limit being applied during the test.

  • 1 = at least one failure
  • 0 = all passed
Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none


:CALCulate:EDGE:ORFS:MODulation

Select a blue link to view the command details:

  • :CALCulate:EDGE:ORFS:MODulation:DATA:X?
  • :CALCulate:EDGE:ORFS:MODulation:DATA[:Y]?
  • :CALCulate:EDGE:ORFS:MODulation:LIMit:FAIL?
  • :CALCulate:EDGE:ORFS:MODulation:LIMit:FCOunt?
  • :CALCulate:EDGE:ORFS:MODulation:LIMit:MARGin?
  • :CALCulate:EDGE:ORFS:MODulation:LIMit:STATus?
  • :CALCulate:EDGE:ORFS:MODulation:REFerence?

:CALCulate:EDGE:ORFS:MODulation:DATA:X?

Returns the frequency offsets used to measure ORFS due to modulation, from largest negative offset to largest positive. Use the :CALC:ORFS:MOD:REF? command to convert the offset to dBm.Returns ASCII, Real 32, Real 64. The return data format follows the :FORMat command.

Query | Return | Set | Special | Units
yes | ascii| hexadecimal| octal| binary | n/a | none | none

:CALCulate:EDGE:ORFS:MODulation:DATA[:Y]?

Reads the ORFS due to modulation data in dBc, from largest negative offset to largest positive. Returns ASCII, Real 32, Real 64. The return data format follows the :FORMat command.

Query | Return | Set | Special | Units
yes | ascii| hexadecimal| octal| binary | n/a | none | none

:CALCulate:EDGE:ORFS:MODulation:LIMit:FAIL?

Reads the ORFS due to modulation and returns an array, one element per offset frequency. You must also query the status of the limit test to separate an actual failure from the situation of no limit being applied during the test.

  • 1 = failure
  • 0 = pass or no limit applied
Query | Return | Set | Special | Units
yes | Boolean,..., Boolean | n/a | none | none

:CALCulate:EDGE:ORFS:MODulation:LIMit:FCOunt?

Reads the number of measured values that failed the limit test.

  • -1 = no limit was applied
  • 0 = passed all limits
  • positive value = number of failures
Query | Return | Set | Special | Units
yes | NR1 | n/a | none | none

:CALCulate:EDGE:ORFS:MODulation:LIMit:MARGin?

Reads the margin with which the ORFS due to modulation passed the limit test and returns an array, one element per offset. The returned values are the worst case. A negative margin indicates a failed limit.

  • 0 = no limit is applied
  • positive value = margin
  • negative value = failed limit
Query | Return | Set | Special | Units
yes | NR2 | n/a | none | none

:CALCulate:EDGE:ORFS:MODulation:LIMit:STATus?

Reads if the ORFS due to modulation limit test is applied and returns an array, one element per offset.

  • 1 = limit is applied
  • 0 = no limit is applied
Query | Return | Set | Special | Units
yes | NR2,..., NR2 | n/a | none | none

:CALCulate:EDGE:ORFS:MODulation:REFerence?

Returns the measured power in dBm at the 0 Hz offset. You can also use this value to convert ORFS values from dBc to dBm.

Query | Return | Set | Special | Units
yes | NR2 | n/a | none | dBm


:CALCulate:EDGE:ORFS:SWITching

Select a blue link to view the command details:

  • :CALCulate:EDGE:ORFS:SWITching:DATA:X?
  • :CALCulate:EDGE:ORFS:SWITching:DATA[:Y]?
  • :CALCulate:EDGE:ORFS:SWITching:LIMit:FAIL?
  • :CALCulate:EDGE:ORFS:SWITching:LIMit:FCOunt?
  • :CALCulate:EDGE:ORFS:SWITching:LIMit:MARGin?
  • :CALCulate:EDGE:ORFS:SWITching:LIMit:STATus?
  • :CALCulate:EDGE:ORFS:SWITching:REFerence?

:CALCulate:EDGE:ORFS:SWITching:DATA:X?

Returns the offsets where the ORFS was measured. These offset values correspond to the data values in the DATA? query. Returns ASCII, Real 32, Real 64. The return data format follows the :FORMat command.

Query | Return | Set | Special | Units
yes | ascii| hexadecimal| octal| binary | n/a | none | none

:CALCulate:EDGE:ORFS:SWITching:DATA[:Y]?

Reads the ORFS due to switching data in dBc, from largest negative offset to largest positive. Use the :CALC:EDDGE:ORFS:SWIT:REF? to convert to dBm. Returns ASCII, Real 32, Real 64. The return data format follows the :FORMat command.

Query | Return | Set | Special | Units
yes | ascii| hexadecimal| octal| binary | n/a | none | none

:CALCulate:EDGE:ORFS:SWITching:LIMit:FAIL?

Reads the ORFS due to switching and returns an array, one element per offset frequency. You must also query the status of the limit test to separate an actual failure from the situation of no limit being applied during the test.

  • 1 = failure
  • 0 = pass or no limit applied
Query | Return | Set | Special | Units
yes | Boolean,..., Boolean | n/a | none | none

:CALCulate:EDGE:ORFS:SWITching:LIMit:FCOunt?

Returns an ASCII integer representing the number of offsets that failed.

  • -1 = no limit was applied
  • 0 = passed all limits
  • positive value = number of failures
Query | Return | Set | Special | Units
yes | NR1 | n/a | none | none

:CALCulate:EDGE:ORFS:SWITching:LIMit:MARGin?

Reads the ORFS due to switching limit test and returns an array, one element per offset frequency. The returned values are the measured worst case.

  • 0 = no limit is applied
  • positive value = margin
  • negative value = failed limit

A negative value indicates a failed limit test.

Query | Return | Set | Special | Units
yes | NR2,..., NR2 | n/a | none | none

:CALCulate:EDGE:ORFS:SWITching:LIMit:STATus?

Reads if the ORFS due to switching limit test is applied and returns an array, one element per offset frequency.

  • 1 = limit is applied
  • 0 = no limit is applied
Query | Return | Set | Special | Units
yes | Boolean,..., Boolean | n/a | none | none

:CALCulate:EDGE:ORFS:SWITching:REFerence?

Returns a single ASCII floating point value, the power in dBm measured at zero offset frequency. You can also use this value to convert ORFS values from dBc to dBm.

Query | Return | Set | Special | Units
yes | NR2 | n/a | none | none


:CALCulate:EDGE:SYMBols:DATA

Select a blue link to view the command details:

  • :CALCulate:EDGE:SYMBols:DATA:X?
  • :CALCulate:EDGE:SYMBols:DATA[:Y]?

:CALCulate:EDGE:SYMBols:DATA:X?

Returns the X axis associated with :CALC:EDGE:SYMBOLS:DATA? command (ASCII, Real 32, Real 64). The data type follows the :FORMat command.

Query | Return | Set | Special | Units
yes | ascii| hexadecimal| octal| binary | n/a | none | none

:CALCulate:EDGE:SYMBols:DATA[:Y]?

Returns the symbols trace, 282 points (2*142 - 2). To create the staircase appearance, each value is repeated twice, except for the first and last symbol. The Symbols trace must be selected with DISP:VIEW:EDGE:TYPE SYM. Returns ASCII, Real 32, Real 64. Data type follows the :FORMat command.

Query | Return | Set | Special | Units
yes | ascii| hexadecimal| octal| binary | n/a | none | none


:CALCulate:EDGE:TMASk

Select a blue link to view the command details:

  • :CALCulate:EDGE:TMASk:DATA:X?
  • :CALCulate:EDGE:TMASk:DATA[:Y]?
  • :CALCulate:EDGE:TMASk:LIMit
  • :CALCulate:EDGE:TMASk:LIMit:FAIL?
  • :CALCulate:EDGE:TMASk:LIMit:FCOunt?
  • :CALCulate:EDGE:TMASk:LIMit:MARGin?
  • :CALCulate:EDGE:TMASk:LIMit:STATus?

:CALCulate:EDGE:TMASk:DATA:X?

Returns an array of floating point values (ASCII, Real 32, Real 64). The time values correspond to the time mask data from the :CALCulate:EDGE:TMASk:DATA? query. The return data type follows the :FORMat command.

Query | Return | Set | Special | Units
yes | NR2,..., NR2 | n/a | none | none

:CALCulate:EDGE:TMASk:DATA[:Y]?

Returns an array of floating point values. The time mask is in dBm. The return data type follows the :FORMat command: binary or ASCII.

Query | Return | Set | Special | Units
yes | NR2,..., NR2 | n/a | none | none

:CALCulate:EDGE:TMASk:LIMit

Accepts a time mask limit table as a comma-separated list. Specifies a 2-D file to load. Sets the filename and path for the selected file. You can optionally specify the file extension (*.tml). The file is in the following form: time, max dBc, max dBm, min dBc,..., time, max dBc, max dBm, min dBc.

Note: The EDGE standards specifies both relative (dBc) and absolute (dBm) limits. You should use absolute limits with caution because the EDGE standard states that the device will pass a limit test even if it only meets one of the limits specified (absolute or relative). For example, if you enter an absolute limit without accounting for the fixture loss, devices that do not meet the specification will appear to pass the test.

Query | Return | Set | Special | Units
yes | NR2 | n/a | none | none

:CALCulate:EDGE:TMASk:LIMit:FAIL?

Reads the time mask limit test and returns an array of three elements that correspond to the rising, middle, and falling portions of the time mask. You must also query the status of the limit test to separate an actual failure from the situation of no limit being applied during the test.

  • 1 = failure
  • 0 = pass or no limit applied
Query | Return | Set | Special | Units
yes | Boolean, Boolean, Boolean | n/a | none | none

:CALCulate:EDGE:TMASk:LIMit:FCOunt?

Returns an integer, indicating how many of the three parts of the time mask failed.

  • -1 = no limit was applied
  • 0 = passed all limits
  • positive value = number of failures
Query | Return | Set | Special | Units
yes | NR1 | n/a | none | none

:CALCulate:EDGE:TMASk:LIMit:MARGin?

Reads the time mask limit test and returns an array of three elements that correspond to the rising, middle, and falling portions of the time mask. The returned values are the measured worst case.

  • 0 = no limit is applied
  • positive value = margin
  • negative value = failed limit
Query | Return | Set | Special | Units
yes | NR2 | n/a | none | none

:CALCulate:EDGE:TMASk:LIMit:STATus?

Reads if the time mask limit test is applied and returns an array of three elements that correspond to the rising, middle, and falling portions of the time mask.

  • 1 = limit is applied
  • 0 = no limit is applied
Query | Return | Set | Special | Units
yes | Boolean, Boolean, Boolean | n/a | none | none


:CALCulate:GSM

Select a blue link to view the command details:

  • :CALCulate:GSM:CPOWer
  • :CALCulate:GSM:LIMit:FAIL?
  • :CALCulate:GSM:ORFS:MODulation
  • :CALCulate:GSM:ORFS:SWITching
  • :CALCulate:GSM:PERRor
  • :CALCulate:GSM:SYMBols:DATA
  • CALCulate:GSM:TMASk


:CALCulate:GSM:CPOWer

Select a blue link to view the command details:

  • :CALCulate:GSM:CPOWer:DATA?
  • :CALCulate:GSM:CPOWer:LIMit:FAIL?
  • :CALCulate:GSM:CPOWer:LIMit:FCOUnt?
  • :CALCulate:GSM:CPOWer:LIMit:MARGin?
  • :CALCulate:GSM:CPOWer:LIMit:MIN
  • :CALCulate:GSM:CPOWer:LIMit:STATus?
  • :CALCulate:GSM:CPOWer:LIMit[:MAX]

:CALCulate:GSM:CPOWer:DATA?

Reads the channel power in dBm and returns the actual value measured.

Query | Return | Set | Special | Units
yes | NR2 | n/a | none | dBm

:CALCulate:GSM:CPOWer:LIMit:FAIL?

Reads the channel power in dBm and returns the actual value measured. You must also query the status of the limit test to separate an actual failure from the situation of no limit being applied during the test.

  • 1 = failure
  • 0 = pass or no limit applied
Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:GSM:CPOWer:LIMit:FCOUnt?

Returns the number of measured values that failed the channel power limit test.

  • -1 = no limit was applied
  • 0 = passed all limits
  • positive value = number of failures
Query | Return | Set | Special | Units
yes | NR1 | n/a | none | none

:CALCulate:GSM:CPOWer:LIMit:MARGin?

Reads the channel power in dBm and returns the value of the measured worst case.

  • 0 = no limit is applied
  • positive value = margin
  • negative value = failed limit
Query | Return | Set | Special | Units
yes | NR2 | n/a | none | none

:CALCulate:GSM:CPOWer:LIMit:MIN

Sets the smallest acceptable channel power value, in dBm. If you select a value of -200, the limit is ignored.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | dBm

:CALCulate:GSM:CPOWer:LIMit:STATus?

Reads if the channel power limit test is applied.

  • 1 = limit is applied
  • 0 = no limit is applied
Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:GSM:CPOWer:LIMit[:MAX]

Sets the largest acceptable channel power value, in dBm. If you select a value of +200, the limit is ignored.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | dBm


:CALCulate:GSM:LIMit:FAIL?

Reads the GSM limit test and returns "1" if at least one GSM measurement failed or "0" if all passed. You must also query the status of the limit test to separate an actual failure from the situation of no limit being applied during the test.

Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none


:CALCulate:GSM:ORFS:MODulation

Select a blue link to view the command details:

  • :CALCulate:GSM:ORFS:MODulation:DATA:X?
  • :CALCulate:GSM:ORFS:MODulation:DATA?
  • :CALCulate:GSM:ORFS:MODulation:LIMit:FAIL?
  • :CALCulate:GSM:ORFS:MODulation:LIMit:FCOunt?
  • :CALCulate:GSM:ORFS:MODulation:LIMit:MARGin?
  • :CALCulate:GSM:ORFS:MODulation:LIMit:STATus?
  • :CALCulate:GSM:ORFS:MODulation:REFerence?

:CALCulate:GSM:ORFS:MODulation:DATA:X?

Returns the offsets where the ORFS was measured (ASCII, Real 32, Real 64). These offset values correspond to the data values in the DATA? query. The return data format follows the :FORMat command.

Query | Return | Set | Special | Units
yes | ascii| hexadecimal| octal| binary | n/a | none | Hz

:CALCulate:GSM:ORFS:MODulation:DATA[:Y]?

Reads the ORFS due to modulation data in dBc, from largest negative offset to largest positive (ASCII, Real 32, Real 64). Use the :CALC:GSM:ORFS:MOD:REF? command to convert the data to dBm. The return data format follows the :FORMat command.

Query | Return | Set | Special | Units
yes | ascii| hexadecimal| octal| binary | n/a | none | dBc

:CALCulate:GSM:ORFS:MODulation:LIMit:FAIL?

Reads the ORFS due to modulation and returns an array, one element per entry in the data table. You must also query the status of the limit test to separate an actual failure from the situation of no limit being applied during the test.

  • 1 = failure
  • 0 = pass or no limit applied
Query | Return | Set | Special | Units
yes | Boolean,... Boolean | n/a | none | none

:CALCulate:GSM:ORFS:MODulation:LIMit:FCOunt?

Returns an ASCII integer, indicating the number of offsets that failed.

  • -1 = no limit was applied
  • 0 = passed all limits
  • positive value = number of failures
Query | Return | Set | Special | Units
yes | NR1 | n/a | none | none

:CALCulate:GSM:ORFS:MODulation:LIMit:MARGin?

Reads the ORFS due to modulation limit test and returns an array, one element per entry in the data table. The returned values are the measured worst case.

  • 0 = no limit is applied
  • positive value = margin
  • negative value = failed limit
Query | Return | Set | Special | Units
yes | NR2 | n/a | none | none

:CALCulate:GSM:ORFS:MODulation:LIMit:STATus?

Reads if the ORFS due to modulation limit test is applied and returns one element per entry in the data table.

  • 1 = limit is applied
  • 0 = no limit is applied
Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:GSM:ORFS:MODulation:REFerence?

Returns a single ASCII floating point value, the power in dBm measured at zero offset frequency. You can also use this command to convert a data trace from dBc to dBm.

Query | Return | Set | Special | Units
yes | NR2 | n/a | none | none


:CALCulate:GSM:ORFS:SWITching

Select a blue link to view the command details:

  • :CALCulate:GSM:ORFS:SWITching:DATA:X?
  • :CALCulate:GSM:ORFS:SWITching:DATA[:Y]?
  • :CALCulate:GSM:ORFS:SWITching:LIMit:FAIL?
  • :CALCulate:GSM:ORFS:SWITching:LIMit:FCOunt?
  • :CALCulate:GSM:ORFS:SWITching:LIMit:MARGin?
  • :CALCulate:GSM:ORFS:SWITching:LIMit:STATus?
  • :CALCulate:GSM:ORFS:SWITching:REFerence?

:CALCulate:GSM:ORFS:SWITching:DATA:X?

Returns the offsets in Hz where the ORFS was measured (ASCII, Real 32, Real 64). These offset values correspond to the data values in the DATA? query. The return data format follows the :FORMat command.

Query | Return | Set | Special | Units
yes | ascii| hexadecimal| octal| binary | n/a | none | Hz

:CALCulate:GSM:ORFS:SWITching:DATA[:Y]?

Reads the ORFS due to switching data in dBc, from largest negative offset to largest positive (ASCII, Real 32, Real 64). Use the :CALC:GSM:ORFS:SWIT:REF? command to convert the data to dBm. The return data format follows the :FORMat command.

Query | Return | Set | Special | Units
yes | ascii| hexadecimal| octal| binary | n/a | none | dBc

:CALCulate:GSM:ORFS:SWITching:LIMit:FAIL?

Reads the ORFS due to switching and returns one element per entry in the data table. You must also query the status of the limit test to separate an actual failure from the situation of no limit being applied during the test.

  • 1 = failure
  • 0 = pass or no limit applied
Query | Return | Set | Special | Units
yes | Boolean,... Boolean | n/a | none | none

:CALCulate:GSM:ORFS:SWITching:LIMit:FCOunt?

Returns an ASCII integer, indicating the number of offsets that failed.

  • -1 = no limit was applied
  • 0 = passed all limits
  • positive value = number of failures
Query | Return | Set | Special | Units
yes | NR1 | n/a | none | none

:CALCulate:GSM:ORFS:SWITching:LIMit:MARGin?

Reads the ORFS due to switching limit test and returns a measured worse case for each entry in the data table.

  • 0 = no limit is applied
  • positive value = margin
  • negative value = failed limit
Query | Return | Set | Special | Units
yes | NR2 | n/a | none | none

:CALCulate:GSM:ORFS:SWITching:LIMit:STATus?

Reads if the ORFS due to switching limit test is applied and returns one element per entry in the data table.

  • 1 = limit is applied
  • 0 = no limit is applied
Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:GSM:ORFS:SWITching:REFerence?

Returns a single ASCII floating point value, the power in dBm measured at zero offset frequency. You can also use this command to convert the data trace from dBc to dBm.

Query | Return | Set | Special | Units
yes | NR2 | n/a | none | dBm


:CALCulate:GSM:PERRor

Select a blue link to view the command details:

  • :CALCulate:GSM:PERRor:DATA?
  • :CALCulate:GSM:PERRor:LIMit:FAIL?
  • :CALCulate:GSM:PERRor:LIMit:FCOunt?
  • :CALCulate:GSM:PERRor:LIMit:FREQ
  • :CALCulate:GSM:PERRor:LIMit:MARGin?
  • :CALCulate:GSM:PERRor:LIMit:PEAK
  • :CALCulate:GSM:PERRor:LIMit:RMS
  • :CALCulate:GSM:PERRor:LIMit:STATus?
  • :CALCulate:GSM:PERRor:PHASe:DATA:X?
  • :CALCulate:GSM:PERRor:PHASe:DATA[:Y]?
  • :CALCulate:GSM:PERRor:TRACe:DATA:X?
  • :CALCulate:GSM:PERRor:TRACe:DATA[:Y]?

:CALCulate:GSM:PERRor:DATA?

Reads the GSM phase error measurement and returns the actual values measured.

If the measurement completed successfully, the following are returned:

  • rms phase error in degrees
  • peak phase error in degrees
  • peak error at bit
  • carrier frequency error in Hz

If the measurement did not complete successfully, a blank string is returned.

Query | Return | Set | Special | Units
yes | NR2, NR2, NR2 | n/a | none | none

:CALCulate:GSM:PERRor:LIMit:FAIL?

Reads the phase error and returns one element per entry in the data table. You must also query the status of the limit test to separate an actual failure from no limit being applied during the test.

  • 1 = failure
  • 0 = pass or no limit applied
Query | Return | Set | Special | Units
yes | Boolean,..., Boolean | n/a | none | none

:CALCulate:GSM:PERRor:LIMit:FCOunt?

Returns the number of measured values that failed the channel power limit test. A value of "0" indicates that all limits passed.

  • -1 = no limit was applied
  • 0 = passed all limits
  • positive value = number of failures
Query | Return | Set | Special | Units
yes | NR1 | n/a | none | none

:CALCulate:GSM:PERRor:LIMit:FREQ

Sets the largest acceptable frequency error, in parts per million.

Query | Return | Set | Special | Units
yes | NR2 | NRf | none | ppm

:CALCulate:GSM:PERRor:LIMit:MARGin?

Reads the phase error and returns the worse case value for each entry in the data table.

  • 0 = no limit is applied
  • positive value = margin
  • negative value = failed limit
Query | Return | Set | Special | Units
yes | NR2 | n/a | none | none

:CALCulate:GSM:PERRor:LIMit:PEAK

Sets the largest acceptable peak phase error, in degrees.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | degrees

:CALCulate:GSM:PERRor:LIMit:RMS

Sets the largest acceptable RMS phase error, in percent.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | degrees

:CALCulate:GSM:PERRor:LIMit:STATus?

Reads if the phase error limit test is applied and returns one element per entry in the data table.

  • 0 = no limit is applied
  • positive value = margin
  • negative value = failed limit
Query | Return | Set | Special | Units
yes | Boolean,..., Boolean | n/a | none | none

:CALCulate:GSM:PERRor:PHASe:DATA:X?

Returns the time access, in seconds, associated with the :CALC:GSM:PERR:PHASE:DATA? query (ASCII, Real 32, Real 64). The return data format follows the :FORMat command.

Query | Return | Set | Special | Units
yes | ascii| hexadecimal| octal| binary | n/a | none | seconds

:CALCulate:GSM:PERRor:PHASe:DATA[:Y]?

Returns an array of floating point values; the unwrapped measured phase as a function of time (ASCII, Real 32, Real 64). You must also send the :DISP:VIEW:GSM:TYPE:MPHASe command to select the correct measurement trace. The return data format follows the :FORMat:DATA command argument.

Query | Return | Set | Special | Units
yes | ascii| hexadecimal| octal| binary | n/a | none | degrees

:CALCulate:GSM:PERRor:TRACe:DATA:X?

Returns an array of floating point values (ASCII, Real 32, Real 64), corresponding to the time axis of the :CALC:GSM:PERR:TRACe:DATA? query. The return data format follows the :FORMat command.

Query | Return | Set | Special | Units
yes | ascii| hexadecimal| octal| binary | n/a | none | seconds

:CALCulate:GSM:PERRor:TRACe:DATA[:Y]?

Returns an array of floating point values, the unwrapped measured phase as a function of time (ASCII, Real 32, Real 64). You must also send the :DISP:VIEW:GSM:TYPE PERRor command to select the correct measurement trace. The return data format follows the :FORMat:DATA command argument.

Query | Return | Set | Special | Units
yes | ascii| hexadecimal| octal| binary | n/a | none | degrees


:CALCulate:GSM:SYMBols:DATA

Select a blue link to view the command details:

  • :CALCulate:GSM:SYMBols:DATA:X?
  • :CALCulate:GSM:SYMBols:DATA[:Y]?

:CALCulate:GSM:SYMBols:DATA:X?

Returns X axis for plotting results from :CALC:GSM:SYMB:DATA? query. Returns ASCII, Real 32, Real 64. The data type follows the :FORMat command.

Query | Return | Set | Special | Units
yes | ascii| hexadecimal| octal| binary | n/a | none | none

:CALCulate:GSM:SYMBols:DATA[:Y]?

Returns a 194 element array (2x148 - 2) with the staircase data symbols trace. Except for the first and last symbol, each value is repeated twice to give a staircase appearance. The Symbol trace must be selected using the :DISP:VIEW:GSM:TYPE command. Returns ASCII, Real 32, Real 64. The returned data type follows the :FORMat command.

Query | Return | Set | Special | Units
yes | ascii| hexadecimal| octal| binary | n/a | none | none


CALCulate:GSM:TMASk

Select a blue link to view the command details:

  • :CALCulate:GSM:TMASkDATA:X?
  • :CALCulate:GSM:TMASk:DATA[:Y]?
  • :CALCulate:GSM:TMASk:LIMit
  • :CALCulate:GSM:TMASk:LIMit:FAIL?
  • :CALCulate:GSM:TMASk:LIMit:FCOunt?
  • :CALCulate:GSM:TMASk:LIMit:MARGin?
  • :CALCulate:GSM:TMASk:LIMit:STATus?

:CALCulate:GSM:TMASk:DATA:X?

Returns an array of floating 992 point values, the time values corresponding to the time mask (ASCII, Real 32, Real 64). The return data type follows the :FORMat command.

Query | Return | Set | Special | Units
yes | ascii| hexadecimal| octal| binary | n/a | none | seconds

:CALCulate:GSM:TMASk:DATA[:Y]?

Returns array of 992 floating point values, the time mask in dBm (ASCII, Real 32, Real 64). The return data type follows the :FORMat command.

Query | Return | Set | Special | Units
yes | ascii| hexadecimal| octal| binary | n/a | none | dBm

:CALCulate:GSM:TMASk:LIMit

Accepts a time mask limit table as a comma-separated list. Specifies a 2-D file to load. Sets the filename and path for the selected file. You can optionally specify the file extension (*.csv). The file is in the following form: time, max dBc, max dBm, min dBc,..., time, max dBc, max dBm, min dBc.

Note: The GSM standard specifies both relative (dBc) and absolute (dBm) limits. You should use absolute limits with caution because the GSM standard states that the device will pass a limit test even if it only meets one of the limits specified (absolute or relative). For example, if you enter an absolute limit without accounting for the fixture loss, devices that do not meet the specification will appear to pass the test.

Query | Return | Set | Special | Units
yes | NR2 | n/a | none | none

:CALCulate:GSM:TMASk:LIMit:FAIL?

Reads the time mask limit test and returns an array of three elements that correspond to rising, middle and falling portions of the time mask. You must also query the status of the limit test to separate an actual failure from the situation of no limit being applied during the test.

  • 1 = failure
  • 0 = pass or no limit applied
Query | Return | Set | Special | Units
yes | Boolean, Boolean, Boolean | n/a | none | none

:CALCulate:GSM:TMASk:LIMit:FCOunt?

Returns an integer, indicating how many of the three parts of the time mask failed.

  • -1 = no limit was applied
  • 0 = passed all limits
  • positive value = number of failures
Query | Return | Set | Special | Units
yes | NR1 | n/a | none | none

:CALCulate:GSM:TMASk:LIMit:MARGin?

Reads the time mask limit test and returns the measured worst case for rising, middle and falling values.

  • 0 = no limit is applied
  • positive value = margin
  • negative value = failed limit
Query | Return | Set | Special | Units
yes | NR2 | n/a | none | none

:CALCulate:GSM:TMASk:LIMit:STATus?

Reads if the time mask limit test is applied to the rising, middle and falling values.

  • 1 = limit is applied
  • 0 = no limit is applied
Query | Return | Set | Special | Units
yes | Boolean, Boolean, Boolean | n/a | none | none


:CALCulate:MARKer

Select a blue link to view the command details:

  • :CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:DELTa:ZERO
  • :CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:DELTa[:STATe]
  • :CALCulate:MARKer:EXCursion
  • :CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:FUNCtion:CENTer
  • :CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:FUNCtion:REFerence
  • :CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum
  • :CALCulate:MARKer:THReshold
  • :CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:X
  • :CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:X:DELTa
  • :CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:Y?
  • :CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:Y:DELTa:?
  • :CALCulate:MARKer1|MARKer2|MARKer3|MARKer4[:STATe]


:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:DELTa:ZERO

Sets specified marker and the associated delta marker to the same X/Y location.

Query | Return | Set | Special | Units
no | n/a | n/a | none | none


:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:DELTa[:STATe]

Sets the state of the delta marker associated with the specified marker. FPOint - sets the delta marker that is associated with selected marker to fixed point. TRACking - sets the delta marker that is associated with the selected marker to tracking.

Query | Return | Set | Special | Units
yes | OFF| TRACking| FPOint | OFF| TRACking| FPOint | Default | none


:CALCulate:MARKer:EXCursion

Sets the excursion factor used for marker peak searches. The difference in amplitude between the peak and a data point on each side of the peak must be greater than or equal to the excursion factor.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | dB


:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:FUNCtion:CENTer

Sets the center frequency to the X-axis value of the specified marker.

Query | Return | Set | Special | Units
no | n/a | n/a | none | none


:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:FUNCtion:REFerence

Sets the reference level to the Y-axis value of the specified marker.

Query | Return | Set | Special | Units
no | n/a | n/a | none | none


:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum

Select a blue link to view the command details:

  • :CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:LEFT
  • :CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:NEXT
  • :CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:PREVious
  • :CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:RIGHt
  • :CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum[:PEAK]

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:LEFT

Sets the specified marker to the top of the nearest peak that is left of the marker's current X-axis position.

Query | Return | Set | Special | Units
yes | n/a | n/a | none | none

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:NEXT

Sets the specified marker to the top of the next largest peak below the marker's current Y-axis value.

Query | Return | Set | Special | Units
no | n/a | n/a | none | none

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:PREVious

Sets the specified marker to the top of the smallest peak above the marker's current Y-axis value.

Query | Return | Set | Special | Units
no | n/a | n/a | none | none

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum:RIGHt

Sets the specified marker to the top of the nearest peak that is right of the marker's current X-axis position.

Query | Return | Set | Special | Units
no | n/a | <NA | none | none

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:MAXimum[:PEAK]

Sets the specified marker to the position of the maximum value on the displayed measurement trace.

Query | Return | Set | Special | Units
no | n/a | n/a | none | none


:CALCulate:MARKer:THReshold

Sets the threshold used for marker peak searches. The amplitude at a peak must be greater than or equal to the threshold.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | dBm


:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:X

Sets the X-axis position of the specified marker.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | none


:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:X:DELTa

Sets the X-axis delta value between the specified marker and its associated delta marker.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | none


:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:Y?

Reads the Y-axis value of the specified marker.

Note: If a marker is positioned outside the current measurement data range, or if there is no measurement data, the marker query returns a special value (9.91e37) to indicate non data is available. This value 9.91e37 happens to be "Not a Number" (NaN) for 32-bit floating point values.

Query | Return | Set | Special | Units
yes | NR2 | n/a | none | none


:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:Y:DELTa:?

Reads the Y-axis value of the delta marker relative to the associated marker.

Note: If a marker is positioned outside the current measurement data range, or if there is no measurement data, the marker query returns a special value (9.91e37) to indicate non data is available. This value 9.91e37 happens to be "Not a Number" (NaN) for 32-bit floating point values.

Query | Return | Set | Special | Units
yes | NR3 | n/a | none | none


:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4[:STATe]

Switches the specified marker on and off. The off state also applies to the delta marker associated with the specified marker.

  • ON (or 1) - switches on Marker
  • OFF (or 0) - switches off Marker and the delta marker associated with Marker
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none


:CALCulate:WCDMa:DOWNlink

Select a blue link to view the command details:

  • :CALCulate:WCDMa:DOWNlink:ACHannels
  • :CALCulate:WCDMa:DOWNlink:ACLR:LIMIT
  • :CALCulate:WCDMa:DOWNlink:EVM
  • :CALCulate:WCDMa:DOWNlink:FERRor
  • :CALCulate:WCDMa:DOWNlink:IOFFset
  • :CALCulate:WCDMa:DOWNlink:IQOFfset
  • :CALCulate:WCDMa:DOWNlink:MARker
  • :CALCulate:WCDMa:DOWNlink:OBWidth
  • :CALCulate:WCDMa:DOWNlink:PCDE
  • :CACLulate:WCDMa:DOWNlink:QOFFset
  • :CALCulate:WCDMa:DOWNlink:SEMask
  • :CALCulate:WCDMa:DOWNlink:TPOWer

:CALCulate:WCDMa:DOWNlink:ACHannels

Queries data for active channels. Return format is no,<channel data for each of the N active channels>. Channel data is {I|Q}, <SpreadFactor>, <CodeNumber>, <ChannelAmplitude>.

Query | Return | Set | Special | Units
yes | NR1, NR3,..., NR3 | n/a | none | none


:CALCulate:WCDMa:DOWNlink:ACLR:LIMIT

Select a blue link to view the command details:

  • :CALCulate:WCDMa:DOWNlink:ACLR:LIMit:FAIL
  • :CALCulate:WCDMa:DOWNlink:ACLR:LIMit:FAIL:CHANnels
  • :CALCulate:WCDMa:DOWNlink:ACLR:LIMit:MARGin
  • :CALCulate:WCDMa:DOWNlink:ACLR:LIMit[:STATe]

:CALCulate:WCDMa:DOWNlink:ACLR:LIMit:FAIL

Queries the fail status of the ACLR measurement. Returns 1 if there is no valid data, if no limit test is turned on or if any channel with limit test turned on has failed. Returns 0 if at least one channel has limit test turned on and all channels with limit test turned on have passed.

Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:WCDMa:DOWNlink:ACLR:LIMit:FAIL:CHANnels

Queries the fail status of each adjacent channel. Returns: no,<fail status of low-side 1st adjacent channel>,<fail status of high-side 1st adjacent channel>, etc. no is the number of status values. <fail status …> is 0 or 1. 0 indicates data tested with no failure; 1 indicates failure, no data or test is off.

Query | Return | Set | Special | Units
yes | NR1, Boolean,..., Boolean | n/a | none | none

:CALCulate:WCDMa:DOWNlink:ACLR:LIMit:MARGin

Sets margin for limit test. Added to the default limit value for each adjacent channel.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | dB

:CALCulate:WCDMa:DOWNlink:ACLR:LIMit[:STATe]

Turns on/off limit testing. Applies to all adjacent channels.

Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none


:CALCulate:WCDMa:DOWNlink:EVM

Select a blue link to view the command details:

  • :CALCulate:WCDMa:DOWNlink:EVM:PEAK
  • :CALCulate:WCDMa:DOWNlink:EVM:RMS
  • :CALCulate:WCDMa:DOWNlink:EVM:SYMBol


:CALCulate:WCDMa:DOWNlink:EVM:PEAK

Queries EVM peak value for W-CDMA Downlink measurement. Select a blue link to view the command details:

  • :CALCulate:WCDMa:DOWNlink:EVM:PEAK?
  • :CALCulate:WCDMa:DOWNlink:EVM:PEAK:LIMit:FAIL
  • :CALCulate:WCDMa:DOWNlink:EVM:PEAK:LIMit[:STATe]
  • :CALCulate:WCDMa:DOWNlink:EVM:PEAK:LIMit:UPPer

:CALCulate:WCDMa:DOWNlink:EVM:PEAK?

Queries EVM peak value for W-CDMA Downlink measurement.

Query | Return | Set | Special | Units
yes | NR3 | n/a | none | none

:CALCulate:WCDMa:DOWNlink:EVM:PEAK:LIMit:FAIL

Queries fail status of EVM peak limit test. 1 indicates failure; 0 indicates no failure. No failure is not the same as passed.

Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:WCDMa:DOWNlink:EVM:PEAK:LIMit[:STATe]

Turns limit test on/off for EVM peak.

Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

:CALCulate:WCDMa:DOWNlink:EVM:PEAK:LIMit:UPPer

Sets limit for EVM peak.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | %

:CALCulate:WCDMa:DOWNlink:EVM:RMS

Queries EVM RMS value for W-CDMA Downlink measurement. Select a blue link to view the command details:

  • :CALCulate:WCDMa:DOWNlink:EVM:RMS?
  • :CALCulate:WCDMa:DOWNlink:EVM:RMS:LIMit:FAIL
  • :CALCulate:WCDMa:DOWNlink:EVM:RMS:LIMit[:STATe]
  • :CALCulate:WCDMa:DOWNlink:EVM:RMS:LIMit:UPPer

:CALCulate:WCDMa:DOWNlink:EVM:RMS?

Queries EVM RMS value for W-CDMA Downlink measurement.

Query | Return | Set | Special | Units
yes | NR3 | n/a | none | none

:CALCulate:WCDMa:DOWNlink:EVM:RMS:LIMit:FAIL

Queries fail status of EVM RMS limit test. 1 indicates failure; 0 indicates no failure. No failure is not the same as passed.

Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:WCDMa:DOWNlink:EVM:RMS:LIMit[:STATe]

Turns limit test on/off for EVM RMS.

Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

:CALCulate:WCDMa:DOWNlink:EVM:RMS:LIMit:UPPer

Sets the limit for EVM RMS.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | %

:CALCulate:WCDMa:DOWNlink:EVM:SYMBol

Queries Symbol EVM value for W-CDMA Downlink measurement. Select a blue link to view the command details:

  • :CALCulate:WCDMa:DOWNlink:EVM:SYMBol?
  • :CALCulate:WCDMa:DOWNlink:EVM:SYMBol:LIMit:FAIL
  • :CALCulate:WCDMa:DOWNlink:EVM:SYMBol:LIMit[:STATe]
  • :CALCulate:WCDMa:DOWNlink:EVM:SYMBol:LIMit:UPPer

:CALCulate:WCDMa:DOWNlink:EVM:SYMBol?

Queries symbol EVM value for W-CDMA Downlink measurement.

Query | Return | Set | Special | Units
yes | NR3 | n/a | none | none

:CALCulate:WCDMa:DOWNlink:EVM:SYMBol:LIMit:FAIL

Queries fail status of EVM symbol limit test. 1 indicates failure; 0 indicates no failure. No failure is not the same as passed.

Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:WCDMa:DOWNlink:EVM:SYMBol:LIMit[:STATe]

Turns limit test on/off for EVM RMS.

Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

:CALCulate:WCDMa:DOWNlink:EVM:SYMBol:LIMit:UPPer

Sets the limit for EVM symbol.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | %

:CALCulate:WCDMa:DOWNlink:FERRor

Queries frequency error value for W-CDMA Downlink measurement. Select a blue link to view the command details:

  • :CALCulate:WCDMa:DOWNlink:FERRor?
  • :CALCulate:WCDMa:DOWNlink:FERRor:LIMit:FAIL
  • :CALCulate:WCDMa:DOWNlink:FERRor:LIMit[:STATe]
  • :CALCulate:WCDMa:DOWNlink:FERRor:LIMit:UPPer

:CALCulate:WCDMa:DOWNlink:FERRor?

Queries the frequency error value for W-CDMA Downlink measurement.

Query | Return | Set | Special | Units
yes | NR3 | n/a | none | none

:CALCulate:WCDMa:DOWNlink:FERRor:LIMit:FAIL

Queries fail status of frequency error limit test. 1 indicates failure; 0 indicates no failure. No failure is not the same as passed.

Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:WCDMa:DOWNlink:FERRor:LIMit[:STATe]

Sets limit for frequency error.

Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

:CALCulate:WCDMa:DOWNlink:FERRor:LIMit:UPPer

Sets limit for frequency error.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | Hz

:CALCulate:WCDMa:DOWNlink:IOFFset

Queries I Offset value for W-CDMA Downlink measurement.

Query | Return | Set | Special | Units
yes | NR3 | n/a | none | none

:CALCulate:WCDMa:DOWNlink:IQOFfset

Query IQ Offset value for W-CDMA Downlink measurement. Select a blue link to view the command details:

  • :CACLulate:WCDMa:DOWNlink:IQOFfset?
  • :CALCulate:WCDMa:DOWNlink:IQOFfset:LIMit:FAIL
  • :CALCulate:WCDMa:DOWNlink:IQOFfset:LIMit[:STATe]
  • :CALCulate:WCDMa:DOWNlink:IQOFfset:LIMit:UPPer

:CALCulate:WCDMa:DOWNlink:IQOFfset?

Queries I/Q Offset value for W-CDMA Downlink measurement.

Query | Return | Set | Special | Units
yes | NR3 | n/a | none | none

:CALCulate:WCDMa:DOWNlink:IQOFfset:LIMit:FAIL

Queries fail status of I/Q offset limit test. 1 indicates failure; 0 indicates no failure. No failure is not the same as passed.

Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:WCDMa:DOWNlink:IQOFfset:LIMit[:STATe]

Turns on/off limit test for I/Q offset.

Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | No>

:CALCulate:WCDMa:DOWNlink:IQOFfset:LIMit:UPPer

Sets limit for I/Q offset.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | dB


:CALCulate:WCDMa:DOWNlink:MARker

Select a blue link to view the command details:

  • :CALCulate:WCDMa:DOWNlink:MARKer:CNUMber
  • :CALCulate:WCDMa:DOWNlink:MARKer:SFACtor
  • :CALCulate:WCDMa:DOWNlink:MARKer[:STATe]
  • :CALCulate:WCDMa:DOWNlink:MARKer:X
  • :CALCulate:WCDMa:DOWNlink:MARKer:Y

:CALCulate:WCDMa:DOWNlink:MARKer:CNUMber

Queries the code number at the X-axis position of the marker on the code domain power graph. -1 if marker was off.

Query | Return | Set | Special | Units
yes | NR1 | n/a | none | none

:CALCulate:WCDMa:DOWNlink:MARKer:SFACtor

Queries the spread factor at the X-axis position of the marker on the code domain power graph.

Query | Return | Set | Special | Units
yes | NR2 | n/a | none | none

:CALCulate:WCDMa:DOWNlink:MARKer[:STATe]

Turns on/off marker on code domain power graph.

Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

:CALCulate:WCDMa:DOWNlink:MARKer:X

Sets X-axis position (channel) of marker on code domain power graph.

Query | Return | Set | Special | Units
yes | NR1 | NRf | Max | Min | Def | none

:CALCulate:WCDMa:DOWNlink:MARKer:Y

Queries Y-axis power value of marker on code domain power graph.

Query | Return | Set | Special | Units
yes | NR3 | n/a | none | none

:CALCulate:WCDMa:DOWNlink:OBWidth

Queries measured occupied bandwidth value, the bandwidth that contains 99% of the total power measured. Select a blue link to view the command details:

  • :CALCulate:WCDMa:DOWNlink:OBWidth?
  • :CALCulate:WCDMa:DOWNlink:OBWidth:LIMit:FAIL
  • :CALCulate:WCDMa:DOWNlink:OBWidth:LIMit:MARGin
  • :CALCulate:WCDMa:DOWNlink:OBWidth:LIMit[:STATe]
  • :CALCulate:WCDMa:DOWNlink:OBWidth:LIMit:UPPer
  • :CALCulate:WCDMa:DOWNlink:OBWidth:RANGe
  • :CALCulate:WCDMa:DOWNlink:OBWidth:TPOWer

:CALCulate:WCDMa:DOWNlink:OBWidth?

Queries measured occupied bandwidth value, that is, the bandwidth that contains 99% of the total power measured.

Query | Return | Set | Special | Units
yes | NR3 | n/a | none | none

:CALCulate:WCDMa:DOWNlink:OBWidth:LIMit:FAIL

Queries fail status of occupied bandwidth limit test. 1 indicates failure; 0 indicates no failure. No failure is not the same as passed.

Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:WCDMa:DOWNlink:OBWidth:LIMit:MARGin

Sets margin for limit test. Added to default upper bandwidth limit of 1.48 MHz.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | Hz

:CALCulate:WCDMa:DOWNlink:OBWidth:LIMit[:STATe]

Turns on/off limit test for occupied bandwidth.

Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

:CALCulate:WCDMa:DOWNlink:OBWidth:LIMit:UPPer

Queries the limit for the occupied bandwidth.

Query | Return | Set | Special | Units
yes | NR3 | n/a | none | none

:CALCulate:WCDMa:DOWNlink:OBWidth:RANGe

Queries the lower and upper frequencies that define the occupied bandwidth.

Query | Return | Set | Special | Units
yes | NR3 | n/a | none | none

:CALCulate:WCDMa:DOWNlink:OBWidth:TPOWer

Queries the total power used to determine the occupied bandwidth.

Query | Return | Set | Special | Units
yes | NR2 | n/a | none | none


:CALCulate:WCDMa:DOWNlink:PCDE

Select a blue link to view the command details:

  • :CALCulate:WCDMa:DOWNlink:PCDE?
  • :CALCulate:WCDMa:DOWNlink:PCDE:LIMit:FAIL
  • :CALCulate:WCDMa:DOWNlink:PCDE:LIMit[:STATe]
  • :CALCulate:WCDMa:DOWNlink:PCDE:LIMit:UPPer

:CALCulate:WCDMa:DOWNlink:PCDE?

Queries PCDE value for W-CDMA measurement. Returns three comma-separated values: PCDE, Spread factor of peak active CDE and Code number of peak active CDE.

Query | Return | Set | Special | Units
yes | NR3, NR1, NR1 | n/a | none | none

:CALCulate:WCDMa:DOWNlink:PCDE:LIMit:FAIL

Queries fail status of PCDE limit test. 1 indicates failure; 0 indicates no failure. No failure is not the same as passed.

Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:WCDMa:DOWNlink:PCDE:LIMit[:STATe]

Turns on/off limit test for PCDE.

Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

:CALCulate:WCDMa:DOWNlink:PCDE:LIMit:UPPer

Sets limit for PCDE.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | dB

:CALCulate:WCDMa:DOWNlink:QOFFset

Queries Q Offset value for W-CDMA Downlink measurement.

Query | Return | Set | Special | Units
yes | NR3 | n/a | none | none


:CALCulate:WCDMa:DOWNlink:SEMask

Select a blue link to view the command details:

  • :CALCulate:WCDMa:DOWNlink:SEMask:BSMPower
  • :CALCulate:WCDMa:DOWNlink:SEMask:LIMit:FAIL
  • :CALCulate:WCDMa:DOWNlink:SEMask:LIMit:MARGin
  • :CALCulate:WCDMa:DOWNlink:SEMask:LIMit[:STATe]

:CALCulate:WCDMa:DOWNlink:SEMask:BSMPower

Sets the BS maximum output power value used to set limits for spectrum emission mask measurement.

Query | Return | Set | Special | Units
yes | NR1 | NRf | Max | Min | Def | dBm

:CALCulate:WCDMa:DOWNlink:SEMask:LIMit:FAIL

Queries the fail status of the spectrum emission mask measurement. 1 indicates that data is tested and failed, no data, or limit state is off. 0 indicates that data is tested and passed.

Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:WCDMa:DOWNlink:SEMask:LIMit:MARGin

Sets margin for limit test. Added to the default limit values for each frequency as derived from the WCDMA standard.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | dB

:CALCulate:WCDMa:DOWNlink:SEMask:LIMit[:STATe]

Turns on/off limit test for spectrum emission mask measurement.

Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | No>

:CALCulate:WCDMa:DOWNlink:TPOWer

Queries total power value for W-CDMA Downlink measurement.

Query | Return | Set | Special | Units
yes | NR1 | n/a | none | none


:CALCulate:WCDMa:UPLink

Select a blue link to view the command details:

  • :CALCulate:WCDMa:UPLink:ACHannels?
  • :CALCulate:WCDMa:UPLink:ACLR:LIMIT
  • :CALCulate:WCDMa:UPLink:EVM
  • :CALCulate:WCDMa:UPLink:FERRor
  • :CALCulate:WCDMa:UPLink:IMARker
  • :CALCulate:WCDMa:UPLink:IOFfset
  • :CALCulate:WCDMa:UPLink:IQOFfset
  • :CALculate:WCDMa:UPLink:LIMit:EVM:PEAK
  • :CALculate:WCDMa:UPLink:LIMit:EVM:RMS
  • :CALculate:WCDMa:UPLink:LIMit:FERRor
  • :CALculate:WCDMa:UPLink:LIMit:IQOFfset?
  • :CALculate:WCDMa:UPLink:LIMit:PCDE
  • :CALCulate:WCDMa:UPLink:OBWidth
  • :CALCulate:WCDMa:UPLink:PCDE
  • :CALCulate:WCDMa:UPLink:QMARker
  • :CALCulate:WCDMa:UPLink:SEMask:LIMit


:CALCulate:WCDMa:UPLink:ACHannels?

Reads the data for the active channels. The return format is no, <channel data for each of the N active channels>.

The channel data is {I|Q}, <SpreadFactor>, <CodeNumber>, <ChannelAmplitude>.

Query | Return | Set | Special | Units
yes | NR1 | n/a | none | none


:CALCulate:WCDMa:UPLink:ACLR:LIMIT

Select a blue link to view the command details:

  • :CALCulate:WCDMa:UPLINK:ACLR:LIMit:FAIL?
  • :CALCulate:WCDMa:UPLINK:ACLR:LIMit:FAIL:CHANnels?
  • :CALCulate:WCDMa:UPLink:ACLR:LIMIT:FAIL:MARGIN
  • :CALCulate:WCDMa:UPLink:ACLR:LIMIT[:STATe]

:CALCulate:WCDMa:UPLink:ACLR:LIMit:FAIL?

Reads the fail status of the ACLR measurement. Returns "1" if there is no valid data, if no limit test is turned on, or if any channel with limit test turned on has failed. Returns "0" if at least one channel has limit test turned on and all channels with limit test turned on have passed.

Query | Return | Set | Special | Units
yes | Boolean | no | n/a | none

:CALCulate:WCDMa:UPLink:ACLR:LIMit:FAIL:CHANnels?

Queries the fail status of each adjacent channel and returns the following data:

no which is the number of status values

<fail status of low-side 1st adjacent channel> which is either "0" indicating a data tested with no failure, or "1" indicating failure, no data, or the test is off.

Query | Return | Set | Special | Units
yes | NR1Boolean | n/a | none | none

:CALCulate:WCDMa:UPLink:ACLR:LIMIT:MARGIN

Sets the margin for adjacent channel power limit test. Adding a positive value makes the limit more stringent. Adding a negative value makes the limit less stringent. Range = +50 to -50.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | dB

:CALCulate:WCDMa:UPLink:ACLR:LIMIT[:STATe]

Enables and disables the limit testing for the ACLR measurement.

  • ON (or 1) -- enables the limit testing.
  • OFF (or 0) -- disables the limit testing.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none


:CALCulate:WCDMa:UPLink:EVM

Select a blue link to view the command details:

  • :CALCulate:WCDMa:UPLink:EVM:PEAK?
  • :CALCulate:WCDMa:UPLink:EVM:PEAK:LIMit:FAIL?
  • :CALCulate:WCDMa:UPLink:EVM:PEAK:LIMit[:STATe]
  • :CALCulate:WCDMa:UPLink:EVM:PEAK:LIMit:UPPer
  • :CALCulate:WCDMa:UPLink:EVM:RMS?
  • :CALCulate:WCDMa:UPLink:EVM:RMS:LIMit:FAIL?
  • :CALCulate:WCDMa:UPLink:EVM:RMS:LIMit[:STATe]
  • :CALCulate:WCDMa:UPLink:EVM:RMS:LIMit:UPPer

:CALCulate:WCDMa:UPLink:EVM:PEAK?

Reads the EVM peak value for the W-CDMA measurement.

Query | Return | Set | Special | Units
yes | NR3 | n/a | none | none

:CALCulate:WCDMa:UPLink:EVM:PEAK:LIMit:FAIL?

Reads the fail status of the limit test on the EVM peak measurement.

  • 1 = fail
  • 0 = no failure; not the same as passed
Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:WCDMa:UPLink:EVM:PEAK:LIMit[:STATe]

Enables and disables the limit test on an EVM peak measurement.

  • ON (or 1) -- enables the limit testing.
  • OFF (or 0) -- disables the limit testing.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

:CALCulate:WCDMa:UPLink:EVM:PEAK:LIMit:UPPer

Sets the limits for the EVM peak measurement.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | %

:CALCulate:WCDMa:UPLink:EVM:RMS?

Reads the EVM RMS value for the W-CDMA measurement.

Query | Return | Set | Special | Units
yes | NR3 | n/a | none | none

:CALCulate:WCDMa:UPLink:EVM:RMS:LIMit:FAIL?

Reads the fail status of the limit test on the EVM rms measurement.

  • 1 = fail
  • 0 = no failure; not the same as passed
Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:WCDMa:UPLink:EVM:RMS:LIMit[:STATe]

Enables and disables the limit test on an EVM peak measurement.

  • ON (or 1) -- enables the limit testing.
  • OFF (or 0) -- disables the limit testing.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

:CALCulate:WCDMa:UPLink:EVM:RMS:LIMit:UPPer

Sets the limits for the EVM peak measurement.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | %


:CALCulate:WCDMa:UPLink:FERRor

Select a blue link to view the command details:

  • :CALCulate:WCDMa:UPLink:FERRor?
  • :CALCulate:WCDMa:UPLink:FERRor:LIMit:FAIL
  • :CALCulate:WCDMa:UPLink:FERRor:LIMit[:STATe]
  • :CALCulate:WCDMa:UPLink:FERRor:LIMit:UPPer

:CALCulate:WCDMa:UPLink:FERRor?

Reads the frequency error value for the W-CDMA measurement.

Query | Return | Set | Special | Units
yes | NR3 | n/a | none | none

:CALCulate:WCDMa:UPLink:FERRor:LIMit:FAIL?

Reads the fail status of the limit test on the frequency error measurement. This command is an alternate to :CALCulate:WCDMa:UPLink:LIMit:FERRor:FAIL.

  • 1 = fail
  • 0 = no failure; not the same as passed
Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:WCDMa:UPLink:FERRor:LIMit[:STATe]

Enables and disables the limit test on a frequency error measurement. This command is an alternate to :CALCulate:WCDMa:UPLink:LIMit:FERRor[:STATe].

Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

:CALCulate:WCDMa:UPLink:FERRor:LIMit:UPPer

Sets the limits for the frequency error measurement. This command is an alternate to :CALCulate:WCDMa:UPLink:LIMit:FERRor:UPPer.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | Hz


:CALCulate:WCDMa:UPLink:IMARker

Select a blue link to view the command details:

  • :CALCulate:WCDMa:UPLink:IMARker:CNUMber?
  • :CALCulate:WCDMa:UPLink:IMARker:SFACtor?
  • :CALCulate:WCDMa:UPLink:IMARker:X
  • :CALCulate:WCDMa:UPLink:IMARker:Y
  • :CALCulate:WCDMa:UPLink:IMARker[:STATe]

:CALCulate:WCDMa:UPLink:IMARker:CNUMber?

Reads the code number at the X-axis position of the I marker on the code domain power graph.

Query | Return | Set | Special | Units
yes | NR1 | n/a | none | none

:CALCulate:WCDMa:UPLink:IMARker:SFACtor?

Reads the spread factor at the X-axis position of the I marker on the code domain power graph.

Query | Return | Set | Special | Units
yes | NR2 | n/a | none | none

:CALCulate:WCDMa:UPLink:IMARker:X

Sets the X-axis position of the I marker on the code domain power graph.

Query | Return | Set | Special | Units
yes | NR1 | NRf | Max | Min | Def | none

:CALCulate:WCDMa:UPLink:IMARker:Y?

Reads the Y-axis power value of the I marker on the code domain power.

Query | Return | Set | Special | Units
yes | NR3 | n/a | none | none

:CALCulate:WCDMa:UPLink:IMARker[:STATe]

Enables and disables the I marker on code domain power graph.

  • ON (or 1) -- enables the Imarker.
  • OFF (or 0) -- disables the Imarker.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none


:CALCulate:WCDMa:UPLink:IOFFset?

Queries I offset value for W-CDMA uplink measurement.

Query | Return | Set | Special | Units
yes | NR3 | n/a | none | none


:CALCulate:WCDMa:UPLink:IQOFfset

Select a blue link to view the command details:

  • :CALCulate:WCDMa:UPLink:IQOFfset?
  • :CALCulate:WCDMa:UPLink:IQOFfset:LIMit:FAIL?
  • :CALCulate:WCDMa:UPLink:IQOFfset:LIMit[:STATe]
  • :CALCulate:WCDMa:UPLink:IQOFfset:LIMit:UPPer

:CALCulate:WCDMa:UPLink:IQOFfset?

Reads the I/Q offset value for the W-CDMA measurement.

Query | Return | Set | Special | Units
yes | NR3 | n/a | none | none

:CALCulate:WCDMa:UPLink:IQOFfset:LIMit:FAIL?

Reads the fail status of the limit test on the I/Q offset measurement. This command is an alternate to :CALCulate:WCDMa:UPLink:LIMit:IQOFfset:FAIL. This command is an alternate to :CALCulate:WCDMa:UPLink:LIMit:IQOFfset:FAIL.

  • 1 = fail
  • 0 = no failure; not the same as passed
Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:WCDMa:UPLink:IQOFfset:LIMit[:STATe]

Enables and disables the limit test for an I/Q offset measurement. This command is an alternate to :CALCulate:WCDMa:UPLink:LIMit:IQOFfset[:STATe]. This command is an alternate to :CALCulate:WCDMa:UPLink:LIMit:IQOFfset[:STATe].

  • ON (or 1) -- enables the limit testing.
  • OFF (or 0) -- disables the limit testing.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

:CALCulate:WCDMa:UPLink:IQOFfset:LIMit:UPPer

Sets the limits for the I/Q offset measurement. This command is an alternate to :CALCulate:WCDMa:UPLink:LIMit:IQOFfset:UPPer.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | dB


:CALCulate:WCDMa:UPLink:LIMit:EVM:PEAK

Select a blue link to view the command details:

  • :CALCulate:WCDMa:UPLink:LIMit:EVM:PEAK:FAIL?
  • :CALCulate:WCDMa:UPLink:LIMit:EVM:PEAK[:STATe]
  • :CALCulate:WCDMa:UPLink:LIMit:EVM:PEAK:UPPer

:CALCulate:WCDMa:UPLink:LIMit:EVM:PEAK:FAIL?

Reads the fail status of the limit test on the EVM peak measurement.

  • 1 = fail
  • 0 = no failure; not the same as passed
Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:WCDMa:UPLink:LIMit:EVM:PEAK[:STATe]

Enables and disables the limit test on an EVM peak measurement.

  • ON (or 1) -- enables the limit testing.
  • OFF (or 0) -- disables the limit testing.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

:CALCulate:WCDMa:UPLink:LIMit:EVM:PEAK:UPPer

Sets the limits for the EVM peak measurement.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | %


:CALCulate:WCDMa:UPLink:LIMit:EVM:RMS

Select a blue link to view the command details:

  • :CALCulate:WCDMa:UPLink:LIMit:EVM:RMS:FAIL?
  • :CALCulate:WCDMa:UPLink:LIMit:EVM:RMS[:STATe]
  • :CALCulate:WCDMa:UPLink:LIMit:EVM:RMS:UPPer

:CALCulate:WCDMa:UPLink:LIMit:EVM:RMS:FAIL?

Reads the fail status of the limit test on the EVM rms measurement.

  • 1 = fail
  • 0 = no failure; not the same as passed
Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:WCDMa:UPLink:LIMit:EVM:RMS[:STATe]

Enables and disables the limit test on an EVM rms measurement.

  • ON (or 1) -- enables the limit testing.
  • OFF (or 0) -- disables the limit testing.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

:CALCulate:WCDMa:UPLink:LIMit:EVM:RMS:UPPer

Sets the limits for the EVM rms measurement.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | %


:CALCulate:WCDMa:UPLink:LIMit:FERRor

Select a blue link to view the command details:

  • :CALCulate:WCDMa:UPLink:LIMit:FERRor:FAIL?
  • :CALculate:WCDMa:UPLink:LIMit:FERRor[:STATe]
  • :CALCulate:WCDMa:UPLink:LIMit:FERRor:UPPer

:CALCulate:WCDMa:UPLink:LIMit:FERRor:FAIL?

Reads the fail status of the limit test on the frequency error measurement.

  • 1 = fail
  • 0 = no failure; not the same as passed
Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:WCDMa:UPLink:LIMit:FERRor[:STATe]

Enables and disables the limit test on a frequency error measurement.

Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

:CALCulate:WCDMa:UPLink:LIMit:FERRor:UPPer

Sets the limits for the frequency error measurement.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | Hz


:CALCulate:WCDMa:UPLink:LIMit:IQOFfset

Select a blue link to view the command details:

  • :CALCulate:WCDMa:UPLink:LIMit:IQOFfset:FAIL?
  • :CALCulate:WCDMa:UPLink:LIMit:IQOFfset[:STATe]
  • :CALCulate:WCDMa:UPLink:LIMit:IQOFfset:UPPer

:CALCulate:WCDMa:UPLink:LIMit:IQOFfset:FAIL?

Reads the fail status of the limit test on the I/Q offset measurement. This command is an alternate to :CALCulate:WCDMa:UPLink:IQOFfset:LIMit:FAIL.

  • 1 = fail
  • 0 = no failure; not the same as passed
Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:WCDMa:UPLink:LIMit:IQOFfset[:STATe]

Enables and disables the limit test for an I/Q offset measurement. This command is an alternate to :CALCulate:WCDMa:UPLink:IQOFfset:LIMit[:STATe].

  • ON (or 1) -- enables the limit testing.
  • OFF (or 0) -- disables the limit testing.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

:CALCulate:WCDMa:UPLink:LIMit:IQOFfset:UPPer

Sets the limits for the I/Q offset measurement. This command is an alternate to :CALCulate:WCDMa:UPLink:IQOFfset:LIMit:UPPer.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | dB


:CALCulate:WCDMa:UPLink:LIMit:PCDE

Select a blue link to view the command details:

  • :CALCulate:WCDMa:UPLink:LIMit:PCDE:FAIL?
  • :CALCulate:WCDMa:UPLink:LIMit:PCDE[:STATe]
  • :CALCulate:WCDMa:UPLink:LIMit:PCDE:UPPer

:CALCulate:WCDMa:UPLink:LIMit:PCDE:FAIL?

Reads the fail status of the limit test on the PCDE measurement. This command is an alternate to :CALCulate:WCDMa:UPLink:PCDE:LIMit:FAIL.

  • 1 = fail
  • 0 = no failure; not the same as passed
Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:WCDMa:UPLink:LIMit:PCDE[:STATe]

Enables and disables the limit test for a PCDE measurement. This command is an alternate to :CALCulate:WCDMa:UPLink:PCDE:LIMit[:STATe].

  • ON (or 1) -- enables the limit testing.
  • OFF (or 0) -- disables the limit testing.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

:CALCulate:WCDMa:UPLink:LIMit:PCDE:UPPer

Sets the limits for the PCDE measurement. This command is an alternate to :CALCulate:WCDMa:UPLink:PCDE:LIMit:UPPer.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | dB


:CALCulate:WCDMa:UPLink:OBWidth

Select a blue link to view the command details:

  • :CALCulate:WCDMa:UPLink:OBWidth?
  • :CALCulate:WCDMa:UPLink:OBWidth:LIMit:FAIL?
  • :CALCulate:WCDMa:UPLink:OBWidth:LIMit[:STATe]
  • :CALCulate:WCDMa:UPLink:OBWidth:LIMit:MARGin
  • :CALCulate:WCDMa:UPLink:OBWidth:LIMit:UPPer?
  • :CALCulate:WCDMa:UPLink:OBWidth:RANGe?
  • :CALCulate:WCDMa:UPLink:OBWidth:TPOWer?

:CALCulate:WCDMa:UPLink:OBWidth?

Reads the measured occupied bandwidth value, which is the bandwidth that contains 99% of the total power measured.

Query | Return | Set | Special | Units
yes | NR3 | n/a | none | none

:CALCulate:WCDMa:UPLink:OBWidth:LIMit:FAIL?

Reads the occupied bandwidth limit test failure status. A single Boolean value is returned: true indicates the channel power exceeded the limits, false indicates a pass or no limit was applied to the test.

  • 1 = failure
  • 0 = no failure; not the same as passed
Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:WCDMa:UPLink:OBWidth:LIMit[:STATe]

Enables and disables the limit testing for occupied bandwidth.

  • ON (or 1) -- enables the limit testing.
  • OFF (or 0) -- disables the limit testing.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

:CALCulate:WCDMa:UPLink:OBWidth:LIMit:MARGin

Sets the margin for occupied bandwidth limit test. This margin is added to default upper bandwidth limit of 1.48 MHz.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | Hz

:CALCulate:WCDMa:UPLink:OBWidth:LIMit:UPPer?

Queries occupied bandwidth upper limit.

Query | Return | Set | Special | Units
yes | NR2 | n/a | none | none

:CALCulate:WCDMa:UPLink:OBWidth:RANGe?

Reads the lower and upper frequencies that define the occupied bandwidth.

Query | Return | Set | Special | Units
yes | NR2 | n/a | none | none

:CALCulate:WCDMa:UPLink:OBWidth:TPOWer?

Reads the total power that is used to determine the occupied bandwidth.

Query | Return | Set | Special | Units
yes | NR2 | n/a | none | none


:CALCulate:WCDMa:UPLink:PCDE

Select a blue link to view the command details:

  • :CALCulate:WCDMa:UPLink:PCDE?
  • :CALCulate:WCDMa:UPLink:PCDE:LIMit:FAIL?
  • :CALCulate:WCDMa:UPLink:PCDE:LIMit[:STATe]
  • :CALCulate:WCDMa:UPLink:PCDE:LIMit:UPPer

:CALCulate:WCDMa:UPLink:PCDE?

Reads the PCDE value for W-CDMA measurement. Returns three comma-separated values: PCDE, spread factor of peak active CDE, and code number of peak active CDE.

  • Float - returned for PCDE.
  • Integer - returned for spread factor of peak active CDE and code number of peak active CDE.
Query | Return | Set | Special | Units
yes | Float Integer | n/a | none | none

:CALCulate:WCDMa:UPLink:PCDE:LIMit:FAIL?

Reads the fail status of the limit test on the PCDE measurement. This command is an alternate to :CALCulate:WCDMa:UPLink:LIMit:PCDE:FAIL.

  • 1 = fail
  • 0 = no failure; not the same as passed
Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:WCDMa:UPLink:PCDE:LIMit[:STATe]

Enables and disables the limit test for a PCDE measurement. This command is an alternate to :CALCulate:WCDMa:UPLink:LIMit:PCDE[:STATe].

  • ON (or 1) -- enables the limit testing.
  • OFF (or 0) -- disables the limit testing.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

:CALCulate:WCDMa:UPLink:PCDE:LIMit:UPPer

Sets the limits for the PCDE measurement. This command is an alternate to :CALCulate:WCDMa:UPLink:LIMit:PCDE:UPPer.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | dB


:CALCulate:WCDMa:UPLink:QMARker

Select a blue link to view the command details:

  • :CALCulate:WCDMa:UPLink:QMARker:CNUMber?
  • :CALCulate:WCDMa:UPLink:QMARker:SFACtor?
  • :CALCulate:WCDMa:UPLink:QMARker:X
  • :CALCulate:WCDMa:UPLink:QMARker:Y?
  • :CALCulate:WCDMa:UPLink:QMARker[:STATe]

:CALCulate:WCDMa:UPLink:QMARker:CNUMber?

Reads the code number at the X-axis position of the Q marker on the code domain power graph.

Query | Return | Set | Special | Units
yes | NR1 | n/a | none | none

:CALCulate:WCDMa:UPLink:QMARker:SFACtor?

Reads the spread factor at the X-axis position of the Q marker on the code domain power graph.

Query | Return | Set | Special | Units
yes | NR1 | n/a | none | none

:CALCulate:WCDMa:UPLink:QMARker:X

Sets the X-axis position of the Q marker on the code domain power graph.

Query | Return | Set | Special | Units
yes | NR1 | NRf | Max | Min | Def | none

:CALCulate:WCDMa:UPLink:QMARker:Y?

Reads the Y-axis power value of the Q marker on the code domain power graph.

Query | Return | Set | Special | Units
yes | NR2 | n/a | none | none

:CALCulate:WCDMa:UPLink:QMARker[:STATe]

Enables and disables the Q marker on the code domain power graph.

  • ON (or 1) -- enables the Qmarker.
  • OFF (or 0) -- disables the Qmarker.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none


:CALCulate:WCDMa:UPLink:SEMask:LIMit

Select a blue link to view the command details:

  • :CALCulate:WCDMa:UPLink:SEMask:LIMit:FAIL?
  • :CALCulate:WCDMa:UPLink:SEMask:LIMit:MARGin
  • :CALCulate:WCDMa:UPLink:SEMask:LIMit[:STATe]

:CALCulate:WCDMa:UPLink:SEMask:LIMit:FAIL?

Reads the fail status of the spectrum emission mask measurement. A returned "1" indicates that the data is tested and failed, or no data was tested, or the limit state is off. A returned "0" indicates that data is tested and passed.

Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:WCDMa:UPLink:SEMask:LIMit:MARGin

Sets the margin for the spectrum emission limit test. This margin is added to default upper bandwidth limit of 1.48 MHz.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | dB

:CALCulate:WCDMa:UPLink:SEMask:LIMit[:STATe]

Enables and disables the spectrum emission mask limit test.

  • ON (or 1) - enables the limit test.
  • OFF (or 0) - disables the limit test.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none


:CALCulate:WLAN

Select a blue link to view the command details:

  • :CALCulate:WLAN:BANDwidth:
  • :CALCulate:WLAN:CFEedthru
  • :CALCulate:WLAN:CFERror
  • :CALCulate:WLAN:CONStellation
  • :CALCulate:WLAN:CPOWer
  • :CALCulate:WLAN:DRATe
  • :CALCulate:WLAN:EVM:PEAK
  • :CALCulate:WLAN:EVM[:RMS]
  • :CALCulate:WLAN:FMARgin
  • :CALCulate:WLAN:NSYMbols
  • :CALCulate:WLAN:PDRamp
  • :CALCulate:WLAN:PILot:EVM:PEAK
  • :CALCulate:WLAN:PILot:EVM[:RMS]
  • :CALCulate:WLAN:PORamp
  • :CALCulate:WLAN:SCERror
  • :CALCulate:WLAN:SEMask
  • :CALCulate:WLAN:SIGNal

:CALCulate:WLAN:{BANDwidth|BWIDth}

Queries bandwidth of WLAN OFDM signal as Hz.

Query | Return | Set | Special | Units
yes | NR3 | n/a | none | none


:CALCulate:WLAN:CFEedthru

Select a blue link to view the command details:

  • :CALCulate:WLAN:CFEedthru
  • :CALCulate:WLAN:CFEedthru:LIMit:FAIL
  • :CALCulate:WLAN:CFEedthru:LIMit[:STATe]
  • :CALCulate:WLAN:CFEedthru:LIMit:UPPer


:CALCulate:WLAN:CFEedthru

Queries carrier feedthrough error for WLAN measurement.

Query | Return | Set | Special | Units
yes | NR1 | n/a | none | none

:CALCulate:WLAN:CFEedthru:LIMit:FAIL

Query fail status of carrier feedthrough limit test. 1 indicates failure; 0 indicates passed.

Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:WLAN:CFEedthru:LIMit[:STATe]

Turn on/off limit test for WLAN carrier feedthrough.

Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

:CALCulate:WLAN:CFEedthru:LIMit:UPPer

Set upper limit for WLAN carrier feedthrough measurement.

Query | Return | Set | Special | Units
yes | Boolean | NRf | Max | Min | Def | dB


:CALCulate:WLAN:CFERror

Select a blue link to view the command details:

  • :CALCulate:WLAN:CFERror
  • :CALCulate:WLAN:CFERror:LIMit:FAIL
  • :CALCulate:WLAN:CFERror:LIMit[:STATe]
  • :CALCulate:WLAN:CFERror:LIMit:UPPer

:CALCulate:WLAN:CFERror

Queries carrier frequency error for WLAN measurement.

Query | Return | Set | Special | Units
yes | NR1 | n/a | none | none

:CALCulate:WLAN:CFERror:LIMit:FAIL

Queries fail status of carrier frequency error limit test. 1 indicates failed; 0 indicates passed.

Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:WLAN:CFERror:LIMit[:STATe]

Turns on/off limit test for WLAN carrier frequency error.

Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

:CALCulate:WLAN:CFERror:LIMit:UPPer

Sets upper limit for WLAN carrier frequency error measurement.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | Hz

:CALCulate:WLAN:CONStellation

Queries constellation type of WLAN OFDM signal. Return value matches parameter for :SENSe:WLAN:CONStellation command.

Query | Return | Set | Special | Units
yes | BPSK, QPSK, QAM16, QAM64 | n/a | none | none


:CALCulate:WLAN:CPOWer

Select a blue link to view the command details:

  • :CALCulate:WLAN:CPOWer
  • :CALCulate:WLAN:CPOWer:LIMit:FAIL
  • :CALCulate:WLAN:CPOWer:LIMit[:STATe]
  • :CALCulate:WLAN:CPOWer:LIMit:UPPer

:CALCulate:WLAN:CPOWer

Queries channel power for WLAN measurement.

Query | Return | Set | Special | Units
yes | NR3 | n/a | none | none

CALCulate:WLAN:CPOWer:LIMit:FAIL?

Queries fail status of channel power error limit test.

  • 1 indicates failed
  • 0 indicates passed
Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:WLAN:CPOWer:LIMit[:STATe]

Turns on/off limit test for WLAN channel power.

Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

:CALCulate:WLAN:CPOWer:LIMit:UPPer

Sets upper limit for WLAN channel power.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | dBm

:CALCulate:WLAN:DRATe

Queries data rate of WLAN DSSS/CCK signal as bits/second.

Query | Return | Set | Special | Units
yes | NR3 | n/a | none | none


:CALCulate:WLAN:EVM:PEAK

Select a blue link to view the command details:

  • :CALCulate:WLAN:EVM:PEAK
  • :CALCulate:WLAN:EVM:PEAK:LIMit:FAIL
  • :CALCulate:WLAN:EVM:PEAK:LIMit[:STATe]
  • :CALCulate:WLAN:EVM:PEAK:LIMit:UPPer

:CALCulate:WLAN:EVM:PEAK?

Queries EVM peak for WLAN measurement.

Query | Return | Set | Special | Units
yes | NR3 | n/a | none | none

:CALCulate:WLAN:EVM:PEAK:LIMit:FAIL?

Queries fail status of EVM peak limit test. 1 indicates failed; 0 indicates passed.

Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:WLAN:EVM:PEAK:LIMit[:STATe]

Turns on/off limit test for WLAN EVM rms.

Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

:CALCulate:WLAN:EVM:PEAK:LIMit:UPPer

Sets upper limit for WLAN EVM rms.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | dB


:CALCulate:WLAN:EVM[:RMS]

Select a blue link to view the command details:

  • :CALCulate:WLAN:EVM[:RMS]
  • :CALCulate:WLAN:EVM:RMS:LIMit:FAIL?
  • :CALCulate:WLAN:EVM:RMS:LIMit[:STATe]
  • :CALCulate:WLAN:EVM:RMS:LIMit:UPPer

:CALCulate:WLAN:EVM[:RMS]

Queries EVM RMS for WLAN measurement.

Query | Return | Set | Special | Units
yes | NR3 | n/a | none | none

:CALCulate:WLAN:EVM:RMS:LIMit:FAIL?

Queries fail status of EVM RMS limit test. 1 indicates failed; 0 indicates passes.

Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:WLAN:EVM:RMS:LIMit[:STATe]

Turns on/off limit test for WLAN EVM RMS.

Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

:CALCulate:WLAN:EVM:RMS:LIMit:UPPer

Sets upper limit for WLAN EVM RMS.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | dB


:CALCulate:WLAN:FMARgin

Select a blue link to view the command details:

  • :CALCulate:WLAN:FMARgin
  • :CALCulate:WLAN:FMARgin:LIMit:FAIL
  • :CALCulate:WLAN:FMARgin:LIMit[:STATe]
  • :CALCulate:WLAN:FMARgin:LIMit:UPPer

:CALCulate:WLAN:FMARgin

Queries channel flatness margin for WLAN measurement.

Query | Return | Set | Special | Units
yes | NR3 | n/a | none | none

:CALCulate:WLAN:FMARgin:LIMit:FAIL

Queries fail status of channel flatness limit test. 1 indicates failed; 0 indicates passed.

Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:WLAN:FMARgin:LIMit[:STATe]

Turns on/off limit test for channel flatness.

Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

:CALCulate:WLAN:FMARgin:LIMit:UPPer

Sets upper limit for channel flatness margin.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | dB

:CALCulate:WLAN:NSYMbols

Queries number of symbols decoded by WLAN measurement.

Query | Return | Set | Special | Units
yes | NR1 | n/a | none | none


:CALCulate:WLAN:PDRamp

Select a blue link to view the command details:

  • :CALCulate:WLAN:PDRamp
  • :CALCulate:WLAN:PDRamp:LIMit:FAIL
  • :CALCulate:WLAN:PDRamp:LIMit[:STATe]
  • :CALCulate:WLAN:PDRamp:LIMit:UPPer

:CALCulate:WLAN:PDRamp

Queries Power-Down Ramp for WLAN 802.11b measurement.

Query | Return | Set | Special | Units
yes | NR3 | n/a | none | none

:CALCulate:WLAN:PDRamp:LIMit:FAIL

Queries fail status of Power-Down Ramp limit test. 1 indicates failed; 0 indicates passed.

Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:WLAN:PDRamp:LIMit[:STATe]

Turns on/off limit test for Power-Down Ramp.

Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

:CALCulate:WLAN:PDRamp:LIMit:UPPer

Sets upper limit for Power-Down Ramp.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | Seconds


:CALCulate:WLAN:PILot:EVM:PEAK

Select a blue link to view the command details:

  • :CALCulate:WLAN:PILot:EVM:PEAK
  • :CALCulate:WLAN:PILot:EVM:PEAK:LIMit:FAIL
  • :CALCulate:WLAN:PILot:EVM:PEAK:LIMit[:STATe]
  • :CALCulate:WLAN:PILot:EVM:PEAK:LIMit:UPPer

:CALCulate:WLAN:PILot:EVM:PEAK

Queries EVM peak for WLAN measurement.

Query | Return | Set | Special | Units
yes | NR3 | n/a | none | none

:CALCulate:WLAN:PILot:EVM:PEAK:LIMit:FAIL

Queries fail status of EVM peak limit test. 1 indicates failed; 0 indicates passed.

Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:WLAN:PILot:EVM:PEAK:LIMit[:STATe]

Turns on/off limit test for WLAN Pilot EVM rms.

Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

:CALCulate:WLAN:PILot:EVM:PEAK:LIMit:UPPer

Sets upper limit for WLAN Pilot EVM rms.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | dB


:CALCulate:WLAN:PILot:EVM[:RMS]

Select a blue link to view the command details:

  • :CALCulate:WLAN:PILot:EVM[:RMS]
  • :CALCulate:WLAN:PILot:EVM:RMS:LIMit:FAIL
  • :CALCulate:WLAN:PILot:EVM:RMS:LIMit[:STATe]
  • :CALCulate:WLAN:PILot:EVM:RMS:LIMit:UPPer

:CALCulate:WLAN:PILot:EVM[:RMS]

Queries Pilot EVM RMS for WLAN measurement.

Query | Return | Set | Special | Units
yes | NR3 | n/a | none | none

:CALCulate:WLAN:PILot:EVM:RMS:LIMit:FAIL

Queries fail status of Pilot EVM RMS limit test. 1 indicates failed; 0 indicates passes.

Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:WLAN:PILot:EVM:RMS:LIMit[:STATe]

Turns on/off limit test for WLAN Pilot EVM RMS.

Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

:CALCulate:WLAN:PILot:EVM:RMS:LIMit:UPPer

Sets upper limit for WLAN Pilot EVM RMS.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | dB


:CALCulate:WLAN:PORamp

Select a blue link to view the command details:

  • :CALCulate:WLAN:PORamp
  • :CALCulate:WLAN:PORamp:LIMit:FAIL
  • :CALCulate:WLAN:PORamp:LIMit[:STATe]
  • :CALCulate:WLAN:PORamp:LIMit:UPPer

:CALCulate:WLAN:PORamp

Queries Power-On Ramp for WLAN 802.11b measurement.

Query | Return | Set | Special | Units
yes | NR3 | n/a | none | none

:CALCulate:WLAN:PORamp:LIMit:FAIL

Queries fail status of Power-On Ramp limit test. 1 indicates failed; 0 indicates passed.

Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:WLAN:PORamp:LIMit[:STATe]

Turns on/off limit test for Power-On Ramp.

Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

:CALCulate:WLAN:PORamp:LIMit:UPPer

Sets upper limit for Power-On Ramp.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | Seconds


:CALCulate:WLAN:SCERror

Select a blue link to view the command details:

  • :CALCulate:WLAN:SCERror
  • :CALCulate:WLAN:SCERror:LIMit:FAIL
  • :CALCulate:WLAN:SCERror:LIMit[:STATe]
  • :CALCulate:WLAN:SCERror:LIMit:UPPer

:CALCulate:WLAN:SCERror

Queries symbol clock error for WLAN measurement.

Query | Return | Set | Special | Units
yes | NR3 | n/a | none | none

:CALCulate:WLAN:SCERror:LIMit:FAIL

Queries failed status of symbol clock error limit test.1 indicates failed; 0 indicates passed.

Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:WLAN:SCERror:LIMit[:STATe]

Turns on/off limit test for WLAN symbol clock error .

Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

:CALCulate:WLAN:SCERror:LIMit:UPPer

Sets upper limit for WLAN symbol clock error.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | none


:CALCulate:WLAN:SEMask

Select a blue link to view the command details:

  • :CALCulate:WLAN:SEMask:LIMit:FAIL
  • :CALCulate:WLAN:SEMask:LIMit[:STATe]
  • :CALCulate:WLAN:SEMask:LIMit:MARGin

:CALCulate:WLAN:SEMask:LIMit:FAIL

Queries the fail status of the spectrum emission mask measurement. 1 indicates that data is tested and failed, no data, or limit state is off. 0 indicates that data is tested and passed.

Query | Return | Set | Special | Units
yes | Boolean | n/a | none | none

:CALCulate:WLAN:SEMask:LIMit[:STATe]

Turns on/off limit test for spectrum emission mask.

Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

:CALCulate:WLAN:SEMask:LIMit:MARGin

Sets margin for limit test. Added to the default limit values for each frequency as derived from the 802.11 standard.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | dB

:CALCulate:WLAN:SIGNal

Queries signal type. Return value matches parameter type of :SENSe:WLAN:SIGNal command.

Query | Return | Set | Special | Units
yes | AG,BG J,NDR | n/a | none | none


:CALibration[:ALL]

Performs an RF hardware calibration.

Query | Return | Set | Special | Units
no | n/a | n/a | none | none


:DIAGnostic:FREQuency:EXTend[:STATe]

Enables and disables the extended frequency mode.

  • ON (or 1) - enables the extended frequency mode.
  • OFF (or 0) - disables the extended frequency mode.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none


:DIAGnostic:REMote:OUTPut[:STATe]

Enables and disables the remote command diagnostic output.

  • ON (or 1) - enables the command diagnostic output.
  • OFF (or 0) - disables the command diagnostic output.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none


:DISPlay

Select a blue link to view the command details:

  • :DISPlay:CAPTure
  • :DISPlay:ENABle
  • :DISPlay:VIEW:CDMA
  • :DISPlay:VIEW:EDGE:TYPE
  • :DISPlay:VIEW:GSM:TYPE
  • :DISPlay:VIEW:WCDMa
  • :DISPlay:VIEW:WLAN
  • :DISPlay:WINDow:TRACe:Y[:SCALe]:PDIVision
  • :DISPlay:WINDow:TRACe:Y[:SCALe]:RLEVel
  • :DISPlay:WLAN

:DISPlay:CAPTure

Captures the current instrument screen and writes a *.bmp to the specified file. This command will overwrite existing files with the same file name.

Query | Return | Set | Special | Units
no | string | <filename> | none | none

:DISPlay:ENABle

Enables and disables the instrument front panel display circuitry, which controls the backlight and all updating of the display. When the display is disabled, the instrument operates at a higher speed. This maximizes throughput when using the remote interface.

Normal display operation can be resumed by using the ENABle command to enable the display or by putting the instrument into local mode (press Local). All front panel controls (except Local) are disabled.

  • ON (or 1) enables the display backlight.
  • OFF (or 0) disables the display backlight.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

:DISPlay:VIEW:CDMA

Selects the data view for a CDMA2000 measurement.

Query | Return | Set | Special | Units
yes | GRAP| TABL| BOTH | GRAPh| TABLe| BOTH | Default | none

:DISPlay:VIEW:EDGE:TYPE

Selects the displayed trace type for an EDGE measurement.

  • NONE - sets the displayed trace to none.
  • TMASK - sets the displayed trace to the entire time mask.
  • RISing - sets the displayed trace to the rising edge of the time mask.
  • FALLing - sets the displayed trace to the falling edge of the time mask.
  • TOP - sets the displayed trace to the top of the time mask.
  • OMOD - sets the displayed trace to the ORFS due to modulation.
  • OSWI - sets the displayed trace to the ORFS due to switching.
  • EVCTRS - sets the displayed trace to the error vectors.
  • SYMB - sets the displayed trace to the symbols.
  • CONSTellation - sets the displayed trace to the constellation view.
Query | Return | Set | Special | Units
yes | NONE| TMASK| RIS| FALL| TOP| OMOD| OSWI| EVCTRS| SYMB| CONST| | NONE| TMASK| RISing| FALLing| TOP| OMOD| OSWI| EVCTRS| SYMB| CONSTellation| | Default | none

:DISPlay:VIEW:GSM:TYPE

Selects the data view for a GSM measurement.

  • NONE - sets the displayed trace to none.
  • TMASK - sets the displayed trace to the full time mask.
  • RISing - sets the displayed trace to the rising edge of the time mask.
  • FALLing - sets the displayed trace to the falling edge of the time mask.
  • TOP - sets the displayed trace to the top of the time mask.
  • OMOD - sets the displayed trace to the ORFS due to modulation.
  • OSWI - sets the displayed trace to the ORFS due to switching.
  • PERRor - sets the displayed trace to the phase error.
  • MPHASe - sets the displayed trace to the measured phase.
  • SYMB - sets the displayed trace to the symbols.
Query | Return | Set | Special | Units
yes | NONE| TMASK| RIS| FALL| TOP| OMOD| OSWI| PERR| MPHAS| SYMB | NONE| TMASK| RISing| FALLing| TOP| OMOD| OSWI| PERRor| MPHASe| SYMB | Default | none

:DISPlay:VIEW:WCDMa

Selects the data view for a WCDMA measurement.

Query | Return | Set | Special | Units
yes | GRAP| TABL| BOTH | GRAPh| TABLe| BOTH | Default | none


:DISPlay:VIEW:WLAN

Select a blue link to view the command details:

  • :DISPlay:VIEW:WLAN
  • :DISPlay:VIEW:WLAN:TYPE

:DISPlay:VIEW:WLAN

Selects view of the data for WLAN measurement.

Query | Return | Set | Special | Units
yes | GRAP| TABL| BOTH | GRAPh| TABLe| BOTH | Default | none

:DISPlay:VIEW:WLAN:TYPE

Selects the displayed trace type for a WLAN measurement.

Query | Return | Set | Special | Units
yes | NONE| CONS| EVCH| EVSY| EHIS| GCOM| CCDF| MFL| PFL | NONE| CONStellation| EVCHannel| EVSYmbol| EHIStory| GCOMpression| CCDF| MFLatness| PFLatness | Default | none

:DISPlay:WINDow:TRACe:Y[:SCALe]:PDIVision

Sets or queries the scale per division value.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | dB

:DISPlay:WINDow:TRACe:Y[:SCALe]:RLEVel

Sets or queries the displayed reference level.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | dBm


:DISPlay:WLAN

Select a blue link to view the command details:

  • :DISPlay:WLAN:CCDF:X[:SCALe]:PDIVision
  • :DISPlay:WLAN:EVCHannel:Y[:SCALe]:PDIVision
  • :DISPlay:WLAN:EVCHannel:Y[:SCALe]:TOP
  • :DISPlay:WLAN:EHIStory:Y[:SCALe]:PDIVision
  • :DISPlay:WLAN:EHIStory:Y[:SCALe]:TOP
  • :DISPlay:WLAN:EVSYmbol:Y[:SCALe]:PDIVision
  • :DISPlay:WLAN:EVSYmbol:Y[:SCALe]:TOP
  • :DISPlay:WLAN:GCOMpression:Y[:SCALe]:PDIVision
  • :DISPlay:WLAN:GCOMpression:Y[:SCALe]:RPOSition
  • :DISPlay:WLAN:MFLatness:Y[:SCALe]:PDIVision
  • :DISPlay:WLAN:PFLatness:Y[:SCALe]:PDIVision

:DISPlay:WLAN:CCDF:X[:SCALe]:PDIVision

Sets X-Axis scale of WLAN CCDF graph. Limited to .5, 1.0, 1.5 and 2.0 dB/div.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | dB

:DISPlay:WLAN:EVCHannel:Y[:SCALe]:PDIVision

Sets Y-Axis scale of WLAN EVM vs Channel graph.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | dB

:DISPlay:WLAN:EVCHannel:Y[:SCALe]:TOP

Sets Y-Axis top value of WLAN EVM vs Channel graph.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | dB

:DISPlay:WLAN:EHIStory:Y[:SCALe]:PDIVision

Sets Y-Axis scale of WLAN EVM History graph.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | dB

:DISPlay:WLAN:EHIStory:Y[:SCALe]:TOP

Sets Y-Axis top value of WLAN EVM History graph.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | dB

:DISPlay:WLAN:EVSYmbol:Y[:SCALe]:PDIVision

Sets Y-Axis scale of WLAN EVM vs Symbol graph.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | dB

:DISPlay:WLAN:EVSYmbol:Y[:SCALe]:TOP

Sets Y-Axis top value of WLAN EVM vs Symbol graph.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | dB

:DISPlay:WLAN:GCOMpression:Y[:SCALe]:PDIVision

Sets Y-Axis scale of WLAN Gain Compression graph.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | dB

:DISPlay:WLAN:GCOMpression:Y[:SCALe]:RPOSition

Sets Y-Axis reference position of WLAN Gain Compression graph.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | dB

:DISPlay:WLAN:MFLatness:Y[:SCALe]:PDIVision

Sets Y-Axis scale of WLAN Magnitude Flatness graph.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | dB

:DISPlay:WLAN:PFLatness:Y[:SCALe]:PDIVision

Sets Y-Axis scale of WLAN Phase Flatness graph.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | dB


:FORMat

Select a blue link to view the command details:

  • :FORMat:SREGister
  • :FORMat[:DATA]

:FORMat:SREGister

Sets the numeric format of query results for status registers and enable registers. See Status structure.

  • Decimal format = 0 to 32767
  • Binary format (each x = 1 or 0) = #Bxx...x
  • Hexadecimal format (x = 0 to 7FFF) = #Hx
  • Octal format (x = 77777) =#Qx
Query | Return | Set | Special | Units
yes | ASC| HEX| BIN| OCT| | ASCii| HEXidecimal| BINary| OCTal| | Default | none

:FORMat[:DATA]

Sets the format of the data that is returned from the :CALCulate:DATA? query. The parameters are sent as <type>[,<length>].

ASCII - returns the queried data as an ASCII comma-separated list of numeric values. The <length> value is optional and specifies the number of significant values to be returned. The default value of 0 for the <length>, indicates that the device selects the number of digits. For the VSA, the value of 0 is the only valid length value.

REAL - returns the queried data as a definite-length binary block. Each value is an IEEE 754 floating-point value. The <length> value is optional and specifies the number of bits in each floating-point value. Valid values of <length> are 32 and 64. The default is 64.

Query | Return | Set | Special | Units
yes |  | ASCii[,0]| REAL[,32|64] | Default | none


:INITiate

Select a blue link to view the command details:

  • :INITiate:CONTinuous
  • INITiate[:IMMediate][ALL]

:INITiate:CONTinuous

Switches between continuous sweep and single sweep.

  • ON (or 1) - sets the sweep to continuous.
  • OFF (or 0) - sets the sweep to single.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

:INITiate[:IMMediate]

Arms the trigger. See Trigger.

When using this command to trigger a single sweep (or list), the command must be used in a single-string programming message that includes *OPC?, followed by a newline character. When the source completes the sweep, the instrument responds with a "1."

Note: Sending INITiate while the instrument is performing measurements will cause error -213 (init ignored).

Query | Return | Set | Special | Units
no | n/a | n/a | none | none


:MEASure

Select a blue link to view the command details:

  • :MEASure[:SELect]
  • :MEASure:IQ
  • :MEASure:IQ:CFACtor?

:MEASure[:SELect]

Selects the measurement category.

  • SPECtrum - sets the General Purpose > Spectrum measurement.
  • ZSPan - sets the General Purpose > Zero Span measurement.
  • ACPR - sets the General Purpose > ACPR measurement.
  • CPL - sets the General Purpose > Channel Power List measurement.
  • GSM - sets the GSM measurement.
  • EDGE - sets the EDGE measurement.
  • WDDemodulate - sets the W-CDMA Downlink Demodulate measurement.
  • WDACLR - sets the W-CDMA Downlink ACLR measurement.
  • WDOBW - sets the W-CDMA Downlink Occupied Bandwidth measurement.
  • WDSEM - sets the W-CDMA Downlink Spectrum Emission Mask measurement.
  • WCDMa - sets the W-CDMA measurement.
  • CDMA - sets the cdma2000 measurement.
  • WUACLR - sets the W-CDMA ACLR measurement.
  • WUDemodulate - sets the W-CDMA Uplink Demodulate measurement.
  • WUSEM - sets the W-CDMA Spectrum Emission Mask measurement.
  • WUOBW - sets the W-CDMA Occupied Bandwidth measurement.
  • CRACPR - sets the cdma2000 ACPR measurement.
  • CRSEM - sets the cdma2000 Spectrum Emission Mask measurement.
  • CROBW - sets the cdma2000 Occupied Bandwidth measurement.
  • WLAN - sets the WLAN Demodulation measurement.
  • WLSEM - sets the WLAN Spectrum Emission Mask measurement.
Query | Return | Set | Special | Units
yes | SPEC| ZSP| ACPR| CPL| GSM| EDGE| WDD| CDMA| WUACLR| WUSEM| WDACLR| WDOBW| WDSEM| WUOBW| CRACPR| WUD| CRSEM| CROBW| WLAN| WLSEM| | SPECtrum| ZSPan| ACPR| CPL| GSM| EDGE| WDDemodulate| CDMA| WUACLR| WUSEM| WDACLR| WDOBW| WDSEM| WUOBW| CRACPR| WUDemodulate| CRSEM| CROBW| WLAN| WLSEM| | Default | none

:MEASure:IQ?

Initiates a single sweep measurement that returns IQ values as 16-bit integers. Before you send the :MEAS:IQ command, you must send commands to set up the following conditions:

  • Zero span measurement
  • Single sweep

    Note: If you do not first set up the above conditions before sending the :MEAS:IQ? command, the instrument will generate a settings conflict error.

Returns String and binary

#NNMMM <binary data>

First digit (N) indicates the number of digits that specify the length of the data.

Second number (MMM) indicates the data length in bytes.

The <binary data> is the resulting IQ data.

Refer to Extracting IQ Data for a programming example.

Query | Return | Set | Special | Units
yes | string, binary | n/a | none | none

:MEASure:IQ:CFACtor?

Returns the Calibration Factor for the data from the :MEASure:IQ command.

To learn more, see :MEASure:IQ:CFACtor? note

Query | Return | Set | Special | Units
yes | string, binary | n/a | none | none


:MEASure:IQ:CFACtor? note

The Calibration (C) Factor is measured in dB

The MEAS:IQ? measurement returns a real and imaginary array. Each array element is returned as an integer and needs to be scaled in order to be calibrated for correct power levels. After MEAS:IQ? is issued, a second call is made to return a calibration factor. The calibration factor is converted from dB to linear.

The processed calibration factor is then divided into each element of the real and imaginary array.

The C Factor can be obtained by the following procedure:

  1. Make the MEAS:IQ? measurement, transferring data as 16 bit integers
  2. Data returned is alternate samples of real and imaginary 16 bit integers
  3. Convert each integer array element to a floating point value and divide by 32768 (i.e. 2^15).
  4. Make the MEAS:IQ:CFACtor? measurement and read back the
  5. Convert the returned value to linear, with linearVal = 10^(dBVal/20)
  6. Divide the real and imaginary values by the linearVal


:MMEMory:CATalog

Queries for the contents of the file system, starting at the specified directory root. The parameter is an alias for the physical file path. The contents of all subdirectories are included in the response. The response is per SCPI standard for :MMEMory:CATalog?. The file type is left blank. See File management.

  • SETUPS - sets the query to return the contents of the file system, starting with the SETUPS directory.
  • USB - sets the query to return the contents of the file system, starting with the USB directory.
  • USB2 - sets the query to return the contents of the file system, starting with the USB2 directory.
  • USB3 - sets the query to return the contents of the file system, starting with the USB3 directory.
  • USB4 - sets the query to return the contents of the file system, starting with the USB4 directory.
  • USER - sets the query to return the contents of the file system, starting with the USER directory
  • CPL\USER - sets the query to return the contents of the file system, starting with the CPL\USER directory.
  • USER FLATNESS\USER - sets the query to return the contents of the file system, starting with the USER FLATNESS\USER directory.
Query | Return | Set | Special | Units
yes | string | SETUPS| USB| USB2| USB3| USB4| USER| CPL\USER| USER FLATNESS\ USER | none | none


:MMEMory:DATA

Creates a file in the location specified and copies the information in the programming message into the file.

no = "filename"

#NN = First digit indicates the number of digits to follow that specify the length of the data in bytes.

<data> = Specifies the data to be written to the file.

Query | Return | Set | Special | Units
yes | string | <filename>, #NN<data> | none | none

Example:

You can use the programming command :MMEM:DATA to create a file (with specified contents) in a directory in the VSA or a USB memory stick inserted in the VSA.

The following command creates a file named "example1.txt" on a USB memory stick that is inserted in the VSA.

:MMEM:DATA "\HARD DISK\example1.txt", #257Hello! This is example content for the example text file.

  • The # indicates the start of a binary transmission.
  • The 2 indicates that the next two digits specify the length of the transmission.
  • The 57 indicates that the transmission is 57 bytes. This number includes characters, spaces, and line breaks.
  • The text is the contents of the file "example1.txt."


:SERVice:BACKground[:STATe]

Enables and disables the instrument background tasks. These tasks include periodically checking for indication of a network connection, external reference status, and an overheated operation status. The status checks happen between measurements. Therefore, the background tasks will not interrupt the VSA operation if the instrument is in a state where the trigger is armed and the instrument is waiting for the trigger event.

  • ON (or 1) -- enables the instrument background tasks.
  • OFF (or 0) -- disables the instrument background tasks.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none


:SOURce

Select a blue link to view the command details:

  • :SOURce:DWELl
  • :SOURce:EEVensecond
  • :SOURce:FREQuency:CENTer
  • :SOURce:FREQuency:SPAN
  • :SOURce:FREQuency[:START]
  • :SOURce:FREQuency:STOP
  • :SOURce:INTernal:CLOCk
  • :SOURce:POINts
  • :SOURce:ROSCillator:EXTernal:FREQuency
  • :SOURce:ROSCillator:SOURce
  • :SOURce[:STATe]
  • :SOURce:TTL:INPut?
  • :SOURce:TTL[:LEVel]
  • :SOURce:UFLatness:LOAD
  • :SOURce:UFLatness[:STATe]

:SOURce:DWELl

Sets the RF out dwell time per measurement point.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | Seconds

:SOURce:EEVensecond

Select a blue link to view the command details:

  • :SOURce:EEVensecond:POLarity
  • :SOURce:EEVensecond:POLarity:IN
  • :SOURce:EEVensecond:POLarityOUT

:SOURce:EEVensecond:POLarity

Sets the polarity of the even second output (for backward compatibility).

Query | Return | Set | Special | Units
yes | RIS|FALL | RISing| FALLing | Default | <NO

:SOURce:EEVensecond:POLarity:IN

Sets the polarity of the even second input.

Query | Return | Set | Special | Units
yes | RIS|FALL | RISing| FALLing | Default | <NO

:SOURce:EEVensecond:POLarity:OUT

Sets the polarity of the even second output.

Query | Return | Set | Special | Units
yes | RIS|FALL | RISing| FALLing | Default | <NO

:SOURce:FREQuency:CENTer

Sets the RF out center frequency.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | Hz

:SOURce:FREQuency:SPAN

Sets the RF out frequency span.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | Hz

:SOURce:FREQuency[:STARt]

Sets the RF out start frequency.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | Hz

:SOURce:FREQuency:STOP

Sets the RF out stop frequency.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | Hz

:SOURce:INTernal:CLOCk

Turns internal clock oscillator on/off.

  • ON (or 1) -- enables the internal clock oscillator.
  • OFF (or 0) -- disables the internal clock oscillator.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

:SOURce:POINts

Sets the RF out number of points.

Query | Return | Set | Special | Units
yes | NR1 | NRf | Max | Min | Def | none

:SOURce:ROSCillator:EXTernal:FREQuency

Sets the reference oscillator frequency.

Query | Return | Set | Special | Units
yes | NR1 | NRf | MIN|MAX | Hz

:SOURce:ROSCillator:SOURce

Sets the reference oscillator source.

  • INTernal - sets the source that is internal to the instrument as the reference oscillator.
  • EXTernal - sets a source that is external to the instrument as the reference oscillator.
  • EEVensecond - sets the source to an internal even second source.
Query | Return | Set | Special | Units
yes | INT|EXT|EEV | INTernal| EXTernal| EEVensecond | Default | none

:SOURce[:STATe]

Enables and disables the RF out.

  • ON (or 1) -- enables the RF out.
  • OFF (or 0) -- disables the RF out.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

:SOURce:TTL:INPut?

Reads the digital I/O input.

Query | Return | Set | Special | Units
yes | NR1 | n/a | none | none

:SOURce:TTL[:LEVel]

Sets the digital I/O output.

Query | Return | Set | Special | Units
yes | NR1 | NRf | Max | Min | Def | none


[:SOURce]:UFLatness:LOAD

Selects the user flatness data file that gets loaded in the instrument. If no filename is specified, the current user flatness parameter settings are loaded. A query returns the filename, if the user flatness is enabled. See User flatness.

HorizontalRuleSm
Parameters |
<string> | Filename sets the filename and path for the selected waveform. You can optionally specify the file extension (*.csv).
HorizontalRuleSm
 | [:SOURce]:UFLatness:LOAD TUESDAY1.csv
Examples | :UFL:LOAD TUESDAY1
 | :uflatness:load tuesday1
HorizontalRuleSm
Query Syntax | [:SOURce]:UFLatness:LOAD?
Return Type | String
HorizontalRuleSm
Default | n/a

Example:

You can use the programming command [:SOURce]:UFLatness:LOAD to load a file from a directory in the Model 2910-VSG, a USB memory stick inserted in the Model 2910-VSG, or another computer directory. To load a file from one of the available directories, use the following paths in the programming message.

Directory | Directory path in programming message
User Flatness User | User flatness\User\filename
another computer directory | \\UNC\directory\filename
USB (connected first) | \USB
USB (connected second) | \USB2
USB (connected third) | \USB3
USB (connected fourth) | \USB4

[:SOURce]:UFLatness[:STATe]

Enables and disables the user flatness operation. See User flatness.

HorizontalRuleSm
Parameters |
<b> | ON (or 1) switches on the user flatness mode.
 | OFF (or 0) switches off the user flatness mode.
 | DEFault returns to the default (preset) mode.
HorizontalRuleSm
 | [:SOURce]:UFLatness:STATe 1
Examples | :UFL:STAT ON
 | :uflatness:state off
HorizontalRuleSm
Query Syntax | [:SOURce]:UFLatness:STATe?
Return Type | Boolean (1 = On, 0 = Off)
HorizontalRuleSm
Default | Off (or 0)


:SOUTput

Select a blue link to view the command details:

  • :SOUTput:IMMediate
  • :SOUTput:MODE
  • :SOUTput:POLarity

:SOUTput:IMMediate

Immediately generates a sync out pulse. See Sync out.

Query | Return | Set | Special | Units
no | n/a | n/a | none | none

:SOUTput:MODE

Sets the sync out pulse to coincide with the specified event.

  • OFF - switches off the sync pulse.
  • BSWEep - sends a pulse at the beginning the channel power list.
  • PRETune - sends a pulse each time the analyzer tunes to a new frequency.
  • POSTune - sends a pulse when the analyzer is ready to acquire data. This is independent of the Acquisition Interval setting.
  • BACQuire - sends as pulse each time the analyzer starts acquiring data.
  • EACQuire - sends a pulse each time the analyzer finishes acquiring data.
  • ESWEeep - sends a pulse when the analyzer has reached the end of the list.
Query | Return | Set | Special | Units
yes | OFF| BSWE| PRET| POST| BACQ| EACQ| ESWE | OFF| BSWEep| PRETune| POSTune| BACQuire| EACQuire| ESWEeep | none | none

:SOUTput:POLarity

Sets the polarity of the sync pulse.

  • RISing - sets the sync pulse polarity to rising.
  • FALLing - sets the sync pulse polarity to falling.
Query | Return | Set | Special | Units
yes | RIS|FALL | RISing| FALLing | none | none


:STATus

Select a blue link to view the command details:

  • :STATus:MEASurement
  • :STATus:OPERation
  • :STATus:PRESet
  • :STATus:QUEStionable
  • :STATus:QUEue:CLEar


:STATus:MEASurement

Select a blue link to view the command details:

  • :STATus:MEASurement:CONDition?
  • :STATus:MEASurement:ENABle
  • :STATus:MEASurement[:EVENt]?

:STATus:MEASurement:CONDition?

Reads the measurement condition register. Each status register set (except the standard event register set) has a condition register. A condition register is a real-time, read-only register that constantly updates to reflect the present operating conditions of the instrument. See Measurement event register.

Query | Return | Set | Special | Units
yes | NR1 | n/a | none | none

:STATus:MEASurement:ENABle

Programs the measurement event enable register. When used as a query, it reads the enable register. Each status register set has an enable register. Each event register bit is logically ANDed (&) to a corresponding enable bit of an enable register. When an event bit is set and the corresponding enable bit is set (programmed by a user), the output (summary) of the register will set to 1, which is turn sets the summary bit of the status byte register. See Measurement event register.

The format of the response message for the query is set by the FORMat:SREGister command.

Power-up and *CLS resets all bits of all event registers to 0. STATus:PRESet has no effect.

Query | Return | Set | Special | Units
yes | NR1 | NRf | none | none

:STATus:MEASurement[:EVENt]?

Reads the measurement event register. Each status register has an event register. When an event occurs, the appropriate event register bit sets to 1. The bit remains latched to 1 until the register is reset. Reading an event register clears the bits of that register. *CLS resets all four event registers. See Measurement event register.

The format of the response message for the query is set by the FORMat:SREGister command.

Power-up and *CLS resets all bits of all event registers to 0. STATus:PRESet has no effect.

Query | Return | Set | Special | Units
yes | NR1 | n/a | none | none


:STATus:OPERation

Select a blue link to view the command details:

  • :STATus:OPERation:CONDition?
  • :STATus:OPERation:ENABle
  • :STATus:OPERation[:EVENt]?

:STATus:OPERation:CONDition?

Reads the operation condition register. Each status register set (except the standard event register set) has a condition register. A condition register is a real-time, read-only register that constantly updates to reflect the present operating conditions of the instrument. For example, while the instrument is in the idle state, bit B10 (Idle) of the operation condition register will be set. When the instrument is taken out of idle, bit B10 clears. See Operation event register.

Query | Return | Set | Special | Units
yes | NR1 | n/a | none | none

:STATus:OPERation:ENABle

Programs operation event enable register. When used as a query, it reads the enable register. When used as a query, it reads the enable register. Each status register set has an enable register. Each event register bit is logically ANDed (&) to a corresponding enable bit of an enable register. When an event bit is set and the corresponding enable bit is set (programmed by a user), the output (summary) of the register will set to 1, which is turn sets the summary bit of the status byte register. See Operation event register.

The format of the response message for the query is set by the FORMat:SREGister command.

Power-up and *CLS resets all bits of all event registers to 0. STATus:PRESet has no effect.

Query | Return | Set | Special | Units
yes | NR1 | NRf | none | none

:STATus:OPERation[:EVENt]?

Reads the operation event register. Each status register has an event register. When an event occurs, the appropriate event register bit sets to 1. The bit remains latched to 1 until the register is reset. Reading an event register clears the bits of that register. *CLS resets all four event registers. See Operation event register.

The format of the response message for the query is set by the FORMat:SREGister command.

Power-up and *CLS resets all bits of all event registers to 0. STATus:PRESet has no effect.

Query | Return | Set | Special | Units
yes | NR1 | n/a | none | none


:STATus:PRESet

Clears the following registers: operation event enable, measurement event enable, and questionable event enable. See Preset.

Query | Return | Set | Special | Units
no | n/a | n/a | none | none


:STATus:QUEStionable

Select a blue link to view the command details:

  • :STATus:QUEStionable:CONDition?
  • :STATus:QUEStionable:ENABle
  • :STATus:QUEStionable[:EVENt]?

:STATus:QUEStionable:CONDition?

Reads the questionable condition register. Each status register set (except the standard event register set) has a condition register. A condition register is a real-time, read-only register that constantly updates to reflect the present operating conditions of the instrument. See Questionable event register.

Query | Return | Set | Special | Units
yes | NR1 | n/a | none | none

:STATus:QUEStionable:ENABle

Programs questionable event enable register. When used as a query, it reads the enable register. Each status register set has an enable register. Each event register bit is logically ANDed (&) to a corresponding enable bit of an enable register. When an event bit is set and the corresponding enable bit is set (programmed by a user), the output (summary) of the register will set to 1, which is turn sets the summary bit of the status byte register. See Questionable event register.

The format of the response message for the query is set by the FORMat:SREGister command.

Power-up and *CLS resets all bits of all event registers to 0. STATus:PRESet has no effect.

Query | Return | Set | Special | Units
yes | NR1 | NRf | none | none

:STATus:QUEStionable[:EVENt]?

Reads the questionable event register. Each status register has an event register. When an event occurs, the appropriate event register bit sets to 1. The bit remains latched to 1 until the register is reset. Reading an event register clears the bits of that register. *CLS resets all four event registers. See Questionable event register.

The format of the response message for the query is set by the FORMat:SREGister command.

Power-up and *CLS resets all bits of all event registers to 0. STATus:PRESet has no effect.

Query | Return | Set | Special | Units
yes | NR1 | n/a | none | none


:STATus:QUEue:CLEar

Clears the status (error) queue. See Error queue.

Query | Return | Set | Special | Units
no | n/a | n/a | none | none


:SYStem

Select a blue link to view the command details:

  • :SYStem:CLEar
  • :SYStem:COMMunicate:GPIB:ADDRess
  • :SYStem:DATE
  • :SYStem:ERRor
  • :SYStem:KLOCk
  • :SYStem:LOCal
  • :SYStem:PRESet
  • :SYStem:REMote
  • :SYStem:SSAVer
  • :SYStem:TIME


:SYStem:CLEar

Clears all codes and messages from the error queue. See Error queue.

Query | Return | Set | Special | Units
no | n/a | n/a | none | none


:SYSTem:COMMunicate:GPIB:ADDRess

Sets the GPIB address. See System Setup for Remote Control.

Query | Return | Set | Special | Units
yes | NR1 | NRf | none | none


:SYSTem:DATE

Sets the system clock date. See Time and date. Numeric representation format <yr, mo, day>; yr specified as 20xx.

Query | Return | Set | Special | Units
yes | NR1,NR1, NR1 | NRf,NRf, NRf | none | none


:SYSTem:ERRor

Select a blue link to view the command details:

  • :SYSTem:ERRor:[NEXT]?
  • :SYSTem:ERRor:ALL?
  • :SYSTem:ERRor:CLEar
  • :SYSTem:ERRor:CODE:[NEXT]?
  • :SYSTem:ERRor:CODE:ALL?
  • :SYSTem:ERRor:COUNt?
  • :SYSTem:ERRor:ENABle:ADD
  • :SYSTem:ERRor:ENABle:DELete
  • :SYSTem:ERRor:ENABle[:LIST]

:SYSTem:ERRor:[NEXT]?

Reads the next error in the queue. As error and status messages occur, they are placed in the error queue. The error queue is a first-in first-out (FIFO) register that can hold up to 10 messages. After sending this command and addressing the instrument to talk, the oldest code and message is sent to the computer and is then removed from the queue. See Error queue.

Query | Return | Set | Special | Units
yes | string | n/a | none | none

:SYSTem:ERRor:ALL?

Reads all errors in the error queue. This query command is similar to the [:NEXT]? command except that all messages in the error queue are sent to the computer when the instrument is addressed to talk. All codes and messages are removed from the queue. See Error queue.

Query | Return | Set | Special | Units
yes | string | no | none | none

:SYSTem:ERRor:CLEar

Clears the error queue. See Error queue.

Query | Return | Set | Special | Units
no | n/a | none | none | none

:SYSTem:ERRor:CODE:[NEXT]?

Reads the next error by error code in the error queue. See Error queue.

Query | Return | Set | Special | Units
yes | string | n/a | none | none

:SYSTem:ERRor:CODE:ALL?

Reads all errors by error code in the error queue. See Error queue.

Query | Return | Set | Special | Units
yes | NR1 | n/a | none | none

:SYSTem:ERRor:COUNt?

Reads the count of the number of errors in the error queue.

Query | Return | Set | Special | Units
yes | NR1 | n/a | none | none

:SYSTem:ERRor:ENABle:ADD

Adds the specific errors to enable in the error queue. See Error queue. When you enable messages, the messages not specified in the list are disabled. When you disable messages, each listed message is removed from the enabled list.

  • Single message (-110)
  • Range of messages (-110:-222 = -110 through -222)
  • Range entry and single entry (separated by a comma -110:-222, -220)
Query | Return | Set | Special | Units
no | n/a | <list> | none | none

:SYSTem:ERRor:ENABle:DELete

Deletes the specific errors to enable the error queue. See Error queue. When you enable messages, the messages not specified in the list are disabled. When you disable messages, each listed message is removed from the enabled list.

  • Single message (-110)
  • Range of messages (-110:-222 = -110 through -222)
  • Range entry and single entry (separated by a comma -110:-222, -220)
Query | Return | Set | Special | Units
no | n/a | <list> | none | none

:SYSTem:ERRor:ENABle[:LIST]

Enables the specific errors in the error queue. See Error queue.

HorizontalRuleSm
Parameters |
<list> | Single message (-110)
 | Range of messages (-110:-222 = -110 through -222)
 | Range entry and single entry (separated by a comma -110:-222, -220)
 | When you enable messages, the messages not specified in the list are disabled. When you disable messages, each listed message is removed from the enabled list.
HorizontalRuleSm
 | :SYSTem:ERRor:ENABle[:LIST]
Examples | :SYST:ERR:ENAB
 | :system:error:enable
HorizontalRuleSm
Query Syntax | :SYSTem:ERRor:ENABle?
Return Type | Integer
HorizontalRuleSm
Default | Not applicable.


:SYSTem:KLOCk

Locks out the instrument front panel Local and Preset key when in the Remote mode. Sending the command, *RST, switches off the lock. See Local button and Preset.

  • ON (or 1) switches on lock out of the front panel Local key.
  • OFF (or 0) switches off the lock out of the front panel Local key.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | none | none


:SYSTem:LOCal

Puts the instrument in the local mode. See local button.

Query | Return | Set | Special | Units
no | n/a | none | none | none


:SYSTem:PRESet

Restores the instrument settings to the preset state defaults. See Preset.

Query | Return | Set | Special | Units
no | n/a | none | none | none


:SYSTem:REMote

Puts the instrument in the remote mode. See Remote and local operation differences.

Query | Return | Set | Special | Units
no | n/a | none | none | none


:SYSTem:SSAVer

Select a blue link to view the command details:

  • :SYSTem:SSAVer:DELay
  • :SYSTem:SSAVer[:STATe]

:SYSTem:SSAVer:DELay

Sets the delay of the screen saver, in minutes. See Screen saver.

Query | Return | Set | Special | Units
yes | NR1 | NRf | none | Minutes

:SYSTem:SSAVer[:STATe]

Sets the state of the screen saver. See Screen saver.

  • ON (or 1) switches on the screen saver.
  • OFF (or 0) switches off the screen saver.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | none | none


:SYSTem:TIME

Sets the system time. See Time and date. Hour, minute, second -- numeric representation format. This parameter is a number that can be expressed as an integer (for example, 8).

Query | Return | Set | Special | Units
yes | NR1,NR1, NR1 | NRf,NRf, NRf | none | none


:TRACe

Select a blue link to view the command details:

  • :TRACe:ACPR:HOLD
  • :TRACe:CPList:HOLD
  • :TRACe:HOLD

:TRACe:ACPR:HOLD

Sets the trace hold for ACPR/ACLR measurements.

Holds the measurement trace in a persistent state, visually adding the results of subsequent measurements. This allows you to analyze the data in a steady state.

  • NORMal -- shows the current positions of the measurement points, with no visual persistence.
  • MAXimum -- shows and holds the maximum values for the measurement points.
  • MINimum -- shows and holds the minimum values for the measurement points.
Query | Return | Set | Special | Units
yes | NORM| MAX| MIN | NORM| MAX| MIN | none | none

:TRACe:CPList:HOLD

Set trace hold for channel power list measurement.

Holds the measurement trace in a persistent state, visually adding the results of subsequent measurements. This allows you to analyze the data in a steady state.

  • NORMal -- shows the current positions of the measurement points, with no visual persistence.
  • MAXimum -- shows and holds the maximum values for the measurement points.
  • MINimum -- shows and holds the minimum values for the measurement points.
Query | Return | Set | Special | Units
yes | NORM| MAX| MIN | NORM| MAX| MIN | none | none

:TRACe:HOLD

Holds the measurement trace in a persistent state, visually adding the results of subsequent measurements. This allows you to analyze the data in a steady state.

Each trace point represents a band of frequency (or time) that is equal to Span/500. Among the 500 there is an upper and a lower value. The analyzer returns these two values for each of the 501 measurement trace points:

  • Upper value
  • Lower value

The parameter settings are as follows:

  • NORMal -- shows the current positions of the measurement points, with no visual persistence.
  • MAXimum -- shows and holds the maximum values for the measurement points.
  • MINimum -- shows and holds the minimum values for the measurement points.
  • MMAX -- shows and holds the maximum upper value and the minimum lower value for the measurement points.
Query | Return | Set | Special | Units
yes | NORM| MAX|| MIN | NORM| MAX|| MIN| MMAX | none | none


TRIGger

Select a blue link to view the command details:

  • :TRIGger[:SEQuence]:AUTO:TIMEout
  • :TRIGger[:SEQuence]:AUTO[:STATe]
  • :TRIGger[:SEQuence]:DELay
  • :TRIGger[:SEQuence]:EXTernal:SLOPe
  • :TRIGger[:SEQuence]:HYSTeresis[:LEVel]
  • :TRIGger[:SEQuence]:HYSTeresis:WINDow
  • :TRIGger[:SEQuence]:LEVel
  • :TRIGger[:SEQuence]:MODE
  • :TRIGger[:SEQuence]:PREQual:WINDow
  • :TRIGger[:SEQuence]:PREQual[:LEVel]
  • :TRIGger[:SEQuence]:SOURce
  • TRIGger[:SEQuence]:TYPE
  • :TRIGger[:SEQuence]:VIDeo:SLOPe

:TRIGger[:SEQuence]:AUTO:TIMEout

Sets the time to wait in seconds for a trigger before automatically providing an internal trigger to acquire a measurement.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | Seconds

:TRIGger[:SEQuence]:AUTO[:STATe]

Enables and disables the trigger timeout. If the timeout is enabled, a timeout is forced on any trigger type that is not free run. See TRIGger:AUTO:TIMEout.

  • ON (or 1) - enables trigger timeout.
  • OFF (or 0) - disables trigger timeout.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | none | none

:TRIGger:[:SEQuence]:DELay

Sets a delay between a trigger event and the instrument response.

When the trigger delay is set to zero, the center point of the data window is where the trigger occurred. Changing the trigger delay value allows you to see measurement trace events that occurred before or after the trigger. The trigger delay value is the point at the center of the data acquisition window. See Trigger.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | Seconds

:TRIGger[:SEQuence]:EXTernal:SLOPe

Sets external trigger slope.

  • POSitive -- sets the trigger slope to positive going.
  • NEGative -- sets the trigger slope to negative going.
Query | Return | Set | Special | Units
yes | POS|NEG | POSitive| NEGative | Default | none

:TRIGger[:SEQuence]:HYSTeresis[:LEVel]

Once a video trigger level is recognized by the DSP, the input signal must excur by this offset amount before the trigger will again be recognized. If the polarity of the signal is rising, the excursion must be negative and vice-versa.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | dB

:TRIGger[:SEQuence]:HYSTeresis:WINDow

The window specifies a time adjacent to the last trigger indication in which no trigger will be recognized by the DSP.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | Seconds

:TRIGger[:SEQuence]:LEVel

Sets the power level that the incoming RF signal must reach to cause a trigger event.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | dBm

:TRIGger[:SEQuence]:MODE

Sets the effect the trigger has on the analyzer.

  • MEASurement -- sets the trigger mode to On Measurement.
  • ACQuire -- sets the trigger mode to On Acquire.
Query | Return | Set | Special | Units
yes | ACQ|MEAS | ACQuire| MEASurement | Default | none

:TRIGger[:SEQuence]:PREQual:WINDow

When the trigger source is set to Video or Ext Arm/Video Trig, this command sets a window area in seconds adjacent to the leading edge of a bursted RF signal that is to be cause of the trigger event. The RF signal must not fall within this window area to qualify as a trigger event.

Query | Return | Set | Special | Units
yes | NR2 | NRf | MMD> | Seconds

:TRIGger[:SEQuence]:PREQual[:LEVel]

Once a video trigger level is recognized by the instrument, the input signal must reach this offset amount before the trigger will again be recognized.

Query | Return | Set | Special | Units
yes | NR2 | NRf | MMD> | dB

:TRIGger[:SEQuence]:SOURce

Sets the source of the trigger signal(s).

  • IMMediate -- sets the instrument to a continuous trigger mode.
  • EXTernal -- sets the instrument to receive a trigger from the rear panel TRIG IN connector.
  • ELATched -- sets the instrument to receive a trigger if the external input has sent an active edge since the last latch reset.
  • VIDeo -- sets the instrument to receive a trigger when the input signal reaches a specified level in dBm.
  • EVIDeo -- sets the instrument to receive a trigger from a combination of sources: an external pulse to arm the trigger, and a video signal to perform the trigger.
  • BUS -- sets the instrument to receive a trigger from a *TRG command.
  • BEXTernal -- sets the instrument to receive a trigger from a combination of sources: a bus *TRG to arm the trigger, and an external signal to perform the trigger.
  • BVIDeo -- sets the instrument to receive a trigger from a combination of sources: a bus *TRG to arm the trigger, and a video signal to perform the trigger.
Query | Return | Set | Special | Units
yes | IMM| EXT| ELAT| VID| EVID| BUS| BEXT| BVID | IMMediate| EXTernal| ELATched| VIDeo| EVIDeo| BUS| BEXTernal| BVIDeo | Default | none

TRIGger[:SEQuence]:TYPE

Sets the type of event that triggers the analyzer.

  • EDGE -- sets the video trigger type to edge.
  • LEVel -- sets the video trigger type to level.
Query | Return | Set | Special | Units
yes | EDGE| LEV | EDGE| LEVel | Default | none

:TRIGger[:SEQuence]:VIDeo:SLOPe

Sets video trigger slope.

  • POSitive -- sets the trigger slope to positive going.
  • NEGative -- sets the trigger slope to negative going.
Query | Return | Set | Special | Units
yes | POS|NEG | POSitive| NEGative | Default | none


[:SENSe]:ACPR

Select a blue link to view the command details:

  • [:SENSe]:ACPR:ADJacent1|ADJacent2
  • [:SENSe]:ACPR:AVERage
  • [:SENSe]:ACPR:BANDwidth[:RESolution]:TYPE
  • [:SENSe]:ACPR:BWIDth[:RESolution]:TYPE
  • [:SENSe]:ACPR:CENTer
  • [:SENSe]:ACPR:FAST
  • [:SENSe]:ACPR:NCORrection


[:SENSe]:ACPR:ADJacent1|ADJacent2

Select a blue link to view the command details:

  • [:SENSe]:ACPR:ADJacent1|ADJacent2:BANDwidth
  • [:SENSe]:ACPR:ADJacent1|ADJacent2:BWIDth
  • [:SENSe]:ACPR:ADJacent1|ADJacent2:OFRequency
  • [:SENSe]:ACPR:ADJacent1|ADJacent2[:STATe]
  • [:SENSe]:ACPR:ADJacent1|ADJacent2:SWEep:TIME

[:SENSe]:ACPR:ADJacent1|ADJacent2:BANDwidth

Sets the bandwidth of the specified adjacent ACPR channel.

Query | Return | Set | Special | Units
yes | NR1 | NRf | Max | Min | Def | Hz

[:SENSe]:ACPR:ADJacent1|ADJacent2:BWIDth

Sets the bandwidth of the specified adjacent ACPR channel (alternate form for BANDwidth command).

Query | Return | Set | Special | Units
yes | NR1 | NRf | Max | Min | Def | Hz

[:SENSe]:ACPR:ADJacent1|ADJacent2:OFRequency

Sets the frequency offset from the carrier center frequency to the center of the specified adjacent channel.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | <Hz>

[:SENSe]:ACPR:ADJacent1|ADJacent2[:STATe]

Enables and disables the adjacent channel measurement.

  • ON (or 1) - enables adjacent channel measurement.
  • OFF (or 0) - disables adjacent channel measurement.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

[:SENSe]:ACPR:ADJacent1|ADJacent2:SWEep:TIME

Sets the sweep time for the specified adjacent ACPR channel.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | Seconds


[:SENSe]:ACPR:AVERage

Select a blue link to view the command details:

  • [:SENSe]:ACPR:AVERage:COUNt
  • [:SENSe]:ACPR:AVERage:TYPE
  • [:SENSe]:ACPR:AVERage[:STATe]

[:SENSe]:ACPR:AVERage:COUNt

Sets the number of averages for ACPR/ACLR measurements.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | none

[:SENSe]:ACPR:AVERage:TYPE

Selects the average type.

  • LOG - sets the Running Log type of measurement averaging.
  • POWer - sets the Power Running type of measurement averaging.
  • GLOG - sets the Log Group type of measurement averaging.
  • GPOWer - sets the Power Group type of measurement averaging.
  • GMAX - sets the Max Group type of measurement averaging.
  • GMIN - sets the Min Group type of measurement averaging.
  • GMMAX - sets the Min/Max Group type of measurement averaging. This choice does not apply for Spectrum > General Purpose > ACPR.
Query | Return | Set | Special | Units
yes | LOG| POW| GLOG| GPOW| GMAX| GMIN| GMMAX | LOG| POWer| GLOG| GPOWer| GMAX| GMIN| GMMAX | Default | none

[:SENSe]:ACPR:AVERage[:STATe]

Enables and disables measurement averaging.

  • ON (or 1) - enables measurement averaging.
  • OFF (or 0) - disables measurement averaging.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none


[:SENSe]:ACPR:BANDwidth[:RESolution]:TYPE

Sets the bandwidth filter type for ACPR channels. The center channel and adjacent channels share the same setting.

  • BRICKwall - sets the filter type to Brickwall.
  • FOURstpole - sets the filter type to Sync Tuned 4 Pole.
  • FIVEstpole - sets the filter type to Sync Tuned 5 Pole.
  • RRC - sets the filter type to Raised-Root-Cosine.
  • GAUSsian - sets the filter type to True Gaussian.
Query | Return | Set | Special | Units
yes | BRIC| FOUR| FIVE| RRC| GAUS | BRICkwall| FOURstole| FIVEstole| RRC| GAUSsian | Default | none


[:SENSe]:ACPR:BWIDth[:RESolution]:TYPE

Sets the bandwidth filter type for ACPR channels. The center channel and adjacent channels share the same setting. (Alternate form for bandwidth TYPE command.)

  • BRICKwall - sets the filter type to Brickwall.
  • FOURstpole - sets the filter type to Sync Tuned 4 Pole.
  • FIVEstpole - sets the filter type to Sync Tuned 5 Pole.
  • RRC - sets the filter type to Raised-Root-Cosine.
  • GAUSsian - sets the filter type to True Gaussian.
Query | Return | Set | Special | Units
 | BRIC| FOUR| FIVE| RRC| GAUS | BRICkwall| FOURstole| FIVEstole| RRC| GAUSsian | Default | none


[:SENSe]:ACPR:CENTer

Select a blue link to view the command details:

  • [:SENSe]:ACPR:CENTer:BANDwidth
  • [:SENSe]:ACPR:CENTer:BWIDth
  • [:SENSe]:ACPR:CENTer:SWEep:TIME

[:SENSe]:ACPR:CENTer:BANDwidth

Sets the width of the ACPR center (carrier) channel.

Query | Return | Set | Special | Units
yes | NR1 | NRf | Max | Min | Def | <Hz>

[:SENSe]:ACPR:CENTer:BWIDth

Sets the width of the ACPR center (carrier) channel (alternate for BANDwidth command).

Query | Return | Set | Special | Units
yes | NR1 | NRf | Max | Min | Def | <Hz>

[:SENSe]:ACPR:CENTer:SWEep:TIME

Sets the sweep time for the ACPR center (carrier) channel.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | Seconds


[:SENSe]:ACPR:FAST

Enables and disables the ACPR fast mode.

  • ON (or 1) - enables the ACPR fast mode.
  • OFF (or 0) - disables the ACPR fast mode.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none


[:SENSe]:ACPR:NCORrection

Enables and disables the ACPR noise correction.

  • ON (or 1) - enables the ACPR noise correction.
  • OFF (or 0) - disables the ACPR noise correction.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none


[:SENSe]:ADC:DITHer[:STATe]

Sets the acquisition interval on which data will be acquired. Used primarily for channel power list mode when there is no hardware handshake is available.

  • ON (or 1) - enables measurement dithering.
  • OFF (or 0) - disables measurement dithering.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none


[:SENSe]:AINT

Sets the data acquisition interval for the channel power list.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | Seconds


[:SENSe]:CDMA:REVerse:AVERage

Select a blue link to view the command details:

  • [:SENSe]:CDMA:REVerse:AVERage:COUNt
  • [:SENSe]:CDMA:REVerse:AVERage:TYPE
  • [:SENSe]:CDMA:REVerse:AVERage[:STATe]

[:SENSe]:CDMA:REVerse:AVERage:COUNt

Sets the number of averages for a cdma2000 reverse measurement.

Query | Return | Set | Special | Units
yes | NR1 | NRf | Max | Min | Def | none

[:SENSe]:CDMA:REVerse:AVERage:TYPE

Sets the type of averaging for a cdma2000 reverse measurement.

  • GMEan - sets the averaged measurement trace to show the calculated mean of multiple measurements.
  • GMAX - sets the measurement trace to show the average of the maximum power data results from multiple measurements.
  • GMIN - sets the measurement trace to show the average of the minimum power data results from multiple measurements.
Query | Return | Set | Special | Units
yes | GME| GMAX| GMIN | GMEan| GMAX| GMIN | Default | none

[:SENSe]:CDMA:REVerse:AVERage[:STATe]

Sets whether measurement averaging is applied in the cdma2000 reverse measurement.

  • ON (or 1) - applies the averaging in the cdma2000 reverse measurement.
  • OFF (or 0) - omits the averaging in the cdma2000 reverse measurement.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none


[:SENSe]:CPList

Select a blue link to view the command details:

  • [:SENSe]:CPList:AVERage:COUNt
  • [:SENSe]:CPList:AVERage:TYPE
  • [:SENSe]:CPList:AVERage[:STATe]
  • [:SENSe]:CPList:BANDwidth[:RESolution]:TYPE
  • [:SENSe]:CPList:BWIDth[:RESolution]:TYPE
  • [:SENSe]:CPList:COUNt
  • [:SENSe]:CPList:FAST
  • [:SENSe]:CPList:LOAD
  • [:SENSe]:CPList:NCORrection

[:SENSe]:CPList:AVERage:COUNt

Sets the number of averages for a channel power list measurement.

Query | Return | Set | Special | Units
yes | NR1 | NRf | Max | Min | Def | none

[:SENSe]:CPList:AVERage:TYPE

Selects the average type.

  • LOG - sets the Running Log type of measurement averaging.
  • POWer - sets the Power Running type of measurement averaging.
  • GLOG - sets the Log Group type of measurement averaging.
  • GPOWer - sets the Power Group type of measurement averaging.
  • GMAX - sets the Max Group type of measurement averaging.
  • GMIN - sets the Min Group type of measurement averaging.
  • GMMAX - sets the Min/Max Group type of measurement averaging. This choice does not apply for Spectrum > General Purpose > ACPR.
Query | Return | Set | Special | Units
yes | LOG| POW| GLOG| GPOW| GMAX| GMIN| GMMAX | LOG| POWer| GLOG| GPOWer| GMAX| GMIN| GMMAX | Default | none

[:SENSe]:CPList:AVERage[:STATe]

Enables and disables measurement averaging.

  • ON (or 1) - enables measurement averaging.
  • OFF (or 0) - disables measurement averaging.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

[:SENSe]:CPList:BANDwidth[:RESolution]:TYPE

Sets bandwidth filter type for channel power list measurement.

  • BRICKwall - sets the filter type to Brickwall.
  • FOURstpole - sets the filter type to Sync Tuned 4 Pole.
  • FIVEstpole - sets the filter type to Sync Tuned 5 Pole.
  • RRC - sets the filter type to Raised-Root-Cosine.
  • GAUSsian - sets the filter type to True Gaussian.
Query | Return | Set | Special | Units
yes | BRIC| FOUR| FIVE| RRC| GAUS | BRICkwall| FOURstole| FIVEstole| RRC| GAUSsian | Default | none

[:SENSe]:CPList:BWIDth[:RESolution]:TYPE

Alternate method for setting bandwidth filter type for channel power list measurement.

  • BRICKwall - sets the filter type to Brickwall.
  • FOURstpole - sets the filter type to Sync Tuned 4 Pole.
  • FIVEstpole - sets the filter type to Sync Tuned 5 Pole.
  • RRC - sets the filter type to Raised-Root-Cosine.
  • GAUSsian - sets the filter type to True Gaussian.
Query | Return | Set | Special | Units
yes | BRIC| FOUR| FIVE| RRC| GAUS | BRICkwall| FOURstole| FIVEstole| RRC| GAUSsian | Default | none

[:SENSe]:CPList:COUNt

Sets the number of averages for a channel power list measurement.

Query | Return | Set | Special | Units
yes | NR1 | NRf | Max | Min | Def | none

[:SENSe]:CPList:FAST

Enables and disables channel power list fast mode.

  • ON (or 1) - enables channel power list fast mode.
  • OFF (or 0) - disables channel power list fast mode.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

[:SENSe]:CPList:LOAD

Loads the channel power list table from the specified file. The argument sets the filename and path for the selected waveform. You can optionally specify the file extension (*.list). The query returns the CPList file name without the file path or file extension.

You must create the list description file in an external application, such as Excel or Notepad. You must make all modifications to the list file from the application that you used to create it.

Example channel power list file:

Channel Power List Version 2.0,,,

Begin Table,,,

State, Frequency, RBW, SweepTime,RefLevel,Preamp

1,1.800000e+009,1.000000e+007,1.000000e-004,20,Off

1,1.788500e+009,1.000000e+006,1.000000e-004,10,Off

1,1.793000e+009,1.000000e+006,1.000000e-004,0,off

1,1.794450e+009,1.000000e+005,1.000000e-004,-10,OFF

1,1.805550e+009,1.000000e+005,1.000000e-004,-20,0

1,1.807000e+009,1.000000e+006,1.000000e-004,-30,0

Query | Return | Set | Special | Units
yes | string - filename | string filename | Default, " " | none

[:SENSe]:CPList:NCORrection

Enables and disables channel power list correction.

  • ON (or 1) - enables channel power list correction.
  • OFF (or 0) - disables channel power list correction.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none


[:SENSe]:DETector[:FUNCtion]

Selects the detector function.

  • NORMal - sets the detector to normal.
  • MAX - sets both the upper and lower values to the maximum.
  • MIN - sets both the upper and lower values to the minimum.
  • SAMPle - sets both the upper and lower values to the middle span value.
  • PAVerage - sets both the upper and lower values to the average of the signal power.
  • NCPAverage - draws the trace using the result of two separate measurements with power average detection.
Query | Return | Set | Special | Units
yes | NORM| MAX| MIN| SAMP| PAV| NCPA | NORMal| MAX| MIN| SAMPle| PAVerage| NCPAverage | Default | none


[:SENSe]:DSP

Select a blue link to view the command details:

  • [:SENSe]:DSP:RANDomize[:STATe]
  • [:SENSe]:DSP:RANGe[:STATe]

[:SENSe]:DSP:RANDomize[:STATe]

Enables and disables the DSP process of randomly setting the actual start time of a free run trigger to avoid a repetitive static measurement period.

  • ON (or 1) - enables the process of randomly setting the start time.
  • OFF (or 0) - disables the process of randomly setting the start time.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

[:SENSe]:DSP:RANGe[:STATe]

Enables and disables the DSP process of checking for an input overload.

  • ON (or 1) - enables the process of checking for an input overload.
  • OFF (or 0) - disables the process of checking for an input overload.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none


[:SENSe]:EDGE

Select a blue link to view the command details:

  • [:SENSe]:EDGE:CPOWer
  • [:SENSe]:EDGE:EVM
  • [:SENSe]:EDGE:ORFS:MODulation
  • [:SENSe]:EDGE:ORFS:SWITching
  • [:SENSe]:EDGE:TMASk
  • [:SENse]:EDGE:TSEQuence
  • [:SENSe]:EDGE:TSLot


[:SENSe]:EDGE:CPOWer

Select a blue link to view the command details:

  • [:SENSe]:EDGE:CPOWer:AVERage:COUNt
  • [:SENSe]:EDGE:CPOWer:AVERage:TYPE

[:SENSe]:EDGE:CPOWer:AVERage:COUNt

Sets the number of averages for an EDGE channel power measurement.

Query | Return | Set | Special | Units
yes | NR1 | [1 to 1001] | Max | Min | Def | none

[:SENSe]:EDGE:CPOWer:AVERage:TYPE

Sets the tracking when averaging is applied.

  • MEAN - tracks the mean value of the channel power.
  • MAXimum - tracks the maximum value of the channel power.
  • MINimum - sets the minimum value of the channel power.
Query | Return | Set | Special | Units
yes | MEAN| MAX| MIN | MEAN| MAX| MIN | Default | none


[:SENSe]:EDGE:EVM

Select a blue link to view the command details:

  • [:SENSe]:EDGE:EVM:AVERage:COUNt
  • [:SENSe]:EDGE:EVM:AVERage:TYPE
  • [:SENSe]:EDGE:EVM[:STATe]

[:SENSe]:EDGE:EVM:AVERage:COUNt

Sets the number of averages for an EDGE EVM measurement.

Query | Return | Set | Special | Units
yes | NR1 | [1 to 1001] | Max | Min | Def | none

[:SENSe]:EDGE:EVM:AVERage:TYPE

Sets the tracking when averaging is applied.

  • MEAN - tracks the mean value of the EDGE EVM measurement.
  • MAXimum - tracks the maximum value of the EDGE EVM measurement.
  • MINimum - sets the minimum value of the EDGE EVM measurement.
Query | Return | Set | Special | Units
yes | MEAN| MAX| MIN | MEAN| MAX| MIN | Default | none

[:SENSe]:EDGE:EVM[:STATe]

Enables and disables the EDGE EVM measurement.

  • ON (or 1) - enables the EVM measurement.
  • OFF (or 0) - disables the EVM measurement.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none


[:SENSe]:EDGE:ORFS:MODulation

Select a blue link to view the command details:

  • [:SENSe]:EDGE:ORFS:MODulation:AVERage:COUNt
  • [:SENSe]:EDGE:ORFS:MODulation:AVERage:TYPE
  • [:SENSe]:EDGE:ORFS:MODulation:AVERage:UNIT
  • [:SENSe]:EDGE:ORFS:MODulation:DETector[:FUNCtion]
  • [:SENSe]:EDGE:ORFS:MODulation:FLIMits
  • [:SENSe]:EDGE:ORFS:MODulation:VBW[:STATe]
  • [:SENSe]:EDGE:ORFS:MODulation[:STATe]

[:SENSe]:EDGE:ORFS:MODulation:AVERage:COUNt

Sets the number of averages for a measurement.

Query | Return | Set | Special | Units
yes | NR1 | [1 to 1001] | Max | Min | Def | none

[:SENSe]:EDGE:ORFS:MODulation:AVERage:TYPE

Sets the tracking when averaging is applied.

  • MEAN - tracks the mean value of the measurement.
  • MAXimum - tracks the maximum value of the measurement.
  • MINimum - sets the minimum value of the measurement.
Query | Return | Set | Special | Units
yes | MEAN| MAX| MIN | MEAN| MAXimum| MINimum | Default | none

[:SENSe]:EDGE:ORFS:MODulation:AVERage:UNIT

Averaging data type is much like the detector function. Some analyzers detect the data in one mode, integrate across a portion of the pulse, then save that result in another mode. When averaging is then applied burst-to-burst, you get statistical variation depending on the averaging data type.

Query | Return | Set | Special | Units
yes | WATTS| DB| VMAG | WATTS| DB| VMAG | Default | none

[:SENSe]:EDGE:ORFS:MODulation:DETector[:FUNCtion]

Sets the detector function for ORFS modulation measurement.

Query | Return | Set | Special | Units
yes | WATTS| DB| VMAG | WATTS| DB| VMAG | Default | none

[:SENSe]:EDGE:ORFS:MODulation:FLIMits

Queries and sets the limit table as a set of comma-separated values. Progresses from left to right across rows, then down the table. Does not give the column headers and separates the rows with a comma.

Query | Return | Set | Special | Units
yes | NR2 | n/a | none | none

[:SENSe]:EDGE:ORFS:MODulation:VBW[:STATe]

Sets whether the video bandwidth filter is applied in the ORFS calculation.

  • ON (or 1) - applies the video bandwidth filter in the ORFS calculation.
  • OFF (or 0) - omits the video bandwidth filter from the ORFS calculation.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

[:SENSe]:EDGE:ORFS:MODulation[:STATe]

Enables and disables the output RF spectrum due to modulation (ORFS Mod) measurement. When enabled, you get the measurement results for the power in a specific portion of the burst at a specific offset from the carrier.

  • ON (or 1) - enables the ORFS Mod measurement.
  • OFF (or 0) - disables the ORFS Mod measurement.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none


[:SENSe]:EDGE:ORFS:SWITching

Select a blue link to view the command details:

  • [:SENSe]:EDGE:ORFS:SWITching:AVERage:COUNt
  • [:SENSe]:EDGE:ORFS:SWITching:AVERage:TYPE
  • [:SENSe]:EDGE:ORFS:SWITching:AVERage:UNIT
  • [:SENSe]:EDGE:ORFS:SWITching:DETector[:FUNCtion]
  • [:SENSe]:EDGE:ORFS:SWITching:FLIMits
  • [:SENSe]:EDGE:ORFS:SWITching:VBW[:STATe]
  • [:SENSe]:EDGE:ORFS:SWITching[:STATe]

[:SENSe]:EDGE:ORFS:SWITching:AVERage:COUNt

Sets the number of averages for a measurement.

Query | Return | Set | Special | Units
yes | NR1 | [1 to 1001] | Max | Min | Def | none

[:SENSe]:EDGE:ORFS:SWITching:AVERage:TYPE

Sets the tracking when averaging is applied.

  • MEAN - tracks the mean value of the measurement.
  • MAXimum - tracks the maximum value of the measurement.
  • MINimum - sets the minimum value of the measurement.
Query | Return | Set | Special | Units
yes | MEAN| MAX| MIN | MEAN| MAXimum| MINimum | none | none

[:SENSe]:EDGE:ORFS:SWITching:AVERage:UNIT

Averaging data type is much like the detector function. Some analyzers detect the data in one mode, integrate across a portion of the pulse, then save that result in another mode. When averaging is then applied burst-to-burst, you get statistical variation depending on the averaging data type.

Query | Return | Set | Special | Units
yes | WATTS| DB| VMAG | WATTS| DB| VMAG | Default | none

[:SENSe]:EDGE:ORFS:SWITching:DETector[:FUNCtion]

Sets the detector function for ORFS measurement.

Query | Return | Set | Special | Units
yes | WATTS| DB| VMAG | WATTS| DB| VMAG | Default | none

[:SENSe]:EDGE:ORFS:SWITching:FLIMits

Queries and sets the limit table as a set of comma-separated values. Progresses from left to right across rows, then down the table. Does not give the column headers and separates the rows with a comma.

Query | Return | Set | Special | Units
yes | NR2 | n/a | none | none

[:SENSe]:EDGE:ORFS:SWITching:VBW[:STATe]

Sets whether the video bandwidth filter is applied in the ORFS calculation.

  • ON (or 1) - applies the video bandwidth filter in the ORFS calculation.
  • OFF (or 0) - omits the video bandwidth filter from the ORFS calculation.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

[:SENSe]:EDGE:ORFS:SWITching[:STATe]

Enables and disables the output RF spectrum due to switching (ORFS Swi). When the ORFS switching is enabled, you get measurement results for the power in a specific portion of the burst. ORFS switching tracks peak power across the burst, assuming the peak is due to the burst transitions at either end.

  • ON (or 1) - enables the ORFS Switching.
  • OFF (or 0) - disables the ORFS Switching.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none


[:SENSe]:EDGE:TMASk

Select a blue link to view the command details:

  • [:SENSe]:EDGE:TMASk:AVERage:COUNt
  • [:SENSe]:EDGE:TMASk:AVERage:TYPE
  • [:SENSe]:EDGE:TMASk[:STATe]

[:SENSe]:EDGE:TMASk:AVERage:COUNt

Sets the number of averages for a measurement.

Query | Return | Set | Special | Units
yes | NR1 | [1 to 1001] | Max | Min | Def | none

[:SENSe]:EDGE:TMASk:AVERage:TYPE

Sets the tracking for a time mask measurement when averaging is applied.

Query | Return | Set | Special | Units
yes | MEAN| MAX| MIN | MEAN| MAXimum| MINimum | Default | none

[:SENSe]:EDGE:TMASk[:STATe]

Enables and disables the time mask measurement.

  • ON (or 1) - enables the time mask measurement.
  • OFF (or 0) - disables the time mask measurement.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none


[:SENse]:EDGE:TSEQuence

Sets the training sequence to look for in the selected slot to measure.

Note: If there is only one time slot active, set TSLot:COUNt to 1 and then set this parameter.

Query | Return | Set | Special | Units
yes | NR1 | 0...7 | Max | Min | Def | none


[:SENSe]:EDGE:TSLot

Select a blue link to view the command details:

  • [:SENSe]:EDGE:TSLot:COUNt
  • [:SENSe]:EDGE:TSLot:FIRSt
  • [:SENSe]:EDGE:TSLot[:SELect]

[:SENSe]:EDGE:TSLot:COUNt

Sets the number of active time slots in the incoming signal. Must be contiguous and no more than 7 slots.

Query | Return | Set | Special | Units
yes | NR1 | 1...7 | Max | Min | Def | none

[:SENSe]:EDGE:TSLot:FIRSt

Sets the first slot that is active.

Query | Return | Set | Special | Units
yes | NR1 | 0...7 | none | none

[:SENSe]:EDGE:TSLot[:SELect]

Sets the time slot to measure, 0 to 7. The training sequence is assumed to match the time slot.

Query | Return | Set | Special | Units
yes | NR1 | 0...7 | none | none


[:SENSe]:EPOWer

Sets the expected channel power. This is similar to the reference level in a spectrum and zero-span measurements.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | dBm


[:SENSe]:FREQuency

Select a blue link to view the command details:

  • [:SENSe]:FREQuency:CENTer
  • [:SENSe]:FREQuency:SPAN
  • [:SENSe]:FREQuency:STARt
  • [:SENSe]:FREQuency:STOP

[:SENSe]:FREQuency:CENTer

Sets center frequency value.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | Hz

[:SENSe]:FREQuency:SPAN

Sets the frequency span.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | Hz

[:SENSe]:FREQuency:STARt

Sets the start frequency value.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | Hz

[:SENSe]:FREQuency:STOP

Sets the stop frequency value.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | Hz


[:SENSe]:GSM

Select a blue link to view the command details:

  • [:SENSe]:GSM:CPOWer
  • [:SENSe]:GSM:ORFS:MODulation
  • [:SENSe]:GSM:ORFS:SWITching
  • [:SENSe]:GSM:PERRor
  • [:SENSe]:GSM:TMASk
  • [:SENSe]:GSM:TSEQuence
  • [:SENSe]:GSM:TSLot


[:SENSe]:GSM:CPOWer

Select a blue link to view the command details:

  • [:SENSe]:GSM:CPOWer:AVERage:COUNt
  • [:SENSe]:GSM:CPOWer:AVERage:TYPE

[:SENSe]:GSM:CPOWer:AVERage:COUNt

Sets the number of averages for the channel power measurement. Bursts are acquired in a block. The channel power is always available in GSM.

Query | Return | Set | Special | Units
yes | NR1 | [1 to 1001] | Max | Min | Def | none

[:SENSe]:GSM:CPOWer:AVERage:TYPE

Sets the tracking when averaging is applied.

Query | Return | Set | Special | Units
yes | MEAN| MAX| MIN | MEAN| MAX| MIN | Default | none


[:SENSe]:GSM:ORFS:MODulation

Select a blue link to view the command details:

  • [:SENSe]:GSM:ORFS:MODulation:AVERage:COUNt
  • [:SENSe]:GSM:ORFS:MODulation:AVERage:TYPE
  • [:SENSe]:GSM:ORFS:MODulation:AVERage:UNIT
  • [:SENSe]:GSM:ORFS:MODulation:DETector[:FUNCtion]
  • [:SENSe]:GSM:ORFS:MODulation:FLIMits
  • [:SENSe]:GSM:ORFS:MODulation:VBW[:STATe]
  • [:SENSe]:GSM:ORFS:MODulation[:STATe]

[:SENSe]:GSM:ORFS:MODulation:AVERage:COUNt

Sets the number of averages for ORFS modulation measurement data acquired in a block. Set to 1 to turn off averaging.

Query | Return | Set | Special | Units
yes | NR1 | [1 to 1001] | none | none

[:SENSe]:GSM:ORFS:MODulation:AVERage:TYPE

Sets the averaging type for data acquired in a block.

Query | Return | Set | Special | Units
yes | MEAN| MAX| MIN | MEAN| MAX| MIN | Default | none

[:SENSe]:GSM:ORFS:MODulation:AVERage:UNIT

Sets the Averaging Data Type. You can set the analyzer to detect the data in one mode, integrate across a portion of the pulse, then save that result in another mode. When averaging is then applied burst-to-burst, you get statistical variation depending on the averaging data type.

Query | Return | Set | Special | Units
yes | WATTS| DB| VMAG | WATTS| DB| VMAG | Default | none

[:SENSe]:GSM:ORFS:MODulation:DETector[:FUNCtion]

Sets the detector function for ORFS measurement.

Query | Return | Set | Special | Units
yes | WATTS| DB| VMAG | WATTS| DB| VMAG | Default | none

[:SENSe]:GSM:ORFS:MODulation:FLIMits

Queries and sets the limit table as a set of comma-separated values. Progresses from left to right across rows, then down the table. Does not give the column headers and separates the rows with a comma.

Query | Return | Set | Special | Units
yes | NR2 | n/a | none | none

[:SENSe]:GSM:ORFS:MODulation:VBW[:STATe]

Sets whether the video bandwidth filter is applied in the ORFS calculation.

  • ON (or 1) - applies the video bandwidth filter in the ORFS calculation.
  • OFF (or 0) - omits the video bandwidth filter from the ORFS calculation.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

[:SENSe]:GSM:ORFS:MODulation[:STATe]

Enables and disables the output RF spectrum due to modulation (ORFS Mod). When enabled, you get the measurement results for the power in a specific portion of the burst at a specific offset from the carrier.

  • ON (or 1) - enables the ORFS Mod measurement.
  • OFF (or 0) - disables the ORFS Mod measurement.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none


[:SENSe]:GSM:ORFS:SWITching

Select a blue link to view the command details:

  • [:SENSe]:GSM:ORFS:SWITching:AVERage:COUNt
  • [:SENSe]:GSM:ORFS:SWITching:AVERage:TYPE
  • [:SENSe]:GSM:ORFS:SWITching:AVERage:UNIT
  • [:SENSe]:GSM:ORFS:SWITching:DETector[:FUNCtion]
  • [:SENSe]:GSM:ORFS:SWITching:FLIMits
  • [:SENSe]:GSM:ORFS:SWITching:VBW[:STATe]
  • [:SENSe]:GSM:ORFS:SWITching[:STATe]

[:SENSe]:GSM:ORFS:SWITching:AVERage:COUNt

Sets the number of averages for ORFS switching measurement data acquired in a block. Set to 1 to turn off averaging.

Query | Return | Set | Special | Units
yes | NR1 | [1 to 1001] | none | none

[:SENSe]:GSM:ORFS:SWITching:AVERage:TYPE

Sets the averaging type for data acquired in a block.

Query | Return | Set | Special | Units
yes | MEAN| MAX| MIN | MEAN| MAX| MIN | Default | none

[:SENSe]:GSM:ORFS:SWITching:AVERage:UNIT

Averaging data type is much like the detector function. Some analyzers detect the data in one mode, integrate across a portion of the pulse, then save that result in another mode. When averaging is then applied burst-to-burst, you get statistical variation depending on the averaging data type.

Query | Return | Set | Special | Units
yes | WATTS| DB| VMAG | WATTS| DB| VMAG | Default | none

[:SENSe]:GSM:ORFS:SWITching:DETector[:FUNCtion]

Sets the detector function for ORFS measurement.

Query | Return | Set | Special | Units
yes | WATTS| DB| VMAG | WATTS| DB| VMAG | Default | none

[:SENSe]:GSM:ORFS:SWITching:FLIMits

Queries and sets the limit table as a set of comma-separated values. Progresses from left to right across rows, then down the table. Does not give the column headers and separates the rows with a comma.

Query | Return | Set | Special | Units
yes | NR2 | n/a | none | none

[:SENSe]:GSM:ORFS:SWITching:VBW[:STATe]

Sets whether the video bandwidth filter is applied in the ORFS calculation.

  • ON (or 1) - applies the video bandwidth filter in the ORFS calculation.
  • OFF (or 0) - omits the video bandwidth filter from the ORFS calculation.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

[:SENSe]:GSM:ORFS:SWITching[:STATe]

Enables and disables the output RF spectrum due to switching (ORFS Swi). When the ORFS switch is enabled, you get measurement results for the power in a specific portion of the burst. ORFS switch tracks peak power across the burst, assuming the peak is due to the burst transitions at either end.

  • ON (or 1) - enables the ORFS switch.
  • OFF (or 0) - disables the ORFS switch.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none


[:SENSe]:GSM:PERRor

Select a blue link to view the command details:

  • [:SENSe]:GSM:PERRor:AVERage:COUNt
  • [:SENSe]:GSM:PERRor:AVERage:TYPE
  • [:SENSe]:GSM:PERRor[:STATe]

[:SENSe]:GSM:PERRor:AVERage:COUNt

Sets the number of averages for measurement data acquired in a block. Set to 1 to turn off averaging.

Query | Return | Set | Special | Units
yes | NR1 | [1 to 1001] | Max | Min | Def | none

[:SENSe]:GSM:PERRor:AVERage:TYPE

Sets the tracking when averaging is applied.

  • MEAN - tracks the mean value of the phase error.
  • MAXimum - tracks maximum value of the phase error.
  • MINimum - tracks the minimum value of the phase error.
Query | Return | Set | Special | Units
yes | MEAN| MAX| MIN | MEAN| MAX| MIN | Default | none

[:SENSe]:GSM:PERRor[:STATe]

Enables and disables the phase error measurement. When the measurement is enabled, you will get results for rms phase error, peak phase error, and carrier frequency.

  • ON (or 1) - enables the phase error measurement.
  • OFF (or 0) - disables the phase error measurement.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none


[:SENSe]:GSM:TMASk

Select a blue link to view the command details:

  • [:SENSe]:GSM:TMASk:AVERage:COUNt
  • [:SENSe]:GSM:TMASk:AVERage:TYPE
  • [:SENSe]:GSM:TMASk[:STATe]

[:SENSe]:GSM:TMASk:AVERage:COUNt

Sets the number of averages for measurement data acquired in a block. Set to 1 to turn off averaging.

Query | Return | Set | Special | Units
yes | NR1 | [1 to 1001] | Max | Min | Def | none

[:SENSe]:GSM:TMASk:AVERage:TYPE

Sets the tracking for a time mask measurement when averaging is applied.

Query | Return | Set | Special | Units
yes | MEAN| MAX| MIN | MEAN| MAX| MIN | none | none

[:SENSe]:GSM:TMASk[:STATe]

Enables and disables the time mask measurement.

  • ON (or 1) - enables the time mask measurement.
  • OFF (or 0) - disables the time mask measurement.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none


[:SENSe]:GSM:TSEQuence

Sets the training sequence to look for in the selected slot to measure.

Note: If there is only one time slot active, set TSLot:COUNt to 1 and then set this parameter.

Query | Return | Set | Special | Units
yes | NR1 | 0...7 | Max | Min | Def | none


[:SENSe]:GSM:TSLot

Select a blue link to view the command details:

  • [:SENSe]:GSM:TSLot:COUNt
  • [:SENSe]:GSM:TSLot:FIRSt
  • [:SENSe]:GSM:TSLot[:SELect]

[:SENSe]:GSM:TSLot:COUNt

Sets the number of active time slots in the incoming signal. Must be contiguous and no more than 7 slots.

Query | Return | Set | Special | Units
yes | NR1 | 1...7 | Max | Min | Def | none

[:SENSe]:GSM:TSLot:FIRSt

Sets the first slot that is active.

Query | Return | Set | Special | Units
yes | NR1 | 0...7 | Max | Min | Def | none

[:SENSe]:GSM:TSLot[:SELect]

Sets the time slot to measure, 0 to 7. The training sequence is assumed to match the time slot.

Query | Return | Set | Special | Units
yes | NR1 | 0...7 | Max | Min | Def | none


[:SENSe]:OBWidth:AVERage

Select a blue link to view the command details:

  • [:SENSe]:OBWidth:AVERage:COUNt
  • [:SENSe]:OBWidth:AVERage:TYPE
  • [:SENSe]:OBWidth:AVERage[:STATe]

[:SENSe]:OBWidth:AVERage:COUNt

Sets the number of averages.

Query | Return | Set | Special | Units
yes | NR1 | NRf | Max | Min | Def | none

[:SENSe]:OBWidth:AVERage:TYPE

Selects the average type.

  • Sets the Power Running type of measurement averaging.
  • Sets the Power Running type of measurement averaging.
Query | Return | Set | Special | Units
yes | POW| GPOW | POWer| GPOWer | Default | none

[:SENSe]:OBWidth:AVERage[:STATe]

Enables and disables measurement averaging.

  • ON (or 1) - enables measurement averaging.
  • OFF (or 0) - disables measurement averaging.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none


[:SENSe]:POWer

Select a blue link to view the command details:

  • [:SENSe]:POWer[:RF]:ATTenuation
  • [:SENSe]:POWer[:RF]:ATTenuation:AUTO
  • [:SENSe]:POWer[:RF]:GAIN[:STATe]

[:SENSe]:POWer[:RF]:ATTenuation

Sets the power attenuation value.

Query | Return | Set | Special | Units
yes | NR1 | NRf | Max | Min | Def | dB

[:SENSe]:POWer[:RF]:ATTenuation:AUTO

Enables and disables the automatic mode of the power attenuation.

  • ON (or 1) - enables the auto mode for the attenuation.
  • OFF (or 0) - disables the auto mode for the attenuation.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

[:SENSe]:POWer[:RF]:GAIN[:STATe]

Enables and disables the power gain.

  • ON (or 1) - enables the power gain.
  • OFF (or 0) - disables the power gain.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none


[:SENSe]:SEMask:AVERage

Select a blue link to view the command details:

  • [:SENSe]:SEMask:AVERage:COUNt
  • [:SENSe]:SEMask:AVERage:TYPE
  • [:SENSe]:SEMask:AVERage[:STATe]

[:SENSe]:SEMask:AVERage:COUNt

Sets the number of averages.

Query | Return | Set | Special | Units
yes | NR1 | NRf | Max | Min | Def | none

[:SENSe]:SEMask:AVERage:TYPE

Selects the average type.

  • GLOG - sets the Log Group type of measurement averaging.
  • GPOWer - sets the Power Group type of measurement averaging.
  • GMAX - sets the Max Group type of measurement averaging.
  • GMIN - sets the Min Group type of measurement averaging.
  • GMMAX - sets the Min/Max Group type of measurement averaging. This choice does not apply for Spectrum > General Purpose > ACPR.
Query | Return | Set | Special | Units
yes | GLOG| GPOW| GMAX| GMIN| GMM | GLOG| GPOWer| GMAX| GMIN| GMMax | Default | none

[:SENSe]:SEMask:AVERage[:STATe]

Enables and disables measurement averaging.

  • ON (or 1) - enables measurement averaging.
  • OFF (or 0) - disables measurement averaging.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none


[:SENSe]:SEMask:DETector[:FUNCtion]

Selects the detector function.

  • NORMal - sets the detector to normal.
  • MAX - sets both the upper and lower values to the maximum.
  • MIN - sets both the upper and lower values to the minimum.
  • SAMPle - sets both the upper and lower values to the middle span value.
  • PAVerage - sets both the upper and lower values to the average of the signal power.
  • NCPAverage - draws the trace using the result of two separate measurements with power average detection.
Query | Return | Set | Special | Units
yes | NORM| MAX| MIN| SAMP| PAV| NCPA | NORMal| MAX| MIN| SAMPle| PAVerage| NCPA | Default | none


[:SENSe]:SPECtrum

Select a blue link to view the command details:

  • [:SENSe]:SPECtrum:AVERage:COUNt
  • [:SENSe]:SPECtrum:AVERage:TYPE
  • [:SENSe]:SPECtrum:AVERage[:STATe]
  • [:SENSe]:SPECtrum:BANDwidth[:RESolution]
  • [:SENSe]:SPECtrum:BWIDth[:RESolution]
  • [:SENSe]:SPECtrum:SPUR:CANCellation


[:SENSe]:SPECtrum:AVERage:COUNt

Sets the number of averages for spectrum measurements.

Query | Return | Set | Special | Units
yes | NR1 | NRf | Max | Min | Def | none


[:SENSe]:SPECtrum:AVERage:TYPE

Selects the average type for spectrum measurements.

  • LOG - sets the Running Log type of measurement averaging.
  • POWer - sets the Power Running type of measurement averaging.
  • GLOG - sets the Log Group type of measurement averaging.
  • GPOWer - sets the Power Group type of measurement averaging.
  • GMAX - sets the Max Group type of measurement averaging.
  • GMIN - sets the Min Group type of measurement averaging.
  • GMMAX - sets the Min/Max Group type of measurement averaging. This choice does not apply for Spectrum > General Purpose > ACPR.
Query | Return | Set | Special | Units
yes | LOG| POW| GLOG| GPOW| GMAX| GMIN| GMMAX | LOG| POWer| GLOG| GPOWer| GMAX| GMIN| GMMAX | Default | none


[:SENSe]:SPECtrum:AVERage[:STATe]

Enables and disables measurement averaging for spectrum measurements.

  • ON (or 1) - enables measurement averaging.
  • OFF (or 0) - disables measurement averaging.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none


[:SENSe]:SPECtrum:BANDwidth[:RESolution]

Sets the spectrum bandwidth resolution.

Query | Return | Set | Special | Units
yes | NR1 | NRf | Max | Min | Def | Hz


[:SENSe]:SPECtrum:BWIDth[:RESolution]

Sets the spectrum bandwidth resolution. An alternate command to BANDwidth.

Query | Return | Set | Special | Units
yes | NR1 | NRf | Max | Min | Def | Hz


[:SENSe]:SPECtrum:SPUR:CANCellation

Enables and disables the spur cancellation operation.

  • ON (or 1) - enables the spur cancellation operation.
  • OFF (or 0) - disables the spur cancellation operation.
Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none


[:SENSe]:UFLatness

Select a blue link to view the command details:

  • [:SENSe]:UFLatness:STATe
  • [:SENSe]:UFLatness:LOAD

[:SENSe]:UFLatness:STATe

Turns User Flatness on/off.

Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

[:SENSe]:UFLatness:LOAD

Loads the User Flatness table from the specified file. DEFAULT is clear list and turn off if on.

Query | Return | Set | Special | Units
yes | string filename | <filename> | Default, " " | none


[:SENSe]:WCDMa:DOWNlink

Select a blue link to view the command details:

  • [:SENSe]:WCDMa:DOWNlink:ACLR:SWEep:TIME
  • [:SENSe]:WCDMa:DOWNlink:AVERage
  • [:SENSe]:WCDMa:DOWNlink:CODE
  • [:SENSe]:WCDMa:DOWNlink:EVM:SYMBol

[:SENSe]:WCDMa:DOWNlink:ACLR:SWEep:TIME

Set sweep time for W-CDMA Downlink ACLR measurement.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | Seconds


[:SENSe]:WCDMa:DOWNlink:AVERage

Select a blue link to view the command details:

  • [:SENSe]:WCDMa:DOWNlink:AVERage:COUNt
  • [:SENSe]:WCDMa:DOWNlink:AVERage[:STATe]
  • [:SENSe]:WCDMa:DOWNlink:AVERage:TYPE

[:SENSe]:WCDMa:DOWNlink:AVERage:COUNt

Set averaging count for W-CDMA Downlink measurement.

Query | Return | Set | Special | Units
yes | NR1 | NRf | Max | Min | Def | none

[:SENSe]:WCDMa:DOWNlink:AVERage[:STATe]

Turn on/off averaging for W-CDMA Downlink measurement.

Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

[:SENSe]:WCDMa:DOWNlink:AVERage:TYPE

Set averaging type for W-CDMA Downlink measurement.

Query | Return | Set | Special | Units
yes | GME| GMAX| GMIN | GMEan| GMAXimum| GMINimum | Default | none


[:SENSe]:WCDMa:DOWNlink:CODE

Select a blue link to view the command details:

  • [:SENSe]:WCDMa:DOWNlink:CODE:SCRamble
  • [:SENSe]:WCDMa:DOWNlink:CODE:STYPe

[:SENSe]:WCDMa:DOWNlink:CODE:SCRamble

Set scramble code for W-CDMA Downlink measurement.

Query | Return | Set | Special | Units
yes | NR1 | NRf | Max | Min | Def | none

[:SENSe]:WCDMa:DOWNlink:CODE:STYPe

Set sync type for W-CDMA Downlink measurement.

Query | Return | Set | Special | Units
yes | CPICH | CPICH | Default | none


[:SENSe]:WCDMa:DOWNlink:EVM:SYMBol

Select a blue link to view the command details:

  • [:SENSe]:WCDMa:DOWNlink:EVM:SYMBol:CNUMber
  • [:SENSe]:WCDMa:DOWNlink:EVM:SYMBol:SFACtor

[:SENSe]:WCDMa:DOWNlink:EVM:SYMBol:CNUMber

Set code number for W-CDMA Downlink Symbol EVM measurement.

Query | Return | Set | Special | Units
yes | NR1 | NRf | Default | none

[:SENSe]:WCDMa:DOWNlink:EVM:SYMBol:SFACtor

Set spread factor for W-CDMA Downlink Symbol EVM measurement.

Query | Return | Set | Special | Units
yes | NR1 | NRf | Default | none


[:SENSe]:WCDMa:UPLink

Select a blue link to view the command details:

  • [:SENSe]:WCDMa:AVERage
  • [:SENSe]:WCDMa:UPLink:CODE


[:SENSe]:WCDMa:UPLink:AVERage

Select a blue link to view the command details:

  • [:SENSe]:WCDMa:UPLink:AVERage:COUNt
  • [:SENSe]:WCDMa:UPLink:AVERage:TYPE
  • [:SENSe]:WCDMa:UPLink:AVERage[:STATe]

[:SENSe]:WCDMa:UPLink:AVERage:COUNt

Sets the number of averages for a W-CDMA measurement.

Query | Return | Set | Special | Units
yes | NR1 | NRf | Max | Min | Def | none

[:SENSe]:WCDMa:UPLink:AVERage:TYPE

Selects the average type for a W-CDMA measurement.

  • GMAX - sets the Max Group type of measurement averaging.
  • GMIN - sets the Min Group type of measurement averaging.
  • GME - sets the Mean Group type of measurement averaging.
Query | Return | Set | Special | Units
yes | GMAX| GMIN| GME | GMAX| GMIN| GMEan | Default | none

[:SENSe]:WCDMa:UPLink:AVERage[:STATe]

Enables and disables measurement averaging for a W-CDMA measurement.

Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none


[:SENSe]:WCDMa:UPLink:CODE

Select a blue link to view the command details:

  • [:SENSe]:WCDMa:UPLink:CODE:SCRamble
  • [:SENSe]:WCDMa:UPLink:CODE:SFORmat
  • [:SENSe]:WCDMa:UPLink:CODE:STYPe

[:SENSe]:WCDMa:UPLink:CODE:SCRamble

Sets the scramble code for a W-CDMA uplink measurement.

Query | Return | Set | Special | Units
yes | NR1 | NRf | Max | Min | Def | none

[:SENSe]:WCDMa:UPLink:CODE:SFORmat

Sets the slot format for a W-CDMA uplink measurement.

Query | Return | Set | Special | Units
yes | NR1 | NRf | Max | Min | Def | none

[:SENSe]:WCDMa:UPLink:CODE:STYPe

Sets the sync type for a W-CDMA uplink measurement.

  • DPCCH - sets the Dedicated Physical Control Channel value.
  • PRACH - sets the Physical Random Access Channel value.
Query | Return | Set | Special | Units
yes | DPCCH| PRACH | DPCCH| PRACH | Default | none


[:SENSe]:WLAN

Select a blue link to view the command details:

  • [:SENSe]:WLAN:OPTImize
  • [:SENSe]:WLAN:ATIMe
  • [:SENSe]:WLAN:AVERaging
  • [:SENSe]:WLAN:CCDF
  • [:SENSe]:WLAN:CCK
  • [:SENSe]:WLAN:CONStellation
  • [:SENSe]:WLAN:EHIStory
  • [:SENSe]:WLAN:EMAGnify
  • [:SENSe]:WLAN:GAIN:STATe
  • [:SENSe]:WLAN:HDECode
  • [:SENSe]:WLAN:OFDM:COUNt
  • [:SENSe]:WLAN:SEMask
  • [:SENSe]:WLAN:SIGNal

[:SENSe]:WLAN:OPTImize

Optimizes WLAN measurement setup. Sets signal type, constellation type, acquisition time, max symbol count and trigger settings.

Query | Return | Set | Special | Units
no | n/a | none | none | none

[:SENSe]:WLAN:ATIMe

Sets acquisition time for WLAN measurements.

Query | Return | Set | Special | Units
yes | NR1 | NRf | Max | Min | Def | none


[:SENSe]:WLAN:AVERaging

Select a blue link to view the command details:

  • [:SENSe]:WLAN:AVERaging:COUNT
  • [:SENSe]:WLAN:AVERaging:STATe

[:SENSe]:WLAN:AVERaging:COUNT

Sets averaging count for WLAN measurement.

Query | Return | Set | Special | Units
yes | NR1 | NRf | Max | Min | Def | none

[:SENSe]:WLAN:AVERaging:STATe

Turns on/off averaging for WLAN measurement.

Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none


[:SENSe]:WLAN:CCDF

Select a blue link to view command details:

  • [:SENSe]:WLAN:CCDF:ACCumulate:STATe
  • [:SENSe]:WLAN:CCDF:RESTart

[:SENSe]:WLAN:CCDF:ACCumulate:STATe

Turns on/off data accumulation for WLAN CCDF measurement.

Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

[:SENSe]:WLAN:CCDF:RESTart

Restarts data accumulation for WLAN CCDF measurement.

Query | Return | Set | Special | Units
no | n/a | n/a | none | none


[:SENSe]:WLAN:CCK

Select a blue link to view command details:

  • [:SENSe]:WLAN:CCK:DCOFfset:STATe Turns on/off dc offset for 802.11b/g signal.
  • [:SENSe]:WLAN:CCK:EQUalizer:STATe
  • [:SENSe]:WLAN:CCK:FILTer

[:SENSe]:WLAN:CCK:DCOFfset:STATe

Turns on/off dc offset for 802.11b/g signal.

Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

[:SENSe]:WLAN:CCK:EQUalizer:STATe

Turns on/off equalizer for 802.11b/g signal.

Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

[:SENSe]:WLAN:CCK:FILTer

Sets filter type for 802.11b/g signal.

Query | Return | Set | Special | Units
yes | BART| BLAC| GAUS| HAMM| HANN| NONE| RC| RRC | BARTlett| BLACkman| GAUSsian| HAMMing| HANN| NONE| RC| RRC | Default | none

[:SENSe]:WLAN:CONStellation

Sets constellation type for WLAN measurement. Default is autodetect.

Query | Return | Set | Special | Units
yes | AUT| BPSK| QPSK| QAM16| QAM64 | AUTodetect| BPSK| QPSK| QAM16| QAM64 | Default | none


[:SENSe]:WLAN:EHIStory

Select a blue link to view command details:

  • [:SENSe]:WLAN:EHIStory:CLEar
  • [:SENSe]:WLAN:EHIStory:LENGth

[:SENSe]:WLAN:EHIStory:CLEar

Clears accumulated EVM history data.

Query | Return | Set | Special | Units
no | n/a | n/a | none | none

[:SENSe]:WLAN:EHIStory:LENGth

Sets the length of EVM history data for display and remote query.

Query | Return | Set | Special | Units
yes | L11|L26| L51|L101 L251|L501 | L11|L26| L51|L101 L251|L501 | Default | none

[:SENSe]:WLAN:EMAGnify

Sets error magnify value for WLAN constellation trace type.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | none

[:SENSe]:WLAN:GAIN:STATe

Enables/disables WLAN Gain Compression/CCDF measurement. ON is enabled; OFF is disabled.

Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

[:SENSe]:WLAN:HDECode

Turns on/off 802.11n header decode.

Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

[:SENSe]:WLAN:OFDM:COUNt

Sets maximum symbol count for WLAN measurements.

Query | Return | Set | Special | Units
yes | NR1 | NRf | Max | Min | Def | none


[:SENSe]:WLAN:SEMask

Select a blue link to view command details:

  • [:SENSe]:WLAN:SEMask:AVERage:COUNt
  • [:SENSe]:WLAN:SEMask:AVERage[:STATe]
  • [:SENSe]:WLAN:SEMask:AVERage:TYPE
  • [:SENSe]:WLAN:SEMask:DETector[:FUNCtion]

[:SENSe]:WLAN:SEMask:AVERage:COUNt

Sets averaging state for WLAN spectrum emission mask measurements.

Query | Return | Set | Special | Units
yes | NR1 | NRf | Max | Min | Def | none

[:SENSe]:WLAN:SEMask:AVERage[:STATe]

Turns on/off averaging for WLAN spectrum emission mask measurements.

Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none

[:SENSe]:WLAN:SEMask:AVERage:TYPE

Sets averaging type for WLAN spectrum emission mask measurements.

Query | Return | Set | Special | Units
yes | GLOG| GPOW| GMAX| GMIN| GMM | GLOG| GPOW| GMAX| GMIN| GMM | Default | none

[:SENSe]:WLAN:SEMask:DETector[:FUNCtion]

Set detection type for WLAN spectrum emission mask measurements

Query | Return | Set | Special | Units
yes | NORM | MAX | MIN | SAMP | PAV | NCPA | NORMal|MAX|MIN|SAMPle| PAVerage|NCPAverage | DEFault | none

[:SENSe]:WLAN:SIGNal

Sets signal type for WLAN measurement. Default is autodetect.

Query | Return | Set | Special | Units
yes | AUT|BG| AG|J|NDR | AUTodetect| BG| AG|J| NDRaft | Default | none


[:SENSe]:ZSPan

Select a blue link to view the command details:

  • [:SENSe]:ZSPan:AVERage:COUNt
  • [:SENSe]:ZSPan:AVERage:TYPE
  • [:SENSe]:ZSPan:AVERage[:STATe]
  • [:SENSe]:ZSPan:BANDwidth[:RESolution]
  • [:SENSe]:ZSPan:BANDwidth[:RESolution]:TYPE
  • [:SENSe]:ZSPan:BWIDth[:RESolution]
  • [:SENSe]:ZSPan:BWIDth[:RESolution]:TYPE
  • [:SENSe]:ZSPan:SWEep:TIME


[:SENSe]:ZSPan:AVERage:COUNt

Sets the number of averages for zero-span measurements.

Query | Return | Set | Special | Units
yes | NR1 | NRf | Max | Min | Def | none


[:SENSe]:ZSPan:AVERage:TYPE

Selects the average type for zero-span measurements.

  • LOG - sets the Running Log type of measurement averaging.
  • POWer - sets the Power Running type of measurement averaging.
  • GLOG - sets the Log Group type of measurement averaging.
  • GPOWer - sets the Power Group type of measurement averaging.
  • GMAX - sets the Max Group type of measurement averaging.
  • GMIN - sets the Min Group type of measurement averaging.
  • GMMAX - sets the Min/Max Group type of measurement averaging. This choice does not apply for Spectrum > General Purpose > ACPR.
Query | Return | Set | Special | Units
yes | LOG| POW| GLOG| GPOW| GMAX| GMMAX | LOG| POW| GLOG| GPOW| GMAX| GMMAX | Default | none


[:SENSe]:ZSPan:AVERage[:STATe]

Enables and disables measurement averaging for zero-span measurements.

Query | Return | Set | Special | Units
yes | Boolean | ON | 1 | OFF | 0 | Default | none


[:SENSe]:ZSPan:BANDwidth[:RESolution]

Sets the zero span bandwidth resolution.

Query | Return | Set | Special | Units
yes | NR1 | NRf | Max | Min | Def | Hz


[:SENSe]:ZSPan:BANDwidth[:RESolution]:TYPE

Sets the bandwidth filter type.

  • BRICkwall - sets the filter type to Brickwall.
  • FOURstpole - sets the filter type to Sync Tuned 4 Pole.
  • FIVEstpole - sets the filter type to Sync Tuned 5 Pole.
  • RRC - sets the filter type to Raised-Root-Cosine.
  • GAUSsian - sets the filter type to true Gaussian.
Query | Return | Set | Special | Units
yes | BRIC| FOUR| FIVE| RRC| GAUS | BRICkwall| FOURstole| FIVEstole| RRC| GAUSsian | Default | none


[:SENSe]:ZSPan:BWIDth[:RESolution]

Sets the zero span bandwidth resolution. An alternate command to BANDwidth.

Query | Return | Set | Special | Units
yes | NR1 | NRf | Max | Min | Def | Hz


[:SENSe]:ZSPan:BWIDth[:RESolution]:TYPE

Sets the bandwidth filter type. An alternate command to BANDwidth.

  • BRICkwall - sets the filter type to Brickwall.
  • FOURstpole - sets the filter type to Sync Tuned 4 Pole.
  • FIVEstpole - sets the filter type to Sync Tuned 5 Pole.
  • RRC - sets the filter type to Raised-Root-Cosine.
  • GAUSsian - sets the filter type to true Gaussian.
Query | Return | Set | Special | Units
 | BRIC| FOUR| FIVE| RRC| GAUS | BRICkwall| FOURstole| FIVEstole| RRC| GAUSsian | Default | none

[:SENSe]:ZSPan:SWEep:TIME

Sets sweep time (acquisition time) for Zero Span.

Query | Return | Set | Special | Units
yes | NR2 | NRf | Max | Min | Def | <NO


Series 2800 VSA command locater

Making measurements

General purpose

Spectrum

:MEASure[:SELect]

[:SENSe]:FREQuency

[:SENSe]:SPECtrum

:DISPlay:WINDow:TRACe:Y[:SCALe]:RLEVel

:DISPlay:WINDow:TRACe:Y[:SCALe]:PDIVision

Zero span

:MEASure[:SELect]

[:SENSe]:ZSPan

[:SENSe]:FREQuency

:DISPlay:WINDow:TRACe:Y[:SCALe]:RLEVel

:DISPlay:WINDow:TRACe:Y[:SCALe]:PDIVision

ACPR

:CALCulate:ACPR:LIMit

:MEASure[:SELect]

[:SENSe]:ACPR

[:SENSe]:ACPR:ADJacent1|ADJacent2

[:SENSe]:ACPR:AVERage

[:SENSe]:ACPR:BANDwidth[:RESolution]:TYPE

[:SENSe]:ACPR:BWIDth[:RESolution]:TYPE

[:SENSe]:ACPR:CENTer

[:SENSe]:ACPR:FAST

[:SENSe]:ACPR:NCORrection

Channel power list

:MEASure[:SELect]

:TRACe:CPList:HOLD

[:SENSe]:ADC:DITHer[:STATe]

[:SENSe]:AINT

[:SENSe]:CPList

Modulation standards

EDGE

:CALCulate:EDGE

:CALCulate:EDGE:CONStellation

:CALCulate:EDGE:CPOWer

:CALCulate:EDGE:EVECtors:DATA

:CALCulate:EDGE:EVM:DATA?

:CALCulate:EDGE:EVM:LIMit

:CALCulate:EDGE:EVMTrace:DATA

:CALCulate:EDGE:IQData:DATA

:CALCulate:EDGE:LIMit:FAIL?

:CALCulate:EDGE:ORFS:MODulation

:CALCulate:EDGE:ORFS:SWITching

:CALCulate:EDGE:SYMBols:DATA

:CALCulate:EDGE:TMASk

:DISPlay:VIEW:EDGE:TYPE

:MEASure[:SELect]

[:SENSe]:EDGE

[:SENSe]:EDGE:CPOWer

[:SENSe]:EDGE:EVM

[:SENSe]:EDGE:ORFS:MODulation

[:SENSe]:EDGE:ORFS:SWITching

[:SENSe]:EDGE:TMASK

[:SENse]:EDGE:TSEQuence

[:SENSe]:EDGE:TSLot

[:SENSe]:EPOWer

GSM

:CALCulate:GSM

:CALCulate:GSM:CPOWer

:CALCulate:GSM:LIMit:FAIL?

:CALCulate:GSM:ORFS:MODulation

:CALCulate:GSM:ORFS:SWITching

:CALCulate:GSM:PERRor

:CALCulate:GSM:SYMBols:DATA

:CALCulate:GSM:TMASK

:DISPlay:VIEW:GSM:TYPE

:MEASure[:SELect]

[:SENSe]:EPOWer

[:SENSe]:GSM

[:SENSe]:GSM:CPOWer

[:SENSe]:GSM:ORFS:MODulation

[:SENSe]:GSM:ORFS:SWITching

[:SENSe]:GSM:PERRor

[:SENSe]:GSM:TMASK

[:SENSe]:GSM:TSEQuence

[:SENSe]:GSM:TSLot

cdma2000

:CALCulate:CDMA:REVerse

:CALCulate:CDMA:REVerse:ACHannels?

:CALCulate:CDMA:REVerse:ACPR

:CALCulate:CDMA:REVerse:EVM

:CALCulate:CDMA:REVerse:FERRor?

:CALCulate:CDMA:REVerse:IMARker

:CALCulate:CDMA:REVerse:IQOFfset?

:CALCulate:CDMA:REVerse:LIMit

:CALCulate:CDMA:REVerse:OBWidth

:CALCulate:CDMA:REVerse:PCDE?

:CALCulate:CDMA:REVerse:QMARker

:CALCulate:CDMA:REVerse:SEMask:LIMit

:DISPlay:VIEW:CDMA

:MEASure[:SELect]

:TRACe:ACPR:HOLD

[:SENSe]:ACPR

[:SENSe]:CDMA:REVerse:AVERage

[:SENSe]:OBWidth:AVERage

[:SENSe]:SEMask:AVERage

[:SENSe]:SEMask:DETector[:FUNCtion]

W-CDMA Uplink

:CALCulate:WCDMa:UPLink

:CALCulate:WCDMa:UPLink:ACHannels?

:CALCulate:WCDMa:UPLINK:ACLR:LIMIT

:CALCulate:WCDMa:UPLink:EVM

:CALCulate:WCDMa:UPLink:FERRor?

:CALCulate:WCDMa:UPLink:IMARker

:CALCulate:WCDMa:UPLink:IQOFfset?

:CALCulate:WCDMa:UPLink:LIMit:EVM:PEAK

:CALCulate:WCDMa:UPLink:LIMit:EVM:RMS

:CALCulate:WCDMa:UPLink:LIMit:FERRor

:CALCulate:WCDMa:UPLink:LIMit:IQOFfset

:CALCulate:WCDMa:UPLink:LIMit:PCDE

:CALCulate:WCDMa:UPLink:OBWidth

:CALCulate:WCDMa:UPLink:PCDE?

:CALCulate:WCDMa:UPLink:QMARker

:CALCulate:WCDMa:UPLink:SEMask:LIMit

:DISPlay:VIEW:WCDMa

:MEASure[:SELect]

:TRACE:ACPR:HOLD

[:SENSe]:WCDMa:UPLink

[:SENSe]:WCDMa:UPLink:AVERage

[:SENSe]:WCDMa:UPLink:CODE

W-CDMA Downlink

:CALCulate:WCDMa:DOWNlink:ACHannels

:CALCulate:WCDMa:DOWNlink:ACLR:LIMIT

:CALCulate:WCDMa:DOWNlink:EVM

:CALCulate:WCDMa:DOWNlink:FERRor?

:CALCulate:WCDMa:DOWNlink:MARker

:CALCulate:WCDMa:DOWNlink:IQOFfset?

:CALCulate:WCDMa:DOWNlink:OBWidth

:CALCulate:WCDMa:DOWNlink:PCDE?

:CALCulate:WCDMa:DOWNlink:SEMask:LIMit

:CALCulate:WCDMa:DOWNlink:TPOWer

:DISPlay:VIEW:WCDMa

:MEAS[:SELect]:

:TRACE:ACPR:HOLD

[:SENSe]:WCDMa:DOWNlink:ACLR:SWEep:TIME

[:SENSe]:WCDMa:DOWNlink:AVERage

[:SENSe]:WCDMa:DOWNlink:CODE

[:SENSe]:WCDMa:DOWNlink:EVM:SYMBol

WLAN

Select a blue link to view command details:

  • :CALCulate:WLAN:BANDwidth:
  • :CALCulate:WLAN:CFEedthru
  • :CALCulate:WLAN:CFERror
  • :CALCulate:WLAN:CPOWer
  • :CALCulate:WLAN:EVM:PEAK
  • :CALCulate:WLAN:EVM[:RMS]
  • :CALCulate:WLAN:FMARgin
  • :CALCulate:WLAN:PDRamp
  • :CALCulate:WLAN:PILot:EVM:PEAK
  • :CALCulate:WLAN:PILot:EVM[:RMS]
  • :CALCulate:WLAN:PORamp
  • :CALCulate:WLAN:SCERror
  • :DISPlay:WLAN:CCDF:X[:SCALe]:PDIVision
  • :DISPlay:WLAN:EVCHannel:Y[:SCALe]:PDIVision
  • :DISPlay:WLAN:EVCHannel:Y[:SCALe]:TOP
  • :DISPlay:WLAN:EHIStory:Y[:SCALe]:PDIVision
  • :DISPlay:WLAN:EHIStory:Y[:SCALe]:TOP
  • :DISPlay:WLAN:EVSYmbol:Y[:SCALe]:PDIVision
  • :DISPlay:WLAN:EVSYmbol:Y[:SCALe]:TOP
  • :DISPlay:WLAN:GCOMpression:Y[:SCALe]:PDIVision
  • :DISPlay:WLAN:GCOMpression:Y[:SCALe]:RPOSition
  • :DISPlay:WLAN:MFLatness:Y[:SCALe]:PDIVision
  • :DISPlay:WLAN:PFLatness:Y[:SCALe]:PDIVision
  • [:SENSe]:WLAN:OPTImize
  • [:SENSe]:WLAN:ATIMe
  • [:SENSe]:WLAN:AVERaging
  • [:SENSe]:WLAN:CCDF
  • [:SENSe]:WLAN:CCK
  • [:SENSe]:WLAN:CONStellation
  • [:SENSe]:WLAN:EHIStory
  • [:SENSe]:WLAN:EMAGnify
  • [:SENSe]:WLAN:GAIN:STATe
  • [:SENSe]:WLAN:HDECode
  • [:SENSe]:WLAN:OFDM:COUNt
  • [:SENSe]:WLAN:SEMask
  • [:SENSe]:WLAN:SIGNal

I / Q

:MEASure:IQ

:MEASure[:SELect]

Extracting data

cdma2000 measurements

:CALCulate:CDMA:REVerse

:CALCulate:CDMA:REVerse:ACHannels?

:CALCulate:CDMA:REVerse:ACPR:LIMit:FAIL?

:CALCulate:CDMA:REVerse:EVM

:CALCulate:CDMA:REVerse:FERRor?

:CALCulate:CDMA:REVerse:IMARker

:CALCulate:CDMA:REVerse:IQOFfset?

:CALCulate:CDMA:REVerse:LIMit

:CALCulate:CDMA:REVerse:OBWidth

:CALCulate:CDMA:REVerse:PCDE?

:CALCulate:CDMA:REVerse:QMARker

:CALCulate:CDMA:REVerse:SEMask:LIMit

:CALCulate:DATA?

:CALCulate:DATA:VALid?

:DISPlay:CAPTure

:FORMat[:DATA]

[:SENSe]:SEMask:DETector[:FUNCtion]

EDGE measurements

:CALCulate:DATA?

:CALCulate:DATA:VALid?

:CALCulate:EDGE:CONStellation:DATA

:CALCulate:EDGE:CPOWer:DATA?

:CALCualte:EDGE:EVECtors:DATA

:CALCulate:EDGE:EVM:DATA?

:CALCulate:EDGE:EVMTrace:DATA

:CALCulate:EDGE:EVM:IQData:DATA

:CALCulate:EDGE:ORFS:MODulation:DATA:X?

:CALCulate:EDGE:ORFS:MODulation:DATA[:Y]?

:CALCulate:EDGE:ORFS:SWITching:DATA:X?

:CALCulate:EDGE:ORFS:SWITching:DATA[:Y]?

:CALCulate:EDGE:SYMBols:DATA

:CALCulate:EDGE:TMASk:DATA:X?

:CALCulate:EDGE:TMASK:DATA[:Y]?

:DISPlay:CAPTure

:FORMat[:DATA]

GSM measurements

:CALCulate:DATA?

:CALCulate:DATA:VALid?

:CALCulate:GSM:CPOWer:DATA?

:CALCulate:GSM:ORFS:MODulation:DATA:X?

:CALCulate:GSM:ORFS:MODulation:DATA[:Y]?

:CALCulate:GSM:ORFS:SWITching:DATA:X?

:CALCulate:GSM:ORFS:SWITching:DATA[:Y]?

:CALCulate:GSM:PERRor:DATA?

:CALCulate:GSM:PERRor:PHASe:DATA:X?

:CALCulate:GSM:PERRor:PHASe:DATA[:Y]?

:CALCulate:GSM:PERRor:TRACe:DATA:X?

:CALCulate:GSM:PERRor:TRACe:DATA[:Y]?

:CALCulate:GSM:SYMBols:DATA

:CALCulate:GSM:TMASk:DATA:X?

:CALCulate:GSM:TMASk:DATA[:Y]?

:DISPlay:CAPTure

:FORMat[:DATA]

[:SENSe]:GSM:ORFS:MODulation:DETector[:FUNCtion]

[:SENSe]:GSM:ORFS:SWITching:DETector[:FUNCtion]

WCDMA Uplink measurements

:CALCulate:DATA?

:CALCulate:DATA:VALid?

:CALCulate:WCDMa:UPLink

:CALCulate:WCDMa:UPLink:ACHannels?

:CALCulate:WCDMa:UPLINK:ACLR:LIMIT:FAIL?

:CALCulate:WCDMa:UPLINK:ACLR:LIMIT:FAIL:CHANnels?

:CALCulate:WCDMa:UPLink:EVM

:CALCulate:WCDMa:UPLink:FERRor?

:CALCulate:WCDMa:UPLink:IMARker

:CALCulate:WCDMa:UPLink:IQOFfset?

:CALCulate:WCDMa:UPLink:LIMit:EVM:PEAK

:CALCulate:WCDMa:UPLink:LIMit:EVM:RMS

:CALCulate:WCDMa:UPLink:LIMit:FERRor

:CALCulate:WCDMa:UPLink:LIMit:IQOFfset

:CALCulate:WCDMa:UPLink:LIMit:PCDE

:CALCulate:WCDMa:UPLink:OBWidth

:CALCulate:WCDMa:UPLink:PCDE?

:CALCulate:WCDMa:UPLink:QMARker

:CALCulate:WCDMa:UPLink:SEMask:LIMit

:DISPlay:CAPTure

:FORMat[:DATA]

[:SENSe]:SEMask:DETector[:FUNCtion]

W-CDMA Downlink measurements

  • :CALCulate:DATA?
  • :CALCulate:DATA:VALid?
  • :CALCulate:WCDMa:DOWNlink
  • :CALCulate:WCDMa:DOWNlink:ACHannels?
  • :CALCulate:WCDMa:DOWNlink:ACLR:LIMIT:FAIL?
  • :CALCulate:WCDMa:DOWNlink:ACLR:LIMIT:FAIL:CHANnels?
  • :CALCulate:WCDMa:DOWNlink:EVM
  • :CALCulate:WCDMa:DOWNlink:FERRor?
  • :CALCulate:WCDMa:DOWNlink:IQOFfset?
  • :CALCulate:WCDMa:DOWNlink:EVM:PEAK
  • :CALCulate:WCDMa:DOWNlink:EVM:RMS
  • :CALCulate:WCDMa:DOWNlink:MARker
  • :CALCulate:WCDMa:DOWNlink:OBWidth
  • :CALCulate:WCDMa:DOWNlink:PCDE?
  • :CALCulate:WCDMa:DOWNlink:SEMask:LIMit
  • :DISPlay:CAPTure
  • :FORMat[:DATA]
  • [:SENSe]:SEMask:DETector[:FUNCtion]

WLAN measurements

Select a blue link to view command details:

  • :CALCulate:WLAN:BANDwidth:
  • :CALCulate:WLAN:CFEedthru
  • :CALCulate:WLAN:CFERror
  • :CALCulate:WLAN:CPOWer
  • :CALCulate:WLAN:EVM:PEAK
  • :CALCulate:WLAN:EVM[:RMS]
  • :CALCulate:WLAN:FMARgin
  • :CALCulate:WLAN:PDRamp
  • :CALCulate:WLAN:PILot:EVM:PEAK
  • :CALCulate:WLAN:PILot:EVM[:RMS]
  • :CALCulate:WLAN:PORamp
  • :CALCulate:WLAN:SCERror
  • :DISPlay:WLAN:CCDF:X[:SCALe]:PDIVision
  • :DISPlay:WLAN:EVCHannel:Y[:SCALe]:PDIVision
  • :DISPlay:WLAN:EVCHannel:Y[:SCALe]:TOP
  • :DISPlay:WLAN:EHIStory:Y[:SCALe]:PDIVision
  • :DISPlay:WLAN:EHIStory:Y[:SCALe]:TOP
  • :DISPlay:WLAN:EVSYmbol:Y[:SCALe]:PDIVision
  • :DISPlay:WLAN:EVSYmbol:Y[:SCALe]:TOP
  • :DISPlay:WLAN:GCOMpression:Y[:SCALe]:PDIVision
  • :DISPlay:WLAN:GCOMpression:Y[:SCALe]:RPOSition
  • :DISPlay:WLAN:MFLatness:Y[:SCALe]:PDIVision
  • :DISPlay:WLAN:PFLatness:Y[:SCALe]:PDIVision
  • [:SENSe]:WLAN:OPTImize
  • [:SENSe]:WLAN:ATIMe
  • [:SENSe]:WLAN:AVERaging
  • [:SENSe]:WLAN:CCDF
  • [:SENSe]:WLAN:CCK
  • [:SENSe]:WLAN:CONStellation
  • [:SENSe]:WLAN:EHIStory
  • [:SENSe]:WLAN:EMAGnify
  • [:SENSe]:WLAN:GAIN:STATe
  • [:SENSe]:WLAN:HDECode
  • [:SENSe]:WLAN:OFDM:COUNt
  • [:SENSe]:WLAN:SIGNal

Markers

:CALCulate:CDMA:REVerse:IMARker:X?

:CALCulate:CDMA:REVerse:IMARker:Y?

:CALCulate:CDMA:REVerse:QMARker:X?

:CALCulate:CDMA:REVerse:QMARker:Y?

:CALCulate:MARKer1|:MARKer2|:MARKer3|:MARKer4:X?

:CALCulate:MARKer1|:MARKer2|:MARKer3|:MARKer4:X:DELTa?

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:Y?

:CALCulate:MARKer1|MARKer2|MARKer3|MARKer4:Y:DELTa:?

:CALCulate:WCDMa:UPLink:IMARker:X?

:CALCulate:WCDMa:UPLink:IMARker:Y?

:CALCulate:WCDMa:UPLink:QMARker:X?

:CALCulate:WCDMa:UPLink:QMARker:Y?

:CALCulate:WCDMa:DOWNlink:MARKer:CNUMber

:CALCulate:WCDMa:DOWNlink:MARKer:SFACtor

:CALCulate:WCDMa:DOWNlink:MARKer[:STATe]

:CALCulate:WCDMa:DOWNlink:MARKer:X

:CALCulate:WCDMa:DOWNlink:MARKer:Y

Controlling measurements

Display screen

:DISPlay:CAPTure

:DISPlay:ENABle

:DISPlay:VIEW:CDMA

:DISPlay:VIEW:EDGE:TYPE

:DISPlay:VIEW:GSM:TYPE

:DISPlay:VIEW:WCDMa

:DISPlay:VIEW:WLAN

:DISPlay:WINDow:TRACe:Y[:SCALe]:RLEVel

:DISPlay:WINDow:TRACe:Y[:SCALe]:PDIVision

:DISPlay:WLAN

:SYSTem:SSAVer

:TRACe

[:SENSe]:DETector[:FUNCtion]

[:SENSe]:SEMask:DETector[:FUNCtion]

[:SENSe]:GSM:ORFS:MODulation:DETector[:FUNCtion]

[:SENSe]:GSM:ORFS:SWITching:DETector[:FUNCtion]

Trigger

: TRIGger[:SEQuence]:AUTO:TIMEout

: TRIGger[:SEQuence]:AUTO[:STATe]

: TRIGger[:SEQuence]:DELay

: TRIGger[:SEQuence]:EXTernal:SLOPe

: TRIGger[:SEQuence]:PREQual:WINDow

: TRIGger[:SEQuence]:PREQual[:LEVel]

: TRIGger[:SEQuence]:LEVel

: TRIGger[:SEQuence]:MODE

: TRIGger[:SEQuence]:SOURce

: TRIGger[:SEQuence]:TYPE

: TRIGger[:SEQuence]:VIDeo:SLOPe

Sync Out

:SOURce:TTL:INPut?

:SOURce:TTL[:LEVel]

:SOUTput:MODE

:SOUTput:POLarity

Sweep

:INITiate:CONTinuous

:INITate[:IMMediate]

Detection

[:SENSe]:GSM:ORFS:MODulation:DETector[:FUNCtion]

[:SENSe]:GSM:ORFS:SWITching:DETector[:FUNCtion]

[:SENSe]:DETector[:FUNCtion]

[:SENSe]:SEMask:DETector[:FUNCtion]

Input parameters

:DISPlay:WINDow:TRACe:Y[:SCALe]:RLEVel

[:SENSe]:FREQuency:CENTer

[:SENSe]:FREQuency:SPAN

[:SENSe]:FREQuency:STARt

[:SENSe]:FREQuency:STOP

[:SENSe]:ACPR:CENTer:BANDwidth

[:SENSe]:ACPR:CENTer:BWIDth

[:SENSe]:EPOWer

[:SENSe]:ACPR:CENTer:SWEep:TIME

[:SENSe]:ACPR:ADJacent1|ADJacent2:SWEep:TIME

Source

:SOURce

:SOURce:DWELl

:SOURce:FREQuency:CENTer

:SOURce:FREQuency:SPAN

:SOURce:STOP

:SOURce:[:STARt]

:SOURce:POINts

:SOURce:[:STATe]

:SOURce:ROSCillator:EXTernal:FREQuency

:SOURce:ROSCillator:SOURce

:SOURce:TTL:INPut?

:SOURce:TTL[:LEVel]

[:SOURce]:UFLatness:LOAD

[:SOURce]:UFLatness:STATe

[:SENSe]:POWer

Working with files

File management

*SAV

*RCL

:DISPlay:CAPTure

:MMEMory:DATA

[:SENse]CPList:LOAD

[:SENse]:EDGE:ORFS:MODulation:FLIMits

[:SENse]:EDGE:ORFS:SWITching:FLIMits

[:SENse]:EDGE:ORFS:MODulation:[:STATe]

[:SENse]:EDGE:ORFS:SWITching:[:STATe]

[:SENse]:GSM:ORFS:MODulation:FLIMits

[:SENse]:GSM:ORFS:SWITching:FLIMits

[:SENse]:GSM:ORFS:MODulation:[:STATe]

[:SENse]:GSM:ORFS:SWITching:[:STATe]

:CALCulate:EDGE:TMASk:LIMit

[:SENse]:EDGE:TMASK[:STATe]

:CALCulate:GSM:TMASk:LIMit

[:SENse]:GSM:TMASK[:STATe]

Controlling instrument hardware

Hardware management

[:SENSe]:DSP:RANDomize[:STATe]

[:SENSe]:DSP:RANGe[:STATe]

[:SENSe]:ACD:DITHer[:STATe]

:CALibration[:ALL]

Operating the instrument remotely

Display

:DISPlay:CAPTure

:DISPlay:ENABle

:DISPlay:VIEW:CDMA

:DISPlay:VIEW:EDGE:TYPE

:DISPlay:VIEW:GSM:TYPE

:DISPlay:VIEW:WCDMa

:DISPlay:VIEW:WLAN

:DISPlay:WINDow:TRACe:Y[:SCALe]:RLEVel

:DISPlay:WINDow:TRACe:Y[:SCALe]:PDIVision

:DISPlay:WLAN

:SYSTem:SSAVer

:TRACe

[:SENSe]:DETector[:FUNCtion]

[:SENSe]:SEMask:DETector[:FUNCtion]

[:SENSe]:GSM:ORFS:MODulation:DETector[:FUNCtion]

[:SENSe]:GSM:ORFS:SWITching:DETector[:FUNCtion]

Remote/Local

:DIAGnostic:REMote:OUTPut[:STATe]

:IDN?

:STATUS

:SYSTem:COMMunicate:GPIB:ADDRess

:SYSTem:KLOCk

:SYSTem:LOCal

:SYSTem:PRESet

:SYSTem:REMote

Preset

*RST

:STATus:PRESet

:SYSTem:PRESet

Status register

*CLS

*ESE

*ESE?

*ESR?

*OPC

*OPC?

*SRE

*SRE?

*STB?

:FORMat:SREGister

:STATus:MEASurement

:STATus:OPERation

:STATus:PRESet

:STATus:QUEStionable

:STATus:QUEue:CLEar

:SYSTem:CLEar

:SYSTem:ERRor


SCPI command error messages

SCPI error message strings
-350 | Queue Overflow
-256 | File Name Not Found
-253 | Corrupt Media
-240 | Hardware Error
-230 | Data Corrupt or Stale
-224 | Illegal Parameter Value
-222 | Data Out Of Range
-221 | Settings Conflict
-220 | Parameter Error
-151 | Invalid String Data
-138 | Suffix Not Allowed
-131 | Invalid Suffix
-121 | Invalid Character In Number
-120 | Numeric Data Error
-115 | Unexpected Number of Parameters
-113 | Undefined Header
-109 | Missing Parameter
-102 | Syntax Error
-101 | Invalid Character
-100 | Command Error
0 | No Error
10 | Usb Error
11 | Usb Cable Not Connected
12 | Active Measurement Does Not Support the Command
Shared DSP error messages
20 | Bad Run Checksum
21 | Run Sector Erased
22 | Bad FPGA Checksum
23 | FPGA Sector Erased
24 | Bad Parms Checksum
25 | Bad XParms Checksum
26 | Bad BasicDsp Cmd
27 | Bad DUC FS
28 | Task Already On Queue
29 | Bad Cal Table
30 | Flash Not Erasing
31 | Flash Not Programming
32 | Bad Loader Size
33 | Bad Boot Size
34 | Bad Run Size
35 | Checksum Mismatch
36 | Bad USB Command
37 | Reached Breakpoint
38 | Resource Not Locked
39 | FATAL CRASH!
40 | Debug Not Available
41 | Unrecognized Dsp Error
42 | Missing Task Killed Message
43 | Missing Acknowledged Message
Instrument specific DSP error messages
51 | Invalid Change Flag
52 | Invalid Setting
53 | Amplitude Set Too High For This Modulation Waveform
54 | Missing Source Settled Message
55 | Missing Single Sweep Complete Message
Channel Power List
92 | Channel power list is empty
93 | Channel Power List File Error
Sweep/List/Trigger messages
200 | Sweep Aborted
Arb messages
220 | Operation failed because no digital modulation active
221 | Operation failed because no matching Arb record found
222 | Arb File Header Error: Invalid Sample Rate
223 | Arb File Header Error: Invalid Power Factor
User flatness error messages
270 | User Flatness Data File Error
271 | User Flatness File Frequency Rounded


File management

The VSA allows you to manage various files that are used by the instrument. Select one of the following categories to learn more about file management for the instrument:

  • Directory structure and file types
  • Measurement personality licenses
  • External Drives
  • File management with Web interface
  • File management window
  • File management operations


Directory structure and file types

The Series 2800 VSA has default directories for saving and opening specific types of files.

  • Software upgrade User directory is where you will upload the latest software upgrade file before loading it into the instrument. You can also upgrade the software directly from a USB flash drive or a networked directory. This type of file is a *.cab. See Software Upgrade for more information.
  • License Import User directory is where you will save measurement personality license files. This type of file is a *.txt. See Measurement personality license files and To open a license file.
  • Instrument setups User directory is where you can save and open setup files that describe the entire instrument state. This type of file is a *.set.
  • Channel power list User directory is where you will save list description files to open in channel power list mode. A list description file contains a list of measurement states that includes frequency, RBW, and sweep time values. This type of file is a *.list.
  • ORFS freq/limits User directory is where files are saved that describe the values and conditions for passing an output RF spectrum due to modulation or switching limit test. This type of file is a *.orfs.
  • Time mask limits User directory is where files are saved that describe the values and conditions for passing a time mask limit test. This type of file is a *.tml.
  • Screen User directory is where you save screen captures as image files so you can view them in a graphics application or include them in a report. This type of file is a *.bmp.

    Note: The Series 2800 VSA has 200 Mb of combined memory storage available for the various user directories.


External drives

In addition to the instrument internal file storage directories, you have the following external drives available to help you manage your files:

  • USB memory sticks (up to four)
  • Networked drives (Windows OS)

See Share files or folders for details on managing files on networked drives.


File management with Web interface

The Series 2800 VSA has a Web interface that allows you to perform a set of file management operations:

  • Save and recall instrument states
  • Locate and load channel power lists
  • Locate and load limits files
  • Download and run instrument upgrades
  • Transfer measurement personality licenses
  • Capture instrument screen images

To access the Series 2800 VSA Web interface, launch a Web browser and use the VSA IP address for the URL (for example, http:\\192.168.1.101).

If you do not know the instrument IP address, you can find it from the instrument front panel interface by selecting Menu > Utilities > Ethernet Settings.

  • If you need details on configuring the Ethernet settings, see System configuration for remote control.
  • If you want details on the Web interface, see LXI Web interface.

LXI Web interface

The Keithley Instruments Series 2800 VSA has a Web interface that complies with LXI class C requirements and offers a convenient way to communicate with the VSA from a PC browser. For more information on LXI compliance, see http://www.lxistandard.org/home. The LXI Class C compliance includes the following features:

  • Instrument Welcome page
  • IP configuration control
  • Status information: security, errors/warnings
  • Administration password control

The Web interface also offers the following features:

  • Virtual instrument front panel access
  • Print screen capability from Web browser
  • Instrument help
  • Personality license file management

To access the web interface, launch a web browser and use the LAN-connected instrument IP address for the URL; for example, http://192.40.128.183.

  • If you do not know the instrument IP address, you can find it from the instrument front panel interface by selecting Menu > Utilities > Ethernet Settings.
  • If you need details on configuring the Ethernet settings, refer to Ethernet Settings.

The Web interface menu offers the following choices:

Welcome page -- describes the instrument model and manufacturer, serial number, LXI class, hostname, address, firmware revision, and VISA resource string.

IP Configuration -- lists the instrument Ethernet configuration and allows you to modify the Ethernet configuration, which includes enabling or disabling support for ping.

Status -- lists the status for the instrument security, and errors and warnings.

Instrument -- offers a virtual front panel interface to the Series 2800 VSA. This interface is a subset of the functionality that is available with the actual instrument front panel. Here are a few differences between the true instrument front panel interface and the virtual interface:

  • All editable fields are highlighted on the virtual interface so you can make multiple setting modifications and then select Submit to send the modifications to the instrument.
  • Selection of button elements on the virtual interface will cause immediate instrument action for the button functionality and any other editable fields that you modified.
  • Changes made to the settings from the actual instrument front panel will not be indicated on the virtual interface until you select Refresh.

Administration offers a dialog box that allows administration password control. The default user name/password is admin/admin. The user/password authorization is required to modify the Ethernet configuration, use the remote file browser, upgrade the instrument software, or export an instrument option license over the web. Once you enter the correct user/password, the browser caches the login to enable you to use other password-dependent features without additional password inputs. Please refer to LAN Config Init.

CAUTION: The current release of Keithley Instruments Series 2800 VSA software is 2.0 or higher. If you have a Keithley Instruments Model 2810 VSA with a software revision of less than 2.0 you will be unable to upgrade the software build (CAB file) by way of the LXI web interface. Software revisions prior to the 2.0 release have a 20 Mbyte limit for upload files. Software release 2.0 increases this limit to 40 Mbytes (enough for future upgrades to your instrument over the LXI web interface.) You can verify the software version currently installed on your VSA by selecting Menu > Help > About Keithley 28xx. If your instrument has software release prior to 2.0. you must copy the CAB file to a USB memory stick to upload it to your instrument. Once you have completed this, future uploads may be done using the LXI web interface.

Licensing -- shows the current licenses in the instrument and allows you to export or import license files. See To move personality license files or To open a license file for details. For general licensing information, see Licensing. License files cannot be exported from the instrument front panel; you can only export license files from the Web interface through a password controlled page that has the same password used in the Administration page, described above.

Screen Capture -- allows you to capture an image of the current instrument screen. Click Capture each time you want to update the browser (it is highly recommended that you put the instrument in single sweep before you capture the screen).

NOTE: If you are using Microsoft® Internet Explorer browser, and you are experiencing a failure to update screen captures: First, from the instrument front panel, select: Menu > Utilities > Time and Date... and verify that the time and date are correct. Then, change the browser caching policy by following these steps: In the browser window, click Tools > Internet Options. In the General tab, click Settings. In the Check for newer version of stored pages: section, select Every visit to the page. Click OK.

Print -- offers the standard Windows Print dialog so you can print the screen image.

Help -- offers the same Help topics that are available from the actual front panel interface when you select Menu > Help > Help System....

ID button when selected, visually indicates that a particular instrument is connected through the LXI web interface by displaying a blinking green light on the lower-right corner of the front panel of the connected instrument. This can be helpful when more than one instrument is connected to the LAN. This green indicator is always lit when the instrument is connected to an operational LAN. If there is a LAN error, this indicator changes from green to red. A LAN disconnection indicator is also shown at the lower-right portion of the instrument front panel.


File management window

All file management windows have the following buttons and information fields:

  • Refresh updates the directories and files to show the current structure.
  • Up moves the current directory up one level in the directory structure.
  • Copy duplicates a highlighted (selected) file to the location you specify.
  • Cut removes a highlighted (selected) file from the directory and allows you to place it (paste) in a different location that you specify.
  • Paste places a file in a location that you have specified.
  • Rename changes the name of a highlighted file.
  • Delete removes a highlighted file from the directory.
  • New Folder creates a new folder that you name in the current directory.
  • Look In: displays a menu of the available directories or drives.
  • Save or Open saves or opens a highlighted file, depending on the type of file operation.
  • File name: shows the name of the file currently highlighted (selected).
  • Files of type: shows the type of file currently highlighted (selected).


File management operations

Select from the following procedure categories to learn how to manage various types of files:

  • Save a file
  • Open or load a file
  • Copy or move a file
  • Rename a file or folder
  • Delete a file or folder
  • Share files or folders


Save a file

Select the following procedures to learn how to save the various types of files:

  • Instrument setups
  • ORFS limits
  • Time mask limits
  • Screen capture image


To save an instrument setup file

The instrument setup file save and load operations have the following restrictions:

  • If you save an instrument setup file from the front panel interface, you will only be able to load the file from the front panel interface.
  • If you save an instrument setup file remotely using programming commands, you will be only able to load the file with programming commands.

    Note: If a sequence file is open at the time an instrument setup is saved, the sequence file will be part of the saved setup file. When the instrument setup file is later opened, the sequence file will also be opened if the following conditions exist: the recalled sequence file is located in the User directory and the arbitrary waveform files that are referenced in the sequence file are added to the arbitrary waveform playback table.

With the front panel interface:

Set up the instrument to the values that you want:

  1. Select Menu > File > Save Setup.
  2. Select the File name: field or the keyboard button and type a name.
  3. Select Enter > Save.

With the remote programming interface:

The following example summarizes the basic command sequence for saving and recalling a setup remotely. The current setup is stored in memory location 2, GPIB defaults are restored, and the setup in memory location 2 is recalled.

*SAV 2 | ' Saves present setup in memory location 2.
*RST | ' Restores all instrument settings.
*RCL 2 | ' Recalls location 2 setup.

Note: The frequency reference is not affected by Preset, *RST, or save/recall state.


To save an ORFS freq/limits file

You can save an edited table of ORFS limits to either apply to the current measurement or load into the instrument for a future measurement.

Note: It is recommended that you save the files to a drive that is external to the instrument, ensuring adequate memory storage. See To share a drive or folder on the network .

Note: The GSM and EDGE standards specify both relative (dBc) and absolute (dBm) limits. You should use absolute limits with caution because the GSM and EDGE standards state that the device will pass a limit test even if it only meets one of the limits specified (absolute or relative). For example, if you enter an absolute limit without accounting for the fixture loss, devices that do not meet the specification will appear to pass the test.

With the front panel interface:

Set up the instrument state to the values that you want:

  1. From the measurement menu, select the type of measurement that you want to apply ORFS limit test:
    • If you are making a GSM measurement, select GSM > Settings > ORFS.
    • If you are making an EDGE measurement, select EDGE > Settings > ORFS.
  2. In the ORFS Mod Settings dialog, select Freqs/Limits: Edit.
  3. In the ORFS Freqs/Limits dialog, do one of following steps:
    • If you are editing the limits table to include the values that you want applied to the limits test, double-select values to enter new values, select Add Row to include additional limits, or select Delete Row to delete limits. Then select File > Save....
    • If you are saving the default limit file for a starting point to create you own limits file using a text editor, select File > Save....
  4. Select the memory location to store the file by selecting the drop-down arrow in the Look In: field and navigating to the drive location.
  5. Select the File name: field or the keyboard button and type a name.
  6. Select Enter > Save.
  7. To save a new time mask limits file based on the default limits file, perform these steps:
    1. Edit the previously saved default limits file in a text editor, such as Notepad.
    2. Save the file to a memory location that you can conveniently access.

      An example of a default ORFS frequency/limits file is shown below:

      ORFS Mod Freqs/Limits Version 1.0

      Begin Table

      Offset (Hz), Max (dBc), Max (dBm)

      200000.00, -30.00, 200.00

      250000.00, -33.00, 200.00

      400000.00, -54.00, 200.00

      600000.00, -60.00, 200.00

      1200000.00, -60.00, 200.00

      1800000.00, -63.00, 200.00

See To load an ORFS freqs/limits file for details on using the limits file that you saved.

With the remote programming interface:

[:SENse]:EDGE:ORFS:MODulation:FLIMits

[:SENse]:EDGE:ORFS:SWITching:FLIMits

[:SENse]:GSM:ORFS:MODulation:FLIMits

[:SENse]:GSM:ORFS:SWITching:FLIMits


To save a time mask limits file

You can save an edited table of time mask limits to either apply to the current measurement or load into the instrument for a future measurement. You can also save the Series 2800 VSA default limits file for a starting point to create your own limits file using a text editor.

Note: It is recommended that you save the files to a drive that is external to the instrument, ensuring adequate memory storage. See To share a drive or folder on the network.

Note: The GSM and EDGE standards specify both relative (dBc) and absolute (dBm) limits. You should use absolute limits with caution because the GSM and EDGE standards state that the device will pass a limit test even if it only meets one of the limits specified (absolute or relative). For example, if you enter an absolute limit without accounting for the fixture loss, devices that do not meet the specification will appear to pass the test.

Set up the instrument state to the values that you want:

  1. From the measurement menu, select the type of measurement that you want to apply time mask limit test:
    • If you are making a GSM measurement, select GSM > Settings > Time Mask Limits.
    • If you are making an EDGE measurement, select EDGE > Settings > Time Mask Limits.
  2. In the Time Mask Limits dialog, do one of following steps:
    • If you are editing the limits table to include the values that you want applied to the limits test, double-select values to enter new values, select Add Row to include additional limits, or select Delete Row to delete limits. Then select File > Save....
    • If you are saving the default limit file for a starting point to create you own limits file using a text editor, select File > Save....
  3. Select the memory location to store the file by selecting the drop-down arrow in the Look In: field and navigating to the drive location.
  4. Select the File name: field or the keyboard button and type a name.
  5. Select Enter > Save.
  6. To save a new time mask limits file based on the default limits file, perform these steps:
    1. Edit the previously saved default limits file in a text editor, such as Notepad.
    2. Save the file to a memory location that you can conveniently access.

      An example of a default time mask limits file is shown below:

    Time Mask Limits Version 1.0

    Begin Table

    Time (us), Max (dBc), Max (dBm), Min (dBc)

    -100.00, -59.00, -200.00, -200.00

    -28.00, -30.00, -200.00, -200.00

    -18.00, -6.00, -200.00, -200.00

    -10.00, 4.00, -200.00, -200.00

    0.00, 2.40, -200.00, -2.00

    2.00, 2.40, -200.00, 0.00

    4.00, 4.00, -200.00, -20.00

    538.80, 2.40, -200.00, 0.00

    540.80, 2.40, -200.00, -2.00

    542.80, 4.00, -200.00, -200.00

    552.80, -6.00, -200.00, -200.00

    560.80, -30.00, -200.00, -200.00

    570.80, -59.00, -200.00, -200.00

    See To load a time mask limits file for details on using the limits file that you saved.


Open or load a file

Select the following procedures to learn how to open or load the various types of files:

  • Software upgrade
  • Measurement personality license
  • Instrument setup
  • Channel power list
  • ORFS freq/limits
  • Time mask limits


To open a license file

This procedure shows you how to open a newly-purchased license file in the instrument. The first part of this procedure shows you how to obtain the necessary information for ordering additional licenses. You can purchase licenses when ordering an instrument, or any time after receiving the instrument shipment. Fill out the license certificate that was part of the instrument shipment and contact your Keithley Instruments sales representative to arrange the purchase of desired digital modulation licenses.

The keyboard shortcuts (Ctrl+C, Ctrl+V) in this procedure are for MS Windows.

  • See To move personality license files for instructions on how to transfer license files between instruments.
  • See Measurement personality license files for details on license files.

With the front panel interface:

  1. Locate the License Certificate that was part of the Series 2800 VSA shipment. Fill out the necessary information to purchase additional licenses. If you misplaced this document, contact Keithley Instruments for a replacement.
  2. To find the instrument license ID, select Menu > Utilities > Licensing.
  3. Select Save ID to save the instrument license ID to a *.txt file.
  4. In the Save License ID window, navigate to a location that you can access from your computer. A USB memory stick is convenient for this purpose.
  5. Name the file:
    • If you want to overwrite an existing file, select the file in the directory structure then select Save.
    • If you want to save the file as new, select the keyboard button and enter the filename.txt, then select Enter > Save.
  6. Contact your Keithley Instruments sales representative to arrange for the purchase of the desired licenses.
  7. When you receive a return e-mail message from Keithley Instruments, copy (Ctrl+C) the text of the message and paste (Ctrl+V) it into a newly created *.txt file.
  8. Save the file to a location that you can access from the instrument. A USB memory stick is convenient for this purpose.
  9. From the instrument, select Menu > Utilities > Licensing > Import.
  10. Navigate to the location of the *.txt file that you just created and saved.
  11. Highlight the *.txt file and select Open. The current license status of the instrument is displayed.

With the LXI Web interface:

  1. Locate the License Certificate that was part of the Series 2800 VSA shipment. Fill out the necessary information to purchase additional licenses. If you misplaced this document, contact Keithley Instruments for a replacement.
  2. Connect the Series 2800 VSA to a Web network that includes a computer.
  3. On the computer, launch a Web browser and use the instrument IP address as the URL.
    • If you do not know what the instrument IP address is, you can find it from the front panel interface by selecting Menu > Utilities > Ethernet Settings.
    • If you need details on configuring the Ethernet settings, see System configuration for remote control.
  4. Click Licensing > Import from the instrument Web page.
  5. Find the Instrument License Identifier row of the displayed table, highlight the instrument ID, copy (Ctrl+C) it, and then paste it (Ctrl+V) into a new text file. Save the file.

  6. Contact your Keithley Instruments representative to arrange for the purchase of the desired measurement personality licenses.
  7. When you receive a return e-mail message from Keithley Instruments, submit the license information through the Web page:
    • If you want to keep a copy of the license information, highlight the text of the received e-mail message, copy it (Ctrl+C), and then paste it (Ctrl+V) it into a newly created *.txt file. Save the file to a location that you can access from the instrument. In the instrument Web page, click Licensing > Import > Browse. Navigate to the location of the license *.txt file that you just created and saved and click Open.
    • If you don't need to save a copy of the license information, highlight the text of the received e-mail message and copy it (Ctrl+C). On the instrument Web page, click Licensing > Import and then paste it (Ctrl+V) it in the appropriate field.

  8. Click Submit. The current license status of the instrument is displayed.


To load an instrument setup file

The instrument setup file save and load operations have the following features:

  • If you save an instrument setup file from the front panel interface, you will only be able to load the file from the front panel interface.
  • If you save an instrument setup file remotely using programming commands, you will only be able to load the file with programming commands.

Note: If a sequence file is open at the time an instrument setup is saved, the sequence file will be part of the saved setup file. When the instrument setup file is later opened, the sequence file will also be opened if the following conditions exist: the recalled sequence file is located in the User directory and the arbitrary waveform files that are referenced in the sequence file are added to the arbitrary waveform playback table.

With the front panel interface:

  1. Select Menu > File > Load Setup.
    • If you want to load a setup file from the User directory, select (highlight) the file in the User directory.
    • If you want to load a setup file from another location, select the folder or drive that includes the file you want in the Look In field. Select (highlight) the file.
  2. Select Load.

With the remote programming interface:

The following summarizes the basic command sequence for saving and recalling a setup. The present setup is stored in memory location 2, GPIB defaults are restored, and the memory location 2 setup is recalled.

*SAV 2 | ' Save present setup in memory location 2.
*RST | ' Restore GPIB defaults.
*RCL 2 | ' Recall location 2 setup.

Note: The frequency reference is not affected by Preset, *RST, or save/recall state.


To load a channel power list file

You can load a channel power list description file from the User directory, a connected USB memory stick or a shared network folder. You must create and edit the list description file in an external application, such as Microsoft Excel or Notepad.

Example channel power list file:

Channel Power List Version 2.0,,,

Begin Table,,,

State, Frequency, RBW, SweepTime,RefLevel,Preamp

1,1.800000e+009,1.000000e+007,1.000000e-004,20,Off

1,1.788500e+009,1.000000e+006,1.000000e-004,10,Off

1,1.793000e+009,1.000000e+006,1.000000e-004,0,off

1,1.794450e+009,1.000000e+005,1.000000e-004,-10,OFF

1,1.805550e+009,1.000000e+005,1.000000e-004,-20,0

1,1.807000e+009,1.000000e+006,1.000000e-004,-30,0

With the front panel interface:

  1. Select General Purpose > Channel Power List > Open....
    • If the file that you want is in the User directory, select (highlight) the file.
  2. If the file is in a shared network folder or on a connected USB memory stick, select the directory where the file is located from the Look in: drop-down menu, highlight the file and then select Open.

With the remote programming interface:

You can use the programming command [:SENse]CPList:LOAD to load a file from a directory in the instrument, a USB memory stick inserted in the instrument, or another computer directory. To load a file from one of the available directories, use the following paths in the programming message.

Directory | Directory Path in Programming Message
List User (default) | filename
another computer directory | \\UNC\directory\filename
USB (connected first) | \USB
USB (connected second) | \USB2
USB (connected third) | \USB3
USB (connected fourth) | \USB4

To open a list file that is already in the instrument List User directory, use the SCPI command [:SENse]:CPList:LOAD "\user\listname.csv".


To load an ORFS freqs/limits file

You can load a table of ORFS limits to apply to the current measurement limit test.

Note: The GSM and EDGE standards specify both relative (dBc) and absolute (dBm) limits. You should use absolute limits with caution because the GSM and EDGE standards state that the device will pass a limit test even if it only meets one of the limits specified (absolute or relative). For example, if you enter an absolute limit without accounting for the fixture loss, devices that do not meet the specification will appear to pass the test.

With the front panel interface:

  1. From the measurement menu, select the type of measurement that you want to apply ORFS limit test:
    • If you are making a GSM measurement, select GSM > Settings > ORFS.
    • If you are making an EDGE measurement, select EDGE > Settings > ORFS.
  2. In the ORFS Mod Settings dialog, select Freqs/Limits: Edit.
  3. Edit the limits table to the values that you want applied to the limits test.
  4. Select File > Load... and select the memory location where the file is stored.
  5. Select the filename, and then select Open.

With the remote programming interface:

[:SENse]:EDGE:ORFS:MODulation:FLIMits

[:SENse]:EDGE:ORFS:SWITching:FLIMits

[:SENse]:EDGE:ORFS:MODulation:[:STATe]

[:SENse]:EDGE:ORFS:SWITching:[:STATe]

[:SENse]:GSM:ORFS:MODulation:FLIMits

[:SENse]:GSM:ORFS:SWITching:FLIMits

[:SENse]:GSM:ORFS:MODulation:[:STATe]

[:SENse]:GSM:ORFS:SWITching:[:STATe]

To load an ORFS frequency/limits file into the Series 2800 VSA remotely, you can copy the limits (no header) from a file that you have previously saved, or you can enter in the limits directly into the SCPI command message. See To save an ORFS freq/limits file for details.

Example:

The example SCPI command message below allows the Series 2800 VSA to set the limit table as a set of comma separated values:

[:SENSe]:EDGE:ORFS:MODulation:FLIMits 200000.00, -30.00, 200.00, 250000.00, -33.00, 200.00, 400000.00, -54.00, 200.00, 600000.00, -60.00, 200.00, 1200000.00, -60.00, 200.00, 1800000.00, -63.00, 200.00


To load a time mask limits file

You can load a table of time mask limits to apply to the current measurement limit test.

Note: The GSM and EDGE standards specify both relative (dBc) and absolute (dBm) limits. You should use absolute limits with caution because the GSM and EDGE standards state that the device will pass a limit test even if it only meets one of the limits specified (absolute or relative). For example, if you enter an absolute limit without accounting for the fixture loss, devices that do not meet the specification will appear to pass the test.

With the front panel interface:

  1. From the measurement menu, select the type of measurement that you want to apply ORFS limit test:
    • If you are making a GSM measurement, select GSM > Settings > Time Mask Limits.
    • If you are making an EDGE measurement, select EDGE > Settings > Time Mask Limits.
  2. In the Time Mask Limits dialog, edit the limits table to the values that you want applied to the limits test.
  3. Select File > Load... and select the memory location where the file is stored.
  4. Select the filename and select Open.

With the remote programming interface:

[:SENSe]:EDGE:TMASk[:STATe]

:CALCulate:EDGE:TMASk:LIMit

[:SENSe]:GSM:TMASk[:STATe]

:CALCulate:GSM:TMASk:LIMit

  1. To load a time mask limits file into the Series 2800 VSA remotely, you can copy the limits (no header) from a file that you have previously saved, or you can enter in the limits directly into the SCPI command message. See To save a time mask limits file for details.
  2. The example SCPI command message below allows the Series 2800 VSA to accept a time mask limit table as a comma separated list:

    :CALCulate:GSM:TMASk:LIMit -100.00, -59.00, -200.00, -200.00, -28.00, -30.00, -200.00, -200.00, -18.00, -6.00, -200.00, -200.00, -10.00, 4.00, -200.00, -200.00, 0.00, 2.40, -200.00, -2.00, 2.00, 2.40, -200.00, 0.00, 4.00, 4.00, -200.00, -20.00, 538.80, 2.40, -200.00, 0.00, 540.80, 2.40, -200.00, -2.00, 542.80, 4.00, -200.00, -200.00, 552.80, -6.00, -200.00, -200.00, 560.80, -30.00, -200.00, -200.00, 570.80, -59.00, -200.00, -200.00


To rename a file or folder

  1. Open the directory that contains the file (folder) you want to rename (in Look In, select the drive or folder that contains the file (folder) you want to rename).
  2. Select (highlight) the file (folder) you want to rename.
  3. Select Rename.
  4. Type the new name and select Enter.


To copy or move a file

The first copy/move procedure is intended for the following file types:

  • Instrument setups
  • Lists descriptions
  • ORFS limits
  • Time mask limits

The last move procedure is intended only for the following file type:

  • Measurement personality licenses

With the front panel interface:

  1. Open the directory that contains the file you want to copy (in Look In:, select the drive or folder that contains the file you want to copy).
    • For instrument setup files, choose Menu > File > Load Setup.
    • For channel power list description files, select General Purpose > Channel Power List > Load List.
    • For ORFS limits files, select EDGE or GSM > Settings > ORFS > Freqs/Limits: Edit > File.
    • For time mask limits files, select EDGE or GSM > Settings > Freqs/Limits: Edit > File.
  2. Highlight the file you want to copy or move.
  3. Select the file management operation:
    • To copy the file, select Copy.
    • To move the file, select Cut.
  4. In Look in:, select the directory or drive where you want to place the file.
  5. Select Paste.

With the remote programming interface:

You can also use the programming command :MMEM:DATA to copy a file to a directory in the instrument or a USB memory stick inserted in the instrument. To copy a file to one of the available directories, use the following paths in the programming message.

Instrument Directory | Directory Path in Programming Message
EDGE ORFS due to modulation limits User | \EDGE\User
EDGE ORFS due to switching limits User | \EDGE\User
EDGE Time mask limits | \EDGE\User
GSM ORFS due to modulation limits User | \GSM\User
GSM ORFS due to switching limits User | \GSM\User
GSM Time mask limits | \GSM\User
Channel power list User | \List\User
USB (connected first) | \USB
USB (connected second) | \USB2
USB (connected third) | \USB3
USB (connected fourth) | \USB4

Example:

The following command creates a file named "example1.txt" on a USB memory stick that is inserted in the instrument.

MMEM:DATA "\USB\example1.txt", #257Hello! This is example content for the example text file.

  • The # indicates the start of a binary transmission.
  • The 2 indicates that the next two digits specify the length of the transmission.
  • The 57 indicates that the transmission is 57 bytes. This number includes characters, spaces, and line breaks.
  • The text is the contents of the file "example1.txt."

To move personality license files

This procedure shows you how to transfer existing license files between instruments. The license file transfer can only be done from the instrument Web page interface. The keyboard shortcuts (Ctrl+C, Ctrl+V) in this procedure are for MS Windows. For information on saving a newly purchased license, see To open a license file.

Throughout this procedure, these terms will be used to designate a particular instrument:

  • "Source instrument" designates the instrument that has the existing licenses that will be transferred or exported.
  • "Destination instrument" designates the instrument that will receive or import the existing licenses.

    Note: If you are transferring (exporting) licenses from more than one instrument, you must perform the steps in a particular sequence because the instrument license identifier changes as licenses are transferred. For example, if Instrument A is going to import licenses that are exported from both Instrument B and Instrument C, follow this sequence of steps:
    1. Export licenses from instrument B.
    2. Instrument A imports licenses from instrument B.
    3. Export licenses from instrument C.
    4. Instrument A imports licenses from instrument C.

Procedure

  1. Connect both the source instrument and the destination instrument to a Web network that includes a computer.
  2. On the computer, launch a Web browser and use the source instrument IP address as the URL.
    • If you do not know an instrument IP address, you can find it from the instrument front panel interface by selecting Menu > Utilities > Ethernet Settings.
    • If you need details on configuring the Ethernet settings, see System configuration for remote control.
  3. Launch another Web browser and use the destination instrument IP address as the URL.
  4. In the destination instrument Web page, click Licensing > Import.
  5. In the Instrument License Identifier row of the displayed table, highlight the instrument ID and copy it (Ctrl+C).

  6. In the source instrument Web page, click Licensing > Export.
  7. In the Target Instrument License Identifier field, paste (Ctrl+V) the destination instrument license ID.

  8. In the Export column, select the check boxes for the licenses that you want to transfer to the destination instrument. Click Submit.
  9. Highlight the text in the license file and copy it (Ctrl+C).

  10. In the destination instrument Web page, paste (Ctrl+V) the license file contents in the appropriate field. Click Submit.

    Note: If the power should fail during the license transfer, you can recover the license file by clicking View last exported license.


To view current licenses and license ID

You can view the current license ID and measurement personality licenses from the front panel interface or the Web interface.

From the front panel interface:

  1. Select Menu > Utilities > Licensing.
  2. View the current list of personality licenses in the displayed table.
  3. View the license ID at the top of the displayed dialog.
  4. Select Save ID.
  5. In the Save License ID window, navigate to a location that you can access from your computer. A USB memory stick is convenient for this purpose.
  6. Name the file to save:
    • If you want to overwrite an existing file, select the file in the directory structure, then select Save.
    • If you want to save the file as new, select the keyboard button and enter the filename.txt, then select Enter > Save.

From the LXI Web interface:

  1. Connect the instrument to a Web network that includes a computer.
  2. On the computer, launch a Web browser and use the instrument IP address as the URL.
    • If you do not know the instrument IP address, you can find it from the front panel interface by selecting Menu > Utilities > Ethernet Settings.
    • If you need details on configuring the Ethernet settings, see System configuration for remote control.
  3. In the instrument Web page, click Licensing.
  4. The current list of measurement personality licenses is shown in the displayed table.
  5. Click Import. The modulation license ID is shown in the Instrument License Identifier row of the displayed table.


To delete a file or folder

With the front panel interface:

  1. Open the directory that contains the file (folder) you want to delete.
  2. In the Look In: box, select the drive or folder that contains the file (folder) you want to delete.
  3. Select (highlight) the file (folder) you want to delete.
  4. Select Delete.

To share a drive or folder on the network

You can make a connection between the instrument and any Microsoft® Windows computer drive to share or manage files across multiple memory storage devices. Once you establish a path to another drive through the instrument front panel interface, you can use that path through the remote programming interface or the front panel interface.

Note: You can only establish a shared folder from the front panel interface, and if a password is required, you will need a USB keyboard attached to the instrument.

Note: When the power is cycled on the instrument, the drive sharing path must be re-established.

  1. Connect the instrument and Windows computer to a network.
  2. From a Windows computer, open Microsoft® Windows Explorer, and then locate the drive or folder you want to share.
  3. Click Start, point to All programs, point to Accessories, and then click Windows Explorer.
  4. Right-click the drive or folder, and then click Sharing and Security.
  5. Do one of the following:
    • If the Share this folder on the network check box is available, select it.
    • If the Share this folder on the network check box is not available, the computer is not on a network. Click the Network Setup Wizard link and follow the wizard instructions to switch on the file sharing.
  6. Select Menu > File > Shared Network Folders > Add Shared Folder.
  7. Connect a USB keyboard to the instrument.
  8. Enter the computer name (not IP address) of the computer and the directory path to the shared folder:
    • \\computer_name\shared_directory
  9. Type the password to the shared drive, if necessary.
    • If you do not choose "save credentials as default" you may be prompted for the user/password each time the device accesses the folder.
  10. Select the drive\directory path from the UNC Folder Name column.

After setting up the shared folder, all file dialogs will include the shared folder as a selection under Look In. If the shared path has multiple directories, only the last directory is displayed in Look In.

For example:

\\mycomputer\public shows as "public"

\\mycomputer\public\example shows as "example"

  1. Connect the instrument and Windows computer to a network.
  2. From a Windows computer, open Microsoft® Windows Explorer, and then locate the drive or folder you want to share.
  3. Click Start, point to All programs, point to Accessories, and then click Windows Explorer.
  4. Right-click the drive or folder, and then click Sharing and Security.
  5. Do one of the following:
    • If the Share this folder on the network check box is available, select it.
    • If the Share this folder on the network check box is not available, the computer is not on a network. Click the Network Setup Wizard link and follow the wizard instructions to switch on the file sharing.
  6. Select Menu > File > Shared Network Folders > Add Shared Folder.
  7. Connect a USB keyboard to the instrument.
  8. Enter the computer name (not IP address) of the computer and the directory path to the shared folder:
    • \\computer_name\shared_directory
  9. Type the password to the shared drive, if necessary.
    • If you do not choose "save credentials as default" you may be prompted for the user/password each time the device accesses the folder.
  10. Select the drive\directory path from the UNC Folder Name column.

If a DHCP server is on the LAN, you can choose to have a DHCP automatically assign an IP address.

  1. From the instrument screen, select Menu > Utilities > Ethernet Settings.
  2. Select the IP Address tab.
  3. Select Obtain an IP address via DHCP.
  4. Select the Apply button.
  5. This configures the signal generator as a DHCP client. In DHCP mode, the signal generator requests a new IP address from the DHCP server. The assigned address appears in the IP Address field.

Select Close to close the dialog.


Glossary of Terms

ACPR

Adjacent channel power ratio (ACPR) is a measurement of how much signal energy is introduced from one channel to the next, adjacent channel.

Access point

Wireless devices can connect to a wired LAN through a hardware device called an access point. See Hot spot...

Amplitude modulation (AM)

AM is a transmission technique where the amplitude of a carrier signal is modulated by the amplitude of a base band signal.

Advanced mobile phone service (AMPS)

AMPS is an analog cellular radio standard that represents the first generation of wireless networks.

Air interface

This is the wireless network's operating system that enables communication between a cellular phone and its carrier. Examples are CDMA, TDMA, GSM, and OFDM. See Carrier.

Analog

Analog is a technology which utilizes a continuous "wave" of signal to carry information over radio channels. Analog is an inefficient use of system bandwidth.

Antenna

An antenna is a physical device for sending or receiving radio signals. Antennas come in a variety of shapes and sizes. The size and shape of an antenna is carefully designed and tuned to the type of radio wave being transmitted and received.

Antenna gain

This describes an antenna's transmission power as a ratio of its output signal strength to its input signal strength. It is usually expressed in dBi; a higher dBi means a stronger antenna.

Attenuation

Attenuation is the loss or weakening of a signal through a transmission line, transmission component, or signal path. This loss is typically measured in decibels.

Attenuator

An attenuator is a component that reduces the magnitude of current, voltage, or power of a signal in transmission between points.

Bandpass filter

This is a signal filter designed to pass a particular range of frequencies, while attenuating frequencies that are outside that range.

Bandwidth

Bandwidth is the width or capacity of a communications channel or transmission path. It can apply to any analog and digital circuit or system through which data flows.

  • Analog bandwidth is measured in Hertz (Hz) or cycles per second. The actual bandwidth size is the difference between the lowest and highest frequency which can be transmitted at once.
  • Digital bandwidth is the amount or volume of data that may be sent through a channel, without distortion, measured in bits per second. An example of a low-bandwidth connection would be a 56 Kbps dial-up modem. High-bandwidth (broadband) connections deliver more information at a much faster speed, capable of delivering full-screen, full-motion video.

Base station (BS or tower)

A fixed station used for communicating with mobile stations (phones). It often consists of a cabinet or small building containing electronic equipment and associated antennas. See Cell site.

Baud

The number of signal level changes per second. Each signal level contains one or more bits of information.

Bias-T

This is an in-line device that couples DC power onto an RF circuit.

Binary

Is a number system that is base-two, meaning each position must be either "0" or "1." In digital communications systems, it is important to realize that "0" and "1" are states and not necessarily 0 volts and another voltage.

Bit

Bit is an abbreviation for binary digit. A bit is a binary unit, represented by either a "0" or a "1." In digital communications, more than one state can be described by using more than one bit. For example two bits are capable of describing four states: 00, 01, 10 and 11.

Bluetooth

This is a wireless personal area network specification that connects phones, computers, and other devices over short distances by using low-power radio frequencies.

Broadband

A broadband system can transmit more data at a higher speed than narrowband systems. In analog systems, broadband can be described as having a bandwidth of more than 3 MHz. In digital systems broadband is associated with high-speed data transmission. Examples are high-speed Internet access and streaming video.

Byte

A byte is a sequence of 8 adjacent bits. A byte can describe 256 unique states, ranging from 00000000 (0) to 11111111 (255).

Carrier

Wireless carriers, also called service providers or operators, are the companies that operate the wireless networks and sell use of those networks (the service). However, carrier is also a technical radio term for the radio wave that carries voice or data.

CCDF

Complementary Code Distribution Function.

CCK

Complementary Code Keying (CCK) is a modulation scheme used with wireless networks (WLANs) that employ the IEEE 802.11b specification. A complementary code contains a pair of finite bit sequences of equal length, such that the number of pairs of identical elements (1 or 0) with any given separation in one sequence is equal to the number of pairs of unlike elements having the same separation in the other sequence. A network using CCK can transfer more data per unit time for a given signal bandwidth than a network using the previously employed Barker code.

DSSS

Direct Sequence Spread Spectrum (DSSS) is a modulation technique. As with other spread-spectrum technologies, the transmitted signal takes up more bandwidth than the information signal that is being modulated. The name 'spread spectrum' comes from the fact that the carrier signals occur over the full bandwidth (spectrum) of a device's transmitting frequency.

cdma2000

This is a glossary term for cdma2000

See also the following GSM measurement definitions:

  • Adjacent channel power
  • Channel power
  • Code domain power
  • Conducted spurious emissions
  • Frequency error

    The difference between actual measured carrier frequency and specified carrier frequency.

  • Occupied bandwidth
  • Rho

Channel power

This is the total power of the signal in a specified frequency band.

Rho

RHO is the normalized, correlated power between the measured and ideally generated reference signal.

Conducted spurious emissions

Emissions at frequencies that are outside the assigned CDMA channel, measured at the mobile station antenna connector. This test measures the spurious emissions during continuous transmission.

Cell

The cell is the basic geographic unit of a cellular system. A geographic area is divided into smaller "cells," each of which is equipped with a low-powered radio transmitter/receiver.

Cell phone

A cell phone is a wireless telephone that sends and receives messages using the radio frequency (RF) spectrum.

Cell site

This is the location where the wireless antenna and network communications equipment is placed. A cell site consists of a transmitter/receiver, antenna tower, transmission radios and radio controllers. A cell site is operated by a wireless service provider (WSP).

Cellular

Cellular is the name given to wireless communications network architecture that employs cells or modular coverage areas. The area is normally serviced by a cell site and usually provides hand-off capability between cells for roaming devices.

Crest factor (CF)

Crest factor (peak to average power ratio of the RF envelope)

CTIA

Cellular Telecommunications Industry Association.

Cellular base station

This is the transmission and reception equipment, including the base station antenna that connects a cellular phone to the network. This is also called a cell site.

Channel

A channel is an electrical, electromagnetic, or optical path for communication between two points.

Chip

In spread spectrum, a chip is the time it takes to transmit a bit or single symbol of a PN code.

Coaxial cable, coax

A coaxial cable is a concentric two-conductor cable in which a central conductor is surrounded and shielded by another. The two conductors are separated by dielectric material.

Code

Code is a digital bit stream that has noise-like characteristics. In spread spectrum, code refers to the pseudo-random code used in the modulation technique to spread the carrier.

Compression

In RF amplification, an amplifier is said to be "in compression" (distorting) when the output is no longer a linear representation of the input signal. This is typically at the operational limits of the amplifier.

Coverage area

Is the name given to a geographic area within which a carrier provides service. It is the area within which a phone will complete calls using a specific carrier's network or partner networks.

Crosstalk

Interference caused by the electric or magnetic fields of one signal affecting a signal in another circuit or channel. On wireless networks, crosstalk can sometimes result in your hearing part of a voice conversation from another circuit or channel.

Continuous wave (CW)

This signal is always "on"; the un-modulated carrier signal is often referred to as CW.

Demodulate

To demodulate is to convert a modulated carrier signal back to the original modulating base band signal.

De-spreading

De-spreading is the process used to recover narrowband information from a spread spectrum signal.

Digital modulation

Digital modulation is a method of encoding information using a binary code of 0s and 1s from electrical pulses. The nature of this encoding allows increased data security and system capacity compared to analog modulation.

Digital signal processor (DSP)

A DSP is a specialized microprocessor containing hardware features specifically for processing analog signals.

Dipole antenna

A type of antenna commonly used with wireless networking devices. It has a signal range of 360 degrees horizontally and 75 degrees vertically.

Directional antenna

There are many different types of directional antenna. They commonly redirect the signal received from a transmitter to enhance its strength in a certain direction. This is unlike the omni-directional antenna.

Direct sequence (DS)

A technique used in spread spectrum modulation where a pseudo-random code directly modulates the phase of a carrier. This increases the bandwidth of the transmission and results in a signal with a noise-like spectrum. The signal is de-spread by reversing the process using the same pseudo-random code.

Diversity

Describes a receiver's ability to select between two receive antennas, often one horizontal and one vertical. Diversity is useful for operating in areas susceptible to the effects of multi-path interference.

Downlink

The portion of a telecommunications path from a base station or satellite to the ground; also referred to as the forward link.

Droop

Droop is the decline of signal pulse amplitude over time.

Dual-band

A dual-band digital phone will work in two frequency bands, for example, North American TDMA and CDMA phones. Dual-band indicates that the phone will work in both the 800/850 MHz band and the 1900 MHz band. Note: dual-band phones can also be dual mode, working in both analog and digital modes.

Dual mode

A dual-mode phone can have different meanings around the globe. Common descriptions are:

  • A phone that supports both analog (i.e. AMPS) and a digital technology (CDMA or TDMA). In addition, the digital mode could be dual band, operating in either the 800/850 MHz frequency band or the 1900 band.
  • A phone that supports both 2G and 3G technologies, for instance, a GSM/UMTS phone.

Duplexer

A device allowing simultaneous reception and transmission on one transmission line.

Duty cycle

The percentage of the "on time" (transmitting) versus "off time" (not transmitting). Continuous transmission is referred to as 100% duty cycle.

EDGE

See also the following GSM measurement definitions:

  • Channel power
  • Droop
  • Frequency error
  • EVM
  • IQ gain error
  • IQ origin offset
  • Output RF spectrum
  • Time mask

Channel power (EDGE)

The measure, with sufficient accuracy, is equivalent to the long-term average of the power when taken over the useful part of the burst for random data at a specific carrier frequency.

EVM (EDGE)

The modulation accuracy is defined by the error vector between the vector representing the actual transmitted signal and the vector representing the error-free modulated signal. The magnitude of the error vector is called error vector magnitude (EVM).

IQ gain error (EDGE)

Also called IQ gain imbalance. It is the difference in scaling between the I and Q components of IQ data.

IQ Origin Offset (EDGE)

Also called carrier feedthrough or DC offset. It is DC that leaks into I/Q path. It is a complex signal impairment that shifts the locus of ideal symbol coordinates off-center in the I/Q plane. A DC offset can be added to the baseband I component, the Q component, or both. The DC offset can be either positive or negative, with the sign indicating direction of the shift. DC offset is expressed as a percentage of full scale, where "full scale" (fs) is the amplitude of the baseband QM waveform.

Enhanced data rates for global evolution (EDGE)

The standard is based on the GSM standard and uses TDMA multiplexing technology. EDGE provides a smooth upgrade for GSM/GPRS networks that triples data speeds over standard GPRS.

Effective radiated power (ERP)

The product of the transmitter peak envelope power delivered to the antenna and the relative gain of the antenna over that of a half wave dipole antenna.

Encryption

The process of encoding a message (that is, a digital phone signal) to prevent it from being deciphered.

Ethernet

A standard for connecting computers into a local-area network (LAN). It is also called 10/100BaseT, which denotes a peak transmission speed of 10Mbps using copper twisted-pair cable.

Federal Communications Commission (FCC)

The FCC is the government agency responsible for regulating telecommunications in the United States.

EVM

The error vector magnitude or EVM is a measure used to quantify the performance of a digital radio transmitter or receiver. A signal sent by an ideal transmitter or received by a receiver would have all constellation points precisely at the ideal locations, however various imperfections in the implementation (such as carrier leakage, low image rejection ratio, phase noise etc.) cause the actual constellation points to deviate from the ideal locations. Informally, EVM is a measure of how far the points are from the ideal locations.

Frequency division multiplexing (FDM)

FDM is a form of analog modulation. It is a very simple method for accommodating multiple, simultaneous users in a radio band of frequency.

Frequency hopping spread spectrum (FHSS)

FHSS is a type of spread spectrum radio technology where the sender and receiver hop together from one frequency to another to avoid detection or jamming.

Filter

A device used to separate signals at certain frequencies. Common filters are low pass, high pass and band pass. These respectively allow transmission of low, high and a band of frequencies to pass through them.

Forward link

The forward link is the wireless connection over which information is sent from a cellular base station (tower) to a mobile phone. It is also referred to as the downlink.

Frequency

The number of oscillations of radio waves per unit of time, usually expressed in either cycles-per-second or Hertz (Hz).

Frequency hopping (FH)

FH is a spread spectrum modulation technique where the transmitter frequency hops from channel to channel in a predetermined but pseudo-random manner. The same is done in reverse at the receiver to recover the original signal.

Frequency modulation (FM)

FM is an analog modulation technique that varies the carrier frequency in proportion to the amplitude of the modulating signal.

Frequency reuse

Frequency reuse is the ability to use the same frequencies repeatedly across a cellular system. Each cell is designed to use radio frequencies only within its boundaries. By design, the same frequencies can be reused in other cells not far away with little potential for interference.

Full-duplex transmission

A channel that allows transmission in two directions at the same time, for example, talking and listening.

Gain

The relative increase in power or magnitude of a signal, normally measured in decibels.

GI

A GI or guard interval is used to ensure that distinct transmissions do not interfere with one another. These transmissions may belong to different users (as in TDMA) or to the same user (as in OFDM). The purpose of the guard interval is to introduce immunity to propagation delays, echoes and reflections, to which digital data is normally very sensitive.

Global positioning system (GPS)

A GPS is a system of satellites for identifying earth locations. By triangulation of signals from three satellites, a receiving unit can pinpoint its current location anywhere on earth to within a few meters.

GSM (global system for mobile communications)

GSM is based on time division multiple access (TDMA). TDMA works by dividing the frequency band up into individual time slots. Each time slot corresponds to an individual communications channel. There are eight time slots in GSM: a cell phone transmits during one time slot, receives in another and stays silent for the remaining six time slots. The GSM signal, therefore, appears as a signal burst in the time domain.

See also the following GSM measurement definitions:

  • Channel power
  • Frequency error
  • Output RF spectrum
  • Peak phase error
  • Phase error
  • RMS phase error
  • Time mask

Channel power (GSM)

The measure of power when averaged over the useful part of the burst at a specific carrier frequency.

Frequency error (GSM and EDGE)

The frequency error is the difference in frequency (after adjustment for the effect of the modulation and phase error) between the RF transmission from the mobile station (MS) and either the:

  • RF transmission from the base station (BS), or
  • Nominal frequency for the ARFCN used.

Output RF spectrum (GSM and EDGE)

Due to the bursty nature of the signal, the output RF spectrum results from two events:

  • The modulation process.
  • The power ramping up and down (switching transients).

Output RF spectrum is a narrow-band measurement that provides information about the distribution of the mobile station transmitter's out-of-channel spectral energy due to modulation and switching.

Peak phase error (GSM)

The peak phase error is the maximum difference between the phase error trajectory and its linear regression on the active part of the time slot.

Phase error (GSM)

For any 148-bits sub-sequence of the 511-bits pseudo-random sequence (defined in CCITT Recommendation O.153 fascicle IV.4) the phase error trajectory on the useful part of the burst (including tail bits) is measured by computing the difference between the phase of the transmitted waveform and the phase of the expected one after adjustment for the effect of the frequency error.

RMS phase error (GSM)

The RMS phase error is the difference between the phase error trajectory and its linear regression on the active part of the time slot.

Time mask (GSM and EDGE)

The time mask is a structure to test the acquired signal against the modulation standard. If the mobile station's transmitter power falls outside the specified power and timing ranges, the signal fails to comply to this standard.

Ground

A ground is a connection between a device or circuit and the earth, or some device serving as the earth.

High speed downlink packet access (HSDPA)

HSDPA is an upgrade for WCDMA (UMTS) networks. It doubles network capacity and increases download data speeds five-fold.

Half-duplex transmission (HDX)

An HDX channel allows transmission in only one direction at a time: transmission and receiving cannot occur simultaneously.

Handoff

In wireless mobile phone systems, a "handoff" is the process of transferring a phone call in progress from one base station (tower) to another base station, without interruption (dropping) of the call.

Many phones and networks are also capable of performing handoffs between different technologies. A digital (CDMA or TDMA) call might be handed off to an analog (AMPS) tower in the middle of the call if the digital signal becomes too weak.

High-pass filter

This is a signal filter which passes frequencies above a certain frequency, and attenuates frequencies below that frequency.

Hot spot

In wireless networking, a hot spot is a specific part of an access point's range in which the general public can walk up and use the network. The service may be available for a fee, the range short to control the physical proximity of the user.

IS-95

This is a mobile phone standard using CDMA transmission methods.

Impedance

Impedance is made up of a resistive component and a frequency variable component. One common measure of impedance with frequency is the voltage standing wave ratio (VSWR).

Insertion loss

This is the loss in signal strength due to the insertion of a device in the signal path.

Isotropic antenna

This is a theoretical, ideal antenna whose signal range is 360 degrees in all directions. It is used as a baseline for measuring a real antenna's signal strength in dBi, where the "i" stands for isotropic antenna.

Intermodulation (intermod)

The distortion product of an amplifier, caused by the interaction of different signal products within the amplifier.

Jamming

This is typically the intentional interference with another radio signal.

LAN

A LAN is a short-distance network used to link a group of computers together, usually within a building. Ethernet is the most commonly used type of LAN. A hub serves as the common wiring point, enabling data to be sent from one machine to another over the network.

Local-area network (LAN)

A LAN is a short-distance network used to link a group of computers together, usually within a building. Ethernet is the most commonly used type of LAN. A hub serves as the common wiring point, enabling data to be sent from one machine to another over the network.

LO

Local oscillator.

Land line

Traditional, wired phone service providing voice, video and data transmission technology over wires.

Linear amplifier

This is a device that accurately reproduces a radio wave in magnified form. The output signal has a linear relationship to the input signal.

Low-pass filter

This signal filter passes all frequencies below a certain frequency, and attenuates all higher frequencies.

Low-noise amplifier (LNA)

This is typically a precision, small-signal amplifier used in receiver applications.

MAC filtering

A network checks a device's MAC address against a database to see if it's authorized to access the network.

Microwave

Usually refers to the band of frequencies above the radio frequency band and below the millimeter frequency band.

Modulate

The characteristics of a base band signal are used to modify the amplitude, frequency or phase of an RF carrier signal. The carrier signal can then be transmitted with the base band signals incorporated in it.

Mobile phone

A term often used interchangeably with "cellular phone" or "wireless phone."

Multi-path interference

Signal reflections and delayed signal images interfere with the desired signal. These situations are typically associated with high-rise city buildings and indoor wireless LAN applications.

Multi-path

The phenomenon of a radio device receiving the same signal multiple times, slightly offset in time. This often happens when a radio signal is received directly from the transmitter, and also reflected off of one or more nearby objects. Because a reflected signal takes a longer path, it is slightly delayed compared to the direct signal. Although many standard formats are degraded by multi-path, CDMA signals can actually benefit from multi-path.

Multiple access

A system technique for accommodating many users in the same frequency band.

Multiplexing

Multiple signals are carried in the same frequency band at the same time. In wireless applications, common multiplexing methods include TDMA, FDMA, and CDMA.

Narrowband

A signal where the transmission bandwidth is on the order of its information bandwidth.

Network

A system designed to provide access paths for communication between users at different geographic locations. Networks may be designed for voice, text, data, fax and video. They may feature limited access (private networks) or open access (public networks). The analog or digital switching and transmission technologies used can vary greatly between networks.

Network address

A unique number associated with a host that identifies it to other hosts during network transactions.

OFDM

Orthogonal Frequency-Division Multiplexing is a digital multi-carrier modulation scheme, which uses a large number of closely-spaced orthogonal sub-carriers. Each sub-carrier is modulated with a conventional modulation scheme at a low symbol rate, maintaining data rates similar to conventional single-carrier modulation schemes in the same bandwidth. In practice, OFDM signals are generated using the Fast Fourier transform algorithm. WIMAX is the communications standard that implements OFDM.

Omni-directional antenna

This is like a dipole antenna because it radiates its signal 360 degrees horizontally; however because its signal is flatter than a dipole's, it has a higher gain.

Oscillator

This is a device which produces a "vibration," or variation in amplitude level at a given frequency.

Packet

In data communication, a packet is a sequence of binary digits, including control signals and a small amount of data, which is transmitted and switched as a unit. In network applications a large file can be broken into many packets, which can be sent to the same destination over different network paths and reassembled at the destination.

Packet switching

The process of routing and transferring data by means of addressed packets. A channel is occupied during the transmission of the packet only. Upon completion of the transmission, the channel is made available for the transfer of other packets or traffic. Due to its nature, packet-switched data is generally faster than circuit-switched data.

Path loss

Path loss is the weakening of a signal over its path of travel due to various factors, such as terrain and environmental conditions.

Point-to-point

A communications channel that transmits between one point and another point is referred to as "point-to-point."

Point-to-multipoint

A communications channel that transmits between one point and several other points is referred to as "point-to-multipoint."

Power meter

A device used to measure radio energy; this is often a broadband instrument.

Propagation

Propagation is the travel of a signal through a medium such as air or free space.

QoS

Quality of service can be used to describe how a network provider guarantees a service's performance.

Radiation

Electromagnetic energy, such as radio waves projected from a transmitter.

Radio frequency (RF)

RF can refer to radio waves themselves, or systems that handle radio signals directly, such as the circuits connected directly to the antenna.

Radio wave

A radio wave is a combination of electric and magnetic fields varying at a radio frequency and traveling through space. Radio waves are often described as electromagnetic energy with frequencies in the kHz to 300 GHz portion of the electromagnetic spectrum.

Receive gain

A measure of receive signal boost contributed by an amplifier or antenna system.

Receiver sensitivity

This is the ability of a receiver to differentiate a signal from the background noise.

Reverse link

The wireless connection over which information is sent from a mobile phone to a cellular base station. It is also referred to as the uplink.

Roaming

The ability to use a cellular phone outside its usual service area when traveling outside of the home service area (as defined by a service provider).

Safety ground

This is the local earth ground that grounds the neutral return.

Saturation

A term that describes the point at which the amplifier is in an over-driven situation. A device driven to saturation is no longer performing in a linear or distortion-free manner.

Settled (source)

The frequency is within 100 Hz, and the output power has settled according to the current ALC mode. The modulation waveform has been calculated and is being played back.

Signal-to-noise ratio (SNR)

SNR is the measure of the magnitude of a desired signal relative to the magnitude of an undesired signal or noise.

Smart antenna

A smart antenna system is one that focuses on a desired signal to reduce interference. A wireless network employs smart antennas in an effort to improve call quality and improve channel capacity.

Soft handoff

In wireless mobile phone systems, a "soft handoff" is the process of transferring a phone call in progress from one base station (tower) to another base station. Both base stations hold on to the call until the handoff is completed (the first cell site does not cut off the conversation until it receives information that the second is maintaining the call).

Spectrum

Spectrum is the range of electromagnetic radio frequencies.

Spectrum analyzer

This is an instrument which can be used to view signals across a range of frequencies. Some spectrum analyzers can measure a vector, giving amplitude and phase information and decoding complex digital modulation formats.

Spectrum assignment

Spectrum is assigned or authorized by the Federal Communications Commission (FCC). It specifies the frequencies that can be used at specific geographic locations.

Splitter/combiner

This is a transmission component that divides or sums power between two or more ports.

Spread spectrum (SS)

This is a wireless communications technology that scatters data transmissions across the allocated frequency band in a pseudorandom pattern. Spreading the data across the frequency spectrum greatly increases the bandwidth and it also makes the signal resistant to noise, interference, and eavesdropping. At the receive end, the signal is de-spread to recover the original signal.

Spurious emissions (spurs)

Spurs are unwanted frequency signals that can cause interference in receiver systems.

Switch

A switch is a mechanical, electrical or electronic device that opens or closes circuits or paths.

Telecommunications

The transmission of words, sounds, or images (usually over great distances) in the form of electromagnetic energy (for example, by telephone, radio, or television).

Throughput

This describes the volume of data which can be transmitted through a communications system.

UMTS (universal mobile telecommunications system)

This is a new-generation technology for rapidly moving data and multimedia over wireless devices. The goal of UMTS is to enable networks that offer true global roaming that can support a wide range of voice, data, and multimedia services.

UHF (ultra high frequency)

Ultra high frequency radio waves are in the 300 MHz to 3,000 MHz frequency range.

Uplink

The uplink portion of a telecommunications path is from the ground to the base station or satellite. It is also referred to as the reverse link.

VPN

Virtual private network.

VSB

Vestigial side band.

VHF (very high frequency)

VHF is in the 30 MHz to 300 MHz frequency range.

VSWR (voltage standing wave ratio)

VSWR is the amount of reflected signal due to impedance mismatch.

W (Watt)

The watt is a measure of energy per unit time, which is one joule per second.

WAN (wide area network)

If two local-area networks (LANs) are connected, a wide-area network results. The Internet can be considered to be a WAN.

WAP (wireless application protocol)

WAP is an open standard for communication between handsets and the Internet. WAP is a wireless communications environment for delivering web data to wireless terminals with minimal screen display.

W-CDMA (wide-band code division multiple access)

W-CDMA has been designed for high-speed data services, and more particularly, internet-based packet-data offering up to 2Mbps in stationary or office environments, and up to 384Kbps in wide area or mobile environments. It also increases data transmission rates in GSM systems by using CDMA instead of TDMA.

See also the following GSM measurement definitions:

  • Adjacent channel power
  • Channel power
  • Code domain power
  • EVM

    The error vector magnitude is a measure of the difference between the reference waveform and the measured waveform.

  • Frequency error

    The difference between actual measured carrier frequency and specified carrier frequency.

  • IQ offset

    This is the DC offset of the signal in % or dB.

  • Occupied bandwidth
  • Peak code domain error

    Peak code domain error (PCDE) is a measure of how much cross-talk exists between different channels within the WCDMA signal. In other words, it is an indication of how well the orthogonality between different code channels is maintained.

    From 3GPP standard:

    The code domain error is computed by projecting the error vector power onto the code domain at a specific spreading factor. The error power for each code is defined as the ratio to the mean power of the reference waveform expressed in dB. The Peak Code Domain Error is defined as the maximum value for Code Domain Error.

  • Spectrum emissions mask
  • Total power

    The total power of the signal in a certain bandwidth at a carrier frequency; see Channel power.

Channel power

The power (transmitted or received) in a bandwidth of at least (1+a) times the chip rate at the specified carrier frequency.

Code domain power

The code domain power is a measure of the power in each code channel of a CDMA channel.

EVM

The error vector magnitude is a measure of the difference between the reference waveform and the measured waveform.

Frequency error

The difference between actual measured carrier frequency and specified carrier frequency.

Peak code domain error

Peak code domain error (PCDE) is a measure of how much cross-talk exists between different channels within the WCDMA signal. In other words, it is an indication of how well the orthogonality between different code channels is maintained.

From 3GPP standard:

The code domain error is computed by projecting the error vector power onto the code domain at a specific spreading factor. The error power for each code is defined as the ratio to the mean power of the reference waveform expressed in dB. The Peak Code Domain Error is defined as the maximum value for Code Domain Error.

IQ offset

This is the DC offset of the signal in % or dB.

Total power

The total power of the signal in a certain bandwidth at a carrier frequency; see Channel power.

Adjacent channel power

An extraneous power from a RF signal in an adjacent channel.

Occupied bandwidth

Occupied bandwidth is a measure of the bandwidth containing 99% of the total integrated power of the transmitted spectrum, centered on the assigned channel frequency. The occupied channel bandwidth shall be less than 5 MHz based on a chip rate of 3.84 Mcps.

Spectrum emissions mask

The spectrum emission mask of the UE applies to frequencies that are between 2.5 MHz and 12.5 MHz from the UE center carrier frequency. The out of channel emission is specified relative to the root raised cosine (RRC) filtered mean power of the UE carrier.

Wi-Fi (wireless fidelity)

Originally referred to the 802.11b specification for wireless LANs, but it is now used to describe any of the 802.11 wireless networking specifications.

WLAN (wireless local-area network)

WLAN is a wirelessly connected LAN, such as an IEEE 802.11 network.

WPA (wi-fi protected access)

Wi-Fi protected access. WPA is a specification for improving the security of Wi-Fi networks. It replaces the weaker WEP (wired equivalent privacy) specification for current and future 802.11 standards.

WPAN (wireless personal area network)

A WPAN is a PAN that uses wireless connections. However, because all current PAN technologies (such as Bluetooth) are wireless, the terms WPAN and PAN are synonymous.

Wavelength

The wavelength is the distance covered by one cycle of a wave.

Wireless local area network (WLAN)

A WLAN is a short-range computer-to-computer wireless data communications network.

Wireline

Traditional telephone technology that relies upon wires is called a wire line or land line.